run ccs_update_schema in postinst
[fence-agents-pve.git] / debian / postinst
1 #!/bin/sh
2
3 # Abort if any command returns an error value 
4 set -e
5
6 case "$1" in
7   configure)
8     # Configure this package.  If the package must prompt the user for
9     # information, do it here.
10
11     ccs_update_schema   
12     
13     # There are three sub-cases:
14     if test "${2+set}" != set; then
15       # We're being installed by an ancient dpkg which doesn't remember
16       # which version was most recently configured, or even whether
17       # there is a most recently configured version.
18       :
19
20     elif test -z "$2" -o "$2" = "<unknown>"; then
21       # The package has not ever been configured on this system, or was
22       # purged since it was last configured.
23       :
24
25     else
26       # Version $2 is the most recently configured version of this
27       # package.
28       :
29
30     fi ;;
31   abort-upgrade)
32     # Back out of an attempt to upgrade this package FROM THIS VERSION
33     # to version $2.  Undo the effects of "prerm upgrade $2".
34     :
35
36     ;;
37   abort-remove)
38     if test "$2" != in-favour; then
39       echo "$0: undocumented call to \`postinst $*'" 1>&2
40       exit 0
41     fi
42     # Back out of an attempt to remove this package, which was due to
43     # a conflict with package $3 (version $4).  Undo the effects of
44     # "prerm remove in-favour $3 $4".
45     :
46
47     ;;
48   abort-deconfigure)
49     if test "$2" != in-favour -o "$5" != removing; then
50       echo "$0: undocumented call to \`postinst $*'" 1>&2
51       exit 0
52     fi
53     # Back out of an attempt to deconfigure this package, which was
54     # due to package $6 (version $7) which we depend on being removed
55     # to make way for package $3 (version $4).  Undo the effects of
56     # "prerm deconfigure in-favour $3 $4 removing $6 $7".
57     :
58
59     ;;
60   *) echo "$0: didn't understand being called with \`$1'" 1>&2
61      exit 0;;
62 esac
63
64 exit 0