add 4.4.0 sources