CryptoPkg PeiCryptLib: Enable SHA384/512 support
[mirror_edk2.git] / CryptoPkg / Library / BaseCryptLib / PeiCryptLib.uni
1 // /** @file\r
2 // Cryptographic Library Instance for PEIM.\r
3 //\r
4 // Caution: This module requires additional review when modified.\r
5 // This library will have external input - signature.\r
6 // This external input must be validated carefully to avoid security issues such as\r
7 // buffer overflow or integer overflow.\r
8 // \r
9 // Note: MD4 Digest functions, HMAC-MD5 functions, HMAC-SHA1 functions, AES/\r
10 // TDES/ARC4 functions, RSA external functions, PKCS#7 SignedData sign functions,\r
11 // Diffie-Hellman functions, X.509 certificate handler functions, authenticode\r
12 // signature verification functions, PEM handler functions, and pseudorandom number\r
13 // generator functions are not supported in this instance.\r
14 //\r
15 // Copyright (c) 2010 - 2014, Intel Corporation. All rights reserved.<BR>\r
16 //\r
17 // This program and the accompanying materials\r
18 // are licensed and made available under the terms and conditions of the BSD License\r
19 // which accompanies this distribution.  The full text of the license may be found at\r
20 // http://opensource.org/licenses/bsd-license.php\r
21 // \r
22 // THE PROGRAM IS DISTRIBUTED UNDER THE BSD LICENSE ON AN "AS IS" BASIS,\r
23 // WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED.\r
24 //\r
25 // **/\r
26 \r
27 \r
28 #string STR_MODULE_ABSTRACT             #language en-US "Cryptographic Library Instance for PEIM"\r
29 \r
30 #string STR_MODULE_DESCRIPTION          #language en-US "Caution: This module requires additional review when modified. This library will have external input - signature. This external input must be validated carefully to avoid security issues such as buffer overflow or integer overflow. Note: MD4 Digest functions, HMAC-MD5 functions, HMAC-SHA1 functions, AES/ TDES/ARC4 functions, RSA external functions, PKCS#7 SignedData sign functions, Diffie-Hellman functions, X.509 certificate handler functions, authenticode signature verification functions, PEM handler functions, and pseudorandom number generator functions are not supported in this instance."\r
31 \r