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1 
Conventions
Table 1‑A Tables for Defining Form Content
	Description
	A description

	Required
	Yes | No

	Editable
	Yes | No

	Prompt
	String

	Field Type
	String | Checkbox | RadioBox | Number | Dropdown | MenuItem

	Data Type
	The XML Data Type

	Field Help
	ToolTip Help Text

	XML Tags
	SubSection.ElementName, SubSection.ElementName:Attribute

	DataSource
	For Dropdown, what to display

	DataVerification
	When to verify data format

	Hover Option
	What to display on mouse over

	Properties
	What to display for right mouse click

	Notes
	Other information that is useful


Table 1.  Base XML Data Types
	Name
	Description

	xs:decimal
	A string containing numbers followed by a period followed by numbers

Example: 1.23

	xs:integer
	A string that represents a signed 32-bit integer.  The range is from 

	xs:nonNegativeInteger
	A string that represents  a positive 32-bit integer.  The range is from 0 to 

	xs:string
	

	xs:normalizedString
	

	xs:NCName
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	xs:anyType
	


Table 2.  Value Types
	Name
	Description

	Boolean
	A string containing ‘true’ or ‘false’

	VersionDataType
	A string that contains a positive decimal number.

	GuidType
	A string containing a GUID in registry format.

Example: AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2


Table 3.  String Types
	Name
	Description

	C_NameType
	A string that starts with either an underscore or a letter, followed by any number of letters, digits or underscores.

	UiNameType
	A string that starts with a letter followed by any combination of letters, digits, underscores, and periods.  No whitespace is allowed.

Example: EdkModulePackage_01

	Sentence
	A string containing two or more words separated by spaces.  No tabs, carriage returns or line feeds are allowed.

	Paragraph
	Same as xs:normalizedString

	PathAndFilename
	

	FeatureFlagExpressionType
	Same as xs:normalizedString


Table 4.  Enumeration Types
	Name
	Description

	ModuleTypeDef
	A string that contains a single module type.  Module types are restricted to the following set:

BASE

SEC

PEI_CORE

PEIM

DXE_CORE

DXE_DRIVER

DXE_RUNTIME_DRIVER

DXE_SAL_DRIVER

DXE_SMM_DRIVER

TOOL

UEFI_DRIVER

UEFI_APPLICATION

USER_DEFINED

	PcdDataType
	A string that contains a single PCD data type.  PCD data types are restricted to the following set:

UINT8

UINT16

UINT32

UINT64

VOID*

BOOLEAN


Table 5.  List Types
	Name
	Description

	ArchTypeList
	A string that contains one or more CPU architectures separated by spaces.  The CPU architectures are restricted to the following set:

IA32

X64

IPF

EBC

PPC

ARM

	ModuleTypeList
	A string that contains one or more module types separated by spaces.  The module types are restricted to the following set:

BASE

SEC

PEI_CORE

PEIM

DXE_CORE

DXE_DRIVER

DXE_RUNTIME_DRIVER

DXE_SAL_DRIVER

DXE_SMM_DRIVER

TOOLE

UEFI_DRIVER

UEFI_APPLICATION

USER_DEFINED

	GuidListType
	A string that contains one or more GUID types separated by spaces.  The GUID types are restricted to the following set:

DATA_HUB_RECORD

EFI_EVENT

EFI_SYSTEM_CONFIGURATION_TABLE

EFI_VARIABLE

HII_PACKAGE_LIST

HOB

	PcdListType
	A string that contains one or more PCD Entry item types separated by spaces.  The PCD Entry item types are restricted to the following set:

FEATURE_FLAG
FIXED_AT_BUILD
PATCHABLE_IN_MODULE
DYNAMIC
DYNAMIC_EX


2 
Overview

This document provides the Minimum Requirements and the Design Specification for the first implementation of the Framework Wizard (Wizard) tool.  The tool will be the primary interface between developers and the build infrastructure.  It must provide an easy to use interface that can handle multiple file types, and hide the complex XML configuration file formats from developers.  The primary goal for this Wizard is to provide developers with multiple choice dialogs that lead them through configuration of new, stand-alone modules, groups of modules and platforms.  These dialogs must provide the developer with applicable choices (for a PEIM module, the developer can select from presented library classes that support PEI only, and not DXE libraries.)  While several of the features of the Wizard may give the appearance of and IDE, the Wizard is not an IDE.  It is a somewhat “smart” interface to the developer’s workspace environment.
The Wizard is to be used for development of modules, groups of modules or platforms.  A separate tool, the Create Distribution Package (CreateDistribution) tool, is provided to bundle the modules, groups of modules or platforms into a distribution file.  The Package tool will also be used to manage the Installation, Upgrade and Removal of packages from the Workspace.
· At a high level, the Wizard must support the following:

· Modification of Module Surface Area (MSA) files

· Must support Defining GUIDs, PPIs, PROTOCOLs and PCDs

· Modification of the Surface area Package Description (SPD) file

· Modification of the Framework Platform Description (FPD) file

· Pick and chose drivers to add to a platform

· For each driver, define library instances and what values and types of PCD are used by the driver

2.1 Framework Developer Roles

There are several roles that a developer may take while working in the EDK2 development environment.  In some cases, developers may fall into only one of these roles.  In other cases a developer may perform operations associated with several roles in order to complete their development activities.  The EDK2 tools support the following Framework Developer Roles:

· Workspace Maintainer – Manages the set of packages and platforms installed in a WORKSPACE.  Package operations include installing Distribution Packages, creating new Packages, cloning existing Packages, and deleting installed Packages.  Platform operations include creating new platforms, closing existing Platforms, and deleting installed Platforms. 

· Package Developer – Manages the contents of a package, which includes the packages name, description, copyright, licenses, and an optional set of libraries and modules implementations.  Packages may also contain elements that are available to the development of new modules by Module Developers.  These include Library Class declarations, Industry Standard Include files, include file extensions to the standard Module Types, GUID declarations, Protocol declarations, PPI declarations, and Platform Configuration Database Entry declarations. 

· Module Developer – Implements new modules or maintains existing module implementations.  A Module Developer is responsible for describing all the information required to build a module and also the behavior of a module.  The information required to build a module include the set of Packages a module depends upon, the set of module source files, and optional build options.  The behavior of a module is captured by the Module Developer by declaring the various items that a module produces and consumes.  These may include Library Classes, Protocols, PPIs, Events, HOBs, Variables, Boot Modes, EFI System Configuration Tables, Data Hub Records, HII Packages, GUIDs, Platform Configuration Database Entries, extern Data Structures, and extern Functions (including the entry point).

· Platform Integrator – Responsible for setting all the features required to build a FLASH image and boot a platform.  This includes selecting pre-built components, selecting modules implemented by Module Developers, selecting the library instances required to link the selected modules, setting the Platform Configuration Database entry parameters for all the entries that are used by the selected modules and libraries, and selecting the FLASH layout required to store the pre-built components and module executables in a FLASH device. 

· Package Distributor – Responsible for creating a distributable version of a Package that can be installed into a WORKSPACE by a Workspace Maintainer.  This involves collecting a set of packages developed by Package Developers which includes modules developed by Module Developers, and a set of platforms developed by Platform Integrators and combining them into a Distribution Package.
Table 6.  UI Tool Operations for Workspace Maintainers
	Name
	Description

	Install a Distribution Package into the WORKSPACE
	Adds a distribution package from an external source into a WORKSPACE.

This operation tests the distribution package’s Manifest file: FrameworkDevPkgManifest.Header.Guid and FrameworkDevPkgManifest.Header.Version against entries in the WORKSPACE/Tools/Conf/FrameworkDatabase.db file:

FrameworkDatabase.PackageList.Package.PackageGuid and FrameworkDatabase.PackageList.Package.PackageVersion

	Create a new Package in the WORKSPACE
	Creates a new SPD file in the WORKSPACE

Asks the user for a directory to place the SPD file.  The UI must support creating new directories so the SPD file can be placed in a new directory.  Once a file location is selected, and empty SPD file can be generated containing the PackageSurfaceArea.SpdHeader element.  This is the is the only required element in the SPD file.  The user should then be allowed to enter the PackageSurfaceArea.SpdHeader details.  See Edit SPD Header in a Package.

	Clone a Package in the WORKSPACE
	Clones a package from one location in the WORKSPACE to another location in the same WORKSPACE.  

If PackageSurfaceArea.SpdHeader.RePackage is false, then this operation must fail with an error message.

Asks the user for a directory to place the cloned SPD file.  The UI must support creating new directories so the cloned package can be placed in a new directory and must also allow a new filename for the SPD file to be entered.  Once a file location is selected, the entire contents of the original package are copied to the new location.  Platform files and temporary output files must be skipped in the copy operation.

PackageSurfaceArea.SpdHeader.ReadOnly must be set to false in the cloned package. PackageSurfaceArea.SpdHeader.RePackage must be set to true in the cloned package.

	Edit a Package in the WORKSPACE
	See “UI Tool Operations for Package Maintenance”

	Delete a Package from the WORKSPACE
	Deletes a package from the WORKSPACE. 

The user selects one of the packages installed in the WORKSPACE.  Once a package is selected, The user must then select if the files associated with the package should be deleted or not.  Finally, the delete operation must be confirmed by the user.  If the delete operation is confirmed, then the package is removed from the framework database, and if the user chose to delete all the file associated with the package, then all the files in the package are deleted except any platform (FPD) files that happen to be in the directory tree of the package.

Asks the user for a directory to place the cloned SPD file.  The UI must support creating new directories so the cloned package can be placed in a new directory and must also allow a new filename for the SPD file to be entered.  Once a file location is selected, the entire contents of the original package are copied to the new location.  Platform files and temporary output files must be skipped in the copy operation.

PackageSurfaceArea.SpdHeader.ReadOnly must be set to false in the cloned package. PackageSurfaceArea.SpdHeader.RePackage must be set to true in the cloned package.

	Create a new Platform in the WORKSPACE
	See “UI Tool Operations for Platform Integrators”

	Clone a Platform in the WORKSPACE
	See “UI Tool Operations for Platform Integrators”

	Edit a Platform in the WORKSPACE
	See “UI Tool Operations for Platform Integrators”

	Delete a Platform from the WORKSPACE
	See “UI Tool Operations for Platform Integrators”


Table 7.  UI Tool Operations for Package Developers
	Name
	Description

	Edit SPD Header in a Package
	

	Add Library Class to a Package
	

	Edit Library Class in a Package
	

	Import Library Class from another Package
	

	Delete Library Class from a Package 
	

	Add Industry Standard Include File to a Package
	

	Edit Industry Standard Include File in a Package
	

	Import Industry Standard Include File from another Package
	

	Delete Industry Standard Include File from a Package 
	

	Add New Module to a Package
	

	Import Module from another Package
	

	Delete Module from a Package
	

	Edit Package Headers Files for each Module Type in a Package
	

	Add GUID to a Package
	

	Import GUID from another Package
	

	Edit GUID in a Package
	

	Delete GUID from a Package
	

	Add Protocol to a Package
	

	Import Protocol from another Package
	

	Edit Protocol in a Package
	

	Delete Protocol from a Package
	

	Add PPI to a Package
	

	Import PPI from another Package
	

	Edit PPI in a Package
	

	Delete PPI from a Package
	

	Add PCD to a Package
	

	Import PCD from another Package
	

	Edit PCD in a Package
	

	Delete PCD from a Package
	


Table 8.  UI Tool Operations for  Module Developers
	Name
	Description

	Add a New Module in a Package
	See Package Developers

	Clone a Module from another Package
	See Package Developers

	Delete a Module from a Package
	See Package Developers

	Edit a Module Header
	

	Add Library Class Definitions to a Module
	

	Edit Library Class Definitions properties in an Module
	

	Delete Library Class Definitions from a Module
	

	Add Source Files to a Module
	

	Edit Source File properties in a Module
	

	Delete Source Files from a Module
	

	Add Package Dependencies for a Module
	

	Edit Package Dependencies properties for a Module
	

	Delete Package Dependencies from a Module
	

	Add Protocols to a Module
	

	Edit Protocol properties for a Module
	

	Delete Protocols from a Module
	

	Add Events to a Module
	

	Edit Event properties for a Module
	

	Delete Events from a Module
	

	Add HOBs to a Module
	

	Edit HOB properties for a Module
	

	Delete HOBs from a Module
	

	Add PPIs to a Module
	

	Edit PPI properties for a Module
	

	Delete PPIs from a Module
	

	Add EFI Variables to a Module
	

	Edit EFI Variable properties for a Module
	

	Delete EFI Variables from a Module
	

	Add Boot Modes to a Module
	

	Edit Boot Mode properties for a Module
	

	Delete Boot Modes from a Module
	

	Add EFI System Configuration Tables to a Module
	

	Edit EFI System Configuration Table properties for a Module
	

	Delete EFI System Configuration Tables from a Module
	

	Add Data Hub Records to a Module
	

	Edit Data Hub Record properties for a Module
	

	Delete Data Hub Records from a Module
	

	Add HII Packages to a Module
	

	Edit  HII Package properties for a Module
	

	Delete HII Packages from a Module
	

	Add GUIDs to a Module
	

	Edit GUID properties for a Module
	

	Delete GUIDs from a Module
	

	Add Externs to a Module
	

	Edit Extern properties for a Module
	

	Delete Externs from a Module
	

	Add PCD Entries to a Module
	

	Edit PCD Entry properties for a Module
	

	Delete PCD Entries from a Module
	

	Add Build Options to a Module
	

	Edit Build Options for a Module
	

	Delete Build Options from a Module
	


Table 9.  UI Tool Operations for  Platform Integrators
	Name
	Description

	Create a new Platform 
	

	Clone a Platform
	

	Delete a Platform 
	

	Edit a Platform Header
	

	Add a SKU to the Platform
	

	Delete a SKU from the Platform
	

	Describe FLASH Layout of the Platform
	TBD.  Will likely be broken up into many smaller steps.

	Add a Module to a Platform
	

	Delete a Module from a Platform
	

	Pick Library Instances required to link a Module 
	This is an iterative process where the form contents and design may have to be updated each time the Platform Integrator changes a library instance selection.

Is it legal to select a library instance from a package that the module does not depend upon?  I think yes.  Then does the developer see all the library instances in the WORKSPACE, or can a platform developer select a subset of the packages in the WORKSPACE to use?

	Select PCD Entry properties for Module
	This is where the Dynamic vs. non-Dynamic choice must be made

	Edit non-Dynamic PCD entries for a Module
	

	Edit Dynamic PCD entries for the Platform
	

	Add Build Options to a Platform
	

	Edit Build Options for a Platform
	

	Delete Build Options from a Platform
	


Table 10.  UI Tool Operations for Package Distributors
	Name
	Description

	Create Distribution Package
	

	Edit a Distribution Package
	


Table 11.  Miscellaneous UI Tool Operations
	Name
	Description

	Display Package
	

	Hover Over Package 
	

	Select Package
	


Table 12.  Build Tool Operations
	Name
	Description

	Build Module
	

	Build Platform
	


3 
Workflow
This section describes the expected workflow for Module Developers, Platform Integrators and folks that create Distribution packages.

3.1 Module Development Process Model
Note this is the expected process, which is not necessarily that the tools have to support.  For example, while the process model states that a developer will add the module’s information before the MSA is created (step 3a below,) it will not be required.  The Wizard should Prompt the user when a new module creation task is requested, but the developer can defer entering the data into an SPD file until a later date.
1) Module developers will install the MDK/EDK from either a self-installing JAR file (both will be available on TianoCore.org in public area) or from a checkout from a SCM, where someone has already done the installation from the JAR file on their local system and imported it to the SCM.

2) Existing Module Development/Maintenance in an Existing Package

a) Module developer works on existing code.

b) Module developers working on an existing module only need to work on their code and update the MSA/SPD files as changes to the code require.

c) They may need to update an existing package level FPD file, if there is one setup for the package, to do testing, or the module has been used in a platform.

d) Module Developer repeats steps a-c until “done.”

3) Create New Module in an Existing Package

a) Module Developer will need to create an entry (MsaFile) in the Package’s SPD file.  The first pass will require the name of the module, a GUID (tool will have a GenGUID button,) the Version and the location (in the existing package’s directory tree) where the module’s MSA file will exist

b) Wizard will use this data to start completing the MSA file.

c) Module developer will have to enter as much information as they have about the module they plan to develop into the MSA file’s forms in the Wizard.

d) Module developer can then start writing their code.

e) Module developer can update the MSA at any time during the code creation process, adding additional source files and other entries.

f) Wizard will auto-complete, where possible, entries into the SPD file.

g) Module developer, once the developer is ready to do testing, must open up the package’s FPD file and add the module data from the SPD into the FPD as well as query the user for:

a. Library Instance usage 

b. PCD usage

c. Module Specific Build Options

h) Module Developer will open up an command window and execute ant in the Existing Package’s root directory (the location where the SPD file is located.)
i) Module developer will then fall back to step #2 of the Module Development Process.

4) Create Module in a New Package (this is NOT a distribution package, refer to the “Create Distribution Package Process Model below.)
a) Module Developer will create a new SPD file, giving the name of the package, a GUID (tool will have a GenGUID button,) the Version and the location in the WORKSPACE directory tree where the package’s SPD file will be located.

b) Module Developer will complete as much of the SPD Header section as they can, then save the file.

c) Module Developer will decide if they want to create a package level FPD file for testing.

d) Module Developer will then fall back to step #3 of the Module Development Process.

3.2 Platform Integration Process Model
1) The Platform Integrator will checkout the code tree from a SCM.

2) Existing Platform Development/Maintenance

a) Platform Integrator will modify FLASH information section of the FPD file.

b) Platform Integrator will modify FPD file as necessary to add/update/remove modules from the Platform

i) Platform Integrator will modify FPD file as necessary to add/update/remove PCD Entries as each Module is added.
ii) Platform Integrator will select the Library Instances for each Library Class that an added module needs.  HOWEVER, since this platform definition already has one or more modules selected, the Wizard should be able to determine (if there is more than one library instance that satisfies a library class) the “most used” library instance for a given library class and present that option as the most likely candidate to use.  “Most likely” library instance just means that the library instance is highlighted in the drop down selection of library instances for that class.  Also, note that a valid selection of a library instance may be “Not Selected,” meaning that the PI has decided to wait until later to select a library instance.  The build should FAIL IMMEDIATELY if this entry is used.
c) Platform Integrator will open a command window and change to the directory where the FPD file is located.  Typing “ant” will start a build, with the output being placed in the directory specified in the global build option, OutputDirectory.

d) Platform Integrator will repeat steps a through d as needed.

3) Create a New Platform

a) Platform Integrator will create a new FPD file, giving the name of the platform, a GUID (tool will have a GenGUID button,) the Version and the location in the WORKSPACE directory tree where the platform’s FPD file will be located.  NOTE: Since a Platform usually has platform specific modules, the Module Developers will probably create a single Platform package (SPD) in the WORKSPACE.  While not required, it is recommended that the FPD file be located in separate directory from any SPD file as this Platform package (SPD) file.  This is usually a policy decision.  For these MINIMUM Requirements, the one and only one FPD file may exist in a directory.
b) Platform Integrator will complete the FLASH information section of the FPD file.

c) Platform Integrator will add Modules from the available modules in the WORKSPACE

d) Wizard will move the modules into the correct locations within a FPD file - and auto complete as much of the FPD file as possible, based on the information in the Module’s SPD and FPD file.  (Modules must always be associated to an SPD file.)

e) Platform Integrator will be required to complete the following entries:

i) For each library class used by the platform’s modules

(1) Global Library Instances (the wizard will automatically populate the libraries library elements for all modules that use a library class)
(2) Platform Integrator may override global Library instances by selecting individual Module Library Instances (these library instances override the global instances)

ii) PCD Usage

iii) Build Options

(1) Global Build Options

(2) Platform Integrator may override global Build Options by selecting individual module build options

f) Platform Integrator will open a command (terminal or x-term) window and change to the directory where the FPD file is located.  Typing “ant” will start a build, with the output being placed in the directory specified in the global build option, OutputDirectory.

g) Platform Integrator will then fall back into step #2 of the Platform Integration Process.
3.3 Distribution Package Creation Process Model
1) The people responsible for creating Distribution packages will check out a copy of the tree from a SCM.

2) Run the CreateDistribution application

a) Using this application, the user will select the name of the package(s) that will be put into a distribution package.

b) User will select whether to create a Source or Binary distribution package.

c) CreateDistribution application will verify:

i) Package has RePackage element set to true if it exists.  If the element does not exist, then RePackage is default to FALSE, which means you would get error message.
ii) All MSA files in the SPD files are within the SPD file’s directory structure.

d) User will be required to select information that will be kept for reduced information FPD, SPD and MSA files.

e) Application will query the user for Manifest information

f) Application will query the user for the output file location

g) Application will generate an FDP file based on information it received

h) User should test the FPD installation, using a clean EDK/MDK installation, and the Wizard to install, update and/or remove the distribution package.

i) User should complete all steps required by their organization to publish and distribute the FPD file, which can be distributed in any method they want.

3) Repeat steps 1 - 2 of the Distribution Package Creation Process as needed.
4 
Design Rules and Requirements
4.1 High Level Rules and Requirements

To present a consistent look and feel to development, modules will be built in the context of a platform.
One of the primary goals of R9 is to provide IHVs with a method for distributing stand-alone EFI/Framework modules, EFI/Framework modules are normally included as part of a platform.  Building a module in the context of a platform is required, however the a full platform build is not required.  A module’s platform need not specify any other modules, nor does the platform have to specify anything at all regarding “flash” storage hardware.  We have included new tools, such as EfiRom and FlashMap to allow easy creation of images and platforms.
Platform BIOS developers, on the other hand, need to know specific details of the storage mechanism and layout.  The re-design of the EFI/Framework provides additional flexibility and allows for generalization of individual module design.  Platform BIOS developers will ultimately determine how to put the individual modules (using either source level compile and link or binary link options) together to create a the firmware image for a specific platform.
The remaining parts of this section describe the requirements for the Wizard to support the new re-design of the EFI/Framework layout.  (The tool is designed to support both EFI 1.0 and UEFI 2.0 architecture specifications, along with other industry standards.)  Refer to the Framework Build and Package Architecture Specification for additional information.
4.2 Visible Changes Between Apr-06 release and Jun-06 Release

· The ModuleEditor program has been replaced by the FrameworkWizard.  Additionally, the creation/modification of the Surface Area Package Description (SPD) files has been moved from the PackageEditor to the Wizard.  Now, the CreateDistribution tool is only responsible for creating distribution packages from a WORKSPACE.

· The Wizard supports creation and modification of Framework Platform Definition (FPD) files.  These FPD files now contain additional information about PCD entries that are dynamic, while the complete PCD information is now under the Module Surface Area entries in the FPD.

· The Wizard supports installation, update and removal of distribution packages from the workspace.

· The Wizard automatically comes up in full edit mode.  You will not be required to select “Update” before editing previously completed entries.

· The Wizard provides multiple tree views of the content of the WORKSPACE.  The left panel of the application window provides either a Package List -> Module view or a Platform List -> Module view.  Both views are created when the application starts., and are refreshed any time SPD or FPD files (containing modified data) are saved.

· The MBD files are no longer required - library instance data for each module will need to be added into any Framework Platform Description file (FPD) that uses the module.  The Build information in the MBD file will also move the FPD files.  

· The Library Instance information MAY be entered into a RecommendedInstance attribute in the MSA/SPD file.
· The Tool Chain Definition File (WORKSPACE/Tools/Conf/tools_def.txt,) is changing to provide more flexibility.  User defined tool chains are now supported, with some additional properties that can classify the tool chains to a vendor “Family.”  Three different tool chain families are supported: Gnu (GCC,)  Intel (INTC) and Microsoft (MSFT.)
· Library Classes may only be defined in the context of the Surface Area Package Description.  To add a library class, the developer must place a single header file in the $WORKSPACE/$PACKAGE/Include/Library directory.  Other header files may be included, however they must be referenced within the single library header.  
4.3 Design Rules and Guidelines

The following section defines rules for development, as well as rules that will be followed by build tools.  Exceptions, as permitted, are noted at the end of the rule.

4.3.1 Naming Convention

· RULE:  Everything: directories, file names, program names, variable names, etc. is CASE SENSITIVE.  It is the developer’s responsibility to ensure that the correct case is used for all newly created elements of the EFI/Framework (modules, packages and/or platforms.)
· RULE: Directory Names MUST start with an Uppercase Alpha Character, followed by zero or more lowercase characters and/or numbers and/or uppercase characters.  The only special characters: underscore “_” and hyphen “-“ characters, are allowed in directory names.

· RULE: Architecture directories MUST be named Ia32, X64, Ipf or Ebc.  Directory names: ia32, iA32, IA32, x64, IPF, ipf, EBC or ebc will not be automatically recognized by the build tools.  NOTE: The XML SupportedArchitectures enumerated data type is used within the tools for flow control.  They will never be interpreted as directory names.
NOTE: The Wizard should flag any directories that violate this rule.

· RULE: When specifying a path in the source files (such as in the #include lines, like #include <Ia32/MyCode.h>) with directory separators, the directory separator MUST be a single forward slash “/” character between the directory names.

· RULE: The Tool Chain properties must follow the format documented in the tools definition section of this document.

· RULE: System Environment Variables MUST be ALL UPPERCASE, with underscore “_” characters permitted. Example: %XML_BEANS_HOME%

· GUIDELINE: User Defined Environment Variables, or portions of constructed variables SHOULD start with an Upper case letter.

Example: $MyToolChain  

· GUIDELINE: For User Defined Properties and constructed properties, the property Should start with an Upper Case Character.  Constructed properties are for combining user defined tags with application specific attributes.

Constructed Example: DEBUG_MyToolChain_IA32_ASM_LINKER

· RULE: Flags for tool chains are specified in text files in the Tools/Conf directory.  For User Defined tool chain tags, the build tools will first look for a file: MyToolChain_tools.txt.  If that file is not found, the build tools will look for the appropriate TOOL_CHAIN_FAMILY_tools.txt.  (See following sections for a description of the valid tool chain families.)  These files contain the default settings for each tool.
· RULE: Provided Tools must ignore any content provided in <UserExtensions> sections of MSA, SPD and/or FPD files.  These sections are available for third party custom extensions.

4.4 Directory Structure & WORKSPACE

Description: The FrameworkDatabase.db file tracks the location of package (SPD) and platform (FPD) files relative to the WORKSPACE environment variable.  The package (SPD) files track the location of the module description (MSA) files by recording the location of the MSA file relative to the SPD file. The MSA files record the location of a module’s source files by recording the location of the files relative to the MSA file.
· RULE: All WORKSPACE content must be within a directory tree with the WORKSPACE (identified as the top most node, or directory of the tree.)  EXCEPTION: OUTPUT from a build is allowed to be placed outside of the WORKSPACE.

· RULE: All package content MUST be within the package’s directory structure.  Use of .. to reference a directory above the current directory is NOT permitted.
· RULE: Multiple WORKSPACE directories are permitted on a development system, however module and platform development can only be performed within a single given WORKSPACE (the developer cannot use modules and platforms outside of the WORKSPACE directory tree) at any one instant in time.

· RULE: The Wizard works on content within a single valid WORKSPACE.  Developers can switch between WORKSPACES, but may modify content only in the current (active) WORKSPACE.
· RULE: Newly created package (SPD) files are automatically added to the WORKSPACE without using the CreateDistribution tool to create a distribution package.
· RULE: Distribution packages can be installed, updated or removed from the active WORKSPACE using the Wizard.

· RULE: Newly created platform (FPD) files are automatically added to the WORKSPACE without using the CreateDistribution tool to create a distribution package.

· RULE: The CreateDistribution tool MUST be used to create distribution packages within a WORKSPACE.  A developer cannot just copy a directory tree from one WORKSPACE to another without manually editing the FrameworkDatabase file for the new WORKSPACE (No tools have been provided to manually modify the FrameworkDatabase.db file.  There are multiple configuration files that must be updated when installing, updating or removing packages in a WORKSPACE.  NOTE: Use the CLONE function of the Wizard to copy a package from one WORKSPACE to another WORKSPACE.
· RULE: The Wizard MUST provide a method for cloning modules, packages, platforms and/or tool chain definitions within a WORKSPACE or to different a different WORKSPACE.  The Wizard can also be used to clone an entire WORKSPACE to another directory structure.

· RULE: Before creating a new module, a package file (SPD) MUST exist so that valid content can be added to the SPD file.  Adding a module to an existing platform file when creating a new module is optional.

4.5 Environment

· RULE: The Wizard will NOT change any System Environment Variables.  Changing of System Environment Variables must be done by the developer outside of the Wizard, using either a command line or through operating system specific tools.
· RULE: The Wizard will not automatically detect information about a developer’s system configuration.  The tool will provide the developer with browse capabilities outside of the WORKSPACE when setting up tool configurations.

· RULE: The Wizard has no inherent knowledge of the best known settings for tool command line options.  It is the responsibility of the developer to define options for third party assemblers, compilers and linkers.  Framework tool options are pre-defined in the build tools, however the Framework tools may be used as stand-alone applications.  The developer using Framework tools as stand-alone applications should view the help information integrated into each of these tools for the setting of tool options in on a command line.

4.6 Build Infrastructure

· RULE: Module Identification is based on Package GUID, Package Version, Module GUID and finally Module Version.

· RULE: Each PACKAGE must have a UNIQUE GUID/Version pair within the WORKSPACE.  No two packages with the same Package GUID and Package Version can exist within a WORKSPACE.  Attempting to clone/install two packages with identical GUID and Versions will not be allowed by the package installation/update/removal functions of the Wizard. 
· RULE: Each MODULE or LIBRARY instance must have a UNIQUE GUID/Version pair within a single PACKAGE in the WORKSPACE. When specifying instances of modules or libraries, the module or library must have a unique GUID/Version pair within a package.  It is permissible to have duplicate GUID/Version pairs, provided they are in different packages.

· RULE: When presenting information to the developer the Wizard will only check the Version if there is a duplicate GUID within a package.  The configuration files, MSA, SPD and/or FPD files will Always specify GUID and VERSION information; the GUID/Version pairs are used to identify unique entries.
· RULE: If a GUID is not found, or there are duplicate GUID/Version entries in a single package, then the BUILD BREAKS with ERROR (the Package tool must prevent the later case.)
· RULE: Each PLATFORM must have a UNIQUE GUID/Version pair within the WORKSPACE
· RULE: For Library Class Declarations (SPD files) - the public Library Header MUST be added to the Package\Include\Library directory.

· RULE: For Library Modules - the Library Module code must reside in the Package\Library directory.

· RULE: All public header files should reside in the PACKAGE\Include directory tree.

· RULE: All platform (FPD) files must specify the tool chain families that will be used to generate binary files.

· RULE: The directory name for the module, library, package or platform does NOT have to match “Basename” values in the MSA, SPD or FPD files.

· RULE: The FeatureFlag Attribute is a string, where the developer will enter values that will be processed using RPN notation, from Left to Right.

 Value1 Value2 Operation1 . . . ValueN OperationN

· RULE: Package Help Text (Abstract and Description) must provide an adequate description of the contents, so that a developer can understand the differences between different versions of a Package.

· RULE: Package GUID values should change with major changes to the content of the package that would break backward compatibility.
· GUIDELINE: Package Version values should change with minor changes and/or bug fixes in the content of the package that do not break backward compatibility.

5 
Features and Requirements
This section provides the a bullet list of the minimum requirements and features that are needed for the first release of the R9 Framework on TianoCore.org.  Note, that while some features, such as localization support may not be deemed necessary, they are simple to implement from the start, and more difficult to implement at a later date.
· Wizard Source Code may not be provided as part of the public release of EDK 2.0 - we are deferring that decision until after the licensed customers have reviewed the content.
5.1 Required Features

· Localization Support based on locale  (support for English - default, French and Simplified Chinese will be provided initially.)
· If we do NOT provide source for building the Wizard (we should) then we need to figure out a way to provide user defined localization. 

· Localization support is for application text / mnemonics only. 
· Localization of the XML forms data is not supported.

· The wizard must support accessibility features, such as no mouse.

· The wizard must conform to the “Java Look & Feel Guidelines” by Sun Microsystems Inc.

· The Wizard must adapt to changes in the XML Schema that defines the surface area of modules, packages and platforms.

· The Wizard will be provided as a stand-alone Java Executable (JAR) file, without needing to install software other than Java (except that the EDK/MDK must be installed and initialized to access the SurfaceArea.jar file.)
· The Wizard must execute on Microsoft Windows, Linux and MAC OS X operating systems.

· The developer must be running a window manager capable of displaying a graphical user interface.

· There are NO command line options for this wizard.

· The wizard must ensure that it working within a valid WORKSPACE

· The wizard must ensure that the WORKSPACE has been initialized (edksetup has been run.)

· The Wizard must support having one MSA, one SPD and/or one FPD file open simultaneously.  ONLY one file of each type is currently supported.
· The Wizard must also support opening of text files (INF or DSC) file in another (fourth) tabbed pane.  This tabbed pane should ONLY appear if the Import INF or Import DSC function is selected.  The tab will display either INF or DSC, it will not display the file name or other attributes of the legacy file.

· INF and DSC files MUST be opened read-only, and the content displayed in the FormEdit window can be copied using highlight with either mouse or the CTRL SHIFT arrow keys on to the clipboard.

· Paste into fields the clipboard contents.

· The Wizard must also support updating the FrameworkDatabase.db file transparent to the user.

· The wizard must support editing multiple open files.  Since the MSA and SPD files are closely coupled, they will probably need to be updated at the same time.  Being able to switch between the SPD and the MSA file, and the ability to use copy and paste, will minimize potential data entry errors.  Additionally, the wizard should be provided for Platform Definition (FPD) files, as one of those may also need to be opened by the developer when modifying SPD or MSA files.
· The Wizard MAY need to open an SPD file when a NEW MSA file is requested by the developer (the developer should be presented with an option to open or create an SPD when they create a new module.)
· The Wizard must be capable of updating the SPD/MSA files - the developer must be able to copy and paste information from one open file to another open file.
· The wizard must present valid entries as drop down menu items, scroll down menus or check boxes for preconfigured data.  For FPD files, we will want to scope the PCD entries in the SPD files of the Modules added to the platform.  We will also want provide Library Instance information for the library classes required for modules (and other libraries - since a library can require another library class.)

· The user must be able to open a Framework file by either clicking on the displayed name in the Tree View, or through the open dialog box.

· The wizard must support standard text edit features, such as delete, cut, copy and paste.

· The wizard must allow the user to configure preferences that are persistent for the wizard.  (Future, initial release - will be per WORKSPACE.)

· The wizard must present all possible tags (both required and optional) in a user friendly manner.  Required elements should be suffixed with an asterisk “*” character.

· The wizard must allow the user to edit all fields that are not computed without any additional steps (other than to position the cursor within the field.)
· The wizard must type check all data as it is type into the entry fields. When the user changes fields (using TAB, Mouse or Keyboard shortcut) or selects a different item from the Tree-View, the application needs to validate the data just entered, prior to changing the focus of the screen.  If the data is not valid, a error dialog needs to popup with an appropriate error message, informing the user of the error.  When the user acknowledges the error with one of two options, 1) fix - the user will be returned to the field (with a hint as to what’s wrong by the label) for correction, or 2) - ignore, the data is left as it is, with the wrong data and focus is changed.  When the user tries to save the form (Save, Save As or Save All) another Error message will allow the user to either fix all errors (one at a time) or ignore the errors and just save the document(s.)
· The wizard must present valid entries as drop down menu items, scroll down menus or check boxes for preconfigured data.  Example, LibraryClass selection in an MSA file should be a drop down menu of valid defined classes that match the target EFI component type of the Module: PEIM Component will only show LibraryClass entries on the system that are related to PEIMs.

· When Creating a new Module, the developer must be presented with the option to either select a package to add the module, create a new package or defer assigning the module to a package at a later time. NOTE: Until a module is assigned to a package, the Framework Infrastructure will not be able to track the module.  It may be re-opened only through the File -> Open dialog.
· The Developer will be given Cancel options for every step, so that they may abort changing of data at any time.

· The entry data will be persistent throughout the course of changing between forms.   The developer MUST not have to select any special buttons to record data. (No DONE button is required.)

· The Save or Save As actions will cause the data to be written to a file.  If the developer selects Save, and there is no open file, the Save As dialog will open.
· The Close menu item will check to see if any data in the opened file has been changed, and if it has, it will prompt the developer to SAVE, SAVE AS or CANCEL.
· The Exit menu item will check to see if any data in the opened file has been changed, and if it has, it will prompt the developer to SAVE, SAVE AS or CANCEL.

· If a developer opens an MSA (File -> Open, or double click) they will be able to edit the Module Header.  However, if they chose to edit an SPD file Module Name, the Wizard can prompt the developer to determine if the Wizard should update the ModuleName field in the MSA file.  If the developer is trying to perform a copy type operation, then the Clone Module Surface Area feature of the Wizard should be used.

· NOTE: Filenames of SPD, MSA or FPD files do NOT have to match the PackageName, ModuleName or PlatformName.  The File -> Save As feature is for storing the file under a different name - this should only be available for MSA and SPD files after a NEW operation.  FPD files can always use the File -> Save As feature.

· A Platform (FPD) file operation of Save As must update the FrameworkDatabase.db file automatically.

· A Platform (FPD) clone operation within the WORKSPACE must update the FrameworkDatabase.db file, adding an additional entry.  The cloned platform must have either a new Guid or an updated version.

· An Package (SPD) file operation of Save As must update the FrameworkDatabase.db file automatically.

· A Package (SPD) clone operation within the WORKSPACE must update the FrameworkDatabase.db file, adding an additional entry.  The cloned package must have either a new Guid or an updated version. 

5.2 Future Development

· Stubs for the following future work must be include

· The wizard must support editing of multiple files.  More than one MSA, SPD and FPD file may be open at any one instant in time.
· The Wizard will keep track of MSA/SPD file pairs in the multiple file open instance.

· Wizard will provide two template C files, one ModuleName.c and another, ModuleName.h file with some information (parsed from the MSA file) added.

· The Wizard will provide an option to the Platform Integrator to “automatically” update ModuleGuid and/or ModuleVersion attributes, if they have been specified and either of these two values get changed in the SPD/MSA files.

· The Wizard must be capable of updating the SPD/MSA pair when a change in the SPD file requires a change in the MSA file that the Wizard is aware of (such as changing the ModuleGuid.)

· Localization of future implementation of Status Color Codes and Indicators (for Section complete, Section Incomplete, Section not viewed.)
· The wizard must present valid entries as drop down menu items, scroll down menus or check boxes for preconfigured data.  Example, LibraryClass selection in an MSA file should be a drop down menu of valid defined classes that match the target EFI component type of the Module: PEIM Component will only show LibraryClass entries on the system that are related to PEIMs.

· The wizard must support page setup and print capabilities.

· The wizard must support both Standard (form displays only required elements) and Advanced (form displays required and optional elements.)

· The wizard must support Find and Find Next within the context of the Form-Edit window only.  (It will not support Find and Find Next within all open files.)

· View Doxygen output from source files (permitting a developer to read the documentation included as part of a source file.)

· View Doxygen output from all sources files belong to a single module.

· Document selection, Contents, Index and Search support for documentation included as part of the EDK.

· Framework Database manipulation - directly modify the FrameworkDatabase.db file.

· Ant Builds

· Progress bar indicators for Clone and Build features.

· Code Size estimation (heuristics for code size on a module basis)

· Additional Administrative functions.

· Execution of the edksetup.bat file.

· Support standard text editing capabilities (for modifying source code.)

· Support for inserting statements (PPI and PROTOCOL) into the auto-generated C source code files.

· Support for automatically updating EDK from a website.

· Merging multiple Modules into a single module (combining MSA files into a single MSA file and archiving the original MSA files.)

· Support for Find and Find Next across multiple files.

· Support Search and Replace within the context of the View-Edit window.

· Support Search and Replace across multiple files.

· Library Class Selection

· The developer will be allowed to select the module components from the list of available modules on the platform, however they will NOT be required to select the library instances as they add modules to the platform.  After all modules have been added, the tool will scan all of the MSA files to determine all of the LIBRARY CLASSES that are needed, and present this list to the platform developer (per below.)  The platform developer can “globally” assign Library Instances to each of the Library Classes required.  

· The Wizard must provide the developer with a list of Library Instances that can be used “globally,” which is to say, the Wizard must scan all MSA files to determine what Library Classes are required by every module.  The Wizard will parse this list to determine

1) If there is only one library instance that supports a library class, then the wizard will automatically complete the library instance entries for every module that uses that library class; 

2) If more than one instance supports the library class and more than one module uses the library class, the developer will be presented with “global” setting of the library instances - every module using that class will be completed using the global library instances with an option to change the library instance on a per module basis; 

3) If more than one instance supports the library class and only one module uses the library class, the developer will be presented with the list of library instances that may be selected for the individual library.

NOTE: There can be ONE and ONLY ONE Library Instance defined for a Module Library Class.

· The wizard must provide the developer with the option to specify a different (with respect to the global definition) library instance for every module.

· Create <ModuleName>_<arch>.c template files.

5.3 Not required for this Wizard 

These are System Environment Variables, and as stated previously, the Wizard is not capable of modifying the system environment.
· Set the Active Workspace  (Environment variable: WORKSPACE)

· Set the “Active Platform” target (Environment variable: ACTIVE_PLATFORM)  NOTE See below WORKSPACE/Tools/Conf/target.txt.

NOTE: Not an environment variable - Flat file and command-line tool are needed.  For Active_Platform, we need to define if this is the UI_Name, the platform_Guid or the uri to the fpd file.
· Set the “Active Tool Chain” (Environment variable: TOOLS_DEF)

DO WE SET the tagname here or the filename for parsing, i.e., not set, used tools_def.txt, otherwise a filename?  files must always be in the tools/conf directory!
· Initialize a WORKSPACE (execute the edksetup.bat file)

· Provide Build button for executing ANT on selected Platform Files.

6 
Configuration Requirements

· The WORKSPACE is the “root” element for the Framework.
· The Framework Database must always be located in the WORKSPACE\Tools\Conf directory.  The Framework Database contains “records” that include the location, relative to the WORKSPACE, of package (SPD) files.

· The SPD files must be placed in the package’s “root” directory.  The location of the SPD file defines the branch that will parsed for module and library MSA files.   The SPD file contains “records” that include the location, relative to the SPD file, of MSA files that are associated with the SPD 
· The MSA files are leaf files that belong to an SPD file and must be within the directory hierarchy of the SPD.

· The Platform Description files (.FPD) are special instances of a package.  Normally, a platform requires custom modules, and as such, these modules must be part of a package (defined in the SPD file.)  An FPD file will not be part of a package (SPD) and may be placed anywhere within the WORKSPACE.  NOTE: At present, the build.xml and the FPD file must be within the same directory.
· The Framework Database also contains a list of Platform (FPD) files.

· The Output of a build will be underneath a Build directory of the directory containing the FPD and build.xml file.  The Output directory must be specified by the developer in the FPD file. The following is a high level, simplified diagram of the WORKSPACE directory layout, showing a build output directory underneath a platform directory.

[image: image1]
Figure 6‑1 Typical WORKSPACE Layout
· Policy Administration - the wizard provides an administrative menu item that permits setting policies for module and package creations.  Currently only one policy rule has been defined.  The Policy is maintained a section of the Framework Database.

· Package Creation Policy - The wizard will allow an administrator to restrict the creation of packages.  There are three states for this policy - No Restriction, Single and Multiple.  No Restriction means that a module developer can create a new package for new modules.  Single means that there is pre-defined package that All new modules must be added to, while Multiple means that there is a restricted list of packages that the module developer will be allowed to add a module to.  The wizard will provide a radio box selection for this policy.
· The wizard must provide the administrator with a list of PACKAGES in the WORKSPACE that are marked as read-only, that can be specified for either the Single or Multiple states.

6.1 Create new Module Surface Area Description (.MSA) files.
· After the developer selects the module type, the Wizard must present choice lists that are pertinent only to the module type selected, these choices must include (but are not limited to) Library Classes, Protocols, Ppis, Guids and Pcds.
· The developer must associate the module with an existing, or create a new, package (SPD) file, before creating the MSA file.
· The MSA file MUST be associated with an SPD file.  The Framework Build infrastructure does not permit unassociated MSA files.

· The wizard must update the SPD file from changes made to an MSA.

· The wizard must automatically add pertinent PCD information into the SPD file.

· The developer must be given the option to associate the module with an existing, or create a new, platform (FPD) file.
· The wizard must update the FPD file.

· The Framework Build infrastructure does not require associating a module to an FPD file, however the association is required if a the developer plans to build the module.

· The wizard must update the Framework Database file if a new package (SPD) or Platform (FPD) file is created.

· The Wizard must create basic <ModuleName>.c and <ModuleName>.h files

· The Wizard must create a build.xml file.

· The developer can select the directory name in which to create the module.

· If the new module is of type Library, make certain the directory, Package\Library exists (create the directory, Library if it does not exist.)

· Assist the developer in setting up the developer’s target build architecture (Architecture Independent, or any combination of IA32, X64, IPF or EBC)

· Modify the MSA file to include SupArchList attribute.

6.2 Create new Surface Area Package Description (.SPD) files.
· When creating a new SPD file, the wizard must update the Framework Database file.

6.3 Create new Framework Platform Description (.FPD) files.
· When creating a new FPD file, the wizard must update the Framework Database file.

· The wizard will allow the Platform developer to specify either a flash definition file (FDF) or generate a flash definition in the FDP file.  (This is form driven from the XMLSchema.)

· The Wizard should assist the developer in creating the Flash definition (XML,) if the developer is not using a Flash Definition (FDF) file.

· Setup the developer’s target build type: “DEBUG,” “RELEASE” or “BOTH.”  (NEW XMLSchema Element for FPD Header, <BuildTarget> with the enumerated data type.)
· The wizard must provide the developer with a selection list of modules to include, and automatically add them to the correct section on the Wizard Display (SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVERS, OTHER_COMPONENTS) None of these sections in the FPD file, however the Wizard should display the modules in the sections that the module belongs to.
· As a developer adds a module to the platform from the list of available modules, the will be required to complete the Library Instance Data for each module. As the module is added to the platform, the developer will be requested to select an instance that will provide the class.  Since a library instance may also specify library classes that it depends on, the PI may have to select numerous library instances for a module (more instances than library classes llisted in the MSA file .)
· 1) If there is only one library instance that supports a required library class, then the wizard will automatically complete the library instance entries for the new module; 

· 2) If there is more than one library instance that supports a required library class, then the wizard will present the list of library instances that supports the class, the selection drop down should have any “Recommmended” instances highlighted.

· 3) If there are no library instances that support the required library class - the wizard needs to popup a WARNING Dialog box!

NOTE: There can be ONE and ONLY ONE Library Instance defined for a Module Library Class.

· The Wizard must permit the platform developer to define FPD PCD Build Definitions.

· The Wizard must provide the platform developer with easy configuration of PCD entries.

· The Wizard must provide the platform developer with an easy means of describing PCD information in the SPD files.
· During Platform creation/modification, the Wizard must be able to provide help text from existing definitions - using the mouse hover capabilities to provide Abstract information, and the Description data as a menu option on a (right) mouse click.  Additionally, the HelpText fields from both the SPD and MSA files must be made available for Platform Integrators.  The HelpText fields are additive, in that the (optional) MSA HelpText is used to give additonal information beyond that provided by the SPD file.
· During Platform creation/modification, the Wizard must provide drag & drop capability for adding/removing modules from a platform definition.

6.4 The Wizard will NOT provide features for creating Custom Build files, as this feature is not supported.
· The wizard will auto-generate a build.xml file for modules and platforms MUST be common between all module types; platform build.xml files must be common for all platform types.  Customization of build.xml files used by ANT is not supported by the build tools.
6.5 Import (Migrate) an existing INF file to a new MSA file.
· The wizard must automatically detect additional files declared in the include statements in the INF files - IFF they provide the original EFI_SOURCE environment variable.

· When migrating an INF file to a new MSA file (opening an INF file automatically creates a new MSA file, however no SPD nor FPD file will be associated with the new MSA until the developer hits Save (note for INF files, the save action will open the Save As dialog box.)  Prior to Saving the new file, the SPD and FPD Dialog boxes normally associated with the New function are opened.

· If a developer choose to migrate an existing INF configured module by opening a new MSA file, the Wizard will use the Import menu item to fetch the INF/DSC/ENV files associated with the existing module.

6.6 Import (Migrate) an existing DSC file to a new FPD file.
· The wizard must automatically detect additional files declared in the include statements in the DSC files - IFF they provide the original EFI_SOURCE environment variable.

· If a developer choose to migrate an existing DSC configured module by opening a new FPD file, the Wizard will use the Import menu item to fetch the DSC/ENV/INF files associated with the existing module, and will attempt to resolve INF Guid values to previously migrated MSA Guid values.

· The Wizard must be capable of automatically opening pertinent, additional DSC/INF/ENV files within the directory structure of the migration source (INF/DSC) file.

6.7 Development Environment

· Setup the developer’s tool chain definitions (Multiple tool chain definitions are permitted)

· The wizard should be capable of letting the developer change WORKSPACE (however, before changing the WORKSPACE, all open files must be closed, and any file with changes pending must give the developer the option to save, discard or cancel.)

6.8 Basic Capabilities

· Modify existing MSA files.
· Modify existing SPD files.
· Modify existing FPD files.
· Clone existing MSA file to a new <ModuleName>.msa file within the same directory, includes updating the Guid/Version and updating the SPD file.
· Clone an existing Module to a new directory/module, includes either updating Guid/Version or adding to a different package using existing Guid/Version and updating the SPD file.

· Clone existing SPD file to a new <PackageName>.spd file within the same directory - requires updating either the Guid/Version and updating the Framework Database.
· Clone an existing package to a new directory, copying the entire directory structure, updating the Guid or Version and updating the Framework Database.

· Clone existing FPD file to a new <PlatformName>.fpd file within the same directory.
· Clone existing Platform directory structure to a new directory within the WORKSPACE, updating the Guid or Version and updating the Framework Database.

· Clone an existing WORKSPACE to a new location (includes copying the entire directory structure to a new directory tree.

· Clone an existing tool definition file to a new tool definition file within the active WORKSPACE.

· Clone an existing tool definition file to a new WORKSPACE.

· The wizard must be capable of taking “Human Readable Form Style Sheet” data and converting it into XML that will be saved as the configuration files.  It must also be capable of converting the XML data and placing it into the “Form Style Sheet” for further editing.

· In the ADVANCED VIEW, after the assignment, the developer will be given the option to override each library instance on a module by module basis.

7 
Modification of Text Configuration Files

7.1 Build Tool Changes

The Build Tools must automatically detect and build appropriate output using the following.  

Parse the target.txt file. The Target property is a LIST of targets using the target name.  DEBUG, RELEASE and/or USER_DEFINED_STRING targets can be specified in the target.txt file - DEBUG and RELEASE are predefined tags, however a user defined NAME (single WORD) is permitted to select differet options and/or different compilers.

Parse TOOLS_DEF file to get a list of tools by TAG and ARCH.

Parse the FPD file for supported ARCH types.

WORKSPACE/Tools/Conf/target.txt

This file is used to store the “CONTEXT” of the BUILD Target for the developer.  It will also be used as persistent storage for the “CONTEXT” Build Platform.  Exactly what and how the last item will be stored, and the nature of the command-line tools that will be needed to maintain this file are to be defined.  We will also need to define how this file is used.
WORKSPACE/Tools/Conf/tools_def.txt

The following file format is used for defining a tool chain set to be used for compiling images.  Note that tools_def.txt is created from the tools_def.template file the first time the edksetup script is executed.  Developers are encouraged to generate one or more of their own files (which can be any filename.txt) using the Wizard Tool Chain Configuration menu.  Setting the TOOLS_DEF environment variable to filename.txt will override the default use of tools_def.txt.  NOTE: The file, TagName_tools.txt is being removed.  The tools_def.txt file will be created the first time the edksetup script is run from the template, Tools/Conf/tools_def.template file.  This file contains default values for all vendors, and should be edited before running any other files.
Note: Three TagNames have been pre-defined, MSFT, GCC and INTC.  The developer may choose to create their own TagName identifiers, however they must also create a TagName_tools.txt file that contains the default flags for each of the ARCH_TOOLCODE specified in this file.
Note: Two Target names have been pre-defined, DEBUG, RELEASE.  The Target element may be a wildcard of * or a user defined NAME.
Table 7‑A Tool Chain Configuration Scheme

	IDENTIFIER = TagName
	This value is used as “Help Text” by the Wizard.

	Host Tool Chain (Tools used to build the Framework Tools)

	HOST_ARCH = IA32 | X64 | IPF
	This value is the architecture of the development system

	TagName_HOST_CC = /usr/bin/gcc
	This is the fully qualified path and name of the compiler used for generating FrameworkTools executables, i.e., GenSection.exe

	TagName_HOST_DLINK = /usr/bin/ld
	This is the fully qualified path and name of the dynamic linker used for generating FrameworkTools executables

	TagName_HOST_SLINK = /usr/bin/ar
	This is the fully qualified path and name of the static linker used for generating FrameworkTools executables.

	TagName_HOST_ASL = /usr/bin/intel/iasl
	This is the fully qualified path and name of the ACPI Assembler.  The output of this assembler is architecture independent, so it only needs to be specified once.

	TagName_HOST_CC_FLAGS =

string
	Add Compiler Arguments here

	TagName_HOST_DLINK_FLAGS = string
	Add Dynamic Linker Flags here

	TagName_HOST_SLINK_FLAGS = string
	Add Static Linker Flags here

	TagName_HOST_ASL_FLAGS = string
	Add ACPI Flags here

	The remainder of the file uses the following nomenclature to specify different tools, note that * means all

	TARGET_TagName_ARCH_ToolCode_Attribute

	Target = BUILD | RELEASE | ALL | USER_DEFINED_STRING
TagName = User defined tag name - any Word string

	ARCH = IA32 | X64 | IPF | EBC (Note: ARM and PPC  are also defined, but not implemented.)

	ToolCode = CC, SLINK, DLINK, PP, ASM, ASMLINK, ASL, UserDefined

	Attribute = NAME, PATH, DPATH, SPATH, EXT, FLAGS, FAMILY

	Target_TagName_ARCH_*_FAMILY = GCC | INTC | MSFT

	Target_TagName_IA32_*_PATH = /path/to/all/executables

	Target_TagName_IA32_CC_DPATH = /path/to/mspdb71.dll  (NOTE: Only required for the Microsoft IA32 Compiler

	Target_TagName_ARCH_CC_NAME = compiler executable name

	Target_TagName_ARCH_SLINK_NAME = static linker executable name

	Target_TagName_ARCH_DLINK_NAME = dynamic linker executable name

	Target_TagName_ARCH_ASM_PATH - /path/to/assembler

	Target_TagName_ARCH_ASM_NAME = assembler executable name

	Target_TagName_ARCH_ASMLINK_PATH = /path/to/assembly linker

	Target_TagName_ARCH_ASMLINK = assembly linker executable name

	Target_TagName_ARCH_ASM_EXT = .s

	Example: Of ASM_EXT

	*_MSFT_IA32_ASM_EXT = .asm

	*_GCC_IA32_ASM_EXT = .s

	Target_TagName_ARCH_PP = preprocessor executable name

	Multiple TagName definitions are allowed for each ARCH.

	Using Multiple TagName definitions will build the output code for EACH TagName Tool


7.1.1 Tool Flags configuration (BUILD OPTIONS)
All Tags are to be kept in the Tools Definition file. The format for specifying different flags is:

TARGET_TagName_ARCH_TOOLCODE_FLAG = All Flags on a Single Line per Tool

You only need to specify the flags for ARCH tools you have defined in the Filename.txt file above.  The following table shows the format for this file.  Note, if X64 or IPF have not been defined in the TOOLS_DEF file, then any lines starting with X64 and/or IPF are ignored.  MSFT, INTC and GCC files have been specified as a reference.
NOTE: The tools processing the TagName.txt and the tools_def.txt files are case sensitive, to make sure that case sensitivity is preserved.

DEBUG_MSFT_IA32_CC_FLAGS = "/nologo", "/W3", "/WX", "/GX", "/Gy", "/Gs-", "/c"

DEBUG_MSFT_IA32_SLINK_FLAGS = "/NOLOGO"

DEBUG_MSFT_IA32_DLINK_FLAGS = "/NOLOGO", "/IGNORE:4086", "/MAP", "/OPT:REF","/DLL"

DEBUG_MSFT_IA32_ASM_FLAGS = "/nologo", "/W3", "/WX", "/c", "/coff", "/DEFI32"

DEBUG_MSFT_IA32_ASMLINK_FLAGS =

DEBUG_MSFT_IA32_PP_FLAGS = "/P"

RELEASE_INTC_X64_CC_FLAGS = "/nologo", "/W3", "/WX", "/GX", "/Gy", "/Gs-", "/c"

RELEASE_INTC_X64_SLINK_FLAGS = "/NOLOGO"

RELEASE_INTC_X64_DLINK_FLAGS = "/NOLOGO", "/IGNORE:4086", "/OPT:REF","/DLL"

RELEASE_INTC_X64_ASM_FLAGS = "/nologo", "/W3", "/WX", "/c", "/coff", "/DEFI32"

RELEASE_INTC_X64_ASMLINK_FLAGS =

RELEASE_INTC_X64_PP_FLAGS = "/P"

RULE: If the Arch is supported in the FPD, for each tool chain been specified for an Arch in the TOOLS_DEF file (the TagName portion of the tool specification) build directory will be TARGET\TagName\ARCH.
Example 1:

TARGET = ALL is specified in the target.txt file.

MSFT_IA32_CC, BOB_IA32_CC and GCC_IA32_CC are specified in the TOOLS_DEF file.

No tools are specified for X64, IPF or EBC.

The FPD file has support for IA32, X64, IPF and EBC.

The Platform Build directory tree will look like the following, output in the bottom directory:

DEBUG\MSFT\IA32

DEBUG\MSFT\FV

DEBUG\GCC\IA32
DEBUG\GCC\FV

DEBUG\BOB\IA32

DEBUG\BOB\FV

RELEASE\MSFT\IA32
RELEASE\MSFT\FV

RELEASE\GCC\IA32
RELEASE\GCC\FV

RELEASE\BOB\IA32

RELEASE\BOB\FV

Example 2:

TARGET = DEBUG is specified in the target.txt file.

Only one tool chain tag name is defined: BOB_IA32_CC, BOB_X64_CC and BOB_IPF_CC are specified in the TOOLS_DEF file.

The FPD file has support for IA32, X64, IPF and EBC.

The Build directory tree will look like the following, output in the bottom directory:

DEBUG\BOB\IA32

DEBUG\BOB\X64

DEBUG\BOB\IPF

DEBUG\BOB\FV

NOTE: The output directory for a firmware binary image is FV, which will be created under the TagName Directory, a the FV directory is a sibling of the ARCH directory.
8 
Framework Wizard Initialization
During initialization, before the main screen is displayed, the following Splash Screen will be displayed.  As soon as the main frame of the application starts, the splash screen will close automatically.  Based on some of the information that must be obtained during initialization, it is recommended that some sort of progress indicator be used.  Recommended progress would be to display the Spd PackageName, and, based on the number of MsaFiles listed, show % complete using #of MSA Read / Total # of MSA * 100.  The % should be updated on a minor tick of 5%.
[image: image2.png]ms-TianoCore

I Or Pt e e

Framework Wizard

Intilizaing,

Gonpion @ 208 Tan Cagmaion




Figure 8‑1 Splash Screen (w/o Progress bar)
8.1 Workspace Validation

The system environment variable, WORKSPACE must be validated. 
While WORKSPACE is not valid, do the following:
If a WORKSPACE variable has not been specified or the WORKSPACE is not valid, a Dialog browser will query the user for a valid workspace.  The following error messages and conditions will be used.
The environment variable is displayed in the title as shown below.
If the Workspace is null - the error message, “WORKSPACE Environment Variable Is Not Defined” will be displayed (as shown below.)
If the Workspace is defined, but it does not exists - the error message, “WORKSPACE Environment Variable Is Not Valid” will be displayed.
If the Workspace is defined, but it is not a directory - the error message, “WORKSPACE Environment Variable Is Not a Directory” will be displayed.
If the Workspace is defined, but the %WORKSPACE%\Tools\Conf\FrameworkDatabase.db file is not found - the error message, “WORKSPACE Environment Variable Is Invalid” will be displayed.
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Figure 8‑2  Workspace Selection (showing an ERROR)
NOTE: This does not change the System Environment Variable, WORKSPACE, it only applies to where the Wizard will manage modification and file creations.

//
// Returns TRUE if the Workspace is valid

//

WorkspaceValid(x)

{

}

Once the WORKSPACE has been validated, additional initialization proceeds as follows.
8.2 Validate Tools have been built

The application will determine if the WORKSPACE has been initialized - if the file, WORKSPACE\Tools\Jars\SurfaceArea.jar exists, the WORKSPACE is assumed to be initialized.
//

// Returns TRUE if the Tools have been built

//

TianoToolsUpToDate(x)

{

}
8.3 Get Wizard Preferences

The application will determine if a language, other than the default, has been selected, and will load the appropriate resource definitions.  The initial localization will support: English - default (en_US,) French (fr_FR_EURO) and Simplified Chinese (zh_CN)  These localization resources will be supported in files that define the different keys for the localized values.  String and Mnemonic keys are defined in the resource bundles.  Strings are provided for menu labels, button labels and tool tips text.  Initially, the localization preference will be stored in the Framework Database file.  

NOTE: when the tool is first started, it will attempt to read the System environment variables to obtain information, such as locale, however the developer may have specified a different locale during a previous session.  The Tools/Conf/.wizpref.xml file contains all preferences, in the <Preferences> section.

NOTE: XML Tag definitions and “Style sheets” used for Form completion will only be available in English (en_US.)
//
// Returns localization,
//   Check the system environment
//   Check wizard preferences file for locale 
//
getLocalization(x)
{

}

//

// Returns SPD Policy

//

getPolicy(x)

{

}
//

// Returns Recent Files

//

getRecentFileList(x)

{

}
8.4 Validate Wizard support for Framework Specification
Verify that the Wizard is capable of processing the XML Schema.

· Verify the FrameworkDatabase.db element FdbHeader.Specification is: FRAMEWORK_BUILD_RELEASE_SPECIFICATION 0x00000052
//
// Returns TRU if Wizard supports this version of the XML Schema

//

supportSchema(x)

{

}
8.5 Get WORKSPACE Information

The application will scan the WORKSPACE and build an internal “database” of information.  The Scan is performed by:

· Open the WORKSPACE\Tools\Conf\FrameworkDatabase.db file and locate ALL SPD and FPD files. Open every SPD file and locate ALL MSA files.
//
// Create the in memory cache of the WORKSPACE information

//

createWorkspaceDb(x)

{
  FileKeyValue = 0;
  For (SpdFile = FrameworkDatabase.PackageList.Filename; SpdFile != NULL; SpdFile = NextItem (SpdFile)) {
    FileKeyValue +=1;
    Psa = open(SpdFile);
    SpdTable[FileKeyValue].Guid = Psa.SpdHeader.GuidValue;
    SpdTable[FileKeyValue].Version = Psa.SpdHeader.Version;
    SpdTable[FileKeyValue].location = SpdFile;
    AbstractTable[FileKeyValue] = Psa.SpdHeader.Abstract;
    DescriptionTable[FileKeyValue] = Psa.SpdHeader.Description;
    LibraryClassTable[FileKeyValue].UiName =

      Psa.LibraryClassDeclarations.LibraryClass:Name;

    LibraryClassTable[FileKeyValue].Header =

      Psa.LibraryClassDeclarations.LibraryClass.IncludeHeader;
    LibraryClassTable[FileKeyValue].HelpText = 
      Psa.LibraryClassDeclarations.LibraryClass.HelpText;

8.5.1 Create a “database” 
· Using the information for the FrameworkDatabase.db file, every SPD file and every MSA file. This database contains information that will be used to complete any type of Framework file, MSA, SPD or FPD.  Due to the size, a relational database is recommended.  All FPD and SPD files are identified by a unique Guid/Version pair, and all MSA files are identified by the Package Guid/Version pair and the MSA file’s Guid/Version pair.  We may want to add a location for every SPD and MSA file as part of this “database.”  While an MSA may depend on a Package using the GuidValue only, using any version (highest version number in the DB) when we track the information on the system, we do need to track both the GuidValue and the Version in the DB.
· From the FrameworkDatabase

· PackageList.Filename (Path and Filename)
· For Each SPD (NOTE: Library Class Definitions should only be listed once in the package that is defining the library class, however, since we are permitting multiple instances packages that might define a library class - different versions - the class itself may be listed more than once.)
· SpdHeader.PackageName, SpdHeader.GuidValue, SpdHeader.Version, SpdHeader.Abstract, SpdHeaderDescription, PackageDefinitions.ReadOnly, PackageDefinitions.RePackage, PackageLocation (Calculated) GuidDeclarations.Entry:Name, GuidDeclarations.Entry:GuidTypeList, GuidDeclarations.Entry:SupArchList, GuidDelcarations.Entry:FeatureFlag, GuidDeclarations.Entry:SupModuleList, GuidDeclarations.Entry.C_Name, GuidDeclarations.Entry.GuidValue, GuidDeclarations.Entry.HelpText, ProtocolDeclarations.Entry:Name, ProtocolDeclarations.Entry:SupArchList, ProtocolDeclarations.Entry:FeatureFlag, ProtocolDeclarations.Entry:SupModuleList, ProtocolDeclarations.Entry.C_Name, ProtocolDeclarations.Entry.GuidValue, ProtocolDeclarations.Entry.HelpText, PpiDeclarations.Entry:Name, PpiDeclarations.Entry:SupArchList, PpiDeclarations.Entry:FeatureFlag, PpiDeclarations.Entry:SupModuleList, PpiDeclarations.Entry.C_Name, PpiDeclarations.Entry.GuidValue, PpiDeclarations.Entry.HelpText, PcdDeclarations.PcdEntry:SupArchList, PcdDeclarations.PcdEntry:FeatureFlag, PcdDeclarations.PcdEntry:SupModuleList, PcdDeclarations.PcdEntry.C_Name, PcdDeclarations.PcdEntry.Token, PcdDeclarations.PcdEntry.TokenSpaceGuid, PcdDeclarations.PcdEntry.DatumType, PcdDeclarations.PcdEntry.ValidUsage, PcdDeclarations.PcdEntry.DefaultValue, PcdDeclarations.PcdEntry.HelpText
· For each MSA listed in an SPD file. (Track the PackageGuid and PackageVersion)
· MsaHeader.ModuleType, MsaHeader.GuidValue, MsaHeader.Version, MsaHeader.Abstact, MsaHeader.Description, ModuleLocation (Calculated) ModuleDefinitions.SupportedArchitectures, ModuleDefinitions.BinaryModule, ModuleDefinitions.OutputFileBasename, LibraryClassDefinitions.LibraryClass, LibraryClassDefinitions.LibraryClass:Usage, LibraryClassDefinitions.LibraryClass:SupArchList, LibraryClassDefinitions.LibraryClass:FeatureFlag, LibraryClassDefinitions.LibraryClass:RecommendedInstanceGuid, LibraryClassDefinitions.LibraryClass:RecommendedInstanceVersion, PcdCoded.PcdEntry:PcdItemType, PcdCoded.PcdEntry:SupArchList, PcdCoded.PcdEntry:FeatureFlag, PcdCoded.PcdEntry.C_Name, PcdCoded.PcdEntry.DefaultValue, PcdCoded.PcdEntry.HelpText
· A Library table can be extracted using the ModuleDefinitions.BinaryModule element to generate a list of LibraryClasses from the ALWAYS_PRODUCED Usage attribute in the LibraryClass elements and they are classified by the ModuleType.  The current MdePkg library classes by module type are listed in Appendix A.  The library table should keep the following:

· From SPD

· LibraryClassDeclarations.LibraryClass:Name, SpdHeader.GuidValue,  SpdHeader.Version, SpdHeader.Abstract* SpdHeader.Description*, LibraryClassDelcarations.LibraryClass:SupArchList, LibraryClassDeclarations.LibraryClass:SupModuleList, LibraryClassDeclarations.LibraryClass:FeatureFlag
· From MSA specified by the SPD if ModuleDefinitions.BinaryModule == true
· MsaHeader.ModuleType, MsaHeader.GuidValue, MsaHeader.Version, MsaHeader.Abstact, MsaHeader.Description, LibraryClassDefinition.LibraryClass, LibraryClassDefinition.LibraryClass:Usage, (*_PRODUCED) LibraryClassDefinition.LibraryClass:SupArchList, LibraryClassDefinition.LibraryClass:FeatureFlag
· This Library Database will be used to quickly filter possible library instances needed to satisfy library class dependecies of a module.  Each record in the database should contain the following:
· Library Class Name (Keyword)
· HelpText
· Architecture Supported

· Module Type
· FEATURE FLAG EXPRESSION
· Library Instance
· Produced (ALWAYS|SOMETIMES)

· Package Guid and Package Version
· Package Abstract and Package Description
· Module Guid and Module Version
· Module Abstract and Module Description
· FEATURE FLAG EXPRESSION
For a Library Instance that supports multiple Architectures, a separate record could be maintained for each architecture, if using a non-relational database for storing this data.  Multiple Library Instances should be kept in separate records if using a non-relational database.
NOTE: For the initial release, the FEATURE FLAG EXPRESSION Flag will not be used to scope valid library instances.
· PROTOCOLS, GUID, PPIS and PCDs tables should be done in a similar manner.

· Special note for PCDs, the Token must be unique to the package that defines it, as identifed by the TokenSpaceGuid.

8.6 Tool Initialization
· Parse the target.txt file and the TOOLS_DEF file to ensure that they exist.  Verify which tools are valid by checking that the path and executable exists.
Once this initialization has completed, close the Splash Screen and start the Main Application display as described in the next section.
9 
Framework Wizard GUI - Design
The following sections cover the functionality of the FrameworkWizard as viewed by the User.  The FrameworkWizard is a stand-alone Java Graphical User Interface (GUI.)  It must support localization as well as provide for both keyboard and mouse events.  The following section contains screen shots from the GUI preliminary design and text sections covering the high level functionality needed behind the scenes.
Screen Shots are provided as a means to provide feedback on the look and feel of this application.  Additionally, this section covers the User Experience and explains the functions of the menu options.  The actual form content requirements are listed in the “Style Sheet” section of this document.  The “Style Sheet” sections contain the required and optional elements each form section that will be displayed in the right Form-Edit pane.
9.1 
9.2 Main Application Screen

The main application will default to a size of 600x400 (WxH) for the entire Frame.  The application will automatically adjust to size up to 1920x1200.  The panes within the GUI application should automatically scroll if the content of the panes exceeds the viewable space.
The Main Screen will open with the left Tree View collapsed and the right Form Edit window empty as shown below.
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Figure 9‑1 Main Screen on Application Startup
The Main Frame (screen) menu items are File, Edit, View, Workspace, Tools, Window and Help.

Three tool bars may be optionally displayed (in the diagram below, the tool bars are present, but do not have icons added at this time.)
The LEFT Panel is the Tree View section, and will be resizable from 145 to 200 pixels, with a default (startup) size of 155 wide.  This panel displays a tree view of the top level elements of an XML schema for the focus document in the right panel.  If the right panel has two sections, the tree view will add another file under the appropriate section (MSA, SPD or FPD)   The Form-Edit Window, active pane is determined by the focus of the document in the Tree View window.
RULE: The Tree MUST display the User Interface Names of the items, not the full path to a file.  The tree will only contain items that are known within the workspace environment.
RULE: If a user creates a new module (MSA) but does NOT associate it with a package file, the user MUST use the File -> Open sequence to re-open the file until the MSA file is added to a package (SPD) file.
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Figure 9‑2 Main Screen View of Tree Expansion
The RIGHT Panel is the Form-Edit window and is resizable from 415 to 1920 pixels in wide, with a default (startup) size of 425 wide.  This Panel may be aligned either top and bottom or side by side into two Panes.  The active pane (focused pane) will have a white background, while the inactive pane will have a grey background.  The content of a Form-Edit pane is one of the following:  Typical Elements, Advanced Elements, Text (from INF, DSC or ENV files) or XML (the MSA, SPD or FPD file as it will be written out to the file.)  When split vertically, the panes will be resizable up to a 25%/75% split.  When split horizontally, the panes will be automatically resizable up to a 30%/70% split.
All forms will be anchored to the base point of the top left of the Panel.  Per the Java Look & Feel Design Guidelines, this is also noted as location x=0, y=0 for a pane and/or panel.

Each Pane will automatically scroll the contents horizontally and vertically, up to a height of 64000 pixels, and width of 1920 pixels.

Opening an MSA file by double clicking the name of the file will automatically open the file and switch to the Header Section’s Form-Edit section, as shown below.
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Figure 9‑3 Main Window Showing an Open File
Tool Bars (FUTURE REQUIREMENT!)
Initially, three Tool Bars are defined, File, Edit and Window.  Java Look and Feel Icons will be used for each of these tool bars, and will be linked to menu actions.  Graphics for these tool bar items are available free of charge from Sun Microsystems, under the terms and conditions of the Sun License which will be provided in the images directory.
The File toolbar will display: New, Open, Save, Save As, Save All, Page Setup, Print, Import and Properties.
The Edit toolbar will display: Undo, Redo, Cut, Copy, Paste, Delete, Find and Find Next.

The Window toolbar will display: Split Vertical, Split Horizontal, Tab View, Source and XML.
9.2.1 Frame Layers

The following diagram shows the basic layers of the application.  As files are opened and closed, they will be set visible in the appropriate window.
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Figure 9‑4  Frame Layers
10 
Framework GUI Menu Options
10.1 File Menu
The following screen shot shows the drop down for the Main Screen File Menu.
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Figure 10‑1 Main Screen File Menu
10.1.1 New Menu Item
The New Menu Item pops up a Dialog Box that lets the user select between one of the following.
Module Surface Area Description file
Surface Area Package Description file
Framework Platform Description file
NOTE REMOVE: Ant Build File from this display
Buttons at the bottom are Next or Cancel
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New Module Surface Area

When a user selects New MSA, a New MSA data structure is created in memory and another Dialog box appears that requires the user to select from a radio box one of the following three options:

Add to existing Surface Area Package Description (default)  - SPD
Create a new Surface Area Package Description - SPD
Defer adding the module to a Surface Area Package Description - SPD

If Defer is selected, and the OK button is clicked, the dialog will close and a new Header form is presented.

If either the Add or Create radio is selected, a new field should appear below the radio boxes that will perform one of two options, depending on the Add / Create Selection.

Add - A drop down selection of the existing SPD files in the Workspace.

Create - Field is editable with a new SPD File name.

Buttons at the bottom are OK or Cancel.

(Graphic will be provided later.)

Once the OK button is selected, if the Add was selected, the Wizard will open the selected SPD file to the Add Modules to Package form.  The SPD form entry will be the active tab in the left pane.
If the Create option was selected, a New SPD data structure is created in memory and the Wizard will open on the new SPD Header form.  The SPD form entry will be the active tab in the left pane.
Refer the to MSA, SPD and FPD Forms in the Sytle Sheet Definition section, later in this document.
As the user completes each section, they will can click on the next section of the XML Schema that they wish to complete.

NOTE: For new MSA files, two source files, <ModuleName>.c and <ModuleName>.h will be created and automatically inserted into the <SourceFiles> element section.
NOTE: For new MSA files, a standard ANT build.xml file is generated.

Refer to the MSA Section of additional features.

10.1.2 Open Menu Item
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Figure 10‑2 File -> Open
Selecting the Open Menu Item starts a File Chooser Dialog box.

10.1.2.1 Open Dialog (File Chooser Dialog)

The Open Dialog should start the user in WORKSPACE directory, and default looking for .msa files.  The section: Files of Type: must list MSA, SPD and FPD file types. 
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If the Cancel button is selected, the Dialog box closes and focus returns to the main application.
If the Open button is selected, the Dialog box closes after returning the file name to the main application.  The following actions take place before any text:

  The File is read into a buffer.

The User Interface Name (ModuleName, PackageName or PlatformName) is used for the tab name in the FormEdit window. 
10.1.3 Close Menu Item
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The Close function will close the focused file, and if there are pending changes, then the user will be prompted with a dialog box with SAVE, DISCARD and CANCEL buttons.
If DISCARD is selected, the contents of in memory will be freed, without writing the memory contain contents to a file.

If the SAVE button is selected, and the focused file exists, the file will be saved, and the application container will be closed.
If any other documents are open in memory, focus will shift to the last document that was opened, otherwise the FormEdit window will be blank.

Blank FormEdit windows will have either Module, Package or Platform for tab 

10.1.4 Recent Files Menu (FUTURE IMPLEMENTATION)
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The application will track up to a user defined number of the last files created or opened by this wizard.  This information will be stored in a properties file in the Tools/Conf directory.  The properties file will be a hidden XML file.
10.1.5 Save Menu Item
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If the file is an existing file (not a new file,) the file that is under focus will be saved, overwriting the existing file if and only if the file’s buffer has been modified.  If the buffer has not been modified, then the action returns without doing anything.
10.1.6 Save As Menu Item
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Selecting the Save As… file menu option will popup the Save As Dialog box, shown below.

10.1.6.1 Save As Dialog
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10.1.7 Save All Menu Item (FUTURE IMPLEMENTATION)
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For every file that is in an edit buffer, if the file is an existing file (not a new file,) the file that is under focus will be saved, overwriting the existing file if and only if the file’s buffer has been modified.  If the buffer has not been modified, then the action returns without doing anything.  (This is most relevant when a new MSA file is created along with new SPD and FPD files.)

10.1.8 Page Setup Menu Item (FUTURE IMPLEMENTATION)

[image: image18.png]ew_Project Tools Window Help

open..
3

s section

RecentFiles b |\

Properties





10.1.8.1 Page Setup Dialog Box

This implements the java.awt.print class.

<PAGE SETUP DIALOG GRAPHIC TO BE PROVIDED LATER>

10.1.9 Print Menu Item (FUTURE IMPLEMENTATION)
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10.1.9.1 Print Dialog Box

This implements the javax.print class.
<PRINT DIALOG GRAPHIC TO BE PROVIDED LATER>
10.1.10 Import Menu Item (FUTURE IMPLEMENTATION)
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10.1.10.1 Import Dialog Box

<IMPORT DIALOG GRAPHIC TO BE PROVIDED LATER>

This is another Open Dialog box which permits developers to open INF or DSC files.  This is only used during a migration scenario.  An imported file is read into a buffer and any relevant information that can be used to complete entries in an MSA or FPD file are inserted into the appropriate sections of the “Style Sheet.”

10.1.11 Properties Menu Item (FUTURE IMPLEMENTATION)
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10.1.11.1 Properties Dialog Box
TBD

<PROPERTIES DIALOG GRAPHIC TO BE PROVIDED LATER>
10.1.12 Exit Menu Item
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All edit buffers are check to see if un-saved modifications are pending.  If they are, for each file (associated with the edit buffer) the user will be given the choice of SAVE, DISCARD or CANCEL.  If an edit buffer is not associated with file, the SAVE feature will use the Save As Dialog box.

If all edit buffers have no pending data, the application closes.

10.2 Edit Menu
Standard text editing drop downs, with standard mnemonics and keyboard short cuts.  Since these functions are standard to the industry, not special descriptions will be provided for each of the functions.  The only exception is that initially, the Find and Find Next fields are relevant to the focused document only.
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Note, only Cut, Copy, Paste and Delete will be implemented for the initial release.  The remaining functions will be implemented in a future release.
10.3 View Menu
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10.3.1 Toolbars Menu (FUTURE IMPLEMENTATION)
The toolbars selection provides for three toolbars.  If the item is checked, then the toolbar will be displayed, if the item is unchecked, the toolbar will be hidden.

<SCREEN SHOT W/TOOL BAR GRAPHIC TO BE PROVIDED LATER>
10.3.2 Standard Menu Item  (FUTURE IMPLEMENTATION)
This is the default “view” for the forms displayed in the Form-View window.  Only required elements of the XML Schema will be displayed in the form

<SCREEN SHOT GRAPHIC TO BE PROVIDED LATER>

10.3.3 Advanced Menu Item
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All elements of the XML Schema in the Form-View window are displayed - both required and optional.  Required elements noted in the real Form-View display with an asterisk “*” character.
10.4 WORKSPACE Menu
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10.4.1 Admin Menu Item (FUTURE IMPLEMENTATION)
This will popup a Dialog box so that an administrator can set the policies for projects.

The default policy is that a developer may create SPD files when they create MSA files.

The Single policy restricts developers from creating SPD files, only administrators can do that.  Additionally, new MSA files can only be added to a single SPD file.

The Multiple policy restricts developers from creating SPD files, only administrators can do that.  Additionally, new MSA files can only be added to one of a specified list of SPD files.

<ADMIN GRAPHIC TO BE PROVIDED LATER>

10.4.2 Change Workspace Menu Item

This allows the developer to change the active WORKSPACE for the Application.  If any files are open when the user selects this item must be closed, with files that have pending changes popping up the SAVE, DISCARD, CANCEL dialog.  If any data has yet to be saved, the Save As Dialog will open if the SAVE button is selected.  Once the files have been cleaned up, the WORKSPACE Chooser popup Dialog will open.
NOTE The WARNING would not normally appear.   This would only appear if the developer selected OK, but the WORKSPACE entered is not valid.
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NOTE SHOULD WE REMOVE ALL DISTRIBUTION PACKAGE TASKS FROM THIS WIZARD?

10.4.3 Install Distribution Package
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Figure 10‑3 Install Distribution Package Menu Item

This option will popup a dialog box, which will let the user browse for the location of the Framework Distribution Package (FDP) file. There will also be a browser that will allow the user to select, where in the WORKSPACE, the package should be installed.

Prior to installing, the FrameworkDatabase must be checked to see if the package already exists.  The PackageGuid and/or PackageVersion must be different, otherwise the developer will be given an option to either update (replace) or cancel installation.

In all cases (except CANCEL) the FrameworkDatabase will be updated.

Update Distribution Package
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Figure 10‑4 Update an Already Installed Distribution Package

The menu item popup a dialog to locate the distribution package FDP file.

The tool will read the Framework Database and replace an installed package with the contents of the FDP file.  Tests, in order are:

Does GUID exist?


No - Check Package Name



If Package Name does not exists, Popup Dialog with, could not find a matching Package Name to update.  You may need to install this package instead.

                  IFF ONE Package Name values match, Proceed to Directory Location Validation.

                  IFF More than one Package Name value matches, Popup Dialog with, Found more than one Package Name installed.  Show list of Package Names and Abstracts (hidden values will be GUID/Version)  User selects, then proceed to Directory Location Validation.

     Yes - If number of GUID values is 1, Proceed to Directory Location Validation.

                If number of GUID values is more than one, check the package name IFF more than one Package Name value matches, Popup Dialog with, Found more than one Package Name installed.  Show list of Package Names and Abstracts (hidden values will be GUID/Version)  User selects, then proceed to Directory Location Validation.  If only one Package Name value matches, go directly to the Directory Location Validation

Directory Location Validation

   The content of the directory of a previously installed package will be deleted from secondary (near) storage and replaced with the content of the distribution package after verifying that the user wants to it there.

If the user does not want to place the update in the same location, the distribution package will be installed in the user selected location (or the default location as specified in the distribution package) and the original package directory will be removed.

In all cases (except CANCEL) the FrameworkDatabase will be updated.
Distribution Package Removal
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Figure 10‑5 Remove Distribution Package

The tool will read the FrameworkDatabase file and the developer will select the package to remove.  Selecting the package will popup another dialog showing the name, location and version of the package to be removed, along with a warning that all content in the directory will be deleted.  If the developer clicks REMOVE button, then the directory is removed and the FrameworkDatabase file is updated.  If the developer clicks CANCEL, the developer is redirected to the main application window.
10.4.4 Build Targets Menu
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This drop down has Check Box selection.  Debug, Release, All are standard tags.  HOWEVER: The current tools_def.txt file (Or the tools_def.txt file pointed to by the environment ACTIVE_TOOLS) should be parsed.  The Target portion of the lines should be parsed to display any USER DEFINED target types.  User Defined Target types should also be listed as checkbox selections.

This allows the developer to select either DEBUG, RELEASE or ALL.  If User defined, check the content of the target.txt file to see if a name has already been specified, othersize, the Target field in the The results of this selection are stored in the WORKSPACE\Tools\Conf\target.txt file.
10.5 Tools Menu
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10.5.1 Tool Chain Configuration Item
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This selection will popup Dialog boxes that will help the developer complete a tool definition file.  The default, tools_def.txt, and default_tools_def.txt files are configured during WORKSPACE installation.  However, the dialog boxes permit browsing for text files within the context of the WORKSPACE.

Additional functionality in future releases may include setting up standard options for user selected tool chain tags.

NOTE see Table 1 Tool Chain Configuration on the required content of this Dialog box to text file mapping.
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Figure 10‑6 Tool Chain Configuration Start Screen
10.5.2 Clone Menu Item
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Selecting the Clone item will popup a Dialog to lead the developer through the steps of cloning a Module to a new Module within the same WORKSPACE, cloning a package to a new package within the same WORKSPACE, cloning a WORKSPACE to a new WORKSPACE and cloning a tool chain definition to a new tool chain definition.

This option will also permit cloning an existing Module in one WORKSPACE to a new Module in a different WORKSPACE, along with adding that module to a new or existing package in the target WORKSPACE.

Cloning a package from one workspace to another is NOT permitted. It is recommended that the package be installed using the Install Distribution Package item in the Tools menu.

<CLONE GRAPHIC TO BE PROVIDED LATER>

10.5.3 Code Scan (WILL BE PROVIDED LATER)
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Executing the menu item will automatically scan the source files listed in an MSA <SourceFiles> section, and provide completion data for different sections of the MSA and SPD files.  Duplicate entries in an MSA file are not permitted, so the application will merge the existing with those found during the scan.  This function may not be available until a later release.

[Check with Andrew and Mike on design]

<CODE SCAN DIALOG GRAPHIC TO BE PROVIDED LATER>

10.6 Window Menu
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This permits the developer to split the Form-View window into two different panes, Display Top and Bottom, Display Side by Side or tabbed.  This is so that an SPD file can be viewed at the same time as an MSA file.  It may also be useful for view FPD and SPD files simultaneously.
ONLY the Tab View will be provided in the initial release, so that MSA and its associated SPD file can be open at the same time.

10.6.1 XML Menu Item (FUTURE IMPLEMENTATION)
TBD
<SCREEN SHOT GRAPHIC TO BE PROVIDED LATER>

10.6.2 Preferences Menu Item
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This is used to store information about the application, including the locale selection for language display as well as the last (configurable) N number of files that have been opened.  This data is stored in an XML file, Tools/Conf/.wizpref.xml.
<PREFERENCES POPUP DIALOG GRAPHIC TO BE PROVIDED LATER>

10.7 Help Menu
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TBD
<ALL GRAPHIC TO BE PROVIDED LATER>

11 
MSA Style Sheet Definitions

11.1 Module Surface Area File Header Form

This defines what data needs to be displayed and gathered for the MSA Header.  The Field Names are listed in the order that they appear on the screen.
Table 10‑A Module Name
	Description
	User Interface Name

	Required
	Yes

	Editable
	Yes

	Prompt
	Module Name

	Field Type
	String

	Data Type
	xs:NCName

	Field Help
	An brief Identifier, such as USB I/O Library, of the module

	XML Tags
	MsaHeader.ModuleName

	Data Source
	If from File->New and the developer field is blank

If from File->Open read in from file

If from Double Mouse click in TreeView read in from file

	Data Verification
	Loss of focus: verify single word entry

	Hover
	None

	Properties
	None

	Notes
	This field is only used in the UI - TreeView


Table 10‑B Module Guid
	Description
	The Module Guid, part of the Guid-Version pair that uniquely identifies a module

	Required
	Yes

	Editable
	Yes

	Prompt
	Module GUID

	Field Type
	String

	Data Type
	GuidType

	Field Help
	Guaranteed Unique Identification Number (8-4-4-4-12)

	XML Tags
	MsaHeader.GuidValue

	Data Source
	If from File->New, automatically generate

If from File->Open read in from file

If from Double Mouse click in TreeView read in from file

	Data Verification
	Loss of focus: verify entry is a Guid Type

	Hover Option
	This field MUST change if any change is made to the module that will break backward compatibility

	Properties
	None

	Notes
	Provide a Generate Guid button to allow the developer to generate a different GUID


Table 10‑C Module Type

	Description
	The Module type

	Required
	Yes

	Editable
	Yes

	Prompt
	Module Type

	Field Type
	Drop Down

	Data Type
	ENUM value from FrameworkModuleTypes

	Field Help
	None

	XML Tags
	MsaHeader.ModuleType

	Data Source
	If from File->New then use XML Schema FrameworkDataTypes.FrameworkModuleTypes

If from File->Open read file and HighLight entry from file

If from Double Mouse click in TreeView read file and HighLight entry from file

	Data Verification
	None

	Hover Option
	Description of Module Type that is highlighted

	Properties
	None

	Notes
	None



	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	



	
	

	
	

	
	

	
	


Table 10‑E Module Abstract

	Description
	A one sentence description of the module

	Required
	Yes

	Editable
	Yes

	Prompt
	Abstract

	Field Type
	String

	Field Help
	A one sentence description of this module

	Data Type
	Sentence

	XML Tags
	MsaHeader.Abstract

	Data Source
	If from File->New leave blank

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: Must contain \w+\W+(\w+\W+)*

	Hover Option
	Description of Module Type

	Properties
	None

	Notes
	None


Table 10‑F Module Description

	Description
	One or more paragraphs with a detailed description of the module

	Required
	Yes

	Editable
	Yes

	Prompt
	Description

	Field Type
	Strings

	Field Help
	A verbose description of the module

	Data Type
	Paragraph

	XML Tags
	MsaHeader.Description

	Data Source
	If from File->New leave blank

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: Must contain multiple sentences (\w+\W+(\w+\W+)*)+

	Hover Option
	None

	Properties
	None

	Notes
	Display 6 or more “rows” Auto Scroll content VERTICAL (UP AND DOWN) ONLY


Table 10‑G Module Version

	Description
	A non-signed decimal or integer value

	Required
	Yes

	Editable
	Yes

	Prompt
	Version Number

	Field Type
	Number

	Field Help
	A Version Number, 1.0, 1, 1.01

	Data Type
	VersionDataType

	XML Tags
	MsaHeader.Version

	Data Source
	If from File->New Auto populate with 1.0
If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: Must contain (\d)+(.)?(\d)*

	Hover Option
	This field must change if changes are made that do not break compatibility

	Properties
	None

	Notes
	None


Table 10‑H Module Copyright

	Description
	The Copyright for this file

	Required
	Yes

	Editable
	Yes

	Prompt
	Copyright

	Field Type
	Strings

	Field Help
	One or more copyright lines

	Data Type
	Paragraph

	XML Tags
	MsaHeader.Copyright

	Data Source
	If from File->New Leave Blank

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

FUTURE: Autopopulate from an open SPD file.

	Data Verification
	Loss of focus: May contain multiple sentence lines. (\w+\W+(\w+\W+)*)+

	Hover Option
	None

	Properties
	None

	Notes
	Display 4 or more “rows” Auto Scroll content VERTICAL and Horizontal; Field should permit line feed/carriage returns to show multiple Copyright lines.


Table 10‑I Module License

	Description
	The License(s) for this file

	Required
	Yes

	Editable
	Yes

	Prompt
	License

	Field Type
	Strings

	Field Help
	The License for this file

	Data Type
	Paragraph

	XML Tags
	MsaHeader.License

	Data Source
	If from File->New Blank

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

FUTURE: Buttons to have user select from list of known licenses (BSD, Apache)

FUTURE: Autopopulate from an open SPD file.

	Data Verification
	Loss of focus: MUST contain multiple sentence lines. (\w+\W+(\w+\W+)*)+

	Hover Option
	None

	Properties
	None

	Notes
	Display 10 or more “rows” Auto Scroll content Vertical and Horizontal; Field should permit line feed/carriage returns to show multiple lines.


Table 10‑J Module License:URL

	Description
	A URL to use for getting a copy of the license

	Required
	NO

	Editable
	Yes

	Prompt
	URL for License

	Field Type
	Strings

	Field Help
	A URL for the latest version of the license

	Data Type
	xs:anyURI

	XML Tags
	MsaHeader.License:URL

	Data Source
	If from File->New Blank

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

FUTURE: Autopopulate from an open SPD file.

	Data Verification
	Loss of focus: If there is an entry, it should be a URI

	Hover Option
	None

	Properties
	None

	Notes
	None


Table 10‑K Module Supported Architecture

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	ModuleSurfaceArea.ModuleDefinitions.SupportedArchitectures

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures
If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!


Table 10‑L Module Source or Binary

	Description
	Does this module contain only binaries from compiled code or the sources to compile the binaries

	Required
	Yes

	Editable
	Yes

	Prompt
	Module Contains

	Field Type
	Radio Box:  Source Files | Binary Files

	Field Help
	Modules are either source modules which can be compiled or binary modules which are linked.  A module cannot contain both.  The GUID numbers should be identical for a binary and source MSA, but the BINARY MSA should have a higher version number.

	Data Type
	xs:boolean

	XML Tags
	ModuleSurfaceArea.ModuleDefinitions.BinaryModule  (Source: false, Binary: true, Default is: false)

	Data Source
	If from File->New Default Radio Button: Source
If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	None

	Hover Option
	Source Files: Module contains all files needed to compile and link
Binary Files: Module contains binary files and no source files

	Properties
	None

	Notes
	None


<BinaryModule>false</BinaryModule> is the default.

Field Name: Output File Basename *
Table 10‑M OutputFileBasename

	Description
	The XML Specification used to create this file

	Required
	Yes

	Editable
	Yes

	Prompt
	Output Filename Base:

	Field Type
	String

	Field Help
	Enter a single word for generated output file names.

	Data Type
	FileNameConvention

	XML Tags
	ModuleSurfaceArea.ModuleDefinitions.OutputFileBasename

	Data Source
	If from File->New Blank
If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	On loss of focus: Must be a valid one word name

	Hover Option
	None

	Properties
	None

	Notes
	None


Field Name: Specification *
Table 10‑M Specification

	Description
	The XML Specification used to create this file

	Required
	Yes

	Editable
	NO

	Prompt
	None

	Field Type
	FIXED

	Field Help
	None

	Data Type
	Sentence

	XML Tags
	MsaHeader.Specification

	Data Source
	If from File->New from the XML Schema (FRAMEWORK_BUILD_PACKAGING_SPECIFICATION 0x00000052)
If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	None at this time.  This may change for future releases of the Wizard and XML Schema

	Hover Option
	None

	Properties
	None

	Notes
	Display at the bottom of the page in smaller font.
If the Wizard is compiled against another XML Schema Specification, and the file is edited, replace the MsaHeader.Specification value with the newer one when saving the file.


11.2 MSA File Library Class Form

Wizard needs to display the fields, then an ADD Button to add the entry to a table of entires below the Add Button.  The table of entries should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of lines in the table that get displayed.  For REMOVE, the developer should highlight a line in the table, then hit the delete key.
HEADING: Module Surface Area Library Class Definitions
SECTION: <LibraryClass>
Table 10‑N Library Class Name

	Description
	Library Class Name selection

	Required
	Yes

	Editable
	Yes

	Prompt
	Select Library Class:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	Enum list of Library Classes

	XML Tags
	LibraryClassDefinitions.LibraryClass:Name

	Data Source
	List of LibraryClass:Name from all SPD files in the WORKSPACE  Filtered by SupModuleList, PackageDependencies, SupArchList (& FF in F)

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	None


Table 10‑O Library Class Usage

	Description
	Library Class Usage selection

	Required
	Yes

	Editable
	Yes

	Prompt
	Library Class Usage:

	Field Type
	Radio Box

	Field Help
	None

	Data Type
	ENUM Data Type from FrameworkDataTypes.LibraryUsage

	XML Tags
	LibraryClassDefinitions.LibraryClass:Usage

	Data Source
	XML Schema

	Data Verification
	For ComponentType LIBRARY: ALWAYS_CONSUMED, SOMETIMES_CONSUMED or ALWAYS_PRODUCED
For everything else: ALWAYS_CONSUMED or SOMETIMES_CONSUMED

	Hover Option
	None

	Properties
	None

	Notes
	If the ComponentType is NOT LIBRARY, this is either SOMETIMES_CONSUMED or ALWAYS_CONSUMED
If the ComponentType is LIBRARY, then it can be either produced or consumed.


Table 10‑P Library Class Recommended Instance

	Description
	Library Class Recommended Instance selection

	Required
	No

	Editable
	Yes

	Prompt
	Recommended Library Instance

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	Enum list of LibraryInstances that provide support for the selected Library Class - this only appears after the user has selected a Library Class

	XML Tags
	LibraryClassDefinitions.LibraryClass:RecommendedInstanceGuid, LibraryClassDefinitions.LibraryClass:RecommendedInstanceVersion

	Data Source
	Wizard Initialization - WORKSPACE SCAN - list of modules that produce the library class selected above.

	Data Verification
	None

	Hover Option
	Abstract of the highlighted Library Instance

	Properties
	Description of the highlighted Library Instance

	Notes
	Only the UiName is displayed in the Drop Downs


ADD BUTTON GOES HERE
TABLE of Library Selected Library Class Entries showing just the UiNames
NOTE: Highlight of Library Class to DELETE the ROW, HIGHLIGHT the Recommended Instance to edit the recommendation (Provide the DropDown with this instance highlighted

	Library Class
	Recommended Instance

	L1
	LI1

	L2
	LI3


11.3 MSA File Source Files Form

Wizard needs to display the fields. An add button should appear below the entry field. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight an entry in the table, then hit the delete key.  NOTE: changing the width of the wizard should increase the number of columns in the table that get displayed.   The cell should display just the filename, minus the path which is still kept in memory.
HEADING: Module Surface Area Source File List

Table 10‑Q SourceFiles.Filename
	Description
	Source File selection

	Required
	No

	Editable
	Yes

	Prompt
	Select Source Files:

	Field Type
	Text Field

	Field Help
	Path is relative to the MSA file and must include the file name

	Data Type
	PathAndFilename

	XML Tags
	SourceFiles.Filename

	Data Source
	BROWSE BUTTON

	Data Verification
	Filename Exists

	Hover Option
	None

	Properties
	None

	Notes
	Multiple Filename selection is allowed


Table 10‑Q SourceFiles.Filename:TagName

	Description
	Bind a Source file to a specific Tool TagName

	Required
	No

	Editable
	Yes

	Prompt
	Bind to specific tool chain tag name:

	Field Type
	Check Boxes

	Field Help
	You may specify a specific tool chain tag name, such as BILL1

	Data Type
	ToolsNameConvention

	XML Tags
	SourceFiles.Filename:TagName

	Data Source
	Check boxes from the List of Tag Names from Tools/Conf/tools_def.txt

	Data Verification
	None

	Hover Option
	Using this field may cause build failures if the tool tag name is not defined on other developer’s workstations.

	Properties
	None

	Notes
	All Check boxes should be selected at start, if developer deselects any tag name, or deselects all tag name check boxes, do not enter this attribute.


Table 10‑Q SourceFiles.Filename:ToolCode

	Description
	Bind a Source file to a specific Tool Command Code

	Required
	No

	Editable
	Yes

	Prompt
	Bind to specific tool command:

	Field Type
	Drop Down

	Field Help
	You may specify a specific tool command, such as ASM

	Data Type
	ToolsNameConvention

	XML Tags
	SourceFiles.Filename:ToolCode

	Data Source
	Unique List of Tool Codes from Tools/Conf/tools_def.txt

	Data Verification
	None

	Hover Option
	Using this field may cause build failures if the tool code is not defined on other developer’s workstations.

	Properties
	None

	Notes
	None


Table 10‑Q SourceFiles.Filename:ToolChainFamily
	Description
	Bind a Source file to a specific Tool Chain Family

	Required
	No

	Editable
	Yes

	Prompt
	Bind to specific tool chain tag name:

	Field Type
	Drop Down

	Field Help
	You may specify a specific tool chain family, such as GCC

	Data Type
	ToolsNameConvention

	XML Tags
	SourceFiles.Filename:ToolChainFamily

	Data Source
	Unique List of Tool Chain Families from Tools/Conf/tools_def.txt

	Data Verification
	None

	Hover Option
	Using this field may cause build failures if the tool tag name is not defined on other developer’s workstations.

	Properties
	None

	Notes
	None


Table 10‑K Supported Architecture Attribute
	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	SourceFiles.Filename.SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute
	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	SourceFiles.Filename:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form
TABLE of Selected Source Files

NOTE: Highlight of Source File Cell to DELETE the ROW, HIGHLIGHT other cells for each file (or group of files) to change other entries.  This should work like a normal spreadsheet in that you should be able to add entries, even drop down selections, using copy & paste ranges  A description of each of the attribute columns follows below.
NOTE: Editing the Source File filename in this table is allowed!
NOTE: Highlight entire row to copy a row, then use paste (mouse, Edit->Paste, or CTRL-P to insert a duplicate row.  If this is done, attributes MUST be used, and the set of attributes must be unique.  Valid examples are given below.

	Source File
	File Type
	Supported Architectures
	Tag Name
	Command Code
	Tool Chain Family
	Feature Flag

	Ia32/Filename1.c
	
	
	
	
	
	

	X64/Filename1.c
	
	
	
	
	
	

	Filename2.s
	ASM
	IA32
	BILL1, GCC
	ASM
	GCC
	

	Filename2.S
	ASM
	IPF
	
	ASM
	
	

	MyLogo.jpg
	
	
	
	CONVERT2BMP
	
	

	FilePerf2.s
	
	IA32, X64
	OPT, GCC
	
	
	


11.4 MSA File Package Dependencies Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight an entry in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, both the PackageGuid and PackageVersion should be validated.  NOTE: PackageGuid is a hidden field.  When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑W PackageDependencies.Package
	Description
	List of Packages that the Module depends on

	Required
	No

	Editable
	Select From Drop Down List

	Prompt
	Enter Required Package:

	Field Type
	Drop Down

	Field Help
	If your Module requires a package list that here.

	Data Type
	UiNameType

	XML Tags
	PackageDependencies.Package:PackageGuid

	Data Source
	SPD File: SpdHeader.PackageName, SpdHeader.GuidValue

	Data Verification
	Loss of focus: Package must exist in the work space

	Hover Option
	Package Abstract

	Properties
	Package Description

	Notes
	PackageName:PackageGuid is a hidden field


Table 10‑Y Package:Version

	Description
	Version of the Package

	Required
	No

	Editable
	Select from Drop Down List

	Prompt
	Restrict to Package Version

	Field Type
	Drop Down

	Field Help
	If this module depends on a specific version of a package, enter the package version here.  If the module can use the latest version that does not break backward compatibility, leave this field blank

	Data Type
	VersionDataType

	XML Tags
	Package:PackageVersion

	Data Source
	SPD File: SpdHeader, PackageName, SpdHeader.Version

	Data Verification
	None

	Hover Option
	List of Package Versions in the Package for the PackageGuid that was chosen using the UiNameType PackageName

	Properties
	Description from the SPD File.

	Notes
	This field can remain blank.  The Hover option should provide a list of the versions of the package that are installed in the workspace.


Table 10‑X Supported Architecture Attribute
	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	SourceFiles.Filename:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute
	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	SourceFiles.Filename:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!



	
	

	
	

	
	

	
	

	
	

	
	


	
	

	
	

	
	

	
	

	
	

	
	

	
	



	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	


	
	

	
	

	
	

	
	


An ADD Button goes below this section of the form

TABLE of Required Packages
NOTE: Highlight of Pacakge Name Cell to and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet NOTE: Editing the PackageName cell in this table is allowed!

NOTE: Highlight entire row to copy a row, then use paste (mouse, Edit->Paste, or CTRL-P to insert a duplicate row.  If this is done, the VERSION attribute MUST be used, and this attribute must be unique for each PackageName.  Valid examples are given below.

	Package Name
	Supported Architectures
	Version
	Feature Flag

	MdePkg
	
	
	

	EdkFatPkg
	
	0.3
	

	EdkFatBinPkg
	
	
	

	EdkModulePkg
	
	
	

	Itanium2Pkg
	IPF
	
	

	MathPkg2
	X64 IPF
	0.4
	

	MathPkg1
	IA32 X64
	
	


11.5 MSA File Protocols Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ Protocols.Protocol AND/OR Protocols.ProtocolNotify

	Description
	Protocol C Name

	Required
	Yes

	Editable
	Drop Down Selection

	Prompt
	Protocol C Name:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	C NameType

	XML Tags
	Protocols.Protocol OR Protocols.ProtocolNotify

	Data Source
	C_Name should be a pull down list of Protocol names defined in the packages (SPD) supported or required by this module

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑KK Protocols Protocol OR ProtocolNotify

	Description
	Is this a Protocol or a ProtocolNotify entry

	Required
	Yes

	Editable
	Yes

	Prompt
	Is this a Protocol Notify:

	Field Type
	Radio Button YES | NO (default NO)

	Field Help
	ToolTip is: “Select Protocol Type”

	Data Type
	Protocols.Protocol or Protocols.ProtocolNotify

	XML Tags
	Protocols.Protocol or Protocols.ProtocolNotify

	Data Source
	Blank if NEW MSA, otherwise, read from file

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Protocol:Usage OR ProtocolNotify:Usage

	Description
	Usage Element

	Required
	Yes

	Editable
	Yes

	Prompt
	Protocol Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from FrameworkDataTypes.ProtocolUsage OR FrameworkDataTypes.ProtocolNotifyUsage

	XML Tags
	Protocols.Protocol:Usage  OR  Protocols.ProtocolNotify:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	If the Previous Radio selection is Protocol, use ProtocalUsage.  If it was ProtocolNotify, use ProtocolNotifyUsage


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	Protocols.Protocol:SupArchList OR Protocols.ProtocolNotify:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	Protocols.Protocol:FeatureFlag OR Protocols.ProtocolNotify:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Protocols

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet, allowing to cut and paste into ranges of cells.  

	Protocol
	Type (Protocol or ProtocolNotify)
	Usage
	Supported Architectures
	Feature Flag

	
	
	ALWAYS

_CONSUMED
	
	

	
	
	
	
	

	
	
	SOMETIMES

_CONSUMED
	IA32 X64
	



	
	

	
	

	
	

	
	

	
	

	
	


	
	

	
	

	
	

	
	

	
	

	
	

	
	



	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	

	
	


11.6 MSA File Events Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ Events.CreateEvents AND/OR Events.SignalEvents

	Description
	Event C Name

	Required
	Yes

	Editable
	String

	Prompt
	Event Guid C Name:

	Field Type
	Drop Down

	Field Help
	Select the GUID C Name of the Event

	Data Type
	C NameType

	XML Tags
	Events.CreateEvents.Event OR Events.SignalEvents.Event

	Data Source
	File -> New Drop Down of Guids from the SPD file, sorted by the Attribute, GuidTypeList
Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑KK Event CreateEvents OR SignalEvents
	Description
	Is this a Create Event or a Signal Event

	Required
	Yes

	Editable
	Yes

	Prompt
	Event Type:

	Field Type
	Radio Button Create | Signal (default NO)

	Field Help
	ToolTip is: “Select Create event if the Module has an event that is waiting to be signaled.  Select Signal if the Module will signal all events in an event group.  Signal Event The events are named by GUID.”

	Data Type
	None - used to select other options.

	XML Tags
	Either Events.CreateEvents or Events.SignalEvents section

	Data Source
	Wizard

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Event:Usage
	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Event Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from EventUsage

	XML Tags
	Events.SignalEvents.Event:Usage  OR  Events.CreateEvents.Event:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	EventUsage is the same for both Signal and Create Events.


Table 10‑LL Event:EventGroup

	Description
	EventGroup Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Event Group:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from EventTypes

	XML Tags
	Events.SignalEvents.Event:EventGroup  OR  Events.CreateEvents.Event:EventGroup

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	EventTypes is the same for both Signal and Create Events.


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	Events.CreateEvents.Event:SupArchList OR Events.SignalEvents.Event:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	Events.CreateEvents.Event:FeatureFlag OR Events.SignalEvents.Event:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Events
NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet, allowing to cut and paste into ranges of cells.  

	Event Guid C Name
	Type (Create or Signal)
	Usage
	Supported Architectures
	Feature Flag

	
	
	ALWAYS

_CONSUMED
	
	

	
	
	
	
	

	
	
	SOMETIMES

_CONSUMED
	IA32 X64
	


11.7 MSA File HOBs Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ Hobs.Hob
	Description
	Hob Guid C Name

	Required
	Yes

	Editable
	String

	Prompt
	HOB Guid C Name:

	Field Type
	Drop Down

	Field Help
	Select the GUID C Name of the Hob

	Data Type
	C NameType

	XML Tags
	Hobs.Hob

	Data Source
	File -> New Drop Down of Guids from the SPD file, sorted by the Attribute, GuidTypeList

Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Hobs.Hob:Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Hand Of Block Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from HobUsage

	XML Tags
	Hobs.Hob:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Hob:HobType
	Description
	Hob Type Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Hob Type:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from HobTypes

	XML Tags
	Hobs.Hob:HobTypes

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	Hobs.Hob:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	Hobs.Hob:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Hobs

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Hob Type
	Usage
	GUID C Name
	Supported Architectures
	Feature Flag

	CPU
	ALWAYS

_CONSUMED
	
	
	

	GUID_EXTENSION
	
	gSomeName
	
	

	CAPSULE_VOLUME
	SOMETIME

_CONSUMED
	
	IA32 X64
	


11.8 MSA File PPIs Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑EE PPIs.Ppi OR PPIs.PpiNotify
	Description
	PPI C Name

	Required
	Yes

	Editable
	Yes

	Prompt
	PPI C Name:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	C NameType

	XML Tags
	PPIs.Ppi OR PPIs.PpiNotify

	Data Source
	C_Name should be a pull down list of PPI names defined in the packages (SPD) supported by this module

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑FF PPIs Ppi or PpiNotify
	Description
	Is this a Ppi or a PpiNotify entry

	Required
	Yes

	Editable
	Yes

	Prompt
	Is this a PpiNotify:

	Field Type
	Radio Button YES | NO (default NO)

	Field Help
	ToolTip is: “Select PPI Type”

	Data Type
	PPIs.Ppi or PPIs.PpiNotify

	XML Tags
	PPIs.Ppi or PPIs.PpiNotify

	Data Source
	Blank if NEW MSA, otherwise, read from file

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑GG Ppi:Usage

	Description
	Usage Element

	Required
	Yes

	Editable
	Yes

	Prompt
	Ppi Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from FrameworkDataTypes.PpiUsage OR FrameworkDataTypes.PpiNotifyUsage

	XML Tags
	PPIs.Ppi:Usage  OR  PPIs.PpiNotify:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	PPIs.Ppi:SupArchList OR PPIs.PpiNotify:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	PPIs.Ppi:FeatureFlag OR PPIs.PpiNotify:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Ppis
NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Ppi
	Type (Ppi or PpiNotify)
	Usage
	Supported Architectures
	Feature Flag

	
	
	ALWAYS

_CONSUMED
	
	

	
	
	
	
	

	
	
	SOMETIMES

_CONSUMED
	IA32 X64
	


MSA File Variables Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ Variable Name
	Description
	Variable Name

	Required
	Yes

	Editable
	String

	Prompt
	Variable Name (Data Array):

	Field Type
	String

	Field Help
	Enter a Hex Word Array, you must provide leading Zeros. 0x000a, 0x0010, …

	Data Type
	VariableNameDataType

	XML Tags
	Variables.Variable.VariableName

	Data Source
	File -> New Empty Field
Open read from file

	Data Verification
	Valid Hex Word Data Array

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑JJ Variable Guid C Name

	Description
	Variable Guid C Name

	Required
	Yes

	Editable
	String

	Prompt
	Variable Guid’s C Name:

	Field Type
	String

	Field Help
	Enter the C Name for the Variable Guid

	Data Type
	C_NameType

	XML Tags
	Variables.Variable.GuidC_Name

	Data Source
	File -> New Empty Field

Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Variable Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Variable Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from VariableUsage

	XML Tags
	Variables.Variable:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	Variables.Variable:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	Variables.Variable:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Variables
NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Variable Guid C Name
	Usage
	Variable Name
	Supported Architectures
	Feature Flag

	0x0020, 0x0061, 0x0020
	ALWAYS

_CONSUMED
	gSome_aName
	
	

	0x0020, 0x0032, 0x0020
	
	gSomeName
	
	

	0x0020, 0x0064, 0x0065, 0x0020
	SOMETIME

_CONSUMED
	gSomeABName
	IA32 X64
	


11.9 MSA File Boot Modes Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑LL Boot Modes

	Description
	Boot Mode Name Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Boot Mode Name:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from BootModeNames

	XML Tags
	BootModes.BootMode:BootModeName

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL Boot Mode Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Boot Mode Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from BootModeUsage

	XML Tags
	BootModes.BootMode:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	BootModes.BootMode:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	BootModes.BootMode:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of BootModes

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Boot Mode Name
	Usage
	Supported Architectures
	Feature Flag

	FULL
	ALWAYS

_CONSUMED
	
	

	S3_RESUME
	ALWAYS PRODUCED
	
	


11.10 MSA File System Tables Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ SystemTables.SystemTableCName

	Description
	System Table C Name

	Required
	Yes

	Editable
	String

	Prompt
	System Table C Name:

	Field Type
	String

	Field Help
	Enter the C Name of the System Table:

	Data Type
	C NameType

	XML Tags
	SystemTables.SystemTableCName

	Data Source
	File -> New Empty

Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL SystemTables.SystemTableCName:Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	System Table Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from SystemTableUsage

	XML Tags
	SystemTables.SystemTableCName:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	SystemTables.SystemTableCName:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	SystemTables.SystemTableCName:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of System Table C Names

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	System Table C Names
	Usage
	Supported Architectures
	Feature Flag

	gSystemTableFooBar
	ALWAYS

_CONSUMED
	
	


11.11 MSA File Data Hubs Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ DataHubs.DataHubRecord

	Description
	Data Hub Record C Name

	Required
	Yes

	Editable
	String

	Prompt
	Data Hub Record C Name:

	Field Type
	String

	Field Help
	Enter the C Name of the Data Hub Record:

	Data Type
	C NameType

	XML Tags
	DataHubs.DataHubRecord

	Data Source
	File -> New Empty

Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL DataHubs.DataHubRecord:Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	Data Hub Record Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from SystemTableUsage

	XML Tags
	DataHubs.DataHubRecord:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	DataHubs.DataHubRecord:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	DataHubs.DataHubRecord:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Data Hub Record C Names

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Data Hub Record C Names
	Usage
	Supported Architectures
	Feature Flag

	gDataHubRecFooBar
	ALWAYS

_CONSUMED
	
	


11.12 MSA File HII Package Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑JJ HiiPackages.HiiPackage

	Description
	HII Package C Name

	Required
	Yes

	Editable
	String

	Prompt
	HII Package C Name:

	Field Type
	String

	Field Help
	Enter the C Name of the HII Package:

	Data Type
	C NameType

	XML Tags
	HiiPackages.HiiPackage

	Data Source
	File -> New Empty

Open read from file

	Data Verification
	Valid C Name

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑LL HiiPackages.HiiPackage:Usage

	Description
	Usage Attribute

	Required
	Yes

	Editable
	Yes

	Prompt
	HII Package Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from HiiPackageUsage

	XML Tags
	HiiPackages.HiiPackage:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	HiiPackages.HiiPackage:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	HiiPackages.HiiPackage:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of HII Package C Names

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	HII Package C Names
	Usage
	Supported Architectures
	Feature Flag

	gHiiPackarFoo
	ALWAYS

_CONSUMED
	
	


11.13 MSA File Guids Form

Wizard needs to display the fields below. An add button should appear below the last entry field line. A table (list) of entries, below the add button, should contain at least 10 lines before autoscrollbars appear.  NOTE, changing the height of the wizard should increase the number of rows in the table that get displayed.  For REMOVE, the developer should highlight row in the table, then hit the delete key.  To EDIT, the developer should higlight a cell in the table and then modify the entry.  Once focus is lost on the cell, all data in the row should be validated.  NOTE: When this container was created, if it was created from a new, the table should be unpopulated, if it was from an open action, the table should be populated from the entries in the existing MSA file.
Table 10‑OO Guids.GuidC_Name

	Description
	Guid C Name

	Required
	Yes

	Editable
	Yes

	Prompt
	Guid C Name:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	C NameType

	XML Tags
	Guids.GuidC_Name

	Data Source
	C_Name should be a pull down list of Guid names defined in the packages (SPD) supported by this module

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑PP Guids.GuidC_Name:Usage

	Description
	Usage Element

	Required
	Yes

	Editable
	Yes

	Prompt
	Guid Usage:

	Field Type
	Drop Down

	Field Help
	None

	Data Type
	ENUM Data Type from FrameworkDataTypes.GuidUsage 

	XML Tags
	Guids.GuidC_Name:Usage

	Data Source
	XML Schema

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	


Table 10‑X Supported Architecture Attribute

	Description
	A list of supported architectures

	Required
	No

	Editable
	Yes

	Prompt
	Supported Architectures

	Field Type
	Checkbox

	Field Help
	Deselecting a checkbox will restrict this module for use with the selected architectures, based on the list of items that are checked. If all boxes are checked, then the module will support all current AND FUTURE architectures

	Data Type
	ArchListType

	XML Tags
	Guids.GuidC_Name:SupArchList

	Data Source
	If from File->New from the ENUM List of SupportedArchitectures

If from File->Open read entry from file

If from Double Mouse click in TreeView read entry from file

	Data Verification
	Loss of focus: MAY contain a list of enum SupportedArchitectures names

	Hover Option
	None

	Properties
	None

	Notes
	If all boxes are checked, do not complete this entry!  If no boxes are checked, do not complete this entry!


Table 10‑Q Feature Flag Attribute

	Description
	Feature Flag - RESERVED FOR FUTURE USE

	Required
	No

	Editable
	No

	Prompt
	Feature Flag Expression:

	Field Type
	Text Field

	Field Help
	RESERVED FOR FUTURE USE

	Data Type
	FeatureFlagExpressionType

	XML Tags
	Guids.GuidC_Name:FeatureFlag

	Data Source
	None

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	GRAY THIS OUT - RESERVED FOR FUTURE USE!


An ADD Button goes below this section of the form

TABLE of Guids

NOTE: Highlight row and hit the Delete key, to DELETE the ROW, HIGHLIGHT each cell to change the entry.  This should work like a normal spreadsheet.  

	Guid C Name
	Usage
	Supported Architectures
	Feature Flag

	
	ALWAYS

_CONSUMED
	
	

	
	SOMETIMES

_CONSUMED
	IA32 X64
	


Table 10‑RR Protocols.Protocol:FeatureFlag OR Protocols.ProtocolNotify:FeatureFlag

	Description
	TBD

	Required
	No

	Editable
	Yes

	Prompt
	Column Heading is: Feature Flag

	Field Type
	Text Field

	Field Help
	TBD

	Data Type
	TBD

	XML Tags
	Protocols.Protocol:FeatureFlag  OR Protocols.ProtocolNotify:FeatureFlag

	Data Source
	Blank if NEW MSA, otherwise, read from file

	Data Verification
	Loss of Focus: Valid RPN notation

	Hover Option
	None

	Properties
	None

	Notes
	Should be able to copy & paste over a range of cells


11.14 Externs
THE FOLLOWING SECTION ARE COMMENTS FROM ANDREW THAT HAVE NOT BEEN FORMATTED, NOR HAVE CHANGES TO THE SCHEMA BEEN INCORPORATED (THE SCHEMA CHANGES HAVE NOT BEEN CHECKED IN EITHER!)


11.14.1 Externs:

<PcdIsDriver>
<Specification>

Autogen will default these items if they are not present. I’m not sure where this is currently in the schema)


EFI_SPECIFICATION_VERSION=0x0002000 for UEFI 2.0

        EFI_SPECIFICATION_VERSION=0x0001001 for EFI 1.10

 
EDK_RELEASE_VERSION=0x00010000 for EDK 

 
EDK_REALESE_VERSION=0x00020000 for EDK 2/R9
<Extern
    SupArchList

    FeatureFlag>

       Single Choice of
· For a Module

· Module Entry Point

· Module Unload Image (Only valid if Module Type is Dxe Driver, Dxe Runtime Driver, Dxe SAL Driver, DXE SMM Driver, UEFI Driver,  UEFI Application or User Defined)

· ExitBootServicesCallBack (Only valid if Module Type is Dxe Driver, Dxe Runtime Driver, Dxe SAL Driver, DXE SMM Driver, UEFI Driver,  UEFI Application or User Defined)

· SetVirtualAddressMapCallback (Only valid if Runtime Driver, Dxe SAL Driver, or DXE SMM Driver)

· For a Library
· Constructor

· Destructor
· UEFI Driver (only valid for DXE Driver, UEFI Application, and User Defined)
· Driver Binding

· Component Name

· Driver Configuration

· Driver Diagnostic
Or Multiple Instances of
· UserDefined

12 
SPD

Andrew’s comments
The highlighting of file types and starting the file browser in the right location are optional for the first implementation. 

We need to enter the header data

We need to support adding Library Class

· ClassName

· Path in package to Library Class .h

· Would be good to start file browser in Include/Library of the package and highlight .h files in some way.

We need to support adding a .MSA

· Add the .msa file path and name relative to the package

· Would be good to start the file browser in the package root and highlight .msa files in some way.

We need to support adding the package include file for a given module type <IncludeHeader>

· ModuleType

· Include file

· It would be good to start the file browser in package Include and highlight .h files some way.

We need to support adding a GUID definition

· Guid Base Name

· Guid C_Name (default should be gEfi{Guid Base Name}Guid)

· GUID value

· Enter GUID value (copy from a specification) – Cut paste supported

· Generate a GUID value

We need to support adding a Protocol definition

· Protocol Base Name

· Protocol C_Name (default should be gEfi{Guid Base Name}ProtocolGuid)

· GUID value

· Enter GUID value (copy from a specification) – Cut paste supported 

· Generate a GUID value

We need to support adding a PPI definition

· PPI Base Name

· PPI C_Name (default should be gEfi{Guid Base Name}PpiGuid)

· GUID value

· Enter GUID value (copy from a specification) – Cut paste supported 

· Generate a GUID value

We need to support adding a PCD definition

· C Name

· Token Space GUID – Default value is the package GUID

· Token # - Free format

· Set of ItemType 

· Feature Flag must always be by it’s self.

· FixedAtBuild, Patchable, Dynamic, or Dynamic can support 1-4 of these

· DataumType – pick list

· Optional – Default Value

Mike Kinney’s SPD Document Follows.
13 Surface Area Package Description File (SPD) 

This section describes the Surface Area Package Description (SPD) file.  The SPD XML Instance Representation is as follows:

<PackageSurfaceArea> 

  <SpdHeader> ... </SpdHeader> [1] 

  <LibraryClassDeclarations> ... </LibraryClassDeclarations> [0..1] 

  <IndustryStdIncludes> ... </IndustryStdIncludes> [0..1] 

  <MsaFileList> ... </MsaFileList> [0..1] 

  <PackageHeaders> ... </PackageHeaders> [0..1] 

  <GuidDeclarations> ... </GuidDeclarations> [0..1] 

  <ProtocolDeclarations> ... </ProtocolDeclarations> [0..1] 

  <PpiDeclarations> ... </PpiDeclarations> [0..1] 

  <PcdDeclarations> ... </PcdDeclarations> [0..1] 

  <UserExtensions> ... </UserExtensions> [0..*] 

</PackageSurfaceArea>

Figure 1.  PackageSurfaceArea Instance

Table 13.  PackageSurfaceArea
	Description
	This element contains all the information associated with a Surface Area Package Description

	Required
	YES

	Data Type
	Element – Complex

	Data Constraints
	The SpdHeader element is required.  All other elements are optional.  There can be any UserExtensions elements. 

	Examples
	N/A

	Build Tool Usage
	YES.  See details in the following sections.

	UI Tool Usage
	YES.  See details in the following sections.


13.1 PackageSurfaceArea.SpdHeader

<SpdHeader> 

  <PackageName> UiNameType </PackageName> [1] 

  <GuidValue> ... </GuidValue> [1] 

  <Version> ... </Version> [1] 

  <Abstract> ... </Abstract> [1] 

  <Description> ... </Description> [1] 

  <Copyright> ... </Copyright> [1] 

  <License> ... </License> [1] 

  <ReadOnly> ... </ReadOnly> [1] 

  <RePackage> ... </RePackage> [1] 

  <Specification> xs:string </Specification> [1] 

</SpdHeader>
Figure 2.  PackageSurfaceArea.SpdHeader Instance

Table 14.  PackageSurfaceArea.SpdHeader
	Description
	This element contains the header information for a Surface Area Package Description.  This includes the name of the package, descriptions of the package, copyright and licensing information associated with the package, and the version of XML Schema to which this file conforms.

	Required
	YES

	Data Type
	Element – Complex

	Data Constraints
	N/A

	Examples
	N/A

	Build Tool Usage
	YES.  See details in the following sections.

	UI Tool Usage
	YES.  See details in the following sections.


13.1.1 SpdHeader.PackageName

Table 15.  SpdHeader.PackageName
	Description
	The User Interface Name for the package.  This name is only used by a user interface to display the name of a package.  A package is identified by its PackageSurfaceArea.SpdHeader.GuidValue and PackageSurfaceArea.SpdHeader.Version.  The PackageSurfaceArea.SpdHeader.PackageName should never be used by any tools to search for SPD files in a WORKSPACE.

	Required
	YES

	Data Type
	Element – UiNameType

	Data Constraints
	A string that starts with a letter followed by any combination of letters, digits, underscores, and periods.  No whitespace is allowed.

A package is expected to be released many times in its life cycle.  If a package is backwards compatible with a previous release of the same package, then PackageSurfaceArea.SpdHeader.GuidValue element must not be changed, and only the PackageSurfaceArea.SpdHeader.Version element  should be increased.  If a package is not backward compatible with a previous release or a new package is being created, then a new PackageSurfaceArea.SpdHeader.GuidValue must be generated.  Since the PackageSurfaceArea.SpdHeader.PackageName element is the name that will be seen by the module developers and platform integrators, the PackageSurfaceArea.SpdHeader.PackageName should include version information that matches the release notes for the package and the package developer should guarantee that each new release of a package has a unique PackageSurfaceArea.SpdHeader.PackageName.   If the package developer does not generate new PackageSurfaceArea.SpdHeader.PackageName strings, the UI Tool may show two packages with the same name in a WORKSPACE.  The module developer or package integrator will then have to look at more details information about the package, such as the PackageSurfaceArea.SpdHeader.Abstract, PackageSurfaceArea.SpdHeader.Description, PackageSurfaceArea.SpdHeader.GuidValue, and PackageSurfaceArea.SpdHeader.Version fields to distinguish packages with the same PackageSurfaceArea.SpdHeader.PackageName. 

	Examples
	<PackageName>MDE Package Version 1.00</PackageName>

<PackageName>EDK Module Package Version 1.02</PackageName>

<PackageName>NT32 Package Version 2.76</PackageName>

	Build Tool Usage
	NO.  This field should not be used to perform a build.  Only PackageSurfaceArea.SpdHeader.GuidValue and PackageSurfaceArea.SpdHeader.Version elements may be used to identify or lookup a package.  This field may be used during verbose output of the build tools to display the name of the package being processed. 

	UI Tool Usage
	YES.  

Display Package: Whenever the UI needs to present the name of a package from the WORKSPACE in an expansion tree, a form, or a pick list, the PackageSurfaceArea.SpdHeader.PackageName element must be used.  

Hover Over Package: If the cursor in a UI hovers over a PackageSurfaceArea.SpdHeader.PackageName, then the UI should display the PackageSurfaceArea.SpdHeader.Abstract in a bubble next to PackageSurfaceArea.SpdHeader.PackageName.
Select Package: When a package is selected, the PackageSurfaceArea.SpdHeader.Description element should be displayed in a help text window.  The PackageSurfaceArea.SpdHeader.GuidValue and PackageSurfaceArea.SpdHeader.Version elements may also be displayed in the help text window.

Create Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.PackageName element.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.PackageName element.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.PackageName element must be copied to the cloned package.


13.1.2 SpdHeader.GuidValue

Table 16.  SpdHeader.GuidValue
	Description
	The 128-bit GUID that is the unique name of a package.

	Required
	YES

	Data Type
	Element – GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

If a package is backwards compatible with a previous release of the same package, then PackageSurfaceArea.SpdHeader.GuidValue element must not be changed, and only the PackageSurfaceArea.SpdHeader.Version element  should be increased.  If a package is not backward compatible with a previous release or a new package is being created, then a new PackageSurfaceArea.SpdHeader.GuidValue must be generated. 

	Examples
	<GuidValue>AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2</GuidValue>

	Build Tool Usage
	YES.  This field must be used by build tools along with the PackageSurfaceArea.SpdHeader.Version element to identify and lookup packages in a WORKSPACE. 

	UI Tool Usage
	OPTIONAL.  

Select Package: The PackageSurfaceArea.SpdHeader.GuidValue element may be optionally displayed in a help text window.

Create Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.GuidValue element or click on a button to generate a new GUID.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.GuidValue element or click on a button to generate a new GUID.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.GuidValue element must be copied to the cloned package.


13.1.3 SpdHeader.Version

Table 17.  SpdHeader.Version
	Description
	The version of this package.  

	Required
	YES

	Data Type
	Element – VersionDataType

	Data Constraints
	A string that contains a positive decimal number.

If a package is backwards compatible with a previous release of the same package, then PackageSurfaceArea.SpdHeader.GuidValue element must not be changed, and only the PackageSurfaceArea.SpdHeader.Version element  should be increased.  If a package is not backward compatible with a previous release or a new package is being created, then a new PackageSurfaceArea.SpdHeader.GuidValue element and PackageSurfaceArea.SpdHeader.Version element must be generated.  In this case, the PackageSurfaceArea.SpdHeader.Version element will likely be reset to a small positive value.

	Examples
	<Version>1.00</Version>

<Version>1.02</Version>

<Version>3.27</Version>

	Build Tool Usage
	YES.  This field must be used by build tools along with the PackageSurfaceArea.SpdHeader.Guid element to identify and lookup packages in a WORKSPACE. 

	UI Tool Usage
	OPTIONAL.  

Select Package: The PackageSurfaceArea.SpdHeader.Version element may be optionally displayed in a help text window.

Create New Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.Version element.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.Version element.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.Version element must be copied to the cloned package.


13.1.4 SpdHeader.Abstract

Table 18.  SpdHeader.Abstract
	Description
	A brief text description of a package.  This description must include the release name of the package, the version of the package, and a description of the package contents and/or features.

	Required
	YES

	Data Type
	Element – Sentence

	Data Constraints
	A string that contains two or more words.

	Examples
	<Abstract>MDE Package Version 0.75 that conforms to the MDE Package Specification Version 0.75. </Abstract>

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Hover Over Package: If the cursor in a UI hovers over a PackageSurfaceArea.SpdHeader.PackageName, then the UI should display the PackageSurfaceArea.SpdHeader.Abstract in a bubble next to PackageSurfaceArea.SpdHeader.PackageName.
Create New Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.Abstract element.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.Abstract element.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.Abstract element must be copied to the cloned package.


13.1.5 SpdHeader.Description

Table 19.  SpdHeader.Description
	Description
	A complete description of a package.  This description must include the release name of the package, the version of the package, and a complete description of the package contents and/or features including a description of the updates since the previous package release.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	<Description>

MDE Package Version 0.75 that conforms to the MDE Package Specification Version 0.75.  This package contains all the include files, Protocols, PPIs, GUIDs, Library Classes, and Library instances required to build modules that are compliant with the EFI 1.10, UEFI 2.0, and Framework Specifications.  This package was updated from Version 0.74 and now includes addition Base Library String Functions. 

</Description>

	Build Tool Usage
	NO

	UI Tool Usage
	YES.  

Select Package: The PackageSurfaceArea.SpdHeader.Description element must be displayed in a help text window.  The PackageSurfaceArea.SpdHeader.GuidValue and PackageSurfaceArea.SpdHeader.Version elements may also be displayed in the help text window. 

Create New Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.Description element.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.Description element.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.Description element must be copied to the cloned package.


13.1.6 SpdHeader.Copyright

Table 20.  SpdHeader.Copyright
	Description
	The copyright for this package that is generated by the creator of a package.  If a derivative work is generated from an existing package, then the existing copyright must be maintained, and additional copyrights may be appended to the end of this element.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A set of one or more copyright statements on one or more lines of text.

	Examples
	<Copyright>

Copyright (c) 2006,  Intel Corporation. 

</Copyright>

	Build Tool Usage
	NO

	UI Tool Usage
	YES.  

Create New Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.Copyright element that applies to the package.  Must support cut/paste operations.   

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.Copyright element that applies to the package.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.Copyright element  must be copied to the cloned package. 


13.1.7 SpdHeader.License

Table 21.  SpdHeader.License
	Description
	A license that describes any restrictions on the use of this package.  If a derivative work is allowed by the original license and a derivative work is generated from an existing package, then the existing license must be maintained, and additional licenses may be appended to the end of this element.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	<License>

All rights reserved.

      This program and the accompanying materials are licensed and    

      made available under the terms and conditions of the BSD License 
      which accompanies this distribution.  The full text of the 
      license may be found at http://opensource.org/licenses/bsd-
      license.php THE PROGRAM IS DISTRIBUTED UNDER THE BSD LICENSE ON 
      AN "AS IS" BASIS, WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY 
      KIND, EITHER EXPRESS OR IMPLIED.

</License>

	Build Tool Usage
	NO

	UI Tool Usage
	YES.  

Create New Package: The UI must allow the user to type in the PackageSurfaceArea.SpdHeader.License element that applies to the package.  Must support cut/paste operations.

Edit Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.SpdHeader.License element that applies to the package.  Must support cut/paste operations.

Clone Package: The original PackageSurfaceArea.SpdHeader.License element  must be copied to the cloned package. 


13.1.8 SpdHeader.ReadOnly

Table 22.  SpdHeader.ReadOnly
	Description
	If true, then tools should treat the contents of the entire package as read-only. 

If false, then tools should allow package modifications. 

	Required
	YES

	Data Type
	Element – Boolean

	Data Constraints
	A string containing ‘true’ or ‘false’

	Examples
	<ReadOnly>true</ReadOnly>

<ReadOnly>false</ReadOnly>

<ReadOnly>0</ReadOnly>

	Build Tool Usage
	NO

	UI Tool Usage
	YES.  

Create New Package: The UI must allow the user to click on a radio button labeled with “Read Only” to toggle the state of the radio button.  If the radio button is enabled, then the PackageSurfaceArea.SpdHeader.ReadOnly element is set to true, otherwise, the PackageSurfaceArea.SpdHeader.ReadOnly element is set to false.

Edit Package: The UI must allow the user to change the state of the radio button associated with the PackageSurfaceArea.SpdHeader.ReadOnly element.  If the radio button is enabled, then the PackageSurfaceArea.SpdHeader.ReadOnly element is set to true, otherwise, the PackageSurfaceArea.SpdHeader.ReadOnly element is set to false.

TBD: May want to make changing state from true to false an admin operation.
Clone Package: The PackageSurfaceArea.SpdHeader.ReadOnly element in the cloned package must be set to false. 


13.1.9 SpdHeader.RePackage

Table 23.  SpdHeader.RePackage
	Description
	If true, then tools may allow the package to be cloned or repackaged. 

If false, then tools may not allow the package to be cloned or repackaged. 

	Required
	YES

	Data Type
	Element – Boolean

	Data Constraints
	A string containing ‘true’ or ‘false’

	Examples
	<RePackage>true</RePackage>

<RePackage>false</RePackage>

<RePackage>0</RePackage>

	Build Tool Usage
	NO

	UI Tool Usage
	YES.  

Create New Package: The UI must allow the user to click on a radio button labeled with “Re-Package” to toggle the state of the radio button.  If the radio button is enabled, then the PackageSurfaceArea.SpdHeader.RePackage element is set to true, otherwise, the PackageSurfaceArea.SpdHeader.RePackage element is set to false.

Edit Package: The UI must allow the user to change the state of the radio button associated with the PackageSurfaceArea.SpdHeader.RePackage element.  If the radio button is enabled, then the PackageSurfaceArea.SpdHeader.RePackage element is set to true, otherwise, the PackageSurfaceArea.SpdHeader.Repackage element is set to false.

TBD: May want to make changing state from false to true an admin operation.
Clone Package: If the PackageSurfaceArea.SpdHeader.RePackage element in the original package is set to false, then the clone operation must fail.  Otherwise, the PackageSurfaceArea.SpdHeader.RePackage element in the cloned package must be set to true. 
Create Distribution Package: If the PackageSurfaceArea.SpdHeader.RePackage element in the original package is set to false, then the create distribution package operation must fail.


13.1.10 SpdHeader.Specification

Table 24.  SpdHeader.Specification
	Description
	The XML Schema Specification to which this Surface Area Package Description File (SPD) conforms.  

	Required
	YES

	Data Type
	Element – xs:string

	Data Constraints
	Must contain “FRAMEWORK_BUILD_PACKAGING_SPECIFICATION   0x00000052”

	Examples
	<Specification>

FRAMEWORK_BUILD_PACKAGING_SPECIFICATION   0x00000052
</Specification>

	Build Tool Usage
	YES

Every time a Build Tool opens an SPD file, it must verify that the build tool supports the specification listed in the PackageSurfaceArea.SpdHeader.Specification element.  The PackageSurfaceArea.SpdHeader.Specification element may be used during verbose builds to display the specification to which the SPD file conforms.

	UI Tool Usage
	YES  

Every time a UI Tool opens an SPD file, it must verify that the UI Tool supports the specification in the PackageSurfaceArea.SpdHeader.Specification element.
Create New Package: The UI must set the PackageSurfaceArea.SpdHeader.Specification element to “FRAMEWORK_BUILD_PACKAGING_SPECIFICATION   0x00000052”
Edit Package: The  PackageSurfaceArea.SpdHeader.Specification element is not editable.

Clone Package: The original PackageSurfaceArea.SpdHeader.Specification element must be copied to the cloned package. 


13.2 PackageSurfaceArea.LibraryClassDeclarations

<LibraryClassDeclarations> 

  <LibraryClass
    Name=" xs:NCName [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]" 
    SupModuleList=" ModuleListType [0..1]"> [1..*] 

      <IncludeHeader> PathAndFilename </IncludeHeader> [1] 

      <RecommendedInstanceGuid> GuidType </RecommendedInstanceGuid> [0..1] 

      <RecommendedInstanceVersion> VersionDataType </RecommendedInstanceVersion> [0..1] 

      <HelpText> ... </HelpText> [1] 

  </LibraryClass>

</LibraryClassDeclarations> [0..1]
Figure 3.  PackageSurfaceArea.LibraryClassDeclarations Instance

Table 25.  PackageSurfaceArea.LibraryClassDeclarations
	Description
	The list of library classes that the package declares.

	Required
	NO

	Data Type
	Element – Complex

	Data Constraints
	N/A

	Examples
	N/A

	Build Tool Usage
	YES

	UI Tool Usage
	YES


13.2.1 LibraryClassDeclarations.LibraryClass:Name

Table 26.  LibraryClassDeclarations.LibraryClass:Name
	Description
	Used to display the name of a Library Class from a UI Tool. 

	Required
	YES

	Data Type
	Attribute – NCName

	Data Constraints
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	Examples
	Name=”BaseLib”

Name=”PrintLib”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Select Library Class: A Library Class can be selected when Importing a Library Class Declaration from another Package, Deleting a Library Class Declaration from a Package, Adding a Library Class Definition to a Module, Editing Library Class Definition properties in a Module, and Deleting a Library Class Definition from a Module.  When a Library Class Declaration need to be displayed in an expansion tree, or a pick list, or a form, the PackageSurfaceArea.LibraryClassDeclarations.LibraryClass.Name must be used for these display operations.

Add a Library Class Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.LibraryClassDeclarations.LibraryClass.Name element.  Must support cut/paste operations.

Edit a Library Class Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.LibraryClassDeclaration.LibraryClass.Name element.  Must support cut/paste operations.


13.2.2 LibraryClassDeclarations.LibraryClass:SupArchList

Table 27.  LibraryClassDeclarations.LibraryClass:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this Library Class.  If this attribute is not specified, then this Library Class may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this Library Class. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add Library Class Definitions to a Module: When a Module Developer adds a Library Class to a module, the set of available Library Classes must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of Library Declarations from all of those packages.  If the LibraryClassDeclarations.LibraryClass:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that Library Class is filtered from the list.  If the LibraryClassDeclarations.LibraryClass:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the LibraryClassDeclarations.LibraryClass:SupArchList attribute then that Library Class is also filtered.  The Module Developer is only presented the filtered list of Library Classes to select a Library Class to add.

Add a Library Class Declaration to a Package: The UI must allow the user to select the set of CPU Architectures for this Library Class.

Edit a Library Class Declaration in a Package: The UI must allow the user to modify the set of CPU Architectures for this Library Class.


13.2.3 LibraryClassDeclarations.LibraryClass:FeatureFlag

Table 28.  LibraryClassDeclarations.LibraryClass:FeatureFlag
	Description
	Used to restrict the use of this Library Class.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this Library Class is not restricted based on feature flag settings.  If this attribute is specified, then this Library Class may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.2.4 LibraryClassDeclarations.LibraryClass:SupModuleList

Table 29.  LibraryClassDeclarations.LibraryClass:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this Library Class.  If this attribute is not specified, then this Library Class may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this Library Class. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add Library Class Definitions to a Module: When a Module Developer adds a Library Class to a module, the set of available Library Classes must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of Library Declarations from all of those packages.  If the LibraryClassDeclarations.LibraryClass:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that Library Class is filtered from the list.  If the LibraryClassDeclarations.LibraryClass:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the LibraryClassDeclarations.LibraryClass:SupArchList attribute then that Library Class is also filtered.  The Module Developer is only presented the filtered list of Library Classes to select a Library Class to add.

Add a Library Class Declaration to a Package: The UI must allow the user to select the set of Module Types for this Library Class.

Edit a Library Class Declaration in a Package: The UI must allow the user to modify the set of Module Types for this Library Class.


13.2.5 LibraryClassDeclarations.LibraryClass.IncludeHeader

Table 30.  LibraryClassDeclarations.LibraryClass.IncludeHeader
	Description
	A string that specifies the file path to the include file for a Library Class.  This file path is relative to the root directory of the package, and contains directories and a file name.  The full path to the Industry Standard Include file can be generated by appending the file path to the package root in the WORKSPACE to the this file path. 

	Required
	YES

	Data Type
	Element – PathAndFilename

	Data Constraints
	A package relative path and filename for the include file associated with the Library Class.

	Examples
	<IncludeHeader>Include/Library/BaseLib.h</IncludeHeader>

<IncludeHeader>Include/Library/PrintLib.h</IncludeHeader>

	Build Tool Usage
	YES

When a module is built, the build tools are required to generate an AutoGen.h and AutoGen.c file.  The AutoGen.h file must contain a #include statements for each Library Class that a module produces or consumes.  All the packages that a module depends upon must be in the include path for the build tools, so the include statement in the AutoGen.h file is:

#include <LibraryClassDeclarations.LibraryClass.IncludeHeader>

	UI Tool Usage
	YES

Add a Library Class Declaration to a Package: The UI must allow the user to type in the path and filename to the include file for the Library Class.  The UI must also support the user selecting a file from a file explorer.  The selected file must be within the current package.  Must support cut/paste operations.

Edit a Library Class Declaration in a Package: The UI must allow the user to edit the path and filename to the include file for the Library Class.  The UI must also support the user selecting a file from a file explorer.  The selected file must be within the current package.  Must support cut/paste operations.


13.2.6 LibraryClassDeclarations.LibraryClass.RecommendedInstanceGuid

Table 31.  LibraryClassDeclarationsLibraryClass.RecommendedInstanceGuid
	Description
	The GUID of the recommended library instance

	Required
	NO

	Data Type
	Element – GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

	Examples
	<RecommendedInstanceGuid>

AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2

</RecommendedInstanceGuid>

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add a Library Class Declaration to a Package: The UI must allow the user to optionally select a library instance from any package in the WORKSPACE.  The UI must collect all the library instances that produce the same Library Class specified by LibraryClassDeclarations.LibraryClass.Name and allow the user to select one of those library instances.  Both the GUID and Version fields should be filled in based on the selection by the user.  The user should have the option of deleting the version.

Edit a Library Class Declaration in a Package: The UI must allow the user to optionally change the recommended library instance or remove the recommendation.  The UI must collect all the library instances that produce the same Library Class specified by LibraryClassDeclarations.LibraryClass.Name and allow the user to select one of those library instances.  Both the GUID and Version fields should be filled in based on the selection by the user.  The user should have the option of deleting the version.

Add a Module to a Platform: When a module is initially added to a platform, the platform integrator must select a library instance for each Library Class that is required by that module or any of the library instances that have already been selected.  If a module references a Library Class that includes a recommended instance, then the library instance for that Library Class should default to the recommended instance of that instance is available in the WORKSPACE.  The user should then be able to change from the recommended instance to any other compatible instance.  The recommended instance should be marked so the platform integrator know which instance is the recommended one even if the recommended one is not selected.  If the Version element is not present, then the recommended instance is the one with the same GUID and the highest version number.

Edit a Module in a Platform: Same as Add a Module to a Platform.  The platform integrator must be allowed to change the library instance selections.  The list of library instances should always distinguish the recommended library instance is one is specified.


13.2.7 LibraryClassDeclarations.LibraryClass.RecommendedInstanceVersion

Table 32.  LibraryClassDeclarations.LibraryClass.RecommendedInstanceVersion
	Description
	The version of the recommended library instance.  This is an optional element and is not even required when the RecommendedInstanceGuid is specified.  If RecommendedInstanceGuid is specified, and this element is not, then the algorithm to look up the recommended instance is to find the library instance highest version number and a matching GUID.

	Required
	NO

	Data Type
	Element – VersionDataType

	Data Constraints
	A positive decimal number

	Examples
	<RecommendedInstanceVersion>1.0</RecommendedInstanceVersion>

<RecommendedInstanceVersion>27.5</RecommendedInstanceVersion>

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add a Library Class Declaration to a Package: The UI must allow the user to optionally select a library instance from any package in the WORKSPACE.  The UI must collect all the library instances that produce the same Library Class specified by LibraryClassDeclarations.LibraryClass.Name and allow the user to select one of those library instances.  Both the GUID and Version fields should be filled in based on the selection by the user.  The user should have the option of deleting the version.

Edit a Library Class Declaration in a Package: The UI must allow the user to optionally change the recommended library instance or remove the recommendation.  The UI must collect all the library instances that produce the same Library Class specified by LibraryClassDeclarations.LibraryClass.Name and allow the user to select one of those library instances.  Both the GUID and Version fields should be filled in based on the selection by the user.  The user should have the option of deleting the version.

Add a Module to a Platform: When a module is initially added to a platform, the platform integrator must select a library instance for each Library Class that is required by that module or any of the library instances that have already been selected.  If a module references a Library Class that includes a recommended instance, then the library instance for that Library Class should default to the recommended instance of that instance is available in the WORKSPACE.  The user should then be able to change from the recommended instance to any other compatible instance.  The recommended instance should be marked so the platform integrator know which instance is the recommended one even if the recommended one is not selected.  If the Version element is not present, then the recommended instance is the one with the same GUID and the highest version number.

Edit a Module in a Platform: Same as Add a Module to a Platform.  The platform integrator must be allowed to change the library instance selections.  The list of library instances should always distinguish the recommended library instance is one is specified.


13.2.8 LibraryClassDeclarations.LibraryClass.HelpText

Table 33.  LibraryClassDeclarations.LibraryClass.HelpText
	Description
	A complete description of a Library Class.  This must include a description of the functions, macros, defines, and data structures in this Library Class.  It must also describe any use restrictions based on Module Type, CPU Architecture, and Feature Flags.  If a recommended library instance is specified, then that library instance must be described along with a justification for recommending that library instance.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	The MDE Print Library functions provide a simple means to produce formatted output strings.  Many of the output functions use a format string to describe how to format the output of variable arguments.  The format string consists of normal text and argument descriptors.  There are no restrictions for how the normal text and argument descriptors can be mixed.  The format of argument descriptors is described below.  The ANSI C standard for sprint() has been followed for some of the format types, and has not been followed for others.

	Build Tool Usage
	NO

	UI Tool Usage
	YES. 

Select Library Class: If the user selects a Library Class from a package, then the PackageSurfaceArea.LibraryClassDeclarations.LibraryClass.HelpText element must be displayed in a help text window.  If a recommended library instance is specified, then that information can also be displayed in the help text window.   A Library Class can be selected when Importing a Library Class Declaration from another Package, Deleting a Library Class Declaration from a Package, Adding a Library Class Definition to a Module, Editing Library Class Definition properties in a Module, and Deleting a Library Class Definition from a Module.

Add a Library Class Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.LibraryClassDeclarations.LibraryClass.HelpText element.  Must support cut/paste operations.

Edit a Library Class Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.LibraryClassDeclarations.LibraryClass.HelpText element.  Must support cut/paste operations.


13.3 PackageSurfaceArea.IndustryStdIncludes

<IndustryStdIncludes> 

  <IndustryStdHeader
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=" ModuleListType [0..1]"> [1..*]
      <Header> UiNameType </Header> [1] 

      <IncludeHeader> PathAndFilename </IncludeHeader> [1] 

      <HelpText> ... </HelpText> [1] 

  </IndustryStdHeader>

</IndustryStdIncludes>

Figure 4.  PackageSurfaceArea.IndustryStdIncludes Instance

13.3.1 IndustryStdIncludes.IndustryStdHeader:SupArchList

Table 34.  IndustryStdIncludes.IndustryStdHeader:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this Industry Standard Header.  If this attribute is not specified, then this Industry Standard Header may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this Industry Standard Header. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.3.2 IndustryStdIncludes.IndustryStdHeader:FeatureFlag

Table 35.  IndustryStdIncludes.IndustryStdHeader:FeatureFlag
	Description
	Used to restrict the use of this Industry Standard Include file.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this Industry Standard Include file is not restricted based on feature flag settings.  If this attribute is specified, then this Industry Standard Include file may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.3.3 IndustryStdIncludes.IndustryStdHeader:SupModuleList

Table 36.  IndustryStdIncludes.IndustryStdHeader:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this Industry Standard Include file.  If this attribute is not specified, then this Industry Standard Include file  may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this Industry Standard Include file. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.3.4 IndustryStdIncludes.IndustryStdHeader.Header

Table 37.  IndustryStdIncludes.IndustryStdHeader.Header
	Description
	Used to display the name of a Industry Standard Header from a UI Tool.

	Required
	YES

	Data Type
	Element – UiNameType

	Data Constraints
	A string that starts with a letter followed by any combination of letters, digits, underscores, and periods.  No whitespace is allowed.

	Examples
	<Header>PCI_2.2</Header>

<Header>ACPI_3.0</Header>

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.3.5 IndustryStdIncludes.IndustryStdHeader.IncludeHeader

Table 38.  IndustryStdIncludes.IndustryStdHeader.IncludeHeader
	Description
	A string that specifies the file path to the Industry Standard Include file.  This file path is relative to the root directory of the package, and contains directories and a file name.  The full path to the Industry Standard Include file can be generated by appending the file path to the package root in the WORKSPACE to the this file path. 

	Required
	YES

	Data Type
	Element – PathAndFilename

	Data Constraints
	

	Examples
	<IncludeHeader>Include/IndustryStandard/Pci.h</IncludeHeader>

<IncludeHeader>Include/IndustryStandard/Acpi.h</IncludeHeader>

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.3.6 IndustryStdIncludes.IndustryStdHeader.HelpText

Table 39.  IndustryStdIncludes.IndustryStdHeader.HelpText
	Description
	A complete description of an Industry Standard Include file.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	<HelpText>

The file Pci.h contains standard definition from the PCI 2.2 and PCI 3.0 Specifications.

</HelpText>

	Build Tool Usage
	NO

	UI Tool Usage
	NO 


13.4 PackageSurfaceArea.MsaFileList

<MsaFileList> 

  <Filename> PathAndFilename </Filename> [1..*] 

</MsaFileList>
Figure 5.  PackageSurfaceArea.MsaFileList Instance

13.4.1 MsaFileList.Filename

Table 40.  MsaFileList.Filename
	Description
	Specifies the package relative filename of an MSA file in the package.

	Required
	YES

	Data Type
	Element – PathAndFilename

	Data Constraints
	

	Examples
	<Filename>Library/BaseLib/BaseLib.Msa</Filename>

<Filename>Universal/Disk/Diskio/DiskIo.Msa</Filename>

	Build Tool Usage
	YES

When a platform is built, the FPD file lists module by their GUID and Version.  The build tools must search the set of package SPD files to find the paths to the MSA files, and then look in the MSA file to see if a matching GUID and Version has been found.  It is recommended that the build tools generate a database at startup to reduce the search time for modules. 

	UI Tool Usage
	YES

Add a Module to a Package: Allow the user to type in or select through a file browser an MSA file that is contained within the package.  Must support cut/paste operations.

Clone a Module from another Package:  Allow the use to select module in another package SPD file.  Then prompt the user for a location in the current package to clone the module.  One the location is selected, the module directory is copied into the current package and a PackageSurfaceArea.MsaFileList.Filename element is added to the current packages SPD file with the Filename pointing to the MSA file that was cloned into the current package.


13.5 PackageSurfaceArea.PackageHeaders

<PackageHeaders> 

  <IncludePkgHeader
    ModuleType=" ModuleTypeDef [1]"> [1..*] 
      PathAndFilename 
  </IncludePkgHeader>

</PackageHeaders>

Figure 6.  PackageSurfaceArea.PackageHeaders Instance

13.5.1 PackageHeaders.IncludePkgHeader

Table 41.  PackageHeaders.IncludePkgHeader
	Description
	Specifies the package relative filename of an include file that extends the set of definitions available for the standard module typea.

	Required
	YES

	Data Type
	Element – PathAndFilename

	Data Constraints
	

	Examples
	<IncludePkgHeader>Include/Peim.h</IncludePkgHeader>

<IncludePkgHeader>Include/EdkDxeCore.h</IncludePkgHeader>

	Build Tool Usage
	YES

When a module is built, the build tools are required to generate an AutoGen.h and AutoGen.c file.  The AutoGen.h file must contain a #include statements for each package that a module depends upon based on the module’s type.  Each package that a module depends upon is evaluated in order.  For each package, a check is made to see if there is PackageHeaders.IncludePkgHeader:ModuleType attribute that matches the current modules type.  If a match is found, then a #include statement is added to the AutoGen.h file of the form::

#include <PackageHeaders.IncludePkgHeader>

	UI Tool Usage
	YES

Edit Package Headers Files for each Module Type in a Package: When this operation is selected by a package developer a form with each of the module types in ModuleTypeDef should be presented.  For each module type on the form, the user should be able to either type in a file path or use a file browser to select an include file from the current package to associate with each module type.  It is legal to not specify an include file, and it is also legal for more than one module type to point to the same include file.  Must support cut/paste operations.


13.5.2 PackageHeaders.IncludePkgHeader:ModuleType

Table 42.  PackageHeaders.IncludePkgHeader:ModuleType
	Description
	Specifies the module type associated with the include file specified by PackageHeaders.IncludePkgHeader.

	Required
	YES

	Data Type
	Attribute – ModuleTypeDef

	Data Constraints
	A string that contains a single module type.  Module types are restricted to one of BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	ModuleType=”BASE”

ModuleType=”PEIM”

ModuleType=”DXE_CORE”

	Build Tool Usage
	YES

When a module is built, the build tools are required to generate an AutoGen.h and AutoGen.c file.  The AutoGen.h file must contain a #include statements for each package that a module depends upon based on the module’s type.  Each package that a module depends upon is evaluated in order.  For each package, a check is made to see if there is PackageHeaders.IncludePkgHeader:ModuleType attribute that matches the current modules type.  If a match is found, then a #include statement is added to the AutoGen.h file of the form::

#include <PackageHeaders.IncludePkgHeader>

	UI Tool Usage
	YES

Edit Package Headers Files for each Module Type in a Package: When this operation is selected by a package developer a form with each of the module types in ModuleTypeDef should be presented.  For each module type on the form, the user should be able to either type in a file path or use a file browser to select an include file from the current package to associate with each module type.  It is legal to not specify an include file, and it is also legal for more than one module type to point to the same include file.  Must support cut/paste operations.


13.6 PackageSurfaceArea.GuidDeclarations

<GuidDeclarations> 

  <Entry
    Name=" xs:NCName [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=" ModuleListType [0..1]" 
    GuidTypeList=" GuidListType [0..1]"> [1..*] 

      <C_Name> ... </C_Name> [1] 

      <GuidValue> ... </GuidValue> [1] 

      <HelpText> ... </HelpText> [1] 

  </Entry>

</GuidDeclarations>

Figure 7.  PackageSurfaceArea.GuidDeclarations Instance

13.6.1 GuidDeclarations.Entry:Name

Table 43.  GuidDeclarations.Entry:Name
	Description
	Specifies the name used by UI tools to display the name of a GUID.

	Required
	YES

	Data Type
	Attribute – NCName

	Data Constraints
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	Examples
	Name=”Acpi10Table”

Name=”PcAnsi”

Name=”DxeServicesTable”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add GUID Definitions to a Module: When a Module Developer adds a GUID to a module, the set of available GUIDs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of GUID Declarations from all of those packages.  If the GuidDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that GUID is filtered from the list.  If the GuidDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the GuidDeclarations.Entry:SupArchList attribute then that GUID is also filtered.  The Module Developer is only presented the filtered list of GUID to select a GUID to add.  When this filtered list is presented to the user, the GuidDeclarations.Entry.Name should be used to display the name of each GUID.

Add a GUID Declaration to a Package: The UI must allow the user to type in the GuidDeclarations.Entry.Name element.  Must support cut/paste operations.

Edit a GUID Declaration in a Package: The UI must allow the user to edit the GuidDeclarations.Entry.Name element.  Must support cut/paste operations.


13.6.2 GuidDeclarations.Entry:SupArchList

Table 44.  GuidDeclarations.Entry:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this GUID.  If this attribute is not specified, then this GUID may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this GUID. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add GUID Definitions to a Module: When a Module Developer adds a GUID to a module, the set of available GUIDs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of GUID Declarations from all of those packages.  If the GuidDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that GUID is filtered from the list.  If the GuidDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the GuidDeclarations.Entry:SupArchList attribute then that GUID is also filtered.  The Module Developer is only presented the filtered list of GUID to select a GUID to add.

Add a GUID Declaration to a Package: The UI must allow the user to select the set of CPU Architectures for this GUID.

Edit a GUID Declaration in a Package: The UI must allow the user to modify the set of CPU Architectures for this GUID.


13.6.3 GuidDeclarations.Entry:FeatureFlag

Table 45.  GuidDeclarations.Entry:FeatureFlag
	Description
	Used to restrict the use of this GUID.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this GUID is not restricted based on feature flag settings.  If this attribute is specified, then this GUID may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.6.4 GuidDeclarations.Entry:SupModuleList

Table 46.  GuidDeclarations.Entry:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this GUID.  If this attribute is not specified, then this GUID may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this GUID. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add GUID Definitions to a Module: When a Module Developer adds a GUID to a module, the set of available GUIDs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of GUID Declarations from all of those packages.  If the GuidDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that GUID is filtered from the list.  If the GuidDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the GuidDeclarations.Entry:SupArchList attribute then that GUID is also filtered.  The Module Developer is only presented the filtered list of GUID to select a GUID to add.

Add a GUID Declaration to a Package: The UI must allow the user to select the set of Module Types for this GUID.

Edit a GUID Declaration in a Package: The UI must allow the user to modify the set of Module Types for this GUID.


13.6.5 GuidDeclarations.Entry:GuidTypeList

Table 47.  GuidDeclarations.Entry:GuidTypeList
	Description
	Used to restrict the set of GUID types that apply to this GUID. If this attribute is not specified, then this GUID may be used with all GUID types.  If this attribute is specified, then this GUID may only appear in the sections of the modules MSA file that have a matching GUID type. 

	Required
	NO

	Data Type
	Attribute – GuidListType

	Data Constraints
	A string that contains one or more GUID types separated by spaces.  The GUID types are restricted to DATA_HUB_RECORD, EFI_EVENT, EFI_SYSTEM_CONFIGURATION_TABLE, EFI_VARIABLE, HII_PACKAGE_LIST, HOB, GUID.

	Examples
	GuidTypeList=”HOB”

GuidTypeList=”EFI_EVENT EFI_VARIABLE”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add GUID Definitions to a Module: When a Module Developer adds a GUID to a module, the set of available GUIDs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of GUID Declarations from all of those packages.  If the GuidDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that GUID is filtered from the list.  If the GuidDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the GuidDeclarations.Entry:SupArchList attribute then that GUID is also filtered.  The Module Developer is only presented the filtered list of GUID to select a GUID to add.

TBD: Add description for all adding all GUID types to a module.
Add a GUID Declaration to a Package: The UI must allow the user to select the set of GUID Types for this GUID.

Edit a GUID Declaration in a Package: The UI must allow the user to modify the set of GUID Types for this GUID.


13.6.6 GuidDeclarations.Entry.C_Name

Table 48.  GuidDeclarations.Entry.C_Name
	Description
	Specifies the symbol name for a GUID used in C code.

	Required
	YES

	Data Type
	Element – C_NameType

	Data Constraints
	A string that starts with either an underscore or a letter, followed by any number of letters, digits or underscores.

	Examples
	<C_Name>Acpi10Table</C_Name>

<C_Name>PcAnsi</C_Name>

<C_Name>DxeServicesTable</C_Name>

	Build Tool Usage
	YES

Used by autogen tools to add GUID global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a GUID Declaration to a Package: The UI must allow the user to type in the symbol name for the GUID.  Must support cut/paste operations.

Edit a GUID Declaration in a Package: The UI must allow the user to modify the symbol name for a GUID.  Must support cut/paste operations.


13.6.7 GuidDeclarations.Entry.GuidValue

Table 49.  GuidDeclarations.Entry.GuidValue
	Description
	Specifies the GUID value for a GUID.

	Required
	YES

	Data Type
	Element – GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

	Examples
	<GuidValue>AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2</GuidValue>

	Build Tool Usage
	YES

Used by autogen tools to add GUID global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a GUID Declaration to a Package: The UI must allow the user to type in a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations.

Edit a GUID Declaration in a Package: The UI must allow the user to modify a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations. 


13.6.8 GuidDeclarations.Entry.HelpText

Table 50.  GuidDeclarations.Entry.HelpText
	Description
	A complete description of a GUID.  This must include any defines and data structures associated with this GUID.  It must also describe any use restrictions based on GUID Type, Module Type, CPU Architecture, and Feature Flags.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	The Console In Device GUID is used to tag an EFI_HANDLE for a Console Input Device as an active console input device.  This is used by the Console Splitter Driver to search for set of console input devices in the handle database that should be multiplexed.  This GUID is available to all CPU types, but is restricted for use by DXE_DRIVER, UEFI_DRIVER, and UEFI_APPLICATION module types.

	Build Tool Usage
	NO

	UI Tool Usage
	YES. 

Select GUID: If the user selects a GUID from a package, then the PackageSurfaceArea.GuidDeclarations.Entry.HelpText element must be displayed in a help text window.  A GUID can be selected when Importing a GUID Declaration from another Package, Deleting a GUID Declaration from a Package, Adding a GUID Definition to a Module, Editing GUID Definition properties in a Module, and Deleting a GUID Definition from a Module.

Add a GUID Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.GuidDeclarations.Entry.HelpText element.  Must support cut/paste operations.

Edit a GUID Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.GuidDeclarations.Entry.HelpText element.  Must support cut/paste operations.


13.7 PackageSurfaceArea.ProtocolDeclarations

<ProtocolDeclarations> 

  <Entry
    Name=" xs:NCName [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=" ModuleListType [0..1]"> [1..*] 

      <C_Name> ... </C_Name> [1] 

      <GuidValue> ... </GuidValue> [0..1] 

      <HelpText> ... </HelpText> [1] 

  </Entry>

</ProtocolDeclarations>

Figure 8.  PackageSurfaceArea.ProtocolDeclarations Instance

13.7.1 ProtocolDeclarations.Entry:Name

Table 51.  ProtocolDeclarations.Entry:Name
	Description
	Specifies the name used by UI tools to display the name of a Protocol.

	Required
	YES

	Data Type
	Attribute – NCName

	Data Constraints
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	Examples
	Name=”BlockIo”

Name=”DiskIo”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add Protocol Definitions to a Module: 

Add a Protocol Declaration to a Package: The UI must allow the user to type in the ProtocolDeclarations.Entry.Name element.  Must support cut/paste operations.

Edit a Protocol Declaration in a Package: The UI must allow the user to edit the ProtocolDeclarations.Entry.Name element.  Must support cut/paste operations.


13.7.2 ProtocolDeclarations.Entry:SupArchList

Table 52.  ProtocolDeclarations.Entry:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this Protocol.  If this attribute is not specified, then this Protocol may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this Protocol. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add Protocol Definitions to a Module: When a Module Developer adds a Protocol to a module, the set of available Protocols must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of Protocol Declarations from all of those packages.  If the ProtocolDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that Protocol is filtered from the list.  If the ProtocolDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the ProtocolDeclarations.Entry:SupArchList attribute then that Protocol is also filtered.  The Module Developer is only presented the filtered list of Protocol to select a Protocol to add.

Add a Protocol Declaration to a Package: The UI must allow the user to select the set of CPU Architectures for this Protocol.

Edit a Protocol Declaration in a Package: The UI must allow the user to modify the set of CPU Architectures for this Protocol.


13.7.3 ProtocolDeclarations.Entry:FeatureFlag

Table 53.  ProtocolDeclarations.Entry:FeatureFlag
	Description
	Used to restrict the use of this Protocol.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this Protocol is not restricted based on feature flag settings.  If this attribute is specified, then this Protocol may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.7.4 ProtocolDeclarations.Entry:SupModuleList

Table 54.  ProtocolDeclarations.Entry:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this Protocol.  If this attribute is not specified, then this Protocol may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this Protocol. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add Protocol Definitions to a Module: When a Module Developer adds a Protocol to a module, the set of available Protocols must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of Protocol Declarations from all of those packages.  If the ProtocolDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that Protocol is filtered from the list.  If the ProtocolDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the ProtocolDeclarations.Entry:SupArchList attribute then that Protocol is also filtered.  The Module Developer is only presented the filtered list of Protocol to select a Protocol to add.

Add a Protocol Declaration to a Package: The UI must allow the user to select the set of Module Types for this Protocol.

Edit a Protocol Declaration in a Package: The UI must allow the user to modify the set of Module Types for this Protocol.


13.7.5 ProtocolDeclarations.Entry.C_Name

Table 55.  ProtocolDeclarations.Entry.C_Name
	Description
	Specifies the symbol name for a Protocol GUID used in C code.

	Required
	YES

	Data Type
	Element – C_NameType

	Data Constraints
	A string that starts with either an underscore or a letter, followed by any number of letters, digits or underscores.

	Examples
	<C_Name>gEfiBlockIoProtocolGuid</C_Name>

<C_Name>gEfiDiskIoProtocolGuid</C_Name>

	Build Tool Usage
	YES

Used by autogen tools to add Protocol global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a Protocol Declaration to a Package: The UI must allow the user to type in the symbol name for the Protocol.  Must support cut/paste operations.

Edit a Protocol Declaration in a Package: The UI must allow the user to modify the symbol name for a Protocol.  Must support cut/paste operations.


13.7.6 ProtocolDeclarations.Entry.GuidValue

Table 56.  ProtocolDeclarations.Entry.GuidValue
	Description
	Specifies the GUID value for a Protocol.

	Required
	YES

	Data Type
	Element - GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

	Examples
	<GuidValue>AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2</GuidValue>

	Build Tool Usage
	YES

Used by autogen tools to add Protocol global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a Protocol Declaration to a Package: The UI must allow the user to type in a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations.

Edit a Protocol Declaration in a Package: The UI must allow the user to modify a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations. 


13.7.7 ProtocolDeclarations.Entry.HelpText

Table 57.  ProtocolDeclarations.Entry.HelpText
	Description
	A complete description of a Protocol.  This must include any functions, defines, and data structures associated with this Protocol.  It must also describe any use restrictions based on Module Type, CPU Architecture, and Feature Flags.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	The Block I/O Protocol provides services to read, write, and flush block to a block oriented storage device such as a hard disk, CD-ROM, DVD, and floppy.  This Protocol is available to all CPU types, but is restricted for use by DXE_DRIVER, UEFI_DRIVER, and UEFI_APPLICATION module types.

	Build Tool Usage
	NO

	UI Tool Usage
	YES. 

Select Protocol: If the user selects a Protocol from a package, then the PackageSurfaceArea.ProtocolDeclarations.Entry.HelpText element must be displayed in a help text window.  A Protocol can be selected when Importing a Protocol Declaration from another Package, Deleting a Protocol Declaration from a Package, Adding a Protocol Definition to a Module, Editing Protocol Definition properties in a Module, and Deleting a Protocol Definition from a Module.

Add a Protocol Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.ProtocolDeclarations.Entry.HelpText element.  Must support cut/paste operations.

Edit a Protocol Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.ProtocolDeclarations.Entry.HelpText element.  Must support cut/paste operations.


13.8 PackageSurfaceArea.PpiDeclarations

<PpiDeclarations> 

  <Entry
    Name=" xs:NCName [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=" ModuleListType [0..1]"> [1..*] 

      <C_Name> ... </C_Name> [1] 

      <GuidValue> ... </GuidValue> [0..1] 

      <HelpText> ... </HelpText> [1] 

  </Entry>

</PpiDeclarations>

Figure 9.  PackageSurfaceArea.PpiDeclarations Instance

13.8.1 PpiDeclarations.Entry:Name

Table 58.  PpiDeclarations.Entry:Name
	Description
	Specifies the name used by UI tools to display the name of a PPI.

	Required
	YES

	Data Type
	Attribute - NCName

	Data Constraints
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	Examples
	Name=”DkeIpl”

Name=”PciCfg”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add PPI Definitions to a Module: 

Add a PPI Declaration to a Package: The UI must allow the user to type in the PpiDeclarations.Entry.Name element.  Must support cut/paste operations.

Edit a PPI Declaration in a Package: The UI must allow the user to edit the PpiDeclarations.Entry.Name element.  Must support cut/paste operations.


13.8.2 PpiDeclarations.Entry:SupArchList

Table 59.  PpiDeclarations.Entry:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this PPI.  If this attribute is not specified, then this PPI may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this PPI. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add PPI Definitions to a Module: When a Module Developer adds a PPI to a module, the set of available PPIs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PPI Declarations from all of those packages.  If the PpiDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PPI is filtered from the list.  If the PpiDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PpiDeclarations.Entry:SupArchList attribute then that PPI is also filtered.  The Module Developer is only presented the filtered list of PPI to select a PPI to add.

Add a PPI Declaration to a Package: The UI must allow the user to select the set of CPU Architectures for this PPI.

Edit a PPI Declaration in a Package: The UI must allow the user to modify the set of CPU Architectures for this PPI.


13.8.3 PpiDeclarations.Entry:FeatureFlag

Table 60.  PpiDeclarations.Entry:FeatureFlag
	Description
	Used to restrict the use of this PPI.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this PPI is not restricted based on feature flag settings.  If this attribute is specified, then this PPI may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.8.4 PpiDeclarations.Entry:SupModuleList

Table 61.  PpiDeclarations.Entry:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this PPI.  If this attribute is not specified, then this PPI may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this PPI. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add PPI Definitions to a Module: When a Module Developer adds a PPI to a module, the set of available PPIs must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PPI Declarations from all of those packages.  If the PpiDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PPI is filtered from the list.  If the PpiDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PpiDeclarations.Entry:SupArchList attribute then that PPI is also filtered.  The Module Developer is only presented the filtered list of PPI to select a PPI to add.

Add a PPI Declaration to a Package: The UI must allow the user to select the set of Module Types for this PPI.

Edit a PPI Declaration in a Package: The UI must allow the user to modify the set of Module Types for this PPI.


13.8.5 PpiDeclarations.Entry.C_Name

Table 62.  PpiDeclarations.Entry.C_Name
	Description
	Specifies the symbol name for a PPI GUID used in C code.

	Required
	YES

	Data Type
	Element – C_NameType

	Data Constraints
	A string that starts with either an underscore or a letter, followed by any number of letters, digits or underscores.

	Examples
	<C_Name>gEfiDxeiIplPpiGuid</C_Name>

<C_Name>gEfiPciCfgPpiGuid</C_Name>

	Build Tool Usage
	YES

Used by autogen tools to add PPI global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a PPI Declaration to a Package: The UI must allow the user to type in the symbol name for the PPI.  Must support cut/paste operations.

Edit a PPI Declaration in a Package: The UI must allow the user to modify the symbol name for a PPI.  Must support cut/paste operations.


13.8.6 PpiDeclarations.Entry.GuidValue

Table 63.  PpiDeclarations.Entry.GuidValue
	Description
	Specifies the GUID value for a PPI.

	Required
	YES

	Data Type
	Element – GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

	Examples
	<GuidValue>AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2</GuidValue>

	Build Tool Usage
	YES

Used by autogen tools to add PPI global variables to AutoGen.h AutoGen.c

	UI Tool Usage
	YES

Add a PPI Declaration to a Package: The UI must allow the user to type in a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations.

Edit a PPI Declaration in a Package: The UI must allow the user to modify a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations. 


13.8.7 PpiDeclarations.Entry.HelpText

Table 64.  PpiDeclarations.Entry.HelpText
	Description
	A complete description of a PPI.  This must include any functions, defines, and data structures associated with this PPI.  It must also describe any use restrictions based on Module Type, CPU Architecture, and Feature Flags.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	The PCI CFG PPI provides services to access PCI Configuration Headers from a PEIM.  This PPI is available to all CPU types, but is restricted for use by PEIM module types.

	Build Tool Usage
	NO

	UI Tool Usage
	YES. 

Select PPI: If the user selects a PPI from a package, then the PackageSurfaceArea.PpiDeclarations.Entry.HelpText element must be displayed in a help text window.  A PPI can be selected when Importing a PPI Declaration from another Package, Deleting a PPI Declaration from a Package, Adding a PPI Definition to a Module, Editing PPI Definition properties in a Module, and Deleting a PPI Definition from a Module.

Add a PPI Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.PpiDeclarations.Entry.HelpText element.  Must support cut/paste operations.

Edit a PPI Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.PpiDeclarations.Entry.HelpText element.  Must support cut/paste operations.


13.9 PackageSurfaceArea.PcdDeclarations

<PcdDeclarations> 

  <PcdEntry
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=" ModuleListType [0..1]"> [1..*] 

      <C_Name> ... </C_Name> [1] 

      <Token> TokenDataType </Token> [1] 

      <TokenSpaceGuid> GuidType </TokenSpaceGuid> [1] 

      <DatumType> PcdDataTypes </DatumType> [1] 

      <ValidUsage> PcdListType </ValidUsage> [1] 

      <DefaultValue> DefaultValue </DefaultValue> [0..1] 

      <HelpText> ... </HelpText> [1] 

    </PcdEntry>

</PcdDeclarations>

Figure 10.  PackageSurfaceArea.PcdDeclarations Instance

13.9.1 PcdDeclarations.PcdEntry:SupArchList

Table 65.  PcdDeclarations.PcdEntry:SupArchList
	Description
	Used to restrict the set of CPU Architectures that are allowed to use this PCD Entry.  If this attribute is not specified, then this PCD Entry may be used with any CPU Architecture.  If this attribute is specified, then only those modules that support a subset of the CPU architectures specified by this element may use this PCD Entry. 

	Required
	NO

	Data Type
	Attribute – ArchListType

	Data Constraints
	If specified, must contain one or more of the supported CPU architectures separated by spaces.  The supported CPU architectures include IA32, X64, IPF, EBC, PPC, ARM.

	Examples
	SupArchList=“IA32”

SupArchList=“IA32 X64”

SupArchList=“EBC IPF X64”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add PCD Definitions to a Module: When a Module Developer adds a PCD Entry to a module, the set of available PCD Entries must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PCD Declarations from all of those packages.  If the PcdDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PCD Entry is filtered from the list.  If the PcdDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PcdDeclarations.Entry:SupArchList attribute then that PCD Entry is also filtered.  The Module Developer is only presented the filtered list of PCD Entries to select a PCD Entry to add.

Add a PCD Declaration to a Package: The UI must allow the user to select the set of CPU Architectures for this PCD.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the set of CPU Architectures for this PCD.


13.9.2 PcdDeclarations.PcdEntry:FeatureFlag

Table 66.  PcdDeclarations.PcdEntry:FeatureFlag
	Description
	Used to restrict the use of this PCD Entry.  This attribute is a Boolean expression containing PCD Feature Flag names and operators in post fix format.  If this attribute is not specified, the use of this PCD Entry is not restricted based on feature flag settings.  If this attribute is specified, then this PCD Entry may only be used if the Boolean expression evaluates to true.

	Required
	NO

	Data Type
	Attribute – FeatureFlagExpressionType

	Data Constraints
	TBD

	Examples
	TBD

	Build Tool Usage
	NO

	UI Tool Usage
	NO


13.9.3 PcdDeclarations.PcdEntry:SupModuleList

Table 67.  PcdDeclarations.PcdEntry:SupModuleList
	Description
	Used to restrict the set of module types that are allowed to use this PCD Entry.  If this attribute is not specified, then this PCD Entry may be used with all module types.  If this attribute is specified, then only those modules that have a module type that is a member of the set of module types specified by this element may use this PCD Entry. 

	Required
	NO

	Data Type
	Attribute – ModuleListType

	Data Constraints
	If specified, must contain one or more of the supported module types separated by spaces.  The supported module types include BASE, SEC, PEI_CORE, PEIM, DXE_CORE, DXE_DRIVER, DXE_RUNTIME_DRIVER, DXE_SAL_DRIVER, DXE_SMM_DRIVER, TOOL, UEFI_DRIVER, UEFI_APPLICATION, USER_DEFINED.

	Examples
	SupModuleList=“BASE”

SupModuleList=“PEIM DXE_DRIVER”

SupModuleList=“UEFI_DRIVER UEFI_APPLICATION DXE_DRIVER”

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add PCD Definitions to a Module: When a Module Developer adds a PCD Entry to a module, the set of available PCD Entries must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PCD Declarations from all of those packages.  If the PcdDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PCD Entry is filtered from the list.  If the PcdDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PcdDeclarations.Entry:SupArchList attribute then that PCD Entry is also filtered.  The Module Developer is only presented the filtered list of PCD Entries to select a PCD Entry to add.

Add a PCD Declaration to a Package: The UI must allow the user to select the set of Module Types for this PCD.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the set of Module Types for this PCD.


13.9.4 PcdDeclarations.PcdEntry.C_Name

Table 68.  PcdDeclarations.PcdEntry.C_Name
	Description
	Specifies the symbol name for a PCD Entry used in C code.  This element is also used by the UI Tools to display the name of the PCD Entry.

	Required
	YES

	Data Type
	Element – C_NameType

	Data Constraints
	A string that starts with either an underscore or a letter, followed by any number of letters, digits or underscores.

	Examples
	<C_Name>PcdDebugPropertyMask</C_Name>

	Build Tool Usage
	YES

Used by autogen tools to add PCD defines and variables to AutoGen.h AutoGen.c

Also used by autogen tools to generate the PCD database required by the PCD PEIM and PCD DXE Driver

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to type in the symbol name for the PCD Entry.  Must support cut/paste operations.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the symbol name for a PCD Entry.  Must support cut/paste operations.

Add PCD Definitions to a Module: When a Module Developer adds a PCD Entry to a module, the set of available PCD Entries must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PCD Declarations from all of those packages.  If the PcdDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PCD Entry is filtered from the list.  If the PcdDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PcdDeclarations.Entry:SupArchList attribute then that PCD Entry is also filtered.  The Module Developer is only presented the filtered list of PCD Entries to select a PCD Entry to add.  This list is presented using the PcdDeclarations.Entry.C_Name to display each element in the list.


13.9.5 PcdDeclarations.PcdEntry.Token

Table 69.  PcdDeclarations.PcdEntry.Token
	Description
	Specified the 32-bit token value for the PCD Entry

	Required
	YES

	Data Type
	Element – TokenDataType

	Data Constraints
	Each PCD Entry in a Token Space must have a unique Token value. 

	Examples
	<Token>0</Token>

<Token>27</Token>

	Build Tool Usage
	YES

Used by autogen tools to add PCD defines and variables to AutoGen.h AutoGen.c

Also used by autogen tools to generate the PCD database required by the PCD PEIM and PCD DXE Driver

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to type in the token value for the PCD Entry.  Must support cut/paste operations.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the token value for a PCD Entry.  Must support cut/paste operations.

Add a Module to a Platform: This element is used to initialize the PcdBuildDefinitions section of the FPD file.  Also use to initialize the DynamicPcdDefinitions section of the FPD file is the platform developer chooses a PCD Entry item type of DYNAMIC or DYNAMIC_EX.


13.9.6 PcdDeclarations.PcdEntry.TokenSpaceGuid

Table 70.  PcdDeclarations.PcdEntry.TokenSpaceGuid
	Description
	Specifies the GUID of the Token Space of which this PCD Entry is a member.

	Required
	YES

	Data Type
	Element – GuidType

	Data Constraints
	A string that represents a GUID in registry format.  

	Examples
	<GuidValue>AF0DDA2E-EA83-480b-B2CE-FC0BB2F894C2</GuidValue>

	Build Tool Usage
	YES

Used by autogen tools to add PCD defines and variables to AutoGen.h AutoGen.c

Also used by autogen tools to generate the PCD database required by the PCD PEIM and PCD DXE Driver

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to type in a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations.

Edit a PCD Declaration in a Package: The UI must allow the user to modify a GUID value in registry format or click on a button to generate a GUID value.  Must support cut/paste operations.

Add a Module to a Platform: This element is used to initialize the PcdBuildDefinitions section of the FPD file.  Also use to initialize the DynamicPcdDefinitions section of the FPD file is the platform developer chooses a PCD Entry item type of DYNAMIC or DYNAMIC_EX.


13.9.7 PcdDeclarations.PcdEntry.DatumType

Table 71.  PcdDeclarations.PcdEntry.DatumType
	Description
	Specifies the datum type of this PCD Entry.

	Required
	YES

	Data Type
	Element – PcdDataType

	Data Constraints
	A string that contains the data type of the PCD Entry.  PCD data types are restricted to the following set:UINT8, UINT16, UINT32, UINT64, VOID*, BOOLEAN.

	Examples
	<DatumType>UINT8</DatumType>

<DatumType>VOID*</DatumType>

<DatumType>BOOLEAN</DatumType>

	Build Tool Usage
	YES

Used by autogen tools to add PCD defines and variables to AutoGen.h AutoGen.c

Also used by autogen tools to generate the PCD database required by the PCD PEIM and PCD DXE Driver

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to select the datum type from the list of available datum types.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the selected datum type.

Add a Module to a Platform: This element is used to initialize the PcdBuildDefinitions section of the FPD file.  Also use to initialize the DynamicPcdDefinitions section of the FPD file is the platform developer chooses a PCD Entry item type of DYNAMIC or DYNAMIC_EX.


13.9.8 PcdDeclarations.PcdEntry.ValidUsage

Table 72.  PcdDeclarations.PcdEntry.ValidUsage
	Description
	Specifies the set of valid usages for this PCD Entry.

	Required
	YES

	Data Type
	Element - PcdListType

	Data Constraints
	A string that contains one or more PCD Entry item types separated by spaces.  The PCD Entry item types are restricted to FEATURE_FLAG, FIXED_AT_BUILD, PATCHABLE_IN_MODULE, DYNAMIC, DYNAMIC_EX.

	Examples
	<ValidUsage>FEATURE_FLAG</ValidUsage>

<ValidUsage>FIXED_AT_BUILD PATCHABLE_IN_MODULE</ValidUsage>
<ValidUsage>
FIXED_AT_BUILD PATCHABLE_IN_MODULE DYNAMIC DYNAMIC_EX
</ValidUsage>

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to select the set of valid PCD entry usage types.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the set of valid PCD entry usage types.

Add PCD Definitions to a Module: When a Module Developer adds a PCD Entry to a module, the set of available PCD Entries must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PCD Declarations from all of those packages.  If the PcdDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PCD Entry is filtered from the list.  If the PcdDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PcdDeclarations.Entry:SupArchList attribute then that PCD Entry is also filtered.  The Module Developer is only presented the filtered list of PCD Entries to select a PCD Entry to add.  This list is presented using the PcdDeclarations.Entry.C_Name to display each element in the list.  Once a PCD Entry is selected, the module developer must then select the PCD item type for this PCD Entry the declares how the source code to the module accesses the PCD Entry.  The module developer must select one of the values in the set PcdDeclarations.Entry.ValidUsage.  


13.9.9 PcdDeclarations.PcdEntry.DefaultValue

Table 73.  PcdDeclarations.PcdEntry.DefaultValue
	Description
	Specifies the default value for the PCD Entry.  This default value is only used to initialize the contents of an FPD file when a module is added to a platform.  If this element is present, then the value for the PCD Entry in the FPD file is initialized to this value.

	Required
	NO

	Data Type
	Element – DefaultValue

	Data Constraints
	This element must support strings used to encode all the supported datum types, which includes 8, 16, 32, and 64 bit unsigned integers, Booleans, and buffers.  The buffer types supported are ASCII strings, Unicode strings, and arrays of byte values.

	Examples
	<DefaultValue>0x1f</DefaultValue>

<DefaultValue>0x80000000</DefaultValue>

<DefaultValue>234</DefaultValue>

<DefaultValue>”PlatformName”</DefaultValue>

<DefaultValue>L”PlatformName”</DefaultValue>

<DefaultValue>0x01 0x02 0x03 0x45</DefaultValue>

	Build Tool Usage
	NO

	UI Tool Usage
	YES

Add a PCD Declaration to a Package: The UI must allow the user to type in a default value.  Must support cut/paste operations.

Edit a PCD Declaration in a Package: The UI must allow the user to modify the default value.  Must support cut/paste operations.

Add PCD Definitions to a Module: When a Module Developer adds a PCD Entry to a module, the set of available PCD Entries must be filtered.  First, the set of packages that a modules depends on is used to collect the complete set of PCD Declarations from all of those packages.  If the PcdDeclarations.Entry:SupModuleList attribute is present and the ModuleType of the module being edited is not in that list, then that PCD Entry is filtered from the list.  If the PcdDeclarations.Entry:SupArchList attribute is present and the SupArchList of the module is not a proper subset of the PcdDeclarations.Entry:SupArchList attribute then that PCD Entry is also filtered.  The Module Developer is only presented the filtered list of PCD Entries to select a PCD Entry to add.  This list is presented using the PcdDeclarations.Entry.C_Name to display each element in the list.  Once a PCD Entry is selected, the module developer must then select the PCD item type for this PCD Entry the declares how the source code to the module accesses the PCD Entry.  The module developer must select one of the values in the set PcdDeclarations.Entry.ValidUsage.  Once the PCD Entry item type has been selected, the module developer may optionally enter a default value provided by the module.  If the PcdDeclarations.Entry.DefaultValue is specified, then the UI must initialize the module’s default value to the PcdDeclarations.Entry.DefaultValue and allow the module developer to edit this value.

Add a Module to a Platform: This default value is used to initialize the contents of an FPD file when a module is added to a platform.  If this element is present and the default value from the MSA file is not specified, then the value for the PCD Entry in the FPD file is initialized to this value.


13.9.10 PcdDeclarations.PcdEntry.HelpText

Table 74.  PcdDeclarations.PcdEntry.HelpText
	Description
	A complete description of a PCD Entry including the intended use models of the PCD Entry, its valid usage, its data type, and any value assignment constraints.  It must also describe any use restrictions based on Module Type, CPU Architecture, and Feature Flags.

	Required
	YES

	Data Type
	Element – Paragraph

	Data Constraints
	A string that contains one or more lines of text.

	Examples
	The PcdDebugPropertyMask is an 8-bit mask of debug properties that may be set to a unique value for each module in the platform.  This PCD Entry is available to all CPU and Module types and may be configured as FIXED_AT_BUILD or BINARY_PATCHABLE and supports the following bit settings:

    #define DEBUG_PROPERTY_DEBUG_ASSERT_ENABLED       0x01

    #define DEBUG_PROPERTY_DEBUG_PRINT_ENABLED        0x02

    #define DEBUG_PROPERTY_DEBUG_CODE_ENABLED         0x04

    #define DEBUG_PROPERTY_CLEAR_MEMORY_ENABLED       0x08

    #define DEBUG_PROPERTY_ASSERT_BREAKPOINT_ENABLED  0x10

    #define DEBUG_PROPERTY_ASSERT_DEADLOOP_ENABLED    0x20

	Build Tool Usage
	NO

	UI Tool Usage
	YES. 

Select PCD Entry: If the user selects a PCD Entry from a package, then the PackageSurfaceArea.PcdDeclarations.Entry.HelpText element must be displayed in a help text window.  A PCD Entry can be selected when Importing a PCD Declaration from another Package, Deleting a PCD Declaration from a Package, Adding a PCD Definition to a Module, Editing PCD Definition properties in a Module, and Deleting a PCD Definition from a Module.

Add a PCD Declaration to a Package: The UI must allow the user to type in the PackageSurfaceArea.PcdDeclarations.Entry.HelpText element.  Must support cut/paste operations.

Edit a PCD Declaration in a Package: If the PackageSurfaceArea.SpdHeader.ReadOnly element is false, then the UI must allow the user to edit the PackageSurfaceArea.PcdDeclarations.Entry.HelpText element.  Must support cut/paste operations.


13.10 PackageSurfaceArea.UserExtensions

<UserExtensions
  UserID=" xs:NCName [1]" 
  Identifier=" xs:integer [1]"> 
    xs:anyType
</UserExtensions>

Figure 11.  PackageSurfaceArea.UserExtensions Instance

Table 75.  PackageSurfaceArea.UserExtensions
	Description
	A free format section of an SPD file.  An SPD file may contain zero or more of these sections. 

	Required
	NO

	Data Type
	Element – xs:anyType

	Data Constraints
	None

	Examples
	N/A

	Build Tool Usage
	NO.  The default build tools should not depend on any user extension sections.

Build Tools must ignore UserExtensions elements they do not recognize.

	UI Tool Usage
	NO.  The default UI tools should not depend on any user extension sections. 

UI Tools must ignore UserExtensions elements they do not recognize.


13.10.1 PackageSurfaceArea.UserExtensions:UserID

Table 76.  PackageSurfaceArea.UserExtensions:UserID
	Description
	A string that identifies the name of the user extension

	Required
	YES

	Data Type
	Attribute – NCName

	Data Constraints
	A string that start with a letter or an underscore and is followed by any combination of letters, digits, periods, hyphens, and underscores.  No whitespace is allowed.

	Examples
	UserID=”TianoCore.org”

UserID=”MyFavoriteBiosVendor”

	Build Tool Usage
	NO.  The default build tools should not depend on any user extension sections.

Build Tools must ignore UserExtensions elements they do not recognize.

	UI Tool Usage
	NO.  The default UI tools should not depend on any user extension sections. 

UI Tools must ignore UserExtensions elements they do not recognize.


13.10.2 PackageSurfaceArea.UserExtensions:Identifier

Table 77.  PackageSurfaceArea.UserExtensions:Identifier
	Description
	A value that identifies the function, features, or version of the user extension

	Required
	YES

	Data Type
	Attribute – xs:nonNegativeInteger

	Data Constraints
	A 32-bit integer value that is greater than zero.

	Examples
	Identifier=”1”

Identifier=”27”

	Build Tool Usage
	NO.  The default build tools should not depend on any user extension sections.

Build Tools must ignore UserExtensions elements they do not recognize.

	UI Tool Usage
	NO.  The default UI tools should not depend on any user extension sections. 

UI Tools must ignore UserExtensions elements they do not recognize.


14 
Platform (.FPD)

Andrew’s Comments
Add a MSA file.

For each MSA file make a list of:
Set<Instance> ResolveLibraryInstances(Module m) {

  Set<Instance> Instances = Set<Instance>(m);

  Set<LibClass> UnboundClasses=ClassesConsumed(Instances) – ClassesProduced(Instances)        

  While(UnboundClasses != EMPTY) {

    for next c in UnboundClasses {

      Set<LibInst> PotentialInstanceList = EMPTY

      For each module mlib in WORKSPACE {

        If mlib.produces(c) {

          Bool isPotential = true

          For class in ClassesProduced(mlib) {

            If class in ClassesProduced(SelectedInstances) {

              isPotential = false

            }

          }

          If( isPotential ) {

            PotentialInstanceList += mlib

          }

        }

      }

      If(PotentialInstanceList == EMPTY ) {

        // Missing a required instance.        

        ERROR !!! Tell User That they cannot build the module.

        Return EMPTY

      }

   Ask user to choose one Instance from the PotentialInstanceList

      Instances += UserChoice

      SelectedInstances += UserChoice

UnboundClasses=ClassesConsumed(Instances) – ClassesProduced(Instances)

      If UnboundClasses == EMPTY {

        Return SelectedInstances

      }

    }

  }

}

FPD ModuleSA Libraries

Show the class on the left. Show the PotentialInstances on the Right. HIGHLIGHT the recommended Instances in the drop down box.

User selects an instance, and then clicks the add button. The selected instances are displayed in a table below the add button on the same form.

· Library classes required. UI will display a fixed list of library class next to a pick list of library instances of that class from the work space. The library instance info will default to following values:

· If only one library instance for the class exists in the workspace make this the default answer

· If a library instance for the class exists in the <GlobalLibraryInstance> use this instance as a default

· Otherwise default to not selected

· If the FrameworkPlatformDescription.PlatformDefinitions.SkuInfo has been completed, SKUs are enabled.  If this section has been updated and SkuInfo does not appear, then SKUs are disabled.  So for a new FPD file, question right after the header is: Do you want to enable SKUs?    

· Dialog Box
Table 10‑SS Dialog Box to Enable SKUs
	Description
	Enable or Disable SKUs

	Required
	Yes

	Editable
	Yes

	Prompt
	Do you want to enable SKUs?

	Field Type
	Radio YES | NO (default NO)

	Field Help
	None

	Data Type
	None

	XML Tags
	None

	Data Source
	None

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	This is a question only, if Yes, User needs to complete SkuInfo

If No, got to next major section


If Yes, use the following format for the ViewEdit form:

Table 10‑TT PlatformDefinitions.SkuInfo.UiSkuName:SkuID
	Description
	Assign SKU to a label

	Required
	Yes

	Editable
	Yes

	Prompt
	SKU #

	Field Type
	String

	Field Help
	Enter a unique positive number:

	Data Type
	Xs:nonNegativeInteger

	XML Tags
	PlatformDefinitions.SkuInfo.UiSkuName:SkuID

	Data Source
	EMPTY or read from file

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	This is needed before you can complete the PCD sections


Table 10‑UU PlatformDefinitions.SkuInfo.UiSkuName
	Description
	Assign SKU to a label

	Required
	Yes

	Editable
	Yes

	Prompt
	SKU Name to Display

	Field Type
	String

	Field Help
	SKU Name:

	Data Type
	UiNameType

	XML Tags
	PlatformDefinitions.SkuInfo.UiSkuName:SkuID.UiSkuName

	Data Source
	EMPTY or read from file

	Data Verification
	None

	Hover Option
	None

	Properties
	None

	Notes
	This is needed before you can complete the PCD sections


ADD BUTTON

Spreadsheet style table of SkuID and UiSkuNames

Add/del/cut/paste… GET FROM ABOVE

Drag a module in the ModuleSA area, need to complete PCD Section if MSA is PCD Coded

· PCD Entries required. UI will display a fixed list of PCD types next to the information about the PCD entry.

· Save the PCD Type

· If the .MSA file uses the PCD entry in it’s Dynamic form the platform must decide if the FixedAtBuild, PatchableInModule, or Dynamic form will be used. This updates the PCD type that was saved.

· If the PCD entry is Dynamic of DynamicEx add it to the <GlobalPcdFixedValue> section.

· If the PCD entry is Feature Flag, Fixed At Build, or Patchable get data from the user

· If <GlobalPcdFixedValue> has a value for this setting make it the default in the UI

· If there is a default value in the .MSA make it the default value in the UI

· If there is not a default in the .MSA use the default value from the .SPD

· If no default the UI will start with no default data value.

· Note: Most PCD types are fixed size so size information should only be asked if it’s the pointer type. 

· This algorithm implies that Dynamic and DynamicEx data must be filled in before the .FPD is saved. I’m O.K. if we force values to be filed in the first time we pick a PCD entry with an .MSA file to be dynamic or dynamicEx. This could be done with a pop up menu. If you want to wait until a save and force the section to filled out I’m O.K. with that too. 

· We need a screen that lets you edit the dynamic and dynamicEx data. Dynamic is the common case so we should optimize for that. The GUID’s and token numbers are implied so we should not prompt the user for this information. 

14.1.1 Global Information

We should add optional <GlobalLibraryInstance> and <GlobalPcdFixedValue> sections. This information is used to pick default answers to library instance and PCD value resolution when we edit .MSA files. At some phase II we can allow the tool to edit these values directly. 

Dynamic PCD information should be in it’s own section like we discussed and <GlobalPcdFixedValue> only contains information about FeatureFlag, Fixed at build, and Patchable PCD entries.

1. 
Description of Changes to the XMLSchema
14.2 Global Changes

Removed OverrideId attribute from all attributeGroup definitions.
14.3 New XMLSchemna File: WizardPreferences.xsd
This file will be used for maintaining information about how the Wizard application acts.  It will store the Policy information, along with the Preference data (such as locale and last 9 files opened.)

Main element: <WizPref>

<Policy> and <SpdCreation>
This will be used for Administrative content for governing how the Wizard will handle normal developer action, as defined above.

<Policy>

  <SpdCreation Mode=”UNRESTRICTED”/>

OR

  <SpdCreation Mode=”SINGLE|MULTIPLE”>

    <File Guid=”…” Version=”…”>PackageDirectory/SpdFilename.spd</File>

    <File Guid=”…” Version=”…”>PackageDirectory/SpdFilename2.spd</File>

  </SpdCreation>

</Policy>

Note: The 2nd+ entries are only valid for Mode=”Multiple”  If  the Mode is set to Single, only the first <File> entry is presented as an option to the developer when attaching an MSA to a Package.  At least one <File> element must be specified if Single or Multiple Mode values are set.

<Preferences>  and <Locale>
This section will be used to store Wizard application configuration data.
<Preferences>

  <Locale>us_EN</Locale> {0,1}
  <MostRecentFiles> {0,1}
    <NumberToTrack></NumberToTrack> {1}

    <LastOpened></LastOpened> {0,1}

    <File Seq=0”>/path/and/filename.ext</File>  {1,n}
  </MostRecentFiles>

</Preferences>

14.4 Framework Database File

The following changes are being made to the XMLSchema for the Framework Database.
Removed Elements

<ModuleList>
This section is no longer required.  New policy requires that modules be associated with a package.
Element Name Change

<PlatformDescriptions> is being renamed to <PlatformList>
Element Modifications
<Package> sub-element: <InstalledDate> goes from {1} to {0,1}

<Package> sub-element: <CreateDate> {0,1} is new

<Package> sub-element: <ModifiedDate> {0,1} is new
<Package PackageName=”…”> new attribute PackageName, Type: BaseNameConvention, Use=required
<Package PackageGuid=”…”> new attribute PackageGuid, Type GuidType, Use=required

<Package PackageVersion=”…”> new attribute PackageVersion, Type VersionDataType, Use=”required

<Package Type=”…”> rename PackageType attribute to just Type (so as not to confuse the datatype, PackageType with the attribute name.)
<Path> is being deleted.

<File> is being added: Type=DirectoryNamingConvention which actually is Directory and filename together.

Deleting <PackageName> <Guid> <Version> and <PackageType> sub-elements from <Package>

Deleting AttributeGroup: PackageNameAttributes

14.5 Framework Platform Description (.FPD) Files

The FPD files are changing as follows.  Additionally, the since the MBD files are being removed from the XML Schema, the Library Instance and Build Options information from the MBD files must be migrated into the FPD files.
Adding Elements

To <FpdHeader> adding <GuidValue>, <Version> and <Specification>

To <ModuleSA> adding attributes:

  PackageName (required)

  PackageGuid (required)

  PackageVersion (optional)

  Binary (optional Boolean, default=false)

  ModuleName (required)

  ModuleGuid (required)

  ModuleVersion (optional)

To <ModuleSA> adding Optional Element <BuildOptions>  Since we are removing the MBD files, and the MSA files should be Build independent descriptions (save for ARCH specific files) the BuildOptions can be specified here.
14.6 Surface Area Package Description (.SPD) Files

The SPD files are changing as follows.
Changing Elements:

In <SpdHeader> Changed name from <Guid> to <GuidValue>
14.7 Modules Surface Area (MSA) Description Files

Library Module Description tags are being removed from the XML Schema.  Library will no longer receive special consideration, they will be treated as any other module.  Elements that were specific to the Library MSA files are being added as optional elements to the component MSA schema.
NOTE: The Wizard must be able to present the correct forms based on the <ComponentType> selected.

14.8 Modules Build Description (MBD)  Files

ALL Module Build Description files are being removed from the XML Schema

2. 
Framework XML Schema

14.9 SurfaceArea.xsd

Tools/Conf/FrameworkDatabase.db file (DB)
<FrameworkDatabase> 

  <FdbHeader> ... </FdbHeader> [1] 

  <PackageList> ... </PackageList> [1] 

  <PlatformList> ... </PlatformList> [0..1]
  <UserExtensions> ... </UserExtensions> [0..*] 

</FrameworkDatabase>

PackageDirectory/PackageFilename.spd (SPD)

<PackageSurfaceArea> 

  <SpdHeader> ... </SpdHeader> [1]
  <PackageDefinitons> ... </PackageDefinitions> [1] 

  <LibraryClassDeclarations> ... </LibraryClassDeclarations> [0..1] 

  <IndustryStdIncludes> ... </IndustryStdIncludes> [0..1] 

  <MsaFiles> ... </MsaFiles> [1] 

  <PackageHeaders> ... </PackageHeaders> [0..1] 

  <GuidDeclarations> ... </GuidDeclarations> [0..1] 

  <ProtocolDeclarations> ... </ProtocolDeclarations> [0..1] 

  <PpiDeclarations> ... </PpiDeclarations> [0..1] 

  <PcdDeclarations> ... </PcdDeclarations> [0..1] 
  <UserExtensions> ... </UserExtensions> [0..*]
</PackageSurfaceArea>

ModuleDirectory/ModuleFilename.msa (MSA)

<ModuleSurfaceArea> 

  <MsaHeader> ... </MsaHeader> [1]
  <ModuleDefinitions> ... </ModuleDefinitions> [1] 

  <LibraryClassDefinitions> ... </LibraryClassDefinitions> [0..1] 

  <SourceFiles> ... </SourceFiles> [1] 

  <PackageDependencies> ... </PackageDependencies> [0..1] 

  <Protocols> ... </Protocols> [0..1]
  <Events> ... </Events> [0..1] 

  <Hobs> ... </Hobs> [0..1] 

  <PPIs> ... </PPIs> [0..1] 

  <Variables> ... </Variables> [0..1] 

  <BootModes> ... </BootModes> [0..1] 

  <SystemTables> ... </SystemTables> [0..1] 

  <DataHubs> ... </DataHubs> [0..1] 

  <HiiPackages> ... </HiiPackages> [0..1] 

  <Guids> ... </Guids> [0..1] 

  <Externs> ... </Externs> [0..1] 

  <PcdCoded> ... </PcdCoded> [0..1] 
  <ModuleBuildOptions> ... </ModuleBuildOptions> [0..1]

  <UserExtensions> ... </UserExtensions> [0..*]
</ModuleSurfaceArea>

PlatformDirectory/PlatformFilename.fpd (FPD)

<FrameworkPlatformDescription> 

  <PlatformHeader> ... </PlatformHeader> [1]
  <PlatformDefinitions> ... </PlatformDefinitions> [1] 


  <FrameworkModules> ... </FrameworkModules> [0..1] 

  <DynamicPcdBuildDefinitions> ... </DynamicPcdBuildDefinitions> [0..1] 

  <BuildOptions> ... </BuildOptions> [0..1]
  <UserExtensions> ... </UserExtensions> [0..*] 

</FrameworkPlatformDescription>

14.10 FrameworkHeaders.xsd

Note: Specification in the Headers is the Title and Version number (example): FRAMEWORK_BUILD_PACKAGING_SPECIFICATION 0x00000052
<FdbHeader> 

  <DatabaseName> ... </DatabaseName> [1] 

  <GuidValue> ... </GuidValue> [1] 

  <Version> ... </Version> [1] 

  <CreatedDate> ... </CreatedDate> [1] 

  <UpdatedDate> ... </UpdatedDate> [0..1] 

  <Abstract> ... </Abstract> [1] 

  <Description> ... </Description> [1] 

  <Copyright> ... </Copyright> [1] 

  <License> ... </License> [1] 

  <Specification> ... </Specification> [1]

</FdbHeader>

<SpdHeader> 

  <PackageName> BaseNameConvention </PackageName> [1] 

  <GuidValue> ... </GuidValue> [1] 

  <Version> ... </Version> [1] 

  <Abstract> ... </Abstract> [1] 

  <Description> ... </Description> [1] 

  <Copyright> ... </Copyright> [1] 

  <License> ... </License> [1] 

  <CreatedDate> ... </CreatedDate> [1] 

  <E-Mail> ... </E-Mail> [0..1] 

  <ModifiedDate> ... </ModifiedDate> [0..1] 

  <URL> ... </URL> [0..1] 

  <Type> PackageType </Type> [1] 

  <ReadOnly> ... </ReadOnly> [0..1] 

  <RePackage> ... </RePackage> [0..1] 

  <Specification> ... </Specification> [1] 

</SpdHeader>

<MsaHeader> 

  <ModuleName> UiNameType </ModuleName> [1] 

  <ModuleType> ... </ModuleType> [1] 


  <GuidValue> ... </GuidValue> [1] 

  <Version> ... </Version> [1] 

  <Abstract> ... </Abstract> [1] 

  <Description> ... </Description> [1] 

  <Copyright> ... </Copyright> [1] 

  <License> ... </License> [1] 




  <Specification> ... </Specification> [1] 
</MsaHeader>

<PlatformHeader> 

  <PlatformName> PlatformNamingConvention </PlatformName> [1]
  <GuidValue> ... </GuidValue> [1] 

  <Version> ... </Version> [1] 

  <Abstract> ... </Abstract> [1] 

  <Description> ... </Description> [1] 

  <Copyright> ... </Copyright> [1] 

  <License> ... </License> [1] 

  <CreatedDate> ... </CreatedDate> [1] 

  <ModifiedDate> ... </ModifiedDate> [0..1]
  <BuildTarget> BuildTargets </BuildTarget> [1] 

  <Specification> ... </Specification> [1] 

</PlatformHeader>
14.11 FrameworkDataElements.xsd

<Abstract> Sentence </Abstract>

<AntCmd> 

  <Id> xs:int </Id> [0..1] 

  <ExecutionOrder> list of: xs:normalizedString </ExecutionOrder> [1] 

</AntCmd>

<AntTask Id=" xs:int [1]"> 
  Start Choice [1] 

    <AntCmd> ... </AntCmd> [1] 

    <Filename> PathAndFilename </Filename> [1] 

  End Choice 
</AntTask>


<BootModes
  <BootMode
  
  BootModeName=”BootModeNames [1]”

    Usage=”BootModeUsage [1]”
    SupArchList=” ArchListType [0..1]”
  
  FeatureFlage=” FeatureFlagExpressionType [0..1]”/> [1..*]


</BootModes>

<BuildOptions
> 

  <UserDefinedAntTasks> ... </UserDefinedAntTasks> [0..1] 







  <Options> [0..1] ... </Options>
  <UserExtensions> ... </UserExtensions> [0..*]
</BuildOptions>








<Copyright> Paragraph </Copyright>



<DataHubs> 

  <DataHubRecord
    Usage=” DataHubUsage [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]> [1..*]
     C_NameType

 </DataHubRecord>

</DataHubs>

<DefaultValue> xs:normalizedString </DefaultValue>

<Description> Paragraph </Description>






<DynamicPcdBuildDefinitions> 

  <PcdBuildData
   ItemType=" PcdItemTypes [1]"> [1..*] 

    <C_Name> C_NameType </C_Name> [1] 

    <Token> TokenDataType </Token> [1] 

    <TokenSpaceGuid> GuidType </TokenSpaceGuid> [1] 

    <DatumType> PcdDataTypes </DatumType> [1] 

    <MaxDatumSize> DatumSizeLimitation </MaxDatumSize> [0..1] 

    <SkuInfo> [1..*] 

      <SkuId> xs:nonNegativeInteger </SkuId> [1] 

      Start Choice [1] 
        Start Group: HiiEnable [0..1] 

          <VariableName> VariableNameDataType </VariableName> [1] 

          <VariableGuid> C_NameType </VariableGuid> [1] 

          <VariableOffset> Hex64BitDataType </VariableOffset> [1] 

          <HiiDefaultValue> DefaultValueType </HiiDefaultValue> [1] 

        End Group: HiiEnable 
        Start Group: VpdEnable [0..1] 

          <VpdOffset> Hex64BitDataType </VpdOffset> [1] 

        End Group: VpdEnable 
        Start Group: DefaultGroup [0..1] 

          <Value> xs:normalizedString </Value> [1] 

        End Group: DefaultGroup 
      End Choice 
    </SkuInfo>

  </PcdBuildData>

</DynamicPcdBuildDefinitions>

<Events> 

  <CreateEvents> [0..1] 
    Start Sequence [1..*] 

      <Event
        Usage=” EventUsage [1]”

        EventGroup=” EventTypes [1]”

        SupArchList=” ArchListType [0..1]”

        FeatureFlag=” FeatureFlagExpressionType [0..1]”> [1] 

        <GuidC_Name> ... </GuidC_Name> [0..1] 


      </Event>

    End Sequence 
  </CreateEvents>

  <SignalEvents> [0..1]
    Start Sequence [1..*] 

      <Event> [1] 

        Usage=” EventUsage [1]”

        EventGroup=” EventTypes [1]”

        SupArchList=” ArchListType [0..1]”

        FeatureFlag=” FeatureFlagExpressionType [0..1]”> [1] 

        <GuidC_Name> ... </GuidC_Name> [0..1] 



      </Event>

    End Sequence 
  </SignalEvents>

</Events>


<Externs> 
  <PcdIsDriver> PcdDriverTypes </PcdIsDriver> [0..1]
  <Specification> ... </Specification> [0..*]


  <Extern
    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0.11]”> [0..*] 
    Start Choice [1]

      <ModuleEntryPoint> C_NameType </ModuleEntryPoint> [0..1]

      <ModuleUnloadImage> C_NameType </ModuleUnloadImage> [0..1]


      <Constructor> C_NameType </Constructor> [0..1]

      <Destructor> C_NameType </Destructor> [0..1]


      <DriverBinding> C_NameType </DriverBinding> [0..*]

      <ComponentName> C_NameType </ComponentName> [0..*]

      <DriverConfig> C_NameType </DriverConfig> [0..*]

      <DriverDiag> C_NameType </DriverDiag> [0..*]


      <SetVirtualAddressMapCallBack> C_NameType </SetVirtualAddressMapCallBack> [0..1]

      <ExitBootServicesCallBack> C_NameType </ExitBootServicesCallBack> [0..1]


      <UserDefined> C_NameType </UserDefined> [0..*]

    End Choice
   </Extern>


</Externs>

<FarList> 

  <Filename> PathAndFilename </Filename> [1..*] 

</FarList>

<FfsFormatDeclarations> 

  <FfsFormatDeclaration
   FfsFormatKeyword=" FfsNameType [1]" 
   FfsFileType=" EfiFfsFileTypes [0..1]" 
   FfsAttribTailPresent=" xs:boolean [0..1]" 
   FfsAttribRecovery=" xs:boolean [0..1]" 
   FfsAttribDataAlignment=" FfsDataAlignmentType [0..1]" 
   FfsAttribChecksumRequired=" xs:boolean [0..1]" 
   SupModuleList=" ModuleListType [0..1]"> [1..*] 

     <ProcessStep> ... </ProcessStep> [1..*] 

  </FfsFormatDeclaration>

</FfsFormatDeclarations>





<Filename 
 TagName=” ToolsNameConventino [0..1]”

 ToolCode=” ToolsNameConvention [0..1]”

 ToolChainFamily=” ToolsNameConvention [0..1]”

 SupArchList="ArchListType [0..1]"
 FeatureFlag=” FeatureFlagExpressionType [0..1]”>
   PathAndFilename

</Filename>

<Filenames> 

  <Filename> ... </Filename> [0..*]

</Filenames>





<GuidDeclarations> 

  <Entry
    Name=" UiNameType [1]" 
    GuidTypeList=" GuidListType [0..1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]" 
    SupModuleList=" ModuleListType [0..1]"> [1..*] 

      <C_Name> C_NameType </C_Name> [1] 

      <GuidValue> GuidType </GuidValue> [1] 

      <HelpText> Paragraph </HelpText> [1] 

  </Entry>

</GuidDeclarations





>

<Guids> 
  
<Guid
C_Name


    Usage=” GuidUsage [1]”

    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"> [1..*]
     C_NameType



  </GuidC_Name>

</Guids>

<HiiPackages> 

  <HiiPackage
    Usage=" HiiPackageUsage [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"> [1..*] 
      C_NameType 
  </HiiPackage>

</HiiPackages>



<Hobs> 

  <Hob
    HobType=” HobTypes [1]”

    Usage=" HobUsage [1]" 
    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"> [1..*] 



      C_NameType
    </Hob>

  End Sequence
</Hobs>


<IncludeHeader
  SupArchList=" ArchListType [0..1]" 
  FeatureFlag=" FeatureFlagExpressionType [0..1]"
  SupModuleList=” ModuleListType [0..1]”> 
    PathAndFilename

</IncludeHeader>

<IndustryStdHeader
  Name=” KeywordType [1]”
  SupArchList=" ArchListType [0..1]" 
  FeatureFlag=" FeatureFlagExpressionType [0..1]"
  SupModuleList=” ModuleListType [0..1]”> 
    <IncludeHeader> PathAndFilename </IncludeHeader> [1]

    <HelpText> Paragraph </HelpText> [1]
</IndustryStdHeader>

<IndustryStdIncludes>

   <IndustryStdHeader> ... </IndustryStdHeader> [1..*]

</IndustryStdIncludes>





<Libraries>

  <Instance

    ModuleGuid=” GuidType [1]”

    ModuleVersion=” VersionDataType [0..1]”

    PackageGuid=” GuidType [1]”

    PackageVersion=” VersionDataType [0..1]”/> [1..*]
</Libraries>

<LibraryClass
  Usage="LibraryUsage [1]"
  RecommendedInstanceVersion=” VersionDataType [0..1]”

  RecommendedInstanceGuid=” GuidType [0..1]”

  SupArchList=" ArchListType [0..1]" 
  FeatureFlag=" FeatureFlagExpressionType [0..1]">
    KeywordType

</LibraryClass>

<LibraryClassDeclarations> 

  <LibraryClass
    Name=” KeywordType [1]”

    RecommendedInstanceVersion=” VersionDataType [0..1]”

    RecommendedInstanceGuid=” GuidType [0..1]”

    SupArchList=" ArchListType [0..1]" 
    FeatureFlag=" FeatureFlagExpressionType [0..1]"
    SupModuleList=” ModuleListType [0..1]”> [1..*]

      <IncludeHeader> PathAndFilename </IncludeHeader> [1]
      <HelpText> Paragraph </HelpText>

  </LibraryClass>
</LibraryClassDeclarations>










<LibraryClassDefinitions> 
  Start Sequence [1..*]

    <LibraryClass> ... </LibraryClass> [1]

  End Sequence
</LibraryClassDefinitions>

<License URL="xs:anyURI [0..1]"> Paragraph </License>
<ModuleBuildOptions> 

   Allow any elements from no namespace (lax validation). [0..*] 

</ModuleBuildOptions>


<ModuleDefinitions> 

  <SupportedArchitectures> ArchListType </SupportedArchitectures> [1]

  <BinaryModule> xs:boolean </BinaryModule> [1]

  <OutputFileBaseName> FileNameConvention </OutputFileBaseName> [1]


</ModuleDefinitions>

<ModuleSaBuildOptions>
  <FvBinding> FfsNameType </FvBinding> [0..1]

  <FfsFileNameGuid> GuidType </FfsFileNameGuid> [0..1]

  <FfsFormatKey> FfsNameType </FfsFormatKey>

  <Options> ... </Options>

</ModuleSaBuildOptions>





<ModuleType> ModuleTypeDef </ModuleType>


<MsaFiles> 


  <Filename> PathAndFilename </Filename> [1..*]



</MsaFiles>


<Option

  BuildTargets=” BuildTargetList [0..1]”

  ToolChainFamily=” ToolsNameConvention [0..1]”

  TagName=” ToolsNameConvention [0..1]”

  ToolCode=” ToolsNameConvention [0..1]”
  SupArchList=” ArchListType [0..1]”>
    xs:normalizedString

</Option>
<Options>

  <Option> ... </Option>

</Options>

<PPIs> 

  <Ppi
    Usage=” PpiUsage [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”> [0..*] C_Name </Ppi>

  <PpiNotify
    Usage=” PpiNotifyUsage [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”> [0..*] C_Name </PpiNotify>

</PPIs>

<PackageDefinitions>

  <ReadOnly> xs:boolean </ReadOnly> [1]

  <RePackage> xs:boolean </RePackage> [1]
</PackageDefinitions>
<PackageDependencies>

    <Package

      PackageGuid=” GuidType [1]”

      PackageVersion=” VersionDataType [0..1]”

      SupArchList=” ArchListType [0..1]”

      FeatureFlag=” FeatureFlagExpressionType [0..1]”/> [1..*]

</PackageDependencies>

<PackageHeaders> 

  <IncludePkgHeader
    ModuleType=” ModuleTypeDef [1]”> 
      PathAndFilename

  </IncludePkgHeader> [1..*]

</PackageHeaders>
<PackageList>
  <Filename> PathAndFilename </Filename> [1..*]








</PackageList>



<PcdBuildDefiniton> 
<!-- Child of FPD ModuleSA element for FIXED_AT_BUILD, PATCHABLE_IN_MODULE, and FEATURE_FLAG PCDS Only! -->
  <PcdData
    ItemType=” PcdItemTypes [1]”> [1..*]
    <C_Name> ... </C_Name> [1]

    <Token> ... </Token> [1]
    <TokenSpaceGuid> GuidType </TokenSpaceGuid> [1]

    <DatumType> PcdDataTypes </DatumType> [1]





    <MaxDatumSize> DatumSizeLimit </MaxDatumSize> [0..1]
    <Value> DefaultValueType </Value> [0..1]

  </PcdData>

</PcdBuildDefinition>

<PcdCoded>

<!-- Child of Module Surface Area Description (MSA) -->

  <PcdEntry

    PcdItemType=” PcdItemTypes [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”> [1..*]

      <C_Name> C_NameType </C_Name> [1]
      <TokenSpaceGuid> GuidType </TokenSpaceGuid> [0..1]

      <HelpText> Paragraph </HelpText> [1]

  </PcdEntry>

</PcdCoded>

<PcdDeclarations>
<!-- PcdDeclaratins is a child of Package Surface Area Description (SPD) -->
  <PcdEntry
    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”

    SupModuleList=” ModuleListType [0..1]> [1..*]
    <C_Name> C_NameType </C_Name> [1]

    <Token> TokenDataType </Token> [1]

    <TokenSpaceGuid> GuidType </TokenSpaceGuid> [1]

    <DatumType> PcdDataTypes </DatumType> [1]
    <ValidUsage> list of: PcdListType </ValidUsage> [1]
    <DefaultValue> DefaultValue </DefaultValue> [0..1]
    <HelpText> Paragraph </HelpText> [1]
  </PcdEntry>

</PcdDeclarations>



















































<PpiDeclarations> 

  <Entry 
    Name=" UiNameType [1]"
    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”

    SupModuleList=” ModuleListType [0..1]”> [1..*] 

    <C_Name> C_NameType </C_Name> [1]

    <GuidValue> GuidType </GuidValue> [1]

    <HelpText> Paragraph </HelpText> [1]

  </Entry>

</PpiDeclarations>

<ProcessStep
  BindingOrder=” xs:int [0..1]”

  SectionType=” EfiSectionType [0..1]”>
    <ToolName> xs:string </ToolName>

    <ToolArgs> xs:string </ToolArgs>

    <InputPattern> xs:string </InputPattern>

    <OutputPattern> xs:string </OutputPattern>

</ProcessStep>





<ProtocolDeclarations> 

  <Entry
    Name="xs:normalizedString [1]"
    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”

    SupModuleList=” ModuleListType [0..1]”> [1..*] 

  
    <C_Name> C_NameTYpe </C_Name> [1]

    <GuidValue> GuidType </GuidValue> [1]

    <HelpText> Paragraph </HelpText> [1]

  </Entry>

</ProtocolDeclarations>

<Protocols> 
  Start Sequence
    <Protocol
      Usage=" ProtocolUsage [1]"
      SupArchList=” ArchListType [0..1]”

      FeatureFlag=” FeatureFlagExpressionType [0..1]”> [0..*] 
        C_NameType
    </Protocol>

    <ProtocolNotify
      Usage="ProtocolNotifyUsage [1]"
      SupArchList=” ArchListType [0..1]”

      FeatureFlag=” FeatureFlagExpressionType [0..1]”> [0..*] 
        C_NameType 
    </ProtocolNotify>

  End Sequence
</Protocols>






















<SkuInfo>
  <UiSkuName

    SkuID=” xs:nonNegativeInteger [1]”> [1..*]

      UiNameType

  </UiSkuName>

</SkuInfo>

<SourceFiles> 

  <Filename
> ... </Filename>[1..*] 
</SourceFiles>




<SystemTables> 

  <SystemTableCName

    Usage=” SystemTableUsage [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”> [1..*] 

      C_NameType
  </SystemTable>

</SystemTables>




<UserDefinedAntTasks> 
  Start Sequence [1..*]

    <AntTask> ... </AntTask> [1]

  End Sequence
</UserDefinedAntTasks>


<UserExtensions
  UserID=" xs:NCName [1]" 
  Identifier=" xs:nonNegativeInteger [1]"> 

    Allow any elements from no namespace (lax validation). [0..*] 

</UserExtensions>

<Variables> 

  <Variable
    Usage=” SystemTableUsage [1]”

    SupArchList=” ArchListType [0..1]”

    FeatureFlag=” FeatureFlagExpressionType [0..1]”> [1..*] 



      <VariableName> VariableNameDataType </VariableName> [1]
      <GuidC_Name> C_NameTYpe </GuidC_Name> [1]
    </Variable>


</Variables>

<Version> VersionDataType </Version>

14.12 FrameworkPlatformDataElements.xsd

<Disable> xs:string </Disable>

<Enable> xs:string </Ensable>

<Flash MicrocodeFile="FileNameConvention [0..1]"> 
  Start Choice [1]

    <FlashDefinition> FlashData </FlashDefinition> [1]

    <FlashDefinitionFile> FileNameConvention </FlashDefinitionFile> [1]

  End Choice

  <FvImages> ... </FvImages> [0..*]

</Flash>

<FlashDeviceImage Name="xs:string [1]"> 
  Start All [1]

    <RawData
      Name="xs:string [1]"
      Region="xs:string [1]"
      SubRegion="xs:string [1]"> [0..1] 
        Start Sequence [0..1]

          <Data> xs:string </Data> [1]

        End Sequence
    </RawData>

    <File
      Name="xs:string [1]"
      Region="xs:string [1]"
      SubRegion="xs:string [0..1]"
      Optional="xs:boolean [0..1]"/> [0..1]

  End All
</FlashDeviceImage>

<FlashDeviceInfo 
  Name="BlockNameType [1]"
  Size="HexAddressType [1]"
  Flags="HexAddressType [0..1]"> 

    <Blocks> [1] 

      <Block
        Name="BlockNameType [1]"
        Size="HexAddressType [1]"
        Flags="HexAddressType [0..1]"> [1..255] 
          BlockNameType 
      </Block>

    </Blocks>

    <Regions> [1] 

      <Region
        Name="xs:string [1]"
        Size="HexAddressType [1]"
        Flags="HexAddressType [0..1]"
        Alignment="HexAddressType [0..1]"
        Attributes="xs:string [1]"
        AreaType="EfiFvAreaType [1]"> [1..*] 
          Start All [1]

            <SubRegions> [1] 
              Start Sequence [0..*]

                <SubRegion
                  CreateHob="xs:boolean [1]"
                  Name="xs:string [1]"
                  Size="HexAddressType [1]"
                  Attributes="xs:string [1]"
                  AreaType="EfiFvAreaType [1]"
                  NameGuid="xs:string [1]"
                  AreaTypeGuid="xs:string [0..1]"
                  FileSystemGuid="xs:string [0..1]"> [1] 
                        xs:string 
                </SubRegion>

              End Sequence
            </SubRegions>

          End All
      </Region>

    </Regions>

</FlashDeviceInfo>

<FlashDeviceOverrideImage> 

  <Name> NameConvention </Name> [0..1]

  <File> FvImageOverrideFileType </File> [0..*]

</FlashDeviceOverrideImage>

<FlashDeviceOverrideInfo> 

  <Name> UCNameType </Name> [0..1]

  <FlashSize> FlashSize </FlashSize> [0..1]

  <BaseAddress> HexAddressType </BaseAddress> [0..1]

  <OutputDirectory> DirectoryNamingConvention </OutputDirectory> [0..1]

  <MicrocodeFile> FileNameConvention </MicrocodeFile> [0..1]

  <Block> BlockNameType </Block> [0..255]

  <Region> RegionDataType </Region> [0..*]

</FlashDeviceOverrideInfo>

<FrameworkModules> 

  <SEC> Components </SEC> [0..1]

  <PEI_CORE> Components </PEI_CORE> [0..1]

  <PEIM> Components </PEIM> [0..1]

  <DXE_CORE> Components </DXE_CORE> [0..1]

  <DXE_DRIVERS> Components </DXE_DRIVERS> [0..1]

  <OTHER_COMPONENTS> Components </OTHER_COMPONENTS> [0..1]

</FrameworkModules>

<FvImage Type="xs:string [0..1]"> 

  <FvImageNames> ... </FvImageNames> [1..*]

  <FvImageOptions> ... </FvImageOptions> [0..1]

</FvImage>

<FvImageNames> xs:string </FvImageNames>

<FvImageOptions> 

  <NameValue> ... </NameValue> [0..*]

</FvImageOptions>

<FvImages> 

  <NameValue> ... </NameValue> [0..*]

  <FvImage> ... </FvImage> [0..*]

</FvImages>

<ModuleSA> 
  Start Sequence [0..1]

    <Libraries> ... </Libraries> [0..1]

    <Externs> ... </Externs> [0..1]

    <PcdBuildDefinitions> ... </PcdBuildDefinitions> [0..1]

    <BuildOptions> ... </BuildOptions> [0..1]

  End Sequence
</ModuleSA>

<NameValue
  Name="xs:string [1]"
  Value="xs:string [1]"> xs:string </NameValue>

<PlatformList> 
  Start Sequence [1..*]

    <Platform> ... </Platform> [1]

  End Sequence
</PlatformList>

Refer to XML schema checked into SVN for Attribute and Data Types.

14.13 FrameworkDataAttributes.xsd

Refer to XML schema checked into SVN for Attribute and Data Types.
14.14 FrameworkDataTypes.xsd

Refer to XML schema checked into SVN for Attribute and Data Types.
14.15 NamingConvention.xsd

Refer to XML schema checked into SVN for Attribute and Data Types.
14.16 WizardPreferences.xsd
The following XML schema is used for storing a User’s Wizard Preferences. 
<WizPref> 
  Start All [0..1]

    <Policy> ... </Policy> [1]

    <Preferences> ... </Preferences> [1]

  End All
</WizPref>

<Policy> 

  <SpdCreation> [1] 
    Start Sequence [0..1]

      <File GuidValue="GuidType [1]" Version="VersionDataType [1]"> [0..*] 
        FileNameConvention 
      </File>

    End Sequence
  </SpdCreation>

</Policy>

<Preferences> 
  Start All [0..1]

    <Locale> xs:string </Locale> [1]

    <MostRecentFiles> [0..1] 

      <NumberToTrack> xs:int </NumberToTrack> [0..1]

      <LastOpened> xs:int </LastOpened> [0..1]

      <File Seq="xs:int [1]"> [0..*] DirectoryNamingConvention </File>

    </MostRecentFiles>

  End All
</Preferences>

3. Appendix A 

15 MdePkg Library classes by ModuleType
BASE:

BaseLib ./BaseLib/BaseLib.msa

BaseMemoryLib ./BaseMemoryLib/BaseMemoryLib.msa

BaseMemoryLib ./BaseMemoryLibMmx/BaseMemoryLibMmx.msa

BaseMemoryLib ./BaseMemoryLibRepStr/BaseMemoryLibRepStr.msa

BaseMemoryLib ./BaseMemoryLibSse2/BaseMemoryLibSse2.msa

CacheMaintenanceLib ./BaseCacheMaintenanceLib/BaseCacheMaintenanceLib.msa

DebugLib ./BaseDebugLibNull/BaseDebugLibNull.msa

IoLib ./BaseIoLibIntrinsic/BaseIoLibIntrinsic.msa

PcdLib ./BasePcdLibNull/BasePcdLibNull.msa

PciCf8Lib ./BasePciCf8Lib/BasePciCf8Lib.msa

PciExpressLib ./BasePciExpressLib/BasePciExpressLib.msa

PciLib ./BasePciLibCf8/BasePciLibCf8.msa

PciLib ./BasePciLibPciExpress/BasePciLibPciExpress.msa

PeCoffGetEntryPointLib ./BasePeCoffGetEntryPointLib/BasePeCoffGetEntryPointLib.msa

PeCoffLib ./BasePeCoffLib/BasePeCoffLib.msa

PerformanceLib ./BasePerformanceLibNull/BasePerformanceLibNull.msa

PrintLib ./BasePrintLib/BasePrintLib.msa

SmbusLib ./BaseSmbusLib/BaseSmbusLib.msa

TimerLib ./BaseTimerLibLocalApic/BaseTimerLibLocalApic.msa

PEI_CORE:

PeiCoreEntryPoint ./PeiCoreEntryPoint/PeiCoreEntryPoint.msa

PEIM:

BaseMemoryLib ./PeiMemoryLib/PeiMemoryLib.msa

DebugLib ./BaseDebugLibReportStatusCode/BaseDebugLibReportStatusCode.msa

HobLib ./PeiHobLib/PeiHobLib.msa

IoLib ./PeiIoLibCpuIo/PeiIoLibCpuIo.msa

MemoryAllocationLib ./PeiMemoryAllocationLib/PeiMemoryAllocationLib.msa

PcdLib ./PeiPcdLib/PeiPcdLib.msa

PeiCoreLib ./PeiCoreLib/PeiCoreLib.msa

PeiServicesTablePointerLib ./PeiServicesTablePointerLib/PeiServicesTablePointerLib.msa

PeiServicesTablePointerLib ./PeiServicesTablePointerLibMm7/PeiServicesTablePointerLibMm7.msa

PeimEntryPoint ./PeimEntryPoint/PeimEntryPoint.msa

ReportStatusCodeLib ./PeiReportStatusCodeLib/PeiReportStatusCodeLib.msa

ResourcePublicationLib ./PeiResourcePublicationLib/PeiResourcePublicationLib.msa

SmbusLib ./PeiSmbusLib/PeiSmbusLib.msa

DXE_CORE:

DxeCoreEntryPoint ./DxeCoreEntryPoint/DxeCoreEntryPoint.msa

HobLib ./DxeCoreHobLib/DxeCoreHobLib.msa

DXE_DRIVER:

DxeServicesTableLib ./DxeServicesTableLib/DxeServicesTableLib.msa

HiiLib ./HiiLib/HiiLib.msa

HobLib ./DxeHobLib/DxeHobLib.msa

IoLib ./DxeIoLibCpuIo/DxeIoLibCpuIo.msa

MemoryAllocationLib ./DxeMemoryAllocationLib/DxeMemoryAllocationLib.msa

PcdLib ./DxePcdLib/DxePcdLib.msa

ReportStatusCodeLib ./BaseReportStatusCodeLibNull/BaseReportStatusCodeLibNull.msa

ReportStatusCodeLib ./DxeReportStatusCodeLib/DxeReportStatusCodeLib.msa

SmbusLib ./DxeSmbusLib/DxeSmbusLib.msa

UefiBootServicesTableLib ./UefiBootServicesTableLib/UefiBootServicesTableLib.msa

UefiDecompressLib ./BaseUefiDecompressLib/BaseUefiDecompressLib.msa

UefiRuntimeServicesTableLib ./UefiRuntimeServicesTableLib/UefiRuntimeServicesTableLib.msa

DXE_SMM_DRIVER:

DxeSmmDriverEntryPoint ./DxeSmmDriverEntryPoint/DxeSmmDriverEntryPoint.msa

UEFI_DRIVER:

BaseMemoryLib ./UefiMemoryLib/UefiMemoryLib.msa

DebugLib ./UefiDebugLibConOut/UefiDebugLibConOut.msa

DebugLib ./UefiDebugLibStdErr/UefiDebugLibStdErr.msa

DevicePathLib ./UefiDevicePathLib/UefiDevicePathLib.msa

DevicePathLib ./UefiDevicePathLibDevicePathProtocol/UefiDevicePathLibDevicePathProtocol.msa

UefiDriverEntryPoint ./UefiDriverEntryPoint/UefiDriverEntryPoint.msa

UefiDriverModelLib ./UefiDriverModelLib/UefiDriverModelLib.msa

UefiLib ./UefiLib/UefiLib.msa
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