1. Change default PCD in SecurityPkg to 4 (DENY_EXECUTE) in DEC file.
authorFu Siyuan <siyuan.fu@intel.com>
Wed, 28 Aug 2013 09:06:40 +0000 (09:06 +0000)
committersfu5 <sfu5@6f19259b-4bc3-4df7-8a09-765794883524>
Wed, 28 Aug 2013 09:06:40 +0000 (09:06 +0000)
commitdb44ea6c4e093c1a53d752bb21b9eba8ad8fdaa9
treea00daff473008535bad283c2a9f1b97b170b50c6
parent98fed08f9f55e623b8f95518f69e35aca9ff1541
1. Change default PCD in SecurityPkg to 4 (DENY_EXECUTE) in DEC file.
2. ASSERT if PCD value is set to 5 (QUERY_USER_ON_SECURITY_VIOLATION).
3. Update override PCD setting from 5 to 4 in platform DSC file.
Signed-off-by: Fu Siyuan <siyuan.fu@intel.com>
Reviewed-by: Ni Ruiyu <ruiyu.ni@intel.com>
Reviewed-by: Ye Ting <ting.ye@intel.com>
git-svn-id: https://svn.code.sf.net/p/edk2/code/trunk/edk2@14607 6f19259b-4bc3-4df7-8a09-765794883524
Nt32Pkg/Nt32Pkg.dsc
OvmfPkg/OvmfPkgIa32.dsc
OvmfPkg/OvmfPkgIa32X64.dsc
OvmfPkg/OvmfPkgX64.dsc
SecurityPkg/Library/DxeImageVerificationLib/DxeImageVerificationLib.c
SecurityPkg/SecurityPkg.dec