BaseTools/Capsule: Add max value checks to Capsule Generation tools
authorKinney, Michael D <michael.d.kinney@intel.com>
Fri, 27 Jul 2018 19:27:19 +0000 (12:27 -0700)
committerKinney, Michael D <michael.d.kinney@intel.com>
Thu, 2 Aug 2018 21:35:22 +0000 (14:35 -0700)
https://bugzilla.tianocore.org/show_bug.cgi?id=1021
https://bugzilla.tianocore.org/show_bug.cgi?id=1022
https://bugzilla.tianocore.org/show_bug.cgi?id=1026

Cc: Sean Brogan <sean.brogan@microsoft.com>
Cc: Jiewen Yao <jiewen.yao@intel.com>
Cc: Yonghong Zhu <yonghong.zhu@intel.com>
Cc: Liming Gao <liming.gao@intel.com>
Contributed-under: TianoCore Contribution Agreement 1.1
Signed-off-by: Michael D Kinney <michael.d.kinney@intel.com>
Reviewed-by: Yonghong Zhu <yonghong.zhu@intel.com>
BaseTools/Source/Python/Capsule/GenerateCapsule.py

index 4018dc0..5398c12 100644 (file)
@@ -298,6 +298,12 @@ if __name__ == '__main__':
                 parser.error ('--capflag PopulateSystemTable also requires --capflag PersistAcrossReset')\r
             if 'InitiateReset' in args.CapsuleFlag:\r
                 parser.error ('--capflag InitiateReset also requires --capflag PersistAcrossReset')\r
+        if args.CapsuleOemFlag > 0xFFFF:\r
+            parser.error ('--capoemflag must be an integer between 0x0000 and 0xffff')\r
+        if args.HardwareInstance > 0xFFFFFFFFFFFFFFFF:\r
+            parser.error ('--hardware-instance must be an integer in range 0x0..0xffffffffffffffff')\r
+        if args.MonotonicCount > 0xFFFFFFFFFFFFFFFF:\r
+            parser.error ('--monotonic-count must be an integer in range 0x0..0xffffffffffffffff')\r
 \r
     UseSignTool = args.SignToolPfxFile is not None\r
     UseOpenSsl  = (args.OpenSslSignerPrivateCertFile is not None and\r
@@ -319,6 +325,10 @@ if __name__ == '__main__':
         if args.Encode and (UseSignTool or UseOpenSsl):\r
             if args.FwVersion is None or args.LowestSupportedVersion is None:\r
                 parser.error ('the following options are required: --fw-version, --lsv')\r
+            if args.FwVersion > 0xFFFFFFFF:\r
+                parser.error ('--fw-version must be an integer in range 0x0..0xffffffff')\r
+            if args.LowestSupportedVersion > 0xFFFFFFFF:\r
+                parser.error ('--lsv must be an integer in range 0x0..0xffffffff')\r
 \r
         if UseSignTool:\r
             args.SignToolPfxFile.close()\r