Added "source=1.4" attribute to <javac> to override the build warning message.