bump version to 5.0-4
[pve-access-control.git] / changelog.Debian
1 libpve-access-control (5.0-4) unstable; urgency=medium
2
3 * PVE/CLI/pveum.pm: call setup_default_cli_env()
4
5 * PVE/Auth/PVE.pm: encode uft8 password before calling crypt
6
7 * check_api2_permissions: avoid warning about uninitialized value
8
9 -- Proxmox Support Team <support@proxmox.com> Tue, 02 May 2017 11:58:15 +0200
10
11 libpve-access-control (5.0-3) unstable; urgency=medium
12
13 * use new PVE::OTP class from pve-common
14
15 * use new PVE::Tools::encrypt_pw from pve-common
16
17 -- Proxmox Support Team <support@proxmox.com> Thu, 30 Mar 2017 17:45:55 +0200
18
19 libpve-access-control (5.0-2) unstable; urgency=medium
20
21 * encrypt_pw: avoid '+' for crypt salt
22
23 -- Proxmox Support Team <support@proxmox.com> Thu, 30 Mar 2017 08:54:10 +0200
24
25 libpve-access-control (5.0-1) unstable; urgency=medium
26
27 * rebuild for PVE 5.0
28
29 -- Proxmox Support Team <support@proxmox.com> Mon, 6 Mar 2017 13:42:01 +0100
30
31 libpve-access-control (4.0-23) unstable; urgency=medium
32
33 * use new PVE::Ticket class
34
35 -- Proxmox Support Team <support@proxmox.com> Thu, 19 Jan 2017 13:42:06 +0100
36
37 libpve-access-control (4.0-22) unstable; urgency=medium
38
39 * RPCEnvironment: removed check_volume_access() to avoid cyclic dependency
40 (moved to PVE::Storage)
41
42 * PVE::PCEnvironment: use new PVE::RESTEnvironment as base class
43
44 -- Proxmox Support Team <support@proxmox.com> Thu, 19 Jan 2017 09:12:04 +0100
45
46 libpve-access-control (4.0-21) unstable; urgency=medium
47
48 * setup_default_cli_env: expect $class as first parameter
49
50 -- Proxmox Support Team <support@proxmox.com> Thu, 12 Jan 2017 13:54:27 +0100
51
52 libpve-access-control (4.0-20) unstable; urgency=medium
53
54 * PVE/RPCEnvironment.pm: new function setup_default_cli_env
55
56 * PVE/API2/Domains.pm: fix property description
57
58 * use new repoman for upload target
59
60 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Jan 2017 12:13:26 +0100
61
62 libpve-access-control (4.0-19) unstable; urgency=medium
63
64 * Close #833: ldap: non-anonymous bind support
65
66 * don't import 'RFC' from MIME::Base32
67
68 -- Proxmox Support Team <support@proxmox.com> Fri, 05 Aug 2016 13:09:08 +0200
69
70 libpve-access-control (4.0-18) unstable; urgency=medium
71
72 * fix #1062: recognize base32 otp keys again
73
74 -- Proxmox Support Team <support@proxmox.com> Thu, 21 Jul 2016 08:43:18 +0200
75
76 libpve-access-control (4.0-17) unstable; urgency=medium
77
78 * drop oathtool and libdigest-hmac-perl dependencies
79
80 -- Proxmox Support Team <support@proxmox.com> Mon, 11 Jul 2016 12:03:22 +0200
81
82 libpve-access-control (4.0-16) unstable; urgency=medium
83
84 * use pve-doc-generator to generate man pages
85
86 -- Proxmox Support Team <support@proxmox.com> Fri, 08 Apr 2016 07:06:05 +0200
87
88 libpve-access-control (4.0-15) unstable; urgency=medium
89
90 * Fix uninitialized warning when shadow.cfg does not exist
91
92 -- Proxmox Support Team <support@proxmox.com> Fri, 01 Apr 2016 07:10:57 +0200
93
94 libpve-access-control (4.0-14) unstable; urgency=medium
95
96 * Add is_worker to RPCEnvironment
97
98 -- Proxmox Support Team <support@proxmox.com> Tue, 15 Mar 2016 16:47:34 +0100
99
100 libpve-access-control (4.0-13) unstable; urgency=medium
101
102 * fix #916: allow HTTPS to access custom yubico url
103
104 -- Proxmox Support Team <support@proxmox.com> Mon, 14 Mar 2016 11:39:23 +0100
105
106 libpve-access-control (4.0-12) unstable; urgency=medium
107
108 * Catch certificate errors instead of segfaulting
109
110 -- Proxmox Support Team <support@proxmox.com> Wed, 09 Mar 2016 14:41:01 +0100
111
112 libpve-access-control (4.0-11) unstable; urgency=medium
113
114 * Fix #861: use safer sprintf formatting
115
116 -- Proxmox Support Team <support@proxmox.com> Fri, 08 Jan 2016 12:52:39 +0100
117
118 libpve-access-control (4.0-10) unstable; urgency=medium
119
120 * Auth::LDAP, Auth::AD: ipv6 support
121
122 -- Proxmox Support Team <support@proxmox.com> Thu, 03 Dec 2015 12:09:32 +0100
123
124 libpve-access-control (4.0-9) unstable; urgency=medium
125
126 * pveum: implement bash completion
127
128 -- Proxmox Support Team <support@proxmox.com> Thu, 01 Oct 2015 17:22:52 +0200
129
130 libpve-access-control (4.0-8) unstable; urgency=medium
131
132 * remove_storage_access: cleanup of access permissions for removed storage
133
134 -- Proxmox Support Team <support@proxmox.com> Wed, 19 Aug 2015 15:39:15 +0200
135
136 libpve-access-control (4.0-7) unstable; urgency=medium
137
138 * new helper to remove access permissions for removed VMs
139
140 -- Proxmox Support Team <support@proxmox.com> Fri, 14 Aug 2015 07:57:02 +0200
141
142 libpve-access-control (4.0-6) unstable; urgency=medium
143
144 * improve parse_user_config, parse_shadow_config
145
146 -- Proxmox Support Team <support@proxmox.com> Mon, 27 Jul 2015 13:14:33 +0200
147
148 libpve-access-control (4.0-5) unstable; urgency=medium
149
150 * pveum: check for $cmd being defined
151
152 -- Proxmox Support Team <support@proxmox.com> Wed, 10 Jun 2015 10:40:15 +0200
153
154 libpve-access-control (4.0-4) unstable; urgency=medium
155
156 * use activate-noawait triggers
157
158 -- Proxmox Support Team <support@proxmox.com> Mon, 01 Jun 2015 12:25:31 +0200
159
160 libpve-access-control (4.0-3) unstable; urgency=medium
161
162 * IPv6 fixes
163
164 * non-root buildfix
165
166 -- Proxmox Support Team <support@proxmox.com> Wed, 27 May 2015 11:15:44 +0200
167
168 libpve-access-control (4.0-2) unstable; urgency=medium
169
170 * trigger pve-api-updates event
171
172 -- Proxmox Support Team <support@proxmox.com> Tue, 05 May 2015 15:06:38 +0200
173
174 libpve-access-control (4.0-1) unstable; urgency=medium
175
176 * bump version for Debian Jessie
177
178 -- Proxmox Support Team <support@proxmox.com> Thu, 26 Feb 2015 11:22:01 +0100
179
180 libpve-access-control (3.0-16) unstable; urgency=low
181
182 * root@pam can now be disabled in GUI.
183
184 -- Proxmox Support Team <support@proxmox.com> Fri, 30 Jan 2015 06:20:22 +0100
185
186 libpve-access-control (3.0-15) unstable; urgency=low
187
188 * oath: add 'step' and 'digits' option
189
190 -- Proxmox Support Team <support@proxmox.com> Wed, 23 Jul 2014 06:59:52 +0200
191
192 libpve-access-control (3.0-14) unstable; urgency=low
193
194 * add oath two factor auth
195
196 * add oathkeygen binary to generate keys for oath
197
198 * add yubico two factor auth
199
200 * dedend on oathtool
201
202 * depend on libmime-base32-perl
203
204 * allow to write builtin auth domains config (comment/tfa/default)
205
206 -- Proxmox Support Team <support@proxmox.com> Thu, 17 Jul 2014 13:09:56 +0200
207
208 libpve-access-control (3.0-13) unstable; urgency=low
209
210 * use correct connection string for AD auth
211
212 -- Proxmox Support Team <support@proxmox.com> Thu, 22 May 2014 07:16:09 +0200
213
214 libpve-access-control (3.0-12) unstable; urgency=low
215
216 * add dummy API for GET /access/ticket (useful to generate login pages)
217
218 -- Proxmox Support Team <support@proxmox.com> Wed, 30 Apr 2014 14:47:56 +0200
219
220 libpve-access-control (3.0-11) unstable; urgency=low
221
222 * Sets common hot keys for spice client
223
224 -- Proxmox Support Team <support@proxmox.com> Fri, 31 Jan 2014 10:24:28 +0100
225
226 libpve-access-control (3.0-10) unstable; urgency=low
227
228 * implement helper to generate SPICE remote-viewer configuration
229
230 * depend on libnet-ssleay-perl
231
232 -- Proxmox Support Team <support@proxmox.com> Tue, 10 Dec 2013 10:45:08 +0100
233
234 libpve-access-control (3.0-9) unstable; urgency=low
235
236 * prevent user enumeration attacks
237
238 * allow dots in access paths
239
240 -- Proxmox Support Team <support@proxmox.com> Mon, 18 Nov 2013 09:06:38 +0100
241
242 libpve-access-control (3.0-8) unstable; urgency=low
243
244 * spice: use lowercase hostname in ticktet signature
245
246 -- Proxmox Support Team <support@proxmox.com> Mon, 28 Oct 2013 08:11:57 +0100
247
248 libpve-access-control (3.0-7) unstable; urgency=low
249
250 * check_volume_access : use parse_volname instead of path, and remove
251 path related code.
252
253 * use warnings instead of global -w flag.
254
255 -- Proxmox Support Team <support@proxmox.com> Tue, 01 Oct 2013 12:35:53 +0200
256
257 libpve-access-control (3.0-6) unstable; urgency=low
258
259 * use shorter spiceproxy tickets
260
261 -- Proxmox Support Team <support@proxmox.com> Fri, 19 Jul 2013 12:39:09 +0200
262
263 libpve-access-control (3.0-5) unstable; urgency=low
264
265 * add code to generate tickets for SPICE
266
267 -- Proxmox Support Team <support@proxmox.com> Wed, 26 Jun 2013 13:08:32 +0200
268
269 libpve-access-control (3.0-4) unstable; urgency=low
270
271 * moved add_vm_to_pool/remove_vm_from_pool from qemu-server
272
273 -- Proxmox Support Team <support@proxmox.com> Tue, 14 May 2013 11:56:54 +0200
274
275 libpve-access-control (3.0-3) unstable; urgency=low
276
277 * Add new role PVETemplateUser (and VM.Clone priviledge)
278
279 -- Proxmox Support Team <support@proxmox.com> Mon, 29 Apr 2013 11:42:15 +0200
280
281 libpve-access-control (3.0-2) unstable; urgency=low
282
283 * remove CGI.pm related code (pveproxy does not need that)
284
285 -- Proxmox Support Team <support@proxmox.com> Mon, 15 Apr 2013 12:34:23 +0200
286
287 libpve-access-control (3.0-1) unstable; urgency=low
288
289 * bump version for wheezy release
290
291 -- Proxmox Support Team <support@proxmox.com> Fri, 15 Mar 2013 08:07:06 +0100
292
293 libpve-access-control (1.0-26) unstable; urgency=low
294
295 * check_volume_access: fix access permissions for backup files
296
297 -- Proxmox Support Team <support@proxmox.com> Thu, 28 Feb 2013 10:00:14 +0100
298
299 libpve-access-control (1.0-25) unstable; urgency=low
300
301 * add VM.Snapshot permission
302
303 -- Proxmox Support Team <support@proxmox.com> Mon, 10 Sep 2012 09:23:32 +0200
304
305 libpve-access-control (1.0-24) unstable; urgency=low
306
307 * untaint path (allow root to restore arbitrary paths)
308
309 -- Proxmox Support Team <support@proxmox.com> Wed, 06 Jun 2012 13:06:34 +0200
310
311 libpve-access-control (1.0-23) unstable; urgency=low
312
313 * correctly compute GUI capabilities (consider pools)
314
315 -- Proxmox Support Team <support@proxmox.com> Wed, 30 May 2012 08:47:23 +0200
316
317 libpve-access-control (1.0-22) unstable; urgency=low
318
319 * new plugin architecture for Auth modules, minor API change for Auth
320 domains (new 'delete' parameter)
321
322 -- Proxmox Support Team <support@proxmox.com> Wed, 16 May 2012 07:21:44 +0200
323
324 libpve-access-control (1.0-21) unstable; urgency=low
325
326 * do not allow user names including slash
327
328 -- Proxmox Support Team <support@proxmox.com> Tue, 24 Apr 2012 10:07:47 +0200
329
330 libpve-access-control (1.0-20) unstable; urgency=low
331
332 * add ability to fork cli workers in background
333
334 -- Proxmox Support Team <support@proxmox.com> Wed, 18 Apr 2012 08:28:20 +0200
335
336 libpve-access-control (1.0-19) unstable; urgency=low
337
338 * return set of privileges on login - can be used to adopt GUI
339
340 -- Proxmox Support Team <support@proxmox.com> Tue, 17 Apr 2012 10:25:10 +0200
341
342 libpve-access-control (1.0-18) unstable; urgency=low
343
344 * fix bug #151: corretly parse username inside ticket
345
346 * fix bug #152: allow user to change his own password
347
348 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Apr 2012 09:40:15 +0200
349
350 libpve-access-control (1.0-17) unstable; urgency=low
351
352 * set propagate flag by default
353
354 -- Proxmox Support Team <support@proxmox.com> Thu, 01 Mar 2012 12:40:19 +0100
355
356 libpve-access-control (1.0-16) unstable; urgency=low
357
358 * add 'pveum passwd' method
359
360 -- Proxmox Support Team <support@proxmox.com> Thu, 23 Feb 2012 12:05:25 +0100
361
362 libpve-access-control (1.0-15) unstable; urgency=low
363
364 * Add VM.Config.CDROM privilege to PVEVMUser rule
365
366 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 11:44:23 +0100
367
368 libpve-access-control (1.0-14) unstable; urgency=low
369
370 * fix buf in userid-param permission check
371
372 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 10:52:35 +0100
373
374 libpve-access-control (1.0-13) unstable; urgency=low
375
376 * allow more characters in ldap base_dn attribute
377
378 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 06:17:02 +0100
379
380 libpve-access-control (1.0-12) unstable; urgency=low
381
382 * allow more characters with realm IDs
383
384 -- Proxmox Support Team <support@proxmox.com> Mon, 20 Feb 2012 08:50:33 +0100
385
386 libpve-access-control (1.0-11) unstable; urgency=low
387
388 * fix bug in exec_api2_perm_check
389
390 -- Proxmox Support Team <support@proxmox.com> Wed, 15 Feb 2012 07:06:30 +0100
391
392 libpve-access-control (1.0-10) unstable; urgency=low
393
394 * fix ACL group name parser
395
396 * changed 'pveum aclmod' command line arguments
397
398 -- Proxmox Support Team <support@proxmox.com> Tue, 14 Feb 2012 12:08:02 +0100
399
400 libpve-access-control (1.0-9) unstable; urgency=low
401
402 * fix bug in check_volume_access (fixes vzrestore)
403
404 -- Proxmox Support Team <support@proxmox.com> Mon, 13 Feb 2012 09:56:37 +0100
405
406 libpve-access-control (1.0-8) unstable; urgency=low
407
408 * fix return value for empty ACL list.
409
410 -- Proxmox Support Team <support@proxmox.com> Fri, 10 Feb 2012 11:25:04 +0100
411
412 libpve-access-control (1.0-7) unstable; urgency=low
413
414 * fix bug #85: allow root@pam to generate tickets for other users
415
416 -- Proxmox Support Team <support@proxmox.com> Tue, 17 Jan 2012 06:40:18 +0100
417
418 libpve-access-control (1.0-6) unstable; urgency=low
419
420 * API change: allow to filter enabled/disabled users.
421
422 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Jan 2012 12:30:37 +0100
423
424 libpve-access-control (1.0-5) unstable; urgency=low
425
426 * add a way to return file changes (diffs): set_result_changes()
427
428 -- Proxmox Support Team <support@proxmox.com> Tue, 20 Dec 2011 11:18:48 +0100
429
430 libpve-access-control (1.0-4) unstable; urgency=low
431
432 * new environment type for ha agents
433
434 -- Proxmox Support Team <support@proxmox.com> Tue, 13 Dec 2011 10:08:53 +0100
435
436 libpve-access-control (1.0-3) unstable; urgency=low
437
438 * add support for delayed parameter parsing - We need that to disable
439 file upload for normal API request (avoid DOS attacs)
440
441 -- Proxmox Support Team <support@proxmox.com> Fri, 02 Dec 2011 09:56:10 +0100
442
443 libpve-access-control (1.0-2) unstable; urgency=low
444
445 * fix bug in fork_worker
446
447 -- Proxmox Support Team <support@proxmox.com> Tue, 11 Oct 2011 08:37:05 +0200
448
449 libpve-access-control (1.0-1) unstable; urgency=low
450
451 * allow '-' in permission paths
452
453 * bump version to 1.0
454
455 -- Proxmox Support Team <support@proxmox.com> Mon, 27 Jun 2011 13:51:48 +0200
456
457 libpve-access-control (0.1) unstable; urgency=low
458
459 * first dummy package - no functionality
460
461 -- Proxmox Support Team <support@proxmox.com> Thu, 09 Jul 2009 16:03:00 +0200
462