fixup: touch date format does not understands abbreviations
[pve-access-control.git] / debian / changelog
1 libpve-access-control (5.1-3) unstable; urgency=medium
2
3 * api/ticket: move getting cluster name into an eval
4
5 -- Proxmox Support Team <support@proxmox.com> Thu, 29 Nov 2018 12:59:36 +0100
6
7 libpve-access-control (5.1-2) unstable; urgency=medium
8
9 * fix #1998: correct return properties for read_role
10
11 -- Proxmox Support Team <support@proxmox.com> Fri, 23 Nov 2018 14:22:40 +0100
12
13 libpve-access-control (5.1-1) unstable; urgency=medium
14
15 * pveum: introduce sub-commands
16
17 * register userid with completion
18
19 * fix #233: return cluster name on successful login
20
21 -- Proxmox Support Team <support@proxmox.com> Thu, 15 Nov 2018 09:34:47 +0100
22
23 libpve-access-control (5.0-8) unstable; urgency=medium
24
25 * fix #1612: ldap: make 2nd server work with bind domains again
26
27 * fix an error message where passing a bad pool id to an API function would
28 make it complain about a wrong group name instead
29
30 * fix the API-returned permission list so that the GUI knows to show the
31 'Permissions' tab for a storage to an administrator apart from root@pam
32
33 -- Proxmox Support Team <support@proxmox.com> Thu, 18 Jan 2018 13:34:50 +0100
34
35 libpve-access-control (5.0-7) unstable; urgency=medium
36
37 * VM.Snapshot.Rollback privilege added
38
39 * api: check for special roles before locking the usercfg
40
41 * fix #1501: pveum: die when deleting special role
42
43 * API/ticket: rework coarse grained permission computation
44
45 -- Proxmox Support Team <support@proxmox.com> Thu, 5 Oct 2017 11:27:48 +0200
46
47 libpve-access-control (5.0-6) unstable; urgency=medium
48
49 * Close #1470: Add server ceritifcate verification for AD and LDAP via the
50 'verify' option. For compatibility reasons this defaults to off for now,
51 but that might change with future updates.
52
53 * AD, LDAP: Add ability to specify a CA path or file, and a client
54 certificate via the 'capath', 'cert' and 'certkey' options.
55
56 -- Proxmox Support Team <support@proxmox.com> Tue, 08 Aug 2017 11:56:38 +0200
57
58 libpve-access-control (5.0-5) unstable; urgency=medium
59
60 * change from dpkg-deb to dpkg-buildpackage
61
62 -- Proxmox Support Team <support@proxmox.com> Thu, 22 Jun 2017 09:12:37 +0200
63
64 libpve-access-control (5.0-4) unstable; urgency=medium
65
66 * PVE/CLI/pveum.pm: call setup_default_cli_env()
67
68 * PVE/Auth/PVE.pm: encode uft8 password before calling crypt
69
70 * check_api2_permissions: avoid warning about uninitialized value
71
72 -- Proxmox Support Team <support@proxmox.com> Tue, 02 May 2017 11:58:15 +0200
73
74 libpve-access-control (5.0-3) unstable; urgency=medium
75
76 * use new PVE::OTP class from pve-common
77
78 * use new PVE::Tools::encrypt_pw from pve-common
79
80 -- Proxmox Support Team <support@proxmox.com> Thu, 30 Mar 2017 17:45:55 +0200
81
82 libpve-access-control (5.0-2) unstable; urgency=medium
83
84 * encrypt_pw: avoid '+' for crypt salt
85
86 -- Proxmox Support Team <support@proxmox.com> Thu, 30 Mar 2017 08:54:10 +0200
87
88 libpve-access-control (5.0-1) unstable; urgency=medium
89
90 * rebuild for PVE 5.0
91
92 -- Proxmox Support Team <support@proxmox.com> Mon, 6 Mar 2017 13:42:01 +0100
93
94 libpve-access-control (4.0-23) unstable; urgency=medium
95
96 * use new PVE::Ticket class
97
98 -- Proxmox Support Team <support@proxmox.com> Thu, 19 Jan 2017 13:42:06 +0100
99
100 libpve-access-control (4.0-22) unstable; urgency=medium
101
102 * RPCEnvironment: removed check_volume_access() to avoid cyclic dependency
103 (moved to PVE::Storage)
104
105 * PVE::PCEnvironment: use new PVE::RESTEnvironment as base class
106
107 -- Proxmox Support Team <support@proxmox.com> Thu, 19 Jan 2017 09:12:04 +0100
108
109 libpve-access-control (4.0-21) unstable; urgency=medium
110
111 * setup_default_cli_env: expect $class as first parameter
112
113 -- Proxmox Support Team <support@proxmox.com> Thu, 12 Jan 2017 13:54:27 +0100
114
115 libpve-access-control (4.0-20) unstable; urgency=medium
116
117 * PVE/RPCEnvironment.pm: new function setup_default_cli_env
118
119 * PVE/API2/Domains.pm: fix property description
120
121 * use new repoman for upload target
122
123 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Jan 2017 12:13:26 +0100
124
125 libpve-access-control (4.0-19) unstable; urgency=medium
126
127 * Close #833: ldap: non-anonymous bind support
128
129 * don't import 'RFC' from MIME::Base32
130
131 -- Proxmox Support Team <support@proxmox.com> Fri, 05 Aug 2016 13:09:08 +0200
132
133 libpve-access-control (4.0-18) unstable; urgency=medium
134
135 * fix #1062: recognize base32 otp keys again
136
137 -- Proxmox Support Team <support@proxmox.com> Thu, 21 Jul 2016 08:43:18 +0200
138
139 libpve-access-control (4.0-17) unstable; urgency=medium
140
141 * drop oathtool and libdigest-hmac-perl dependencies
142
143 -- Proxmox Support Team <support@proxmox.com> Mon, 11 Jul 2016 12:03:22 +0200
144
145 libpve-access-control (4.0-16) unstable; urgency=medium
146
147 * use pve-doc-generator to generate man pages
148
149 -- Proxmox Support Team <support@proxmox.com> Fri, 08 Apr 2016 07:06:05 +0200
150
151 libpve-access-control (4.0-15) unstable; urgency=medium
152
153 * Fix uninitialized warning when shadow.cfg does not exist
154
155 -- Proxmox Support Team <support@proxmox.com> Fri, 01 Apr 2016 07:10:57 +0200
156
157 libpve-access-control (4.0-14) unstable; urgency=medium
158
159 * Add is_worker to RPCEnvironment
160
161 -- Proxmox Support Team <support@proxmox.com> Tue, 15 Mar 2016 16:47:34 +0100
162
163 libpve-access-control (4.0-13) unstable; urgency=medium
164
165 * fix #916: allow HTTPS to access custom yubico url
166
167 -- Proxmox Support Team <support@proxmox.com> Mon, 14 Mar 2016 11:39:23 +0100
168
169 libpve-access-control (4.0-12) unstable; urgency=medium
170
171 * Catch certificate errors instead of segfaulting
172
173 -- Proxmox Support Team <support@proxmox.com> Wed, 09 Mar 2016 14:41:01 +0100
174
175 libpve-access-control (4.0-11) unstable; urgency=medium
176
177 * Fix #861: use safer sprintf formatting
178
179 -- Proxmox Support Team <support@proxmox.com> Fri, 08 Jan 2016 12:52:39 +0100
180
181 libpve-access-control (4.0-10) unstable; urgency=medium
182
183 * Auth::LDAP, Auth::AD: ipv6 support
184
185 -- Proxmox Support Team <support@proxmox.com> Thu, 03 Dec 2015 12:09:32 +0100
186
187 libpve-access-control (4.0-9) unstable; urgency=medium
188
189 * pveum: implement bash completion
190
191 -- Proxmox Support Team <support@proxmox.com> Thu, 01 Oct 2015 17:22:52 +0200
192
193 libpve-access-control (4.0-8) unstable; urgency=medium
194
195 * remove_storage_access: cleanup of access permissions for removed storage
196
197 -- Proxmox Support Team <support@proxmox.com> Wed, 19 Aug 2015 15:39:15 +0200
198
199 libpve-access-control (4.0-7) unstable; urgency=medium
200
201 * new helper to remove access permissions for removed VMs
202
203 -- Proxmox Support Team <support@proxmox.com> Fri, 14 Aug 2015 07:57:02 +0200
204
205 libpve-access-control (4.0-6) unstable; urgency=medium
206
207 * improve parse_user_config, parse_shadow_config
208
209 -- Proxmox Support Team <support@proxmox.com> Mon, 27 Jul 2015 13:14:33 +0200
210
211 libpve-access-control (4.0-5) unstable; urgency=medium
212
213 * pveum: check for $cmd being defined
214
215 -- Proxmox Support Team <support@proxmox.com> Wed, 10 Jun 2015 10:40:15 +0200
216
217 libpve-access-control (4.0-4) unstable; urgency=medium
218
219 * use activate-noawait triggers
220
221 -- Proxmox Support Team <support@proxmox.com> Mon, 01 Jun 2015 12:25:31 +0200
222
223 libpve-access-control (4.0-3) unstable; urgency=medium
224
225 * IPv6 fixes
226
227 * non-root buildfix
228
229 -- Proxmox Support Team <support@proxmox.com> Wed, 27 May 2015 11:15:44 +0200
230
231 libpve-access-control (4.0-2) unstable; urgency=medium
232
233 * trigger pve-api-updates event
234
235 -- Proxmox Support Team <support@proxmox.com> Tue, 05 May 2015 15:06:38 +0200
236
237 libpve-access-control (4.0-1) unstable; urgency=medium
238
239 * bump version for Debian Jessie
240
241 -- Proxmox Support Team <support@proxmox.com> Thu, 26 Feb 2015 11:22:01 +0100
242
243 libpve-access-control (3.0-16) unstable; urgency=low
244
245 * root@pam can now be disabled in GUI.
246
247 -- Proxmox Support Team <support@proxmox.com> Fri, 30 Jan 2015 06:20:22 +0100
248
249 libpve-access-control (3.0-15) unstable; urgency=low
250
251 * oath: add 'step' and 'digits' option
252
253 -- Proxmox Support Team <support@proxmox.com> Wed, 23 Jul 2014 06:59:52 +0200
254
255 libpve-access-control (3.0-14) unstable; urgency=low
256
257 * add oath two factor auth
258
259 * add oathkeygen binary to generate keys for oath
260
261 * add yubico two factor auth
262
263 * dedend on oathtool
264
265 * depend on libmime-base32-perl
266
267 * allow to write builtin auth domains config (comment/tfa/default)
268
269 -- Proxmox Support Team <support@proxmox.com> Thu, 17 Jul 2014 13:09:56 +0200
270
271 libpve-access-control (3.0-13) unstable; urgency=low
272
273 * use correct connection string for AD auth
274
275 -- Proxmox Support Team <support@proxmox.com> Thu, 22 May 2014 07:16:09 +0200
276
277 libpve-access-control (3.0-12) unstable; urgency=low
278
279 * add dummy API for GET /access/ticket (useful to generate login pages)
280
281 -- Proxmox Support Team <support@proxmox.com> Wed, 30 Apr 2014 14:47:56 +0200
282
283 libpve-access-control (3.0-11) unstable; urgency=low
284
285 * Sets common hot keys for spice client
286
287 -- Proxmox Support Team <support@proxmox.com> Fri, 31 Jan 2014 10:24:28 +0100
288
289 libpve-access-control (3.0-10) unstable; urgency=low
290
291 * implement helper to generate SPICE remote-viewer configuration
292
293 * depend on libnet-ssleay-perl
294
295 -- Proxmox Support Team <support@proxmox.com> Tue, 10 Dec 2013 10:45:08 +0100
296
297 libpve-access-control (3.0-9) unstable; urgency=low
298
299 * prevent user enumeration attacks
300
301 * allow dots in access paths
302
303 -- Proxmox Support Team <support@proxmox.com> Mon, 18 Nov 2013 09:06:38 +0100
304
305 libpve-access-control (3.0-8) unstable; urgency=low
306
307 * spice: use lowercase hostname in ticktet signature
308
309 -- Proxmox Support Team <support@proxmox.com> Mon, 28 Oct 2013 08:11:57 +0100
310
311 libpve-access-control (3.0-7) unstable; urgency=low
312
313 * check_volume_access : use parse_volname instead of path, and remove
314 path related code.
315
316 * use warnings instead of global -w flag.
317
318 -- Proxmox Support Team <support@proxmox.com> Tue, 01 Oct 2013 12:35:53 +0200
319
320 libpve-access-control (3.0-6) unstable; urgency=low
321
322 * use shorter spiceproxy tickets
323
324 -- Proxmox Support Team <support@proxmox.com> Fri, 19 Jul 2013 12:39:09 +0200
325
326 libpve-access-control (3.0-5) unstable; urgency=low
327
328 * add code to generate tickets for SPICE
329
330 -- Proxmox Support Team <support@proxmox.com> Wed, 26 Jun 2013 13:08:32 +0200
331
332 libpve-access-control (3.0-4) unstable; urgency=low
333
334 * moved add_vm_to_pool/remove_vm_from_pool from qemu-server
335
336 -- Proxmox Support Team <support@proxmox.com> Tue, 14 May 2013 11:56:54 +0200
337
338 libpve-access-control (3.0-3) unstable; urgency=low
339
340 * Add new role PVETemplateUser (and VM.Clone priviledge)
341
342 -- Proxmox Support Team <support@proxmox.com> Mon, 29 Apr 2013 11:42:15 +0200
343
344 libpve-access-control (3.0-2) unstable; urgency=low
345
346 * remove CGI.pm related code (pveproxy does not need that)
347
348 -- Proxmox Support Team <support@proxmox.com> Mon, 15 Apr 2013 12:34:23 +0200
349
350 libpve-access-control (3.0-1) unstable; urgency=low
351
352 * bump version for wheezy release
353
354 -- Proxmox Support Team <support@proxmox.com> Fri, 15 Mar 2013 08:07:06 +0100
355
356 libpve-access-control (1.0-26) unstable; urgency=low
357
358 * check_volume_access: fix access permissions for backup files
359
360 -- Proxmox Support Team <support@proxmox.com> Thu, 28 Feb 2013 10:00:14 +0100
361
362 libpve-access-control (1.0-25) unstable; urgency=low
363
364 * add VM.Snapshot permission
365
366 -- Proxmox Support Team <support@proxmox.com> Mon, 10 Sep 2012 09:23:32 +0200
367
368 libpve-access-control (1.0-24) unstable; urgency=low
369
370 * untaint path (allow root to restore arbitrary paths)
371
372 -- Proxmox Support Team <support@proxmox.com> Wed, 06 Jun 2012 13:06:34 +0200
373
374 libpve-access-control (1.0-23) unstable; urgency=low
375
376 * correctly compute GUI capabilities (consider pools)
377
378 -- Proxmox Support Team <support@proxmox.com> Wed, 30 May 2012 08:47:23 +0200
379
380 libpve-access-control (1.0-22) unstable; urgency=low
381
382 * new plugin architecture for Auth modules, minor API change for Auth
383 domains (new 'delete' parameter)
384
385 -- Proxmox Support Team <support@proxmox.com> Wed, 16 May 2012 07:21:44 +0200
386
387 libpve-access-control (1.0-21) unstable; urgency=low
388
389 * do not allow user names including slash
390
391 -- Proxmox Support Team <support@proxmox.com> Tue, 24 Apr 2012 10:07:47 +0200
392
393 libpve-access-control (1.0-20) unstable; urgency=low
394
395 * add ability to fork cli workers in background
396
397 -- Proxmox Support Team <support@proxmox.com> Wed, 18 Apr 2012 08:28:20 +0200
398
399 libpve-access-control (1.0-19) unstable; urgency=low
400
401 * return set of privileges on login - can be used to adopt GUI
402
403 -- Proxmox Support Team <support@proxmox.com> Tue, 17 Apr 2012 10:25:10 +0200
404
405 libpve-access-control (1.0-18) unstable; urgency=low
406
407 * fix bug #151: corretly parse username inside ticket
408
409 * fix bug #152: allow user to change his own password
410
411 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Apr 2012 09:40:15 +0200
412
413 libpve-access-control (1.0-17) unstable; urgency=low
414
415 * set propagate flag by default
416
417 -- Proxmox Support Team <support@proxmox.com> Thu, 01 Mar 2012 12:40:19 +0100
418
419 libpve-access-control (1.0-16) unstable; urgency=low
420
421 * add 'pveum passwd' method
422
423 -- Proxmox Support Team <support@proxmox.com> Thu, 23 Feb 2012 12:05:25 +0100
424
425 libpve-access-control (1.0-15) unstable; urgency=low
426
427 * Add VM.Config.CDROM privilege to PVEVMUser rule
428
429 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 11:44:23 +0100
430
431 libpve-access-control (1.0-14) unstable; urgency=low
432
433 * fix buf in userid-param permission check
434
435 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 10:52:35 +0100
436
437 libpve-access-control (1.0-13) unstable; urgency=low
438
439 * allow more characters in ldap base_dn attribute
440
441 -- Proxmox Support Team <support@proxmox.com> Wed, 22 Feb 2012 06:17:02 +0100
442
443 libpve-access-control (1.0-12) unstable; urgency=low
444
445 * allow more characters with realm IDs
446
447 -- Proxmox Support Team <support@proxmox.com> Mon, 20 Feb 2012 08:50:33 +0100
448
449 libpve-access-control (1.0-11) unstable; urgency=low
450
451 * fix bug in exec_api2_perm_check
452
453 -- Proxmox Support Team <support@proxmox.com> Wed, 15 Feb 2012 07:06:30 +0100
454
455 libpve-access-control (1.0-10) unstable; urgency=low
456
457 * fix ACL group name parser
458
459 * changed 'pveum aclmod' command line arguments
460
461 -- Proxmox Support Team <support@proxmox.com> Tue, 14 Feb 2012 12:08:02 +0100
462
463 libpve-access-control (1.0-9) unstable; urgency=low
464
465 * fix bug in check_volume_access (fixes vzrestore)
466
467 -- Proxmox Support Team <support@proxmox.com> Mon, 13 Feb 2012 09:56:37 +0100
468
469 libpve-access-control (1.0-8) unstable; urgency=low
470
471 * fix return value for empty ACL list.
472
473 -- Proxmox Support Team <support@proxmox.com> Fri, 10 Feb 2012 11:25:04 +0100
474
475 libpve-access-control (1.0-7) unstable; urgency=low
476
477 * fix bug #85: allow root@pam to generate tickets for other users
478
479 -- Proxmox Support Team <support@proxmox.com> Tue, 17 Jan 2012 06:40:18 +0100
480
481 libpve-access-control (1.0-6) unstable; urgency=low
482
483 * API change: allow to filter enabled/disabled users.
484
485 -- Proxmox Support Team <support@proxmox.com> Wed, 11 Jan 2012 12:30:37 +0100
486
487 libpve-access-control (1.0-5) unstable; urgency=low
488
489 * add a way to return file changes (diffs): set_result_changes()
490
491 -- Proxmox Support Team <support@proxmox.com> Tue, 20 Dec 2011 11:18:48 +0100
492
493 libpve-access-control (1.0-4) unstable; urgency=low
494
495 * new environment type for ha agents
496
497 -- Proxmox Support Team <support@proxmox.com> Tue, 13 Dec 2011 10:08:53 +0100
498
499 libpve-access-control (1.0-3) unstable; urgency=low
500
501 * add support for delayed parameter parsing - We need that to disable
502 file upload for normal API request (avoid DOS attacs)
503
504 -- Proxmox Support Team <support@proxmox.com> Fri, 02 Dec 2011 09:56:10 +0100
505
506 libpve-access-control (1.0-2) unstable; urgency=low
507
508 * fix bug in fork_worker
509
510 -- Proxmox Support Team <support@proxmox.com> Tue, 11 Oct 2011 08:37:05 +0200
511
512 libpve-access-control (1.0-1) unstable; urgency=low
513
514 * allow '-' in permission paths
515
516 * bump version to 1.0
517
518 -- Proxmox Support Team <support@proxmox.com> Mon, 27 Jun 2011 13:51:48 +0200
519
520 libpve-access-control (0.1) unstable; urgency=low
521
522 * first dummy package - no functionality
523
524 -- Proxmox Support Team <support@proxmox.com> Thu, 09 Jul 2009 16:03:00 +0200
525