depend on libpve-u2f-server-perl
[pve-access-control.git] / debian / control
index c951d60..cb7f1cd 100644 (file)
@@ -2,13 +2,35 @@ Source: libpve-access-control
 Section: perl
 Priority: optional
 Maintainer: Proxmox Support Team <support@proxmox.com>
-Build-Depends: debhelper (>= 7.0.50~), libpve-common-perl, perl (>= 5.10.0-19), lintian, pve-doc-generator
-Standards-Version: 3.9.5
+Build-Depends: debhelper (>= 9.0.0~),
+               libauthen-pam-perl,
+               libnet-ldap-perl,
+               libpve-common-perl,
+               lintian,
+               perl (>= 5.10.0-19),
+               pve-cluster,
+               pve-doc-generator (>= 5.3-3),
+Standards-Version: 3.9.8
 Homepage: http://www.proxmox.com
 
 Package: libpve-access-control
 Architecture: any
-Depends: libc6 (>= 2.3), perl (>= 5.6.0-16), libcrypt-openssl-rsa-perl, libcrypt-openssl-random-perl, libjson-xs-perl, libjson-perl, libterm-readline-gnu-perl,libnet-ldap-perl, libpve-common-perl, pve-cluster, libauthen-pam-perl, libnet-ssleay-perl, liburi-perl, libwww-perl, libmime-base32-perl
+Depends: libauthen-pam-perl,
+         libcrypt-openssl-random-perl,
+         libcrypt-openssl-rsa-perl,
+         libjson-perl,
+         libjson-xs-perl,
+         libmime-base32-perl,
+         libnet-ldap-perl,
+         libnet-ssleay-perl,
+         libpve-common-perl (>= 5.0-35),
+         libpve-u2f-server-perl,
+         liburi-perl,
+         libwww-perl,
+         perl (>= 5.6.0-16),
+         pve-cluster (>= 5.0-34),
+         ${misc:Depends},
+         ${perl:Depends},
 Description: Proxmox VE access control library
  This package contains the role based user management and access
  control function used by Proxmox VE.