d/control: break pve-manager < 5.2-5 and pmg-api < 5.0-74
[pve-common.git] / debian / control
index 2d85e01..8900622 100644 (file)
@@ -2,11 +2,34 @@ Source: libpve-common-perl
 Section: perl
 Priority: extra
 Maintainer: Proxmox Support Team <support@proxmox.com>
-Build-Depends: debhelper (>= 7.0.50~)
+Build-Depends: debhelper (>= 7.0.50~),
+               libfilesys-df-perl,
+               libjson-perl,
+               liblinux-inotify2-perl,
+               libstring-shellquote-perl,
 Standards-Version: 3.8.4
 
 Package: libpve-common-perl
 Architecture: all
-Depends: ${perl:Depends} ${misc:Depends}, libclone-perl, libdevel-cycle-perl, libwww-perl, libjson-perl, liblinux-inotify2-perl, libio-stringy-perl, liburi-perl, libstring-shellquote-perl, libnet-ip-perl
+Depends: libclone-perl,
+         libcrypt-openssl-random-perl,
+         libcrypt-openssl-rsa-perl,
+         libdevel-cycle-perl,
+         libfilesys-df-perl,
+         libio-stringy-perl,
+         libjson-perl,
+         liblinux-inotify2-perl,
+         libmime-base32-perl,
+         libnet-dbus-perl,
+         libnet-ip-perl,
+         libstring-shellquote-perl,
+         liburi-perl,
+         libwww-perl,
+         ${misc:Depends},
+         ${perl:Depends},
+Breaks: pve-container (<< 1.0-93),
+        qemu-server (<< 5.0-29),
+        pve-manager (<< 5.2-5),
+        pmg-api (<< 5.0-74),
 Description: Proxmox VE base library
  This package contains the base library used by other Proxmox VE components.