d/control: minimize pve-doc-generator depends
[pve-docs.git] / debian / control
1 Source: pve-docs
2 Section: perl
3 Priority: extra
4 Maintainer: Proxmox Support Team <support@proxmox.com>
5 Build-Depends: asciidoc-dblatex,
6                debhelper (>= 10~),
7                docbook-xsl,
8                git,
9                graphviz,
10                imagemagick-6.q16,
11                libjson-perl,
12                librsvg2-bin,
13                lintian,
14                source-highlight,
15 Standards-Version: 3.8.4
16
17 Package: pve-doc-generator
18 Section: perl
19 Architecture: any
20 Depends: asciidoc-base,
21          libpve-common-perl,
22          source-highlight,
23          xmlto,
24          ${perl:Depends},
25 Description: Proxmox VE Documentation helpers
26  Tool to auto-generate various Proxmox VE Documentation files and
27  manual pages. This package is required to build most other Proxmox VE
28  packages.
29
30 Package: pve-docs
31 Section: doc
32 Depends: libjs-extjs,
33 Architecture: all
34 Description: Proxmox VE Documentation
35  This package contains the Proxmox VE Documentation files.
36
37 Package: pve-docs-mediawiki
38 Architecture: all
39 Section: doc
40 Depends: libhtml-parser-perl,
41          pve-docs,
42          ${misc:Depends},
43 Suggests: apache2,
44 Description: Proxmox VE Documentation - mediawiki plugin
45  This package contains tools to view Proxmox VE Documentation with mediakiki.