buildsys: not our job to handle editor files
[pve-docs.git] / pve-package-repos.adoc
1 [[sysadmin_package_repositories]]
2 Package Repositories
3 --------------------
4 ifdef::wiki[]
5 :pve-toplevel:
6 endif::wiki[]
7
8 All Debian based systems use
9 http://en.wikipedia.org/wiki/Advanced_Packaging_Tool[APT] as package
10 management tool. The list of repositories is defined in
11 `/etc/apt/sources.list` and `.list` files found inside
12 `/etc/apt/sources.d/`. Updates can be installed directly using
13 `apt-get`, or via the GUI.
14
15 Apt `sources.list` files list one package repository per line, with
16 the most preferred source listed first. Empty lines are ignored, and a
17 `#` character anywhere on a line marks the remainder of that line as a
18 comment. The information available from the configured sources is
19 acquired by `apt-get update`.
20
21 .File `/etc/apt/sources.list`
22 ----
23 deb http://ftp.debian.org/debian jessie main contrib
24
25 # security updates
26 deb http://security.debian.org jessie/updates main contrib
27 ----
28
29 In addition, {pve} provides three different package repositories.
30
31 {pve} Enterprise Repository
32 ~~~~~~~~~~~~~~~~~~~~~~~~~~~
33
34 This is the default, stable and recommended repository, available for
35 all {pve} subscription users. It contains the most stable packages,
36 and is suitable for production use. The `pve-enterprise` repository is
37 enabled by default:
38
39 .File `/etc/apt/sources.list.d/pve-enterprise.list`
40 ----
41 deb https://enterprise.proxmox.com/debian jessie pve-enterprise
42 ----
43
44 As soon as updates are available, the `root@pam` user is notified via
45 email about the available new packages. On the GUI, the change-log of
46 each package can be viewed (if available), showing all details of the
47 update. So you will never miss important security fixes.
48
49 Please note that and you need a valid subscription key to access this
50 repository. We offer different support levels, and you can find further
51 details at http://www.proxmox.com/en/proxmox-ve/pricing.
52
53 NOTE: You can disable this repository by commenting out the above line
54 using a `#` (at the start of the line). This prevents error messages
55 if you do not have a subscription key. Please configure the
56 `pve-no-subscription` repository in that case.
57
58
59 {pve} No-Subscription Repository
60 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
61
62 As the name suggests, you do not need a subscription key to access
63 this repository. It can be used for testing and non-production
64 use. Its not recommended to run on production servers, as these
65 packages are not always heavily tested and validated.
66
67 We recommend to configure this repository in `/etc/apt/sources.list`.
68
69 .File `/etc/apt/sources.list`
70 ----
71 deb http://ftp.debian.org/debian jessie main contrib
72
73 # PVE pve-no-subscription repository provided by proxmox.com,
74 # NOT recommended for production use
75 deb http://download.proxmox.com/debian jessie pve-no-subscription
76
77 # security updates
78 deb http://security.debian.org jessie/updates main contrib
79 ----
80
81
82 {pve} Test Repository
83 ~~~~~~~~~~~~~~~~~~~~~~
84
85 Finally, there is a repository called `pvetest`. This one contains the
86 latest packages and is heavily used by developers to test new
87 features. As usual, you can configure this using
88 `/etc/apt/sources.list` by adding the following line:
89
90 .sources.list entry for `pvetest`
91 ----
92 deb http://download.proxmox.com/debian jessie pvetest
93 ----
94
95 WARNING: the `pvetest` repository should (as the name implies) only be used
96 for testing new features or bug fixes.
97
98
99 SecureApt
100 ~~~~~~~~~
101
102 We use GnuPG to sign the `Release` files inside those repositories,
103 and APT uses that signatures to verify that all packages are from a
104 trusted source.
105
106 The key used for verification is already installed if you install from
107 our installation CD. If you install by other means, you can manually
108 download the key with:
109
110  # wget http://download.proxmox.com/debian/key.asc
111
112 Please verify the fingerprint afterwards:
113
114 ----
115 # gpg --with-fingerprint key.asc
116 pub  1024D/9887F95A 2008-10-28 Proxmox Release Key <proxmox-release@proxmox.com>
117       Key fingerprint = BE25 7BAA 5D40 6D01 157D  323E C23A C7F4 9887 F95A
118 sub  2048g/A87A1B00 2008-10-28
119 ----
120
121 If this shows the exact same fingerprint, you can add the key to the
122 list of trusted APT keys:
123
124  # apt-key add key.asc
125
126
127 ifdef::wiki[]
128
129 // include note about older releases, but only for wiki
130
131 {pve} 3.x Repositories
132 ~~~~~~~~~~~~~~~~~~~~~~
133
134 {pve} 3.x is based on Debian 7.x (``wheezy''). Please note that this
135 release is out of date, and you should update your
136 installation. Nevertheless, we still provide access to those
137 repositories at our download servers.
138
139 [width="100%",cols="<d,3m",options="header"]
140 |===========================================================
141 |Repository                 | sources.list entry
142 |{pve} 3.x Enterprise       |
143 deb https://enterprise.proxmox.com/debian wheezy pve-enterprise
144 |{pve} 3.x No-Subscription  |
145 deb http://download.proxmox.com/debian wheezy pve-no-subscription
146 |{pve} 3.x Test             |
147 deb http://download.proxmox.com/debian wheezy pvetest
148 |===========================================================
149
150 NOTE: Apt `sources.list` configuration files are basically the same as
151 in newer 4.x versions - just replace `jessie` with `wheezy`.
152
153 Outdated: `stable` Repository `pve`
154 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
155
156 This repository is a leftover to easy the update to 3.1. It will not
157 get any updates after the release of 3.1. Therefore you need to remove
158 this repository after you upgraded to 3.1.
159
160 .File `/etc/apt/sources.list`
161 ----
162 deb http://ftp.debian.org/debian wheezy main contrib
163
164 # PVE packages provided by proxmox.com - NO UPDATES after the initial release of 3.1
165 # deb http://download.proxmox.com/debian wheezy pve
166
167 # security updates
168 deb http://security.debian.org/ wheezy/updates main contrib
169 ----
170
171
172 Outdated: {pve} 2.x Repositories
173 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
174
175 {pve} 2.x is based on Debian 6.0 (``squeeze'') and outdated. Please
176 upgrade to latest version as soon as possible. In order to use the
177 stable `pve` 2.x repository, check your sources.list:
178
179 .File `/etc/apt/sources.list`
180 ----
181 deb http://ftp.debian.org/debian squeeze main contrib
182
183 # PVE packages provided by proxmox.com
184 deb http://download.proxmox.com/debian squeeze pve
185
186 # security updates
187 deb http://security.debian.org/ squeeze/updates main contrib
188 ----
189
190
191 Outdated: {pve} VE 1.x Repositories
192 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
193
194 {pve} 1.x is based on Debian 5.0 (``lenny'') and very outdated. Please
195 upgrade to latest version as soon as possible.
196
197
198 endif::wiki[]