Use run_cli_handler instead of deprecated run_cli