bump version to 1.4-2
[vncterm.git] / debian / changelog.Debian
1 vncterm (1.4-2) unstable; urgency=medium
2
3   * fix bound checking on cursor move
4
5  -- Proxmox Support Team <support@proxmox.com>  Sat, 06 May 2017 08:09:29 +0200
6
7 vncterm (1.4-1) unstable; urgency=medium
8
9   * recompile for Debian Stretch / PVE 5
10
11  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Mar 2017 10:19:48 +0100
12
13 vncterm (1.3-2) unstable; urgency=medium
14
15   * bound check utf8 characters
16
17   * detect empty first parameter of escape codes
18
19  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Mar 2017 10:11:00 +0100
20
21 vncterm (1.3-1) unstable; urgency=low
22
23   * update cipher suites to GnuTLS's NORMAL
24
25   * allow building with GnuTLS 3.5
26
27   * update LibVNCServer to 0.9.11
28
29  -- Proxmox Support Team <support@proxmox.com>  Fri, 3 Feb 2017 08:52:31 +0100
30
31 vncterm (1.2-1) unstable; urgency=low
32
33   * recompile for Debian Jessie / PVE 4
34
35  -- Proxmox Support Team <support@proxmox.com>  Fri, 27 Feb 2015 20:00:46 +0100
36
37 vncterm (1.1-8) unstable; urgency=low
38
39   * update applet signature (new code signing cert)
40
41  -- Proxmox Support Team <support@proxmox.com>  Fri, 25 Jul 2014 06:57:46 +0200
42
43 vncterm (1.1-7) unstable; urgency=low
44
45   *  new option -notls (for novnc)
46
47  -- Proxmox Support Team <support@proxmox.com>  Mon, 23 Jun 2014 13:30:50 +0200
48
49 vncterm (1.1-6) unstable; urgency=low
50
51   * set Caller-Allowable-Codebase and remove Trusted-Library. This avoids
52     security popups with latest Java 7u45. Also see:
53   
54     http://stackoverflow.com/questions/19393826/java-applet-manifest-allow-all-caller-allowable-codebase
55
56  -- Proxmox Support Team <support@proxmox.com>  Fri, 08 Nov 2013 11:27:08 +0100
57
58 vncterm (1.1-5) unstable; urgency=low
59
60   * use Comodo code sign cert for applet signature
61
62  -- Proxmox Support Team <support@proxmox.com>  Fri, 08 Nov 2013 08:35:10 +0100
63
64 vncterm (1.1-4) unstable; urgency=low
65
66   * Allow to add intermediate certificates to /etc/pve/local/pve-ssl.pem 
67   (users previously used apache option SSLCertificateChainFile for that).
68   
69  -- Proxmox Support Team <support@proxmox.com>  Mon, 03 Jun 2013 08:26:59 +0200
70
71 vncterm (1.1-3) unstable; urgency=low
72
73   *  re-enable javascript-events.patch (used for migrate/reload)
74
75  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 May 2013 07:56:35 +0200
76
77 vncterm (1.1-2) unstable; urgency=low
78
79   * recompile VnCViewer.jar with openJDK
80   
81   * set trusted-lib to avoid security popup
82   
83   * disable unused javascript-events.patch
84
85  -- Proxmox Support Team <support@proxmox.com>  Sat, 20 Apr 2013 16:05:41 +0200
86
87 vncterm (1.1-1) unstable; urgency=low
88
89   * recompile for wheezy
90
91  -- Proxmox Support Team <support@proxmox.com>  Fri, 15 Mar 2013 08:26:04 +0100
92
93 vncterm (1.0-3) unstable; urgency=low
94
95   * fix focus traversal
96
97  -- Proxmox Support Team <support@proxmox.com>  Tue, 21 Aug 2012 09:14:04 +0200
98
99 vncterm (1.0-2) unstable; urgency=low
100
101   * do not create a new process group (with setsid), so
102   we can kill the whole pve task if used inside fork_worker().
103
104  -- Proxmox Support Team <support@proxmox.com>  Tue, 13 Sep 2011 10:49:32 +0200
105
106 vncterm (1.0-1) unstable; urgency=low
107
108   * use TigerVNC java sources
109   
110   * implement TLS encryption and vencrypt password auth
111   
112   * removed support for -passwdfile option
113
114  -- root <root@maui.maurer-it.com>  Mon, 24 Jan 2011 10:46:25 +0100
115
116 vncterm (0.9-2) unstable; urgency=low
117
118   * compiled for debian etch
119   
120   * use memmove instead of rfbDoCopyRect (avoid SIGSEGV when
121   called with negative dy)
122
123  -- Proxmox Support Team <support@proxmox.com>  Wed, 22 Apr 2009 10:02:08 +0200
124
125 vncterm (0.9-1) stable; urgency=low
126
127   * initial import
128
129  -- Proxmox Support Team <support@proxmox.com>  Thu, 27 Dec 2007 05:57:17 +0100
130