remove java applet
[vncterm.git] / debian / changelog.Debian
1 vncterm (1.4-1) unstable; urgency=medium
2
3   * recompile for Debian Stretch / PVE 5
4
5  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Mar 2017 10:19:48 +0100
6
7 vncterm (1.3-2) unstable; urgency=medium
8
9   * bound check utf8 characters
10
11   * detect empty first parameter of escape codes
12
13  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Mar 2017 10:11:00 +0100
14
15 vncterm (1.3-1) unstable; urgency=low
16
17   * update cipher suites to GnuTLS's NORMAL
18
19   * allow building with GnuTLS 3.5
20
21   * update LibVNCServer to 0.9.11
22
23  -- Proxmox Support Team <support@proxmox.com>  Fri, 3 Feb 2017 08:52:31 +0100
24
25 vncterm (1.2-1) unstable; urgency=low
26
27   * recompile for Debian Jessie / PVE 4
28
29  -- Proxmox Support Team <support@proxmox.com>  Fri, 27 Feb 2015 20:00:46 +0100
30
31 vncterm (1.1-8) unstable; urgency=low
32
33   * update applet signature (new code signing cert)
34
35  -- Proxmox Support Team <support@proxmox.com>  Fri, 25 Jul 2014 06:57:46 +0200
36
37 vncterm (1.1-7) unstable; urgency=low
38
39   *  new option -notls (for novnc)
40
41  -- Proxmox Support Team <support@proxmox.com>  Mon, 23 Jun 2014 13:30:50 +0200
42
43 vncterm (1.1-6) unstable; urgency=low
44
45   * set Caller-Allowable-Codebase and remove Trusted-Library. This avoids
46     security popups with latest Java 7u45. Also see:
47   
48     http://stackoverflow.com/questions/19393826/java-applet-manifest-allow-all-caller-allowable-codebase
49
50  -- Proxmox Support Team <support@proxmox.com>  Fri, 08 Nov 2013 11:27:08 +0100
51
52 vncterm (1.1-5) unstable; urgency=low
53
54   * use Comodo code sign cert for applet signature
55
56  -- Proxmox Support Team <support@proxmox.com>  Fri, 08 Nov 2013 08:35:10 +0100
57
58 vncterm (1.1-4) unstable; urgency=low
59
60   * Allow to add intermediate certificates to /etc/pve/local/pve-ssl.pem 
61   (users previously used apache option SSLCertificateChainFile for that).
62   
63  -- Proxmox Support Team <support@proxmox.com>  Mon, 03 Jun 2013 08:26:59 +0200
64
65 vncterm (1.1-3) unstable; urgency=low
66
67   *  re-enable javascript-events.patch (used for migrate/reload)
68
69  -- Proxmox Support Team <support@proxmox.com>  Fri, 10 May 2013 07:56:35 +0200
70
71 vncterm (1.1-2) unstable; urgency=low
72
73   * recompile VnCViewer.jar with openJDK
74   
75   * set trusted-lib to avoid security popup
76   
77   * disable unused javascript-events.patch
78
79  -- Proxmox Support Team <support@proxmox.com>  Sat, 20 Apr 2013 16:05:41 +0200
80
81 vncterm (1.1-1) unstable; urgency=low
82
83   * recompile for wheezy
84
85  -- Proxmox Support Team <support@proxmox.com>  Fri, 15 Mar 2013 08:26:04 +0100
86
87 vncterm (1.0-3) unstable; urgency=low
88
89   * fix focus traversal
90
91  -- Proxmox Support Team <support@proxmox.com>  Tue, 21 Aug 2012 09:14:04 +0200
92
93 vncterm (1.0-2) unstable; urgency=low
94
95   * do not create a new process group (with setsid), so
96   we can kill the whole pve task if used inside fork_worker().
97
98  -- Proxmox Support Team <support@proxmox.com>  Tue, 13 Sep 2011 10:49:32 +0200
99
100 vncterm (1.0-1) unstable; urgency=low
101
102   * use TigerVNC java sources
103   
104   * implement TLS encryption and vencrypt password auth
105   
106   * removed support for -passwdfile option
107
108  -- root <root@maui.maurer-it.com>  Mon, 24 Jan 2011 10:46:25 +0100
109
110 vncterm (0.9-2) unstable; urgency=low
111
112   * compiled for debian etch
113   
114   * use memmove instead of rfbDoCopyRect (avoid SIGSEGV when
115   called with negative dy)
116
117  -- Proxmox Support Team <support@proxmox.com>  Wed, 22 Apr 2009 10:02:08 +0200
118
119 vncterm (0.9-1) stable; urgency=low
120
121   * initial import
122
123  -- Proxmox Support Team <support@proxmox.com>  Thu, 27 Dec 2007 05:57:17 +0100
124