]> git.proxmox.com Git - rustc.git/blob - vendor/ui_test/shell.nix
New upstream version 1.75.0+dfsg1
[rustc.git] / vendor / ui_test / shell.nix
1 let
2 pkgs = import <nixpkgs> {};
3 in
4 pkgs.mkShell rec {
5 name = "rustc";
6 buildInputs = with pkgs; [
7 rustup
8 pkg-config
9 alsaLib
10 libGL
11 xorg.libX11
12 xorg.libXi
13 python39
14 ];
15 RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
16 LD_LIBRARY_PATH = "${pkgs.lib.makeLibraryPath buildInputs}";
17 }
18