]> git.proxmox.com Git - pve-eslint.git/blobdiff - debian/changelog
bump version to 8.23.1-1
[pve-eslint.git] / debian / changelog
index babe07150f67badbd3aaf1de0b4cf460bf9cd521..c344e3cd378d034e81d64159ce41c13194319906 100644 (file)
@@ -1,3 +1,518 @@
+pve-eslint (8.23.1-1) bullseye; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 8.23.1 upstream release
+  * remove polyfill plugin via webpack config patch
+
+  [ ESLint ]
+  * relevant changes since 8.4.0
+    + fix: Upgrade eslintrc to stop redefining plugins (#16297) (Brandon Mills)
+    + fix: improve autofix for the `prefer-const` rule (#16292) (Nitin Kumar)
+    + fix: Ensure that glob patterns are normalized (#16287) (Nicholas C. Zakas)
+    + perf: migrate rbTree to js-sdsl (#16267) (Zilong Yao)
+    + fix: Ensure globbing doesn't include subdirectories (#16272) (Nicholas C. Zakas)
+    + feat: Enable eslint.config.js lookup from CLI (#16235) (Nicholas C. Zakas)
+    + feat: add `allowEmptyCase` option to no-fallthrough rule (#15887) (Amaresh  S M)
+    + test: add no-extra-parens tests with rest properties (#16236) (Milos Djermanovic)
+    + refactor: simplify `parseListConfig` (#16241) (Milos Djermanovic)
+    + feat: no-warning-comments support comments with decoration (#16120) (Lachlan Hunt)
+    + feat: Implement caching for FlatESLint (#16190) (Nicholas C. Zakas)
+    + feat: add `methodsIgnorePattern` option to object-shorthand rule (#16185) (Milos Djermanovic)
+    + feat: Implement FlatESLint (#16149) (Nicholas C. Zakas)
+    + feat: improve the key width calculation in `key-spacing` rule (#16154) (Nitin Kumar)
+    + feat: add new `allowLineSeparatedGroups` option to the `sort-keys` rule (#16138) (Nitin Kumar)
+    + feat: add deprecation warnings for legacy API in `RuleTester` (#16063) (Nitin Kumar)
+    + fix: lines-around-comment apply `allowBlockStart` for switch statements (#16153) (Nitin Kumar)
+    + fix: no-warning-comments rule escapes special RegEx characters in terms (#16090) (Lachlan Hunt)
+    + feat: catch preprocess errors (#16105) (JounQin)
+    + fix: ignore spacing before `]` and `}` in comma-spacing (#16113) (Milos Djermanovic)
+    + feat: add importNames support for patterns in no-restricted-imports (#16059) (Brandon Scott)
+    + feat: fix handling of blockless `with` statements in indent rule (#16068) (Milos Djermanovic)
+    + fix: throw helpful exception when rule has wrong return type (#16075) (Bryan Mishkin)
+    + feat: account for rule creation time in performance reports (#15982) (Nitin Kumar)
+    + fix: Make no-unused-vars treat for..of loops same as for..in loops (#15868) (Alex Bass)
+    + feat: fix indent bug with semicolon-first style (#15951) (Milos Djermanovic)
+    + feat: add `allowNamedExports` option to no-use-before-define (#15953) (Milos Djermanovic)
+    + test: cleanup typos (#15937) (Nick Schonning)
+    + fix: cleanup typos (#15939) (Nick Schonning)
+    + fix: typo ocatal -> octal (#15940) (Nick Schonning)
+    + test: ensure no-restricted-imports works with NodeJS imports (#15907) (Nick Mazuk)
+    + feat: add Unicode flag suggestion in no-misleading-character-class (#15867) (Milos Djermanovic)
+    + feat: check Unicode code point escapes in no-control-regex (#15862) (Milos Djermanovic)
+    + feat: Update global variables (#15871) (Sébastien Règne)
+    + fix: function-paren-newline crash on "new new Foo();" (#15850) (coderaiser)
+    + fix: "use strict" should not trigger strict mode in ES3 (#15846) (Milos Djermanovic)
+    + feat: add `enforceInClassFields` option to no-underscore-dangle (#15818) (Roberto Cestari)
+    + fix: allow project paths to have URL-encoded characters (#15795) (Milos Djermanovic)
+    + feat: Add rule no-constant-binary-expression (#15296) (Jordan Eldredge)
+    + fix: update `astUtils.isDirectiveComment` with `globals` and `exported` (#15775) (Milos Djermanovic)
+    + feat: fix no-eval logic for `this` in arrow functions (#15755) (Milos Djermanovic)
+    + fix: invalid operator in operator-assignment messages (#15759) (Milos Djermanovic)
+    + feat: fix logic for top-level `this` in no-invalid-this and no-eval (#15712) (Milos Djermanovic)
+    + fix: escaping for square brackets in ignore patterns (#15666) (Milos Djermanovic)
+    + feat: add `destructuredArrayIgnorePattern` option in `no-unused-vars` (#15649) (Nitin Kumar)
+    + feat: Catch `undefined` and `Boolean()` in no-constant-condition (#15613) (Jordan Eldredge)
+    + feat: Add ESLint favicon to the HTML report document (#15671) (Mahdi Hosseinzadeh)
+    + feat: `valid-typeof` always ban `undefined` (#15635) (Zzzen)
+    + fix: extend the autofix range in comma-dangle to ensure the last element (#15669) (Milos Djermanovic)
+    + fix: Avoid `__dirname` for built-in configs (#15616) (DoZerg)
+    + feat: Add `ignoreOnInitialization` option to no-shadow rule (#14963) (Soufiane Boutahlil)
+    + feat: `--debug` prints time it takes to parse a file (#15609) (Bartek Iwańczuk)
+    + feat: Add `onlyOneSimpleParam` option to no-confusing-arrow rule (#15566) (Gautam Arora)
+    + test: add integration tests with built-in configs (#15612) (Milos Djermanovic)
+    + perf: fix lazy loading of core rules (#15606) (Milos Djermanovic)
+    + fix: false positive in `camelcase` with combined properties (#15581) (Nitin Kumar)
+    + feat: update eslint-scope to ignore `"use strict"` directives in ES3 (#15595) (Milos Djermanovic)
+    + feat: add `es2016`, `es2018`, `es2019`, and `es2022` environments (#15587) (Milos Djermanovic)
+    + feat: fix bug with arrow function return types in function-paren-newline (#15541) (Milos Djermanovic)
+    + feat: Implement FlatRuleTester (#15519) (Nicholas C. Zakas)
+    + feat: implement rfc 2021-suppression-support (#15459) (Yiwei Ding)
+    + fix: no-invalid-this false positive in class field initializer (#15495) (Milos Djermanovic)
+    + feat: no-restricted-imports support casing (#15439) (gfyoung)
+    + fix: Correctly consume RuleTester statics (#15507) (Brad Zacher)
+    + fix: Add property `fatalErrorCount` to ignored file results (#15520) (Francesco Trotta)
+    + fix: Prevent false positives with no-constant-condition (#15486) (Jordan Eldredge)
+    + feat: Support arbitrary module namespace names in no-restricted-imports (#15491) (Milos Djermanovic)
+    + feat: Support arbitrary module namespace names in no-useless-rename (#15493) (Milos Djermanovic)
+    + feat: move `eslint --init` to @eslint/create-config (#15150) (唯然)
+    + feat: false negative with `property` option in `id-match` (#15474) (Nitin Kumar)
+    + feat: Support arbitrary module namespace names in the camelcase rule (#15490) (Milos Djermanovic)
+    + feat: Support arbitrary module namespace names in the quotes rule (#15479) (Milos Djermanovic)
+    + feat: Support arbitrary module namespace names in keyword-spacing (#15481) (Milos Djermanovic)
+    + feat: Support arbitrary module namespace names in no-restricted-exports (#15478) (Milos Djermanovic)
+    + feat: handle logical assignment in no-self-assign (#14152) (Zzzen)
+    + feat: allow to define `eslint-disable-next-line` in multiple lines (#15436) (Nitin Kumar)
+    + refactor: remove unused parameter in `linter.js` (#15451) (Milos Djermanovic)
+    + test: add tests for `allowReserved` parser option with flat config (#15450) (Milos Djermanovic)
+    + feat: false negative with `onlyDeclarations` + `properties` in id-match (#15431) (Nitin Kumar)
+    + fix: improve `prefer-template` fixer (#15230) (Nitin Kumar)
+    + feat: Suggestions support for `prefer-regex-literals` (#15077) (Yash Singh)
+    + fix: do not report global references in `id-match` rule (#15420) (Nitin Kumar)
+    + test: add destructuring test cases for `computed-property-spacing` (#15424) (Nitin Kumar)
+    + fix: improve autofix of `prefer-object-has-own` (#15419) (Nitin Kumar)
+    + fix: add helpful message when test case has non-string code/name (#15425) (Bryan Mishkin)
+    + feat: add `prefer-object-has-own` rule (#15346) (Nitin Kumar)
+    + fix: revert changes to reported locations in max-lines-per-function (#15397) (Milos Djermanovic)
+
+ -- Proxmox Support Team <support@proxmox.com>  Thu, 15 Sep 2022 11:28:52 +0200
+
+pve-eslint (8.4.0-3) bullseye; urgency=medium
+
+  * switch from es2020 to es2021 as standard ecma script version to enforce
+
+ -- Proxmox Support Team <support@proxmox.com>  Tue, 26 Apr 2022 11:11:42 +0200
+
+pve-eslint (8.4.0-2) bullseye; urgency=medium
+
+  * repair `--fix` CLI option
+
+ -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Dec 2021 13:18:14 +0100
+
+pve-eslint (8.4.0-1) bullseye; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 8.4.0 upstream release
+  * change from depreacated CLIEngine module to ESLint one
+
+  [ ESLint ]
+  * relevant changes since 8.3.0
+    + feat: add `allowReserved` parser option (#15387) (Milos Djermanovic)
+    + feat: Flat config support in Linter (refs #13481) (#15185) (Nicholas C. Zakas)
+    + feat: Treat Class/New Expressions as truthy in no-constant-condition (#15326) (Jordan Eldredge)
+    + feat: report only lines that exceed the limit in max-lines-per-function (#15140) (Sneh Khatri)
+    + feat: pass cwd to formatters (refs eslint/rfcs#57) (#13392) (Toru Nagashima)
+    + fix: mark --rulesdir option as deprecated in CLI docs (#15310) (Kevin Partington)
+    + feat: support async formatters (#15243) (MO)
+
+ -- Proxmox Support Team <support@proxmox.com>  Mon, 06 Dec 2021 14:12:21 +0100
+
+pve-eslint (8.3.0-1) bullseye; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 8.3.0 upstream release
+
+  [ ESLint ]
+  * relevant changes since 7.28.0
+    + feat: add `allowReserved` parser option (#15387) (Milos Djermanovic)
+    + feat: Flat config support in Linter (refs #13481) (#15185) (Nicholas C. Zakas)
+    + feat: Treat Class/New Expressions as truthy in no-constant-condition (#15326) (Jordan Eldredge)
+    + feat: report only lines that exceed the limit in max-lines-per-function (#15140) (Sneh Khatri)
+    + feat: pass cwd to formatters (refs eslint/rfcs#57) (#13392) (Toru Nagashima)
+    + fix: mark --rulesdir option as deprecated in CLI docs (#15310) (Kevin Partington)
+    + feat: support async formatters (#15243) (MO)
+    + feat: add `allowProperties` option to require-atomic-updates (#15238) (Milos Djermanovic)
+    + feat: update no-use-before-define for class static blocks (#15312) (Milos Djermanovic)
+    + fix: update vars-on-top for class static blocks (#15306) (Milos Djermanovic)
+    + fix: update semi-style for class static blocks (#15309) (Milos Djermanovic)
+    + feat: update no-redeclare for class static blocks (#15313) (Milos Djermanovic)
+    + feat: update no-inner-declarations for class static blocks (#15290) (Milos Djermanovic)
+    + feat: support for private-in syntax (fixes #14811) (#15060) (Yosuke Ota)
+    + feat: Update espree and eslint-scope (#15338) (Brandon Mills)
+    + feat: update max-depth for class static blocks (#15316) (Milos Djermanovic)
+    + feat: update padded-blocks for class static blocks (#15333) (Milos Djermanovic)
+    + feat: update the complexity rule for class static blocks (#15328) (Milos Djermanovic)
+    + feat: update the indent rule for class static blocks (#15324) (Milos Djermanovic)
+    + feat: update lines-around-comment for class static blocks (#15323) (Milos Djermanovic)
+    + feat: update brace-style for class static blocks (#15322) (Milos Djermanovic)
+    + feat: update max-statements for class static blocks (#15315) (Milos Djermanovic)
+    + feat: update prefer-const for class static blocks (#15325) (Milos Djermanovic)
+    + feat: code path analysis for class static blocks (#15282) (Milos Djermanovic)
+    + feat: update eslint-scope for class static blocks (#15321) (Milos Djermanovic)
+    + feat: update one-var for class static blocks (#15317) (Milos Djermanovic)
+    + feat: update padding-line-between-statements for class static blocks (#15318) (Milos Djermanovic)
+    + fix: update no-invalid-this and no-eval for class static blocks (#15300) (Milos Djermanovic)
+    + feat: update class-methods-use-this for class static blocks (#15298) (Milos Djermanovic)
+    + feat: update no-lone-blocks for class static blocks (#15295) (Milos Djermanovic)
+    + feat: update block-spacing for class static blocks (#15297) (Milos Djermanovic)
+    + feat: update keyword-spacing for class static blocks (#15289) (Milos Djermanovic)
+    + feat: update no-extra-semi for class static blocks (#15287) (Milos Djermanovic)
+    + feat: update semi rule for class static blocks (#15286) (Milos Djermanovic)
+    + feat: add examples for block-scoped-var with class static blocks (#15302) (Milos Djermanovic)
+    + feat: Normalize ecmaVersion to eslint-scope when using custom parser (#15268) (Yosuke Ota)
+    + feat: report class evaluation TDZ errors in no-use-before-define (#15134) (Milos Djermanovic)
+    + perf: don't prepare a fix for valid code in key-spacing (#15239) (Milos Djermanovic)
+    + Fix: keyword-spacing conflict with space-infix-ops on `>` (fixes #14712) (#15172) (Milos Djermanovic)
+    + Fix: allow `baseConfig` to extend preloaded plugin config (fixes #15079) (#15187) (Milos Djermanovic)
+    + New: Add no-unused-private-class-members rule (fixes #14859) (#14895) (Tim van der Lippe)
+    + New: Add name to RuleTester (#15179) (Gareth Jones)
+    + Upgrade: `eslint-plugin-eslint-plugin` to v4 (#15169) (Bryan Mishkin)
+    + Upgrade: @eslint/eslintrc@1.0.3 for Jest workaround (#15164) (Brandon Mills)
+    + Upgrade: unfrozen @eslint/eslintrc (fixes #15036) (#15146) (Brandon Mills)
+    + Fix: require-atomic-updates property assignment message (fixes #15076) (#15109) (Milos Djermanovic)
+    + Update: Suggest missing rule in flat config (fixes #14027) (#15074) (Nicholas C. Zakas)
+    + Update: space-before-blocks ignore after switch colons (fixes #15082) (#15093) (Milos Djermanovic)
+    + Fix: preserve formatting when rules are removed from disable directives (#15081) (Milos Djermanovic)
+    + Update: `no-new-func` rule catching eval case of `MemberExpression` (#14860) (Mojtaba Samimi)
+    + Update: include `ruleId` in error logs (fixes #15037) (#15053) (Ari Perkkiö)
+    + Upgrade: @eslint/eslintrc@1.0.1 (#15047) (Milos Djermanovic)
+    + Breaking: Disallow reserved words in ES3 (fixes #15017) (#15046) (Milos Djermanovic)
+    + Update: support class fields in the `complexity` rule (refs #14857) (#14957) (Milos Djermanovic)
+    + Fix: semicolon-less style in lines-between-class-members (refs #14857) (#15045) (Milos Djermanovic)
+    + Update: enforceForClassFields in class-methods-use-this (refs #14857) (#15018) (YeonJuan)
+    + Fix: Update semi for class-fields (refs #14857) (#14945) (Nicholas C. Zakas)
+    + Update: added ignoreExpressions option to max-classes-per-file (#15000) (Josh Goldberg)
+    + Fix: no-undef-init should not apply to class fields (refs #14857) (#14994) (Milos Djermanovic)
+    + Update: Code path analysis for class fields (fixes #14343) (#14886) (Nicholas C. Zakas)
+    + Update: support class fields in func-name-matching (refs #14857) (#14964) (Milos Djermanovic)
+    + Breaking: remove meta.docs.category in core rules (fixes #13398) (#14594) (薛定谔的猫)
+    + Fix: camelcase ignoreGlobals shouldn't apply to undef vars (refs #14857) (#14966) (Milos Djermanovic)
+    + Update: reporting loc for `never` option in `eol-last` (refs #12334) (#14840) (Nitin Kumar)
+    + Update: fix no-unused-vars false negative with comma operator (#14928) (Sachin)
+    + Update: fix no-unreachable logic for class fields (refs #14857) (#14920) (Milos Djermanovic)
+    + Fix: keyword-spacing private name compat (refs #14857) (#14946) (Nicholas C. Zakas)
+    + Upgrade: @eslint/eslintrc@1.0.0 (#14865) (Milos Djermanovic)
+    + Fix: handle computed class fields in operator-linebreak (refs #14857) (#14915) (Milos Djermanovic)
+    + Upgrade: Debug 4.0.1 > 4.3.2 (#14892) (sandesh bafna)
+    + Fix: no-useless-computed-key edge cases with class fields (refs #14857) (#14903) (Milos Djermanovic)
+    + Upgrade: `js-yaml` to v4 (#14890) (Bryan Mishkin)
+    + Fix: prefer-destructuring PrivateIdentifier false positive (refs #14857) (#14897) (Milos Djermanovic)
+    + Fix: dot-notation false positive with private identifier (refs #14857) (#14898) (Milos Djermanovic)
+    + Update: check class fields in no-extra-parens (refs #14857) (#14906) (Milos Djermanovic)
+    + Upgrade: `eslint-visitor-keys` to v3 (#14902) (Bryan Mishkin)
+    + Upgrade: `markdownlint` dev dependencies (#14883) (Bryan Mishkin)
+    + Upgrade: @humanwhocodes/config-array to 0.6 (#14891) (Bryan Mishkin)
+    + Breaking: Strict package exports (refs #13654) (#14706) (Nicholas C. Zakas)
+    + Breaking: disallow SourceCode#getComments() in RuleTester (refs #14744) (#14769) (Milos Djermanovic)
+    + Breaking: Fixable disable directives (fixes #11815) (#14617) (Josh Goldberg)
+    + Breaking: require `meta` for fixable rules (fixes #13349) (#14634) (Milos Djermanovic)
+    + Breaking: Require `meta.hasSuggestions` for rules with suggestions (#14573) (Bryan Mishkin)
+    + Breaking: support new regex d flag (fixes #14640) (#14653) (Yosuke Ota)
+    + Breaking: fix comma-dangle schema (fixes #13739) (#14030) (Joakim Nilsson)
+    + Breaking: upgrade espree and support new class features (refs #14343) (#14591) (Toru Nagashima)
+    + Breaking: add some rules to eslint:recommended (refs #14673) (#14691) (薛定谔的猫)
+    + Breaking: Drop `codeframe` and `table` formatters (#14316) (Federico Brigante)
+    + Breaking: drop node v10/v13/v15 (fixes #14023) (#14592) (薛定谔的猫)
+    + Update: Suggest missing rule in flat config (fixes #14027) (#15074) (Nicholas C. Zakas)
+    + Update: space-before-blocks ignore after switch colons (fixes #15082) (#15093) (Milos Djermanovic)
+    + Fix: preserve formatting when rules are removed from disable directives (#15081) (Milos Djermanovic)
+    + Update: `no-new-func` rule catching eval case of `MemberExpression` (#14860) (Mojtaba Samimi)
+    + Update: include `ruleId` in error logs (fixes #15037) (#15053) (Ari Perkkiö)
+    + Upgrade: @eslint/eslintrc@1.0.1 (#15047) (Milos Djermanovic)
+    + Breaking: Disallow reserved words in ES3 (fixes #15017) (#15046) (Milos Djermanovic)
+    + Update: support class fields in the `complexity` rule (refs #14857) (#14957) (Milos Djermanovic)
+    + Fix: semicolon-less style in lines-between-class-members (refs #14857) (#15045) (Milos Djermanovic)
+    + Update: enforceForClassFields in class-methods-use-this (refs #14857) (#15018) (YeonJuan)
+    + Fix: Update semi for class-fields (refs #14857) (#14945) (Nicholas C. Zakas)
+    + Update: added ignoreExpressions option to max-classes-per-file (#15000) (Josh Goldberg)
+    + Fix: no-undef-init should not apply to class fields (refs #14857) (#14994) (Milos Djermanovic)
+    + Revert "allow all directives in line comments" (fixes #14960) (#14973) (薛定谔的猫)
+    + Update: Code path analysis for class fields (fixes #14343) (#14886) (Nicholas C. Zakas)
+    + Update: support class fields in func-name-matching (refs #14857) (#14964) (Milos Djermanovic)
+    + Breaking: remove meta.docs.category in core rules (fixes #13398) (#14594) (薛定谔的猫)
+    + Fix: camelcase ignoreGlobals shouldn't apply to undef vars (refs #14857) (#14966) (Milos Djermanovic)
+    + Update: reporting loc for `never` option in `eol-last` (refs #12334) (#14840) (Nitin Kumar)
+    + Update: fix no-unused-vars false negative with comma operator (#14928) (Sachin)
+    + Update: fix no-unreachable logic for class fields (refs #14857) (#14920) (Milos Djermanovic)
+    + Fix: keyword-spacing private name compat (refs #14857) (#14946) (Nicholas C. Zakas)
+    + Upgrade: @eslint/eslintrc@1.0.0 (#14865) (Milos Djermanovic)
+    + Fix: handle computed class fields in operator-linebreak (refs #14857) (#14915) (Milos Djermanovic)
+    + Upgrade: Debug 4.0.1 > 4.3.2 (#14892) (sandesh bafna)
+    + Fix: no-useless-computed-key edge cases with class fields (refs #14857) (#14903) (Milos Djermanovic)
+    + Upgrade: `js-yaml` to v4 (#14890) (Bryan Mishkin)
+    + Fix: prefer-destructuring PrivateIdentifier false positive (refs #14857) (#14897) (Milos Djermanovic)
+    + Fix: dot-notation false positive with private identifier (refs #14857) (#14898) (Milos Djermanovic)
+    + Update: check class fields in no-extra-parens (refs #14857) (#14906) (Milos Djermanovic)
+    + Upgrade: `eslint-visitor-keys` to v3 (#14902) (Bryan Mishkin)
+    + Upgrade: `markdownlint` dev dependencies (#14883) (Bryan Mishkin)
+    + Upgrade: @humanwhocodes/config-array to 0.6 (#14891) (Bryan Mishkin)
+    + Breaking: Strict package exports (refs #13654) (#14706) (Nicholas C. Zakas)
+    + Breaking: disallow SourceCode#getComments() in RuleTester (refs #14744) (#14769) (Milos Djermanovic)
+    + Breaking: Fixable disable directives (fixes #11815) (#14617) (Josh Goldberg)
+    + Breaking: require `meta` for fixable rules (fixes #13349) (#14634) (Milos Djermanovic)
+    + Breaking: Require `meta.hasSuggestions` for rules with suggestions (#14573) (Bryan Mishkin)
+    + Breaking: allow all directives in line comments (fixes #14575) (#14656) (薛定谔的猫)
+    + Breaking: support new regex d flag (fixes #14640) (#14653) (Yosuke Ota)
+    + Breaking: fix comma-dangle schema (fixes #13739) (#14030) (Joakim Nilsson)
+    + Breaking: upgrade espree and support new class features (refs #14343) (#14591) (Toru Nagashima)
+    + Breaking: add some rules to eslint:recommended (refs #14673) (#14691) (薛定谔的猫)
+    + Breaking: Drop `codeframe` and `table` formatters (#14316) (Federico Brigante)
+    + Breaking: drop node v10/v13/v15 (fixes #14023) (#14592) (薛定谔的猫)
+    + Update: change reporting location for `curly` rule (refs #12334) (#14766) (Nitin Kumar)
+    + Fix: ignore lines with empty elements (fixes #12756) (#14837) (Soufiane Boutahlil)
+    + New: Exit on fatal error (fixes #13711) (#14730) (Antonios Katopodis)
+    + Upgrade: @eslint/eslintrc to v0.4.3 (#14808) (Brandon Mills)
+    + Update: add end location to report in `consistent-return` (refs #12334) (#14798) (Nitin Kumar)
+    + Update: Indicating the operator in question (#14764) (Paul Smith)
+    + Update: Clarifying what changes need to be made in no-mixed-operators (#14765) (Paul Smith)
+    + Update: ecmaVersion allows "latest" (#14720) (薛定谔的猫)
+    + Update: improve use-isnan rule to detect `Number.NaN` (fixes #14715) (#14718) (Nitin Kumar)
+    + Update: Implement FlatConfigArray (refs #13481) (#14321) (Nicholas C. Zakas)
+    + New: Add only to RuleTester (refs eslint/rfcs#73) (#14677) (Brandon Mills)
+    + New: Add ESLint#getRulesMetaForResults() (refs #13654) (#14716) (Nicholas C. Zakas)
+    + Fix: allow fallthrough comment inside block (fixes #14701) (#14702) (Kevin Gibbons)
+
+ -- Proxmox Support Team <support@proxmox.com>  Wed, 01 Dec 2021 13:44:36 +0100
+
+pve-eslint (7.28.0-1) unstable; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 7.28.0 upstream release
+  * switch from ECMA script 2018 to 2020, allowing use of optional chaining
+    operator (?.), nullish coalescing operator (??) Promise.allSettled helper,
+    flat / flatMap for Arrays, Object.fromEntries, String trimming, BigInt and
+    matchAll on Strings.
+
+  [ ESLint ]
+  * relevant changes since 7.18.0
+    + Upgrade: @eslint/eslintrc to 0.4.2 (#14672) (Milos Djermanovic)
+    + Update: support multiline /*eslint-env*/ directives (fixes #14652) (#14660) (薛定谔的猫)
+    + Upgrade: glob-parent version in package.json (#14658) (Hamza Najeeb)
+    + Fix: no-implicit-coercion false positive with `String()` (fixes #14623) (#14641) (Milos Djermanovic)
+    + Fix: no-duplicate-imports allow unmergeable (fixes #12758, fixes #12760) (#14238) (Soufiane Boutahlil)
+    + New: add `getPhysicalFilename()` method to rule context (fixes #11989) (#14616) (Nitin Kumar)
+    + Fix: arrow-body-style crash with object pattern (fixes #14633) (#14635) (Milos Djermanovic)
+    + Update: no-unused-vars false negative with comma operator (fixes #14325) (#14354) (Nitin Kumar)
+    + Update: no-restricted-imports custom message for patterns (fixes #11843) (#14580) (Alex Holden)
+    + Upgrade: eslintrc for ModuleResolver fix (#14577) (Brandon Mills)
+    + Fix: track variables, not names in require-atomic-updates (fixes #14208) (#14282) (Patrick Ahmetovic)
+    + Fix: create `.eslintrc.cjs` for `module` type (#14304) (Nitin Kumar)
+    + Update: Add automated suggestion to `radix` rule for parsing decimals (#14291) (Bryan Mishkin)
+    + New: Include XO style guide in `eslint --init` (#14193) (Federico Brigante)
+    + Update: highlight last write reference for no-unused-vars (fixes #14324) (#14335) (Nitin Kumar)
+    + Update: lint code block with same extension but different content (#14227) (JounQin)
+    + Update: Add disallowTemplateShorthand option in no-implicit-coercion (#13579) (Remco Haszing)
+    + Fix: no-unused-vars ignoreRestSiblings check assignments (fixes #14163) (#14264) (YeonJuan)
+    + Update: add ignoreNonDeclaration to no-multi-assign rule (fixes #12545) (#14185) (t-mangoe)
+    + Update: add option "allowInParentheses" to no-sequences (fixes #14197) (#14199) (Daniel Rentz)
+    + Update: `--quiet` should not supress `--max-warnings` (fixes #14202) (#14242) (Milos Djermanovic)
+    + Fix: no-mixed-operators false positives with `? :` (fixes #14223) (#14226) (Milos Djermanovic)
+    + Fix: Clarify line breaks in object-curly-newline (fixes #14024) (#14063) (armin yahya)
+    + Update: eslint --env-info output os info (#14059) (薛定谔的猫)
+    + Update: throw error when fix range is invalid (#14142) (Jacob Bandes-Storch)
+    + Upgrade: Update lodash in package.json to V 4.17.21 (#14159) (Basem Al-Nabulsi)
+    + Update: report es2021 globals in no-extend-native (refs #13602) (#14177) (Milos Djermanovic)
+    + Upgrade: @eslint/eslintrc to 0.4.0 (#14147) (Brandon Mills)
+    + Upgrade: Puppeteer to 7.1.0 (#14122) (Tim van der Lippe)
+    + New: Implement cacheStrategy (refs eslint/rfcs#63) (#14119) (Manu Chambon)
+    + Update: do not ignore symbolic links (fixes #13551, fixes #13615) (#14126) (Pig Fang)
+    + Fix: pluralize 'line' to 'lines' in max-lines-per-function description (#14115) (Trevin Hofmann)
+    + Fix: Crash with esquery when using JSX (fixes #13639) (#14072) (Yosuke Ota)
+    + Update: add enforceForJSX option to no-unused-expressions rule (#14012) (Duncan Beevers)
+    + Fix: `--init` autoconfig shouldn't add deprecated rules (fixes #14017) (#14060) (Milos Djermanovic)
+    + Fix: Support ENOTDIR error code in the folder existence checking utility (#13973) (Constantine Genchevsky)
+    + Upgrade: pin @babel/code-frame@7.12.11 (#14067) (Milos Djermanovic)
+    + Build: package.json update for eslint-config-eslint release (ESLint Jenkins)
+    + Update: add shadowed variable loc to message in no-shadow (fixes #13646) (#13841) (t-mangoe)
+    + Update: fix `let` logic in for-in and for-of loops in no-extra-parens (#14011) (Milos Djermanovic)
+    + Fix: no-useless-rename invalid autofix with parenthesized identifiers (#14032) (Milos Djermanovic)
+    + Fix: nested indenting for offsetTernaryExpressions: true (fixes #13971) (#13972) (Chris Brody)
+    + Update: check ternary `:` even if `?` was reported in space-infix-ops (#13963) (Milos Djermanovic)
+    + Fix: extend prefer-const fixer range to whole declaration (fixes #13899) (#14033) (Nitin Kumar)
+    + Update: fix no-invalid-regexp false negatives with no flags specified (#14018) (Milos Djermanovic)
+
+ -- Proxmox Support Team <support@proxmox.com>  Wed, 09 Jun 2021 16:37:05 +0200
+
+pve-eslint (7.18.0-1) unstable; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 7.18.0 upstream release
+  * switch from ECMA script 2017 to 2018, allowing use of spread operator,
+    async iteration, final prototype for Promise and some RegExp features
+
+  [ ESLint ]
+  * relevant changes since 7.12.1
+    + Upgrade: @eslint/eslintrc to improve error message for invalid extends (#14009) (Milos Djermanovic)
+    + Update: check logical assignment operators in the complexity rule (#13979) (Milos Djermanovic)
+    + Fix: --init crash on question to upgrade/downgrade ESLint (fixes #13978) (#13995) (Milos Djermanovic)
+    + Fix: no-extra-parens false positive with `let` identifier in for-loop (#13981) (Milos Djermanovic)
+    + Upgrade: Bump lodash to fix security issue (#13993) (Frederik Prijck)
+    + Update: check logical assignment in no-constant-condition (#13946) (Milos Djermanovic)
+    + Update: use regexpp's default ecmaVersion in no-control-regex (#13969) (Milos Djermanovic)
+    + Fix: use regexpp's default ecmaVersion in no-invalid-regexp (#13968) (Milos Djermanovic)
+    + Update: add autofix to rule multiline-ternary (#13958) (薛定谔的猫)
+    + Fix: no-useless-escape wrong loc and fix with CRLF in template elements (#13953) (Milos Djermanovic)
+    + Fix: one-var shouldn't split declaration if it isn't in a statement list (#13959) (Milos Djermanovic)
+    + Update: fix false negative of no-extra-parens with NewExpression (#13930) (Milos Djermanovic)
+    + Fix: require-atomic-updates false positive across await (fixes #11954) (#13915) (buhi)
+    + Fix: no-constant-condition false positives with unary expressions (#13927) (Milos Djermanovic)
+    + Fix: false positive with await and ** in no-extra-parens (fixes #12739) (#13923) (Milos Djermanovic)
+    + Upgrade: table@6.0.4 (#13920) (Rouven Weßling)
+    + Fix: prefer-exponentiation-operator invalid autofix with await (#13924) (Milos Djermanovic)
+    + Upgrade: @eslint/esintrc and espree for bug fixes (refs #13878) (#13908) (Brandon Mills)
+    + Upgrade: file-entry-cache@6.0.0 (#13877) (Rouven Weßling)
+    + New: no-unsafe-optional-chaining rule (fixes #13431) (#13859) (YeonJuan)
+    + Fix: one-var autofixing for export (fixes #13834) (#13891) (Anix)
+    + Update: fix 'skip' options in no-irregular-whitespace (fixes #13852) (#13853) (Milos Djermanovic)
+    + New: Add no-nonoctal-decimal-escape rule (fixes #13765) (#13845) (Milos Djermanovic)
+    + Fix: enable debug logs for @eslint/eslintrc (fixes #13850) (#13861) (Milos Djermanovic)
+    + Fix: no-useless-constructor crash on bodyless constructor (fixes #13830) (#13842) (Ari Perkkiö)
+    + New: Configurable List Size For Per-Rule Performance Metrics (#13812) (Bryan Mishkin)
+
+ -- Proxmox Support Team <support@proxmox.com>  Tue, 19 Jan 2021 17:07:51 +0100
+
+pve-eslint (7.12.1-1) unstable; urgency=medium
+
+  [ Proxmox Support Team ]
+  * update to 7.12.1 release
+  * add strict mode, for exiting also uncleanly on warnings
+
+  [ ESLint ]
+  * relevant changes since 7.2.0
+    + Upgrade: @eslint/eslintrc to fix rule schema validation (fixes #13793) (#13794) (Brandon Mills)
+    + Fix: Pass internal config paths in FileEnumerator default (fixes #13789) (#13792) (Brandon Mills)
+    + Update: skip keyword check for fns in space-before-blocks (fixes #13553) (#13712) (Milos Djermanovic)
+    + Fix: autofix shouldn't produce template literals with `\8` or `\9` (#13737) (Milos Djermanovic)
+    + Fix: yoda rule autofix produces syntax errors with adjacent tokens (#13760) (Milos Djermanovic)
+    + Fix: prefer-destructuring invalid autofix with comma operator (#13761) (Milos Djermanovic)
+    + Update: remove suggestion if it didn't provide a fix (fixes #13723) (#13772) (Milos Djermanovic)
+    + Update: check template literal in no-script-url (#13775) (YeonJuan)
+    + Update: treat all literals like boolean literal in no-constant-condition (#13245) (Zen)
+    + Update: Fix && vs || short-circuiting false negatives (fixes #13634) (#13769) (Brandon Mills)
+    + Update: check computed keys in no-prototype-builtins (fixes #13088) (#13755) (Milos Djermanovic)
+    + Fix: don't count line after EOF in max-lines (#13735) (Milos Djermanovic)
+    + Upgrade: eslint-visitor-keys@2.0.0 (#13732) (Milos Djermanovic)
+    + Fix: account for linebreaks before postfix `++`/`--` in no-extra-parens (#13731) (Milos Djermanovic)
+    + Update: support async arrow fn in function-paren-newline (fixes #13728) (#13729) (Michal Dziekonski)
+    + Update: Add ignorePattern to no-inline-comments (#13029) (Edie Lemoine)
+    + Fix: prefer-destructuring invalid autofix with computed property access (#13704) (Milos Djermanovic)
+    + Upgrade: eslint-scope@5.1.1 (#13716) (Milos Djermanovic)
+    + Fix: Corrected notice for invalid (:) plugin names (#13473) (Josh Goldberg)
+    + Fix: prefer-destructuring removes comments (refs #13678) (#13682) (Milos Djermanovic)
+    + Update: fix id-length false negatives on Object.prototype property names (#13670) (Milos Djermanovic)
+    + Fix: NonOctalDecimalIntegerLiteral is decimal integer (fixes #13588) (#13664) (Milos Djermanovic)
+    + Fix: Update broken @eslint/eslintrc version (fixes #13641) (#13647) (Nicholas C. Zakas)
+    + Update: support logical assignments in code path analysis (refs #13569) (#13612) (Milos Djermanovic)
+    + Update: support logical assignments in core rules (refs #13569) (#13618) (Milos Djermanovic)
+    + Update: add es2021 environment (refs #13602) (#13603) (Milos Djermanovic)
+    + Update: support numeric separators (refs #13568) (#13581) (Milos Djermanovic)
+    + Update: Add exceptionPatterns to id-length rule (fixes #13094) (#13576) (sodam)
+    + Update: support numeric-separator in no-loss-of-precision (refs #13568) (#13574) (Anix)
+    + Update: add comment to message in no-warning-comments (fixes #12327) (#13522) (Anix)
+    + Upgrade: espree@7.3.0 (refs #13568) (#13609) (Kai Cataldo)
+    + Update: Add no-magic-numbers 'ignoreDefaultValues' option (#12611) (Dieter Luypaert)
+    + Update: allowFunctionParams option in no-underscore-dangle (fixes 12579) (#13545) (Sunghyun Cho)
+    + Fix: revert "Update: disallow multiple options in comma-dangle schema" (#13564) (Kai Cataldo)
+    + Fix: indent for async arrow functions (fixes #13497) (#13544) (Anix)
+    + Update: require `meta` for fixable rules in RuleTester (refs #13349) (#13489) (Milos Djermanovic)
+    + Fix: Do not output `undefined` as line and column when it's unavailable (#13519) (haya14busa)
+    + Fix: Update the chatroom link to go directly to help channel (#13536) (Nicholas C. Zakas)
+    + Update: Change no-duplicate-case to comparing tokens (fixes #13485) (#13494) (Yosuke Ota)
+    + Update: optional chaining support (fixes #12642) (#13416) (Toru Nagashima)
+    + Upgrade: lodash@4.17.19 (#13499) (Yohan Siguret)
+    + Update: deprecate id-blacklist rule (#13465) (Dimitri Mitropoulos)
+    + Update: Improve report location no-irregular-whitespace (refs #12334) (#13462) (Milos Djermanovic)
+    + Build: update webpack resolve.mainFields to match website config (#13457) (Milos Djermanovic)
+    + Fix: arrow-body-style fixer for `in` wrap (fixes #11849) (#13228) (Anix)
+    + Upgrade: Updated puppeteer version to v4.0.0 (#13444) (odidev)
+    + Update: add allowSeparatedGroups option to sort-imports (fixes #12951) (#13455) (Milos Djermanovic)
+    + Update: Improve report location for no-unneeded-ternary (refs #12334) (#13456) (Milos Djermanovic)
+    + Update: Improve report location for max-len (refs #12334) (#13458) (Milos Djermanovic)
+    + Fix: add end location to reports in object-curly-newline (refs #12334) (#13460) (Milos Djermanovic)
+    + Fix: add end location to reports in keyword-spacing (refs #12334) (#13461) (Milos Djermanovic)
+    + Fix: support typescript generics in arrow-parens (fixes #12570) (#13451) (Milos Djermanovic)
+    + Fix: Revert config cloning (fixes #13447) (#13449) (薛定谔的猫)
+    + Update: Improve array-callback-return report message (#13395) (Philip (flip) Kromer)
+    + Fix: false positive new with member in no-extra-parens (fixes #12740) (#13375) (YeonJuan)
+    + Fix: Clarify documentation on implicit ignore behavior (fixes #12348) (#12600) (Scott Hardin)
+    + Update: Add option "ignoreGlobals" to camelcase rule (fixes #11716) (#12782) (David Gasperoni)
+    + Update: improve report location in arrow-body-style (refs #12334) (#13424) (YeonJuan)
+    + Update: prefer-regex-literal detect regex literals (fixes #12840) (#12842) (Mathias Schreck)
+    + Update: rename id-blacklist to id-denylist (fixes #13407) (#13408) (Kai Cataldo)
+    + Fix: Replace Infinity with Number.MAX_SAFE_INTEGER (fixes #13427) (#13435) (Nicholas C. Zakas)
+    + Update: add missing `additionalProperties: false` to some rules' schema (#13198) (Milos Djermanovic)
+    + Update: fix operator-linebreak overrides schema (#13199) (Milos Djermanovic)
+    + New: Add no-promise-executor-return rule (fixes #12640) (#12648) (Milos Djermanovic)
+    + Update: max-lines reporting loc improvement (refs #12334) (#13318) (Anix)
+    + Update: object-property-newline end location (refs #12334) (#13399) (Anix)
+    + Update: added empty error array check for false negative (#13200) (Anix)
+    + Fix: clone config before validating (fixes #12592) (#13034) (Anix)
+    + Update: semi-spacing should check do-while statements (#13358) (Milos Djermanovic)
+    + Update: disallow multiple options in comma-dangle schema (fixes #13165) (#13166) (Milos Djermanovic)
+    + New: Add no-unreachable-loop rule (fixes #12381) (#12660) (Milos Djermanovic)
+    + Update: curly should check consequent `if` statements (#12947) (Milos Djermanovic)
+    + Update: Drop @typescript-eslint/eslint-recommended from `eslint --init` (#13340) (Minh Nguyen)
+    + Update: key-spacing loc changes for extra space (refs #12334) (#13362) (Anix)
+
+ -- Proxmox Support Team <support@proxmox.com>  Thu, 29 Oct 2020 11:48:08 +0100
+
+pve-eslint (7.2.0-1) unstable; urgency=medium
+
+  * update to 7.2.0 release
+
+  * ship an example config and extend-rules sample files in docs
+
+  * 'no-unused-vars': allow starting with _underscore
+
+  * disable "no-underscore-dangle" as used in explicit unused variables
+
+  * disable 'no-else-return' rule
+
+  * try to improve 'object-curly-newline' rule
+
+  * disable 'semi-style' rule for now
+
+  * add --output-config CLI option
+
+  * add possibiliity to extend base config over CLI
+
+ -- Proxmox Support Team <support@proxmox.com>  Sat, 06 Jun 2020 15:59:23 +0200
+
+pve-eslint (7.0.0-1) unstable; urgency=medium
+
+  * update to final 7.0.0 release
+
+ -- Proxmox Support Team <support@proxmox.com>  Fri, 22 May 2020 14:32:18 +0200
+
+pve-eslint (7.0.0~alpha3-2) unstable; urgency=medium
+
+  * use more condensed output format to save some lines
+
+  * allow '!!' for boolean conversion
+
+  * print file path relative to current working directory
+
+  * ignore unused variable named 'me'
+
+ -- Proxmox Support Team <support@proxmox.com>  Fri, 10 Apr 2020 17:06:59 +0200
+
+pve-eslint (7.0.0~alpha3-1) unstable; urgency=medium
+
+  * exit sanely if no args are given
+
+  * rules: dot-location: set location parameter to property
+
+ -- Proxmox Support Team <support@proxmox.com>  Thu, 09 Apr 2020 18:52:05 +0200
+
 pve-eslint (7.0.0~alpha3) unstable; urgency=medium
 
   * bump version to match upstream one.