]> git.proxmox.com Git - rustc.git/blobdiff - debian/control
Bump LLVM requirement to pull in a fix for a FTBFS on ppc64el
[rustc.git] / debian / control
index 4b2f2dff6ef5b89446baaff617654d9f6263a724..6bdbeafc7bf8340df30f7d0fb740910eecb44193 100644 (file)
@@ -7,39 +7,36 @@ Uploaders: Jordan Justen <jordan.l.justen@intel.com>,
  Sylvestre Ledru <sylvestre@debian.org>,
  Angus Lees <gus@debian.org>,
  Ximin Luo <infinity0@debian.org>
+# :native annotations are to support cross-compiling, see README.Debian
 Build-Depends: debhelper (>= 9),
                dpkg-dev (>= 1.17.14),
                python:native,
-# TODO: related to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839145
-# the non-native lines can be deleted after all versions in unstable are M-A: allowed
-               cargo        (>= 0.17.0)      <!pkg.rustc.dlstage0> |
-               cargo:native (>= 0.17.0)      <!pkg.rustc.dlstage0>,
-               rustc        (>= 1.17.0+dfsg) <!pkg.rustc.dlstage0> |
-               rustc:native (>= 1.17.0+dfsg) <!pkg.rustc.dlstage0>,
-               rustc        (<= 1.18.0++)    <!pkg.rustc.dlstage0> |
-               rustc:native (<= 1.18.0++)    <!pkg.rustc.dlstage0>,
-               llvm-3.9-dev:native   (>= 1:3.9.1-10~),
-               llvm-3.9-tools:native (>= 1:3.9.1-10~),
-               libllvm3.9            (>= 1:3.9.1-10~),
+               cargo:native (>= 0.19.0)      <!pkg.rustc.dlstage0>,
+               rustc:native (>= 1.18.0+dfsg) <!pkg.rustc.dlstage0>,
+               rustc:native (<= 1.19.0++)    <!pkg.rustc.dlstage0>,
+               llvm-4.0-dev:native   (>= 1:4.0.1-6),
+               llvm-4.0-tools:native (>= 1:4.0.1-6),
+               libllvm4.0            (>= 1:4.0.1-6),
                autotools-dev,
-               cmake | cmake3,
+               cmake (>= 3.0) | cmake3,
                gperf,
-# this is sometimes needed depending on the LLVM situation, just keep it here
+# this is sometimes needed by rustc_llvm
+               zlib1g-dev:native,
                zlib1g-dev,
+# used by rust-installer
+               liblzma-dev:native,
+# test dependencies:
                binutils (>= 2.26) <!nocheck> | binutils-2.26 <!nocheck>,
                nodejs <!nocheck>,
                valgrind <!nocheck>,
                git <!nocheck>,
                procps <!nocheck>,
-# the tests require the docs to be built, which requires jquery
-               libjs-jquery <!nocheck>,
 # below are optional tools even for 'make check'
                antlr4 <!nocheck> | antlr <!nocheck>,
                bison <!nocheck>,
                flex <!nocheck>,
                gdb (>= 7.12) <!nocheck>,
                default-jdk-headless <!nocheck> | default-jdk <!nocheck>,
-Build-Depends-Indep: libjs-jquery <!nodoc>
 # Work around #864741. The version constraint for gdb above should already do
 # that, but this will keep things covered even in the case that they change
 # gdb-minimal to do a versioned Provides: gdb.
@@ -54,7 +51,7 @@ Architecture: any
 Multi-Arch: allowed
 Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends}, ${misc:Depends}, libstd-rust-dev (= ${binary:Version}),
- gcc, libc-dev, libjs-jquery, binutils (>= 2.26)
+ gcc, libc-dev, binutils (>= 2.26)
 Recommends: rust-gdb | rust-lldb
 Suggests: rust-doc, rust-src
 Description: Rust systems programming language
@@ -70,7 +67,7 @@ Description: Rust systems programming language
  generic programming and meta-programming, in both static and dynamic
  styles.
 
-Package: libstd-rust-1.18
+Package: libstd-rust-1.19
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -95,7 +92,7 @@ Package: libstd-rust-dev
 Section: libdevel
 Architecture: any
 Multi-Arch: same
-Depends: ${misc:Depends}, libstd-rust-1.18 (= ${binary:Version})
+Depends: ${misc:Depends}, libstd-rust-1.19 (= ${binary:Version})
 Description: Rust standard libraries - development files
  Rust is a curly-brace, block-structured expression language.  It
  visually resembles the C language family, but differs significantly
@@ -136,7 +133,7 @@ Description: Rust debugger (gdb)
 Package: rust-lldb
 Architecture: all
 # When updating, also update rust-lldb.links
-Depends: lldb-3.9, ${misc:Depends}, python-lldb-3.9
+Depends: lldb-4.0, ${misc:Depends}, python-lldb-4.0
 Replaces: rustc (<< 1.1.0+dfsg1-1)
 Description: Rust debugger (lldb)
  Rust is a curly-brace, block-structured expression language.  It