]> git.proxmox.com Git - rustc.git/blobdiff - debian/control
bump version to 1.75.0+dfsg1-1~bpo12+pve1
[rustc.git] / debian / control
index 112547e106b1a23fb2f56199fab5c871dcdc88dc..e94f7410184bf6bb026a89ef20e39905a45c3517 100644 (file)
@@ -13,25 +13,36 @@ Build-Depends:
  debhelper-compat (= 13),
  dpkg-dev (>= 1.17.14),
  python3:native,
- cargo:native (>= 0.60.0)      <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.69.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.70.0++)    <!pkg.rustc.dlstage0>,
- llvm-16-dev:native,
- llvm-16-tools:native,
+ cargo:native (>= 1.74.0+dfsg)      <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.74.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.75.0++)    <!pkg.rustc.dlstage0>,
+ llvm-17-dev:native,
+ llvm-17-tools:native,
  gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
  gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm16 (>= 1:16.0.0),
- libclang-rt-16-dev:native,
- cmake (>= 3.0) | cmake3,
+ libllvm17 (>= 1:17.0.0),
+ libclang-rt-17-dev:native,
+ libclang-rt-17-dev,
+ cmake (>= 3.0),
 # needed by some vendor crates
- pkg-config,
+ pkgconf:native,
+ pkgconf,
 # this is sometimes needed by rustc_llvm
  zlib1g-dev:native,
  zlib1g-dev,
 # used by rust-installer
  liblzma-dev:native,
+# used by cargo
+ bash-completion,
+ libcurl4-openssl-dev | libcurl4-gnutls-dev,
+ libssh2-1-dev,
+ libssl-dev,
+ libgit2-dev (>= 1.7.1),
+ libgit2-dev (<< 1.8~~),
+ libhttp-parser-dev,
 # test dependencies:
  binutils (>= 2.26) <!nocheck> | binutils-2.26 <!nocheck>,
+# temporarily disabled cause of #1066794 / t64 transition
  git <!nocheck>,
  procps <!nocheck>,
 # below are optional tools even for 'make check'
@@ -40,9 +51,9 @@ Build-Depends:
  curl <pkg.rustc.dlstage0>,
  ca-certificates <pkg.rustc.dlstage0>,
 Build-Depends-Indep:
- wasi-libc (>= 0.0~git20230113.4362b18-2~) <!nowasm>,
- wasi-libc (<= 0.0~git20230113.4362b18++) <!nowasm>,
- clang-16:native,
+ wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
+ wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
+ clang-17:native,
 Build-Conflicts: gdb-minimal <!nocheck>
 Standards-Version: 4.6.2
 Homepage: http://www.rust-lang.org/
@@ -57,12 +68,9 @@ Depends: ${shlibs:Depends}, ${misc:Depends},
  libstd-rust-dev (= ${binary:Version}),
  gcc, libc-dev, binutils (>= 2.26)
 Recommends:
- cargo (>= 0.71.0~~), cargo (<< 0.72.0~~),
+ cargo (= ${binary:Version}),
 # llvm is needed for llvm-dwp for -C split-debuginfo=packed
- llvm-16,
-Suggests:
-# lld and clang are needed for wasm compilation
- lld-16, clang-16,
+ rust-llvm,
 Replaces: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
 Breaks: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
 Description: Rust systems programming language
@@ -78,7 +86,7 @@ Description: Rust systems programming language
  generic programming and meta-programming, in both static and dynamic
  styles.
 
-Package: libstd-rust-1.70
+Package: libstd-rust-1.75
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -105,7 +113,7 @@ Section: libdevel
 Architecture: any
 Multi-Arch: same
 Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.70 (= ${binary:Version}),
+ libstd-rust-1.75 (= ${binary:Version}),
 Description: Rust standard libraries - development files
  Rust is a curly-brace, block-structured expression language.  It
  visually resembles the C language family, but differs significantly
@@ -157,7 +165,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
 # Embeds wasi-libc so doesn't need to depend on it
 # None of its licenses require source redistrib, so no need for Built-Using
 Recommends:
- lld-16, clang-16,
+ lld-17, clang-17,
 Suggests:
 # nodejs contains wasi-node for running the program
  nodejs (>= 12.16),
@@ -203,7 +211,7 @@ Description: Rust debugger (gdb)
 Package: rust-lldb
 Architecture: all
 # When updating, also update rust-lldb.links
-Depends: lldb-16, ${misc:Depends}, python3-lldb-16
+Depends: lldb-17, ${misc:Depends}, python3-lldb-17
 Replaces: rustc (<< 1.1.0+dfsg1-1)
 Description: Rust debugger (lldb)
  Rust is a curly-brace, block-structured expression language.  It
@@ -221,6 +229,38 @@ Description: Rust debugger (lldb)
  This package contains pretty printers and a wrapper script for
  invoking lldb on rust binaries.
 
+Package: rust-llvm
+Architecture: all
+Breaks:
+ rustc (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
+Replaces:
+ rustc (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
+Depends:
+ ${misc:Depends},
+# lld and clang are needed for wasm compilation
+ lld-17, clang-17,
+# llvm is needed for llvm-dwp for split-debuginfo=packed
+ llvm-17
+Description: Rust LLVM integration
+ Rust is a curly-brace, block-structured expression language.  It
+ visually resembles the C language family, but differs significantly
+ in syntactic and semantic details.  Its design is oriented toward
+ concerns of "programming in the large", that is, of creating and
+ maintaining boundaries - both abstract and operational - that
+ preserve large-system integrity, availability and concurrency.
+ .
+ It supports a mixture of imperative procedural, concurrent actor,
+ object-oriented and pure functional styles.  Rust also supports
+ generic programming and meta-programming, in both static and dynamic
+ styles.
+ .
+ This package contains symlinks for integration with LLVM tools such as lld and
+ grcov.
+
 Package: rust-doc
 Section: doc
 Architecture: all
@@ -268,7 +308,7 @@ Package: rust-clippy
 Architecture: any
 Multi-Arch: allowed
 Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.70 (= ${binary:Version})
+ libstd-rust-1.75 (= ${binary:Version})
 Recommends: cargo
 Description: Rust linter
  Rust is a curly-brace, block-structured expression language.  It
@@ -323,7 +363,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
  rust-gdb (>= ${binary:Version}) | rust-lldb (>= ${binary:Version}),
  cargo,
 Recommends:
- cargo (>= 0.71.0~~), cargo (<< 0.72.0~~)
+ cargo (= ${binary:Version})
 Suggests:
  rust-doc (>= ${binary:Version}),
  rust-src (>= ${binary:Version}),
@@ -344,3 +384,50 @@ Description: Rust systems programming language - all developer tools
  .
  This package is an empty metapackage that depends on all developer tools
  in the standard rustc distribution that have been packaged for Debian.
+
+# Cargo binaries
+Package: cargo
+Architecture: any
+Multi-Arch: allowed
+Depends: ${shlibs:Depends}, ${misc:Depends},
+         rustc (= ${binary:Version}),
+         binutils,
+         gcc | clang | c-compiler
+Suggests: cargo-doc, python3
+Description: Rust package manager
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+  * Introduces two metadata files with various bits of project information.
+  * Fetches and builds your project's dependencies.
+  * Invokes rustc or another build tool with the correct parameters to build
+    your project.
+  * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project’s dependencies and compiles your
+ project.
+
+Package: cargo-doc
+Section: doc
+Architecture: all
+Build-Profiles: <!nodoc>
+Recommends: rust-doc
+Depends: ${misc:Depends}
+Description: Rust package manager, documentation
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+  * Introduces two metadata files with various bits of project information.
+  * Fetches and builds your project's dependencies.
+  * Invokes rustc or another build tool with the correct parameters to build
+    your project.
+  * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project’s dependencies and compiles your
+ project.
+ .
+ This package contains the documentation.
+
+# TODO: add a cargo-src package