]> git.proxmox.com Git - rustc.git/blobdiff - debian/control
bump version to 1.76.0+dfsg1-1~bpo12+pve1
[rustc.git] / debian / control
index b4956fd54d49ed1404fdf597aee39a01c08ad24c..1cf430b9953d4731b0a62689c392952dc3d8015e 100644 (file)
@@ -13,17 +13,19 @@ Build-Depends:
  debhelper-compat (= 13),
  dpkg-dev (>= 1.17.14),
  python3:native,
- cargo:native (>= 1.70.0+dfsg)      <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.70.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.71.1++)    <!pkg.rustc.dlstage0>,
- llvm-16-dev:native,
- llvm-16-tools:native,
+ cargo:native (>= 1.75.0+dfsg)      <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.75.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.76.0++)    <!pkg.rustc.dlstage0>,
+ llvm-17-dev:native,
+ llvm-17-tools:native,
  gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
  gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm16t64 (>= 1:16.0.0),
- libclang-rt-16-dev:native,
+ libllvm17 (>= 1:17.0.0),
+ libclang-rt-17-dev:native,
+ libclang-rt-17-dev,
  cmake (>= 3.0),
 # needed by some vendor crates
+ pkgconf:native,
  pkgconf,
 # this is sometimes needed by rustc_llvm
  zlib1g-dev:native,
@@ -35,6 +37,7 @@ Build-Depends:
  libcurl4-openssl-dev | libcurl4-gnutls-dev,
  libssh2-1-dev,
  libssl-dev,
+ libsqlite3-dev,
  libgit2-dev (>= 1.7.1),
  libgit2-dev (<< 1.8~~),
  libhttp-parser-dev,
@@ -49,9 +52,9 @@ Build-Depends:
  curl <pkg.rustc.dlstage0>,
  ca-certificates <pkg.rustc.dlstage0>,
 Build-Depends-Indep:
- wasi-libc (>= 0.0~git20230113.4362b18-2~) <!nowasm>,
- wasi-libc (<= 0.0~git20230113.4362b18++) <!nowasm>,
- clang-16:native,
+ wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
+ wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
+ clang-17:native,
 Build-Conflicts: gdb-minimal <!nocheck>
 Standards-Version: 4.6.2
 Homepage: http://www.rust-lang.org/
@@ -84,7 +87,7 @@ Description: Rust systems programming language
  generic programming and meta-programming, in both static and dynamic
  styles.
 
-Package: libstd-rust-1.71
+Package: libstd-rust-1.76
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -111,7 +114,7 @@ Section: libdevel
 Architecture: any
 Multi-Arch: same
 Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.71 (= ${binary:Version}),
+ libstd-rust-1.76 (= ${binary:Version}),
 Description: Rust standard libraries - development files
  Rust is a curly-brace, block-structured expression language.  It
  visually resembles the C language family, but differs significantly
@@ -163,7 +166,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
 # Embeds wasi-libc so doesn't need to depend on it
 # None of its licenses require source redistrib, so no need for Built-Using
 Recommends:
- lld-16, clang-16,
+ lld-17, clang-17,
 Suggests:
 # nodejs contains wasi-node for running the program
  nodejs (>= 12.16),
@@ -209,7 +212,7 @@ Description: Rust debugger (gdb)
 Package: rust-lldb
 Architecture: all
 # When updating, also update rust-lldb.links
-Depends: lldb-16, ${misc:Depends}, python3-lldb-16
+Depends: lldb-17, ${misc:Depends}, python3-lldb-17
 Replaces: rustc (<< 1.1.0+dfsg1-1)
 Description: Rust debugger (lldb)
  Rust is a curly-brace, block-structured expression language.  It
@@ -231,18 +234,18 @@ Package: rust-llvm
 Architecture: all
 Breaks:
  rustc (<< 1.71.1+dfsg1-1~exp1),
- rust-web (<< 1.71.1+dfsg1-1~exp1),
- rust-mozilla (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
 Replaces:
  rustc (<< 1.71.1+dfsg1-1~exp1),
- rust-web (<< 1.71.1+dfsg1-1~exp1),
- rust-mozilla (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
 Depends:
  ${misc:Depends},
 # lld and clang are needed for wasm compilation
- lld-16, clang-16,
+ lld-17, clang-17,
 # llvm is needed for llvm-dwp for split-debuginfo=packed
- llvm-16
+ llvm-17
 Description: Rust LLVM integration
  Rust is a curly-brace, block-structured expression language.  It
  visually resembles the C language family, but differs significantly
@@ -306,7 +309,7 @@ Package: rust-clippy
 Architecture: any
 Multi-Arch: allowed
 Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.71 (= ${binary:Version})
+ libstd-rust-1.76 (= ${binary:Version})
 Recommends: cargo
 Description: Rust linter
  Rust is a curly-brace, block-structured expression language.  It
@@ -403,7 +406,7 @@ Description: Rust package manager
     your project.
   * Introduces conventions, making working with Rust projects easier.
  .
- Cargo downloads your Rust projects dependencies and compiles your
+ Cargo downloads your Rust project's dependencies and compiles your
  project.
 
 Package: cargo-doc
@@ -423,7 +426,7 @@ Description: Rust package manager, documentation
     your project.
   * Introduces conventions, making working with Rust projects easier.
  .
- Cargo downloads your Rust projects dependencies and compiles your
+ Cargo downloads your Rust project's dependencies and compiles your
  project.
  .
  This package contains the documentation.