]> git.proxmox.com Git - rustc.git/blobdiff - debian/control
bump version to 1.80.1+dfsg1-1~bpo12+pve1
[rustc.git] / debian / control
index c6d349a8e81e65aa97925fb67c217d7b680168e1..8fed7104ae9c4f9e1a414e92323d6f758c1e2c84 100644 (file)
@@ -4,32 +4,47 @@ Priority: optional
 Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
 Uploaders:
  Ximin Luo <infinity0@debian.org>,
- Sylvestre Ledru <sylvestre@debian.org>
+ Sylvestre Ledru <sylvestre@debian.org>,
+ Fabian Grünbichler <debian@fabian.gruenbichler.email>
 Rules-Requires-Root: no
 # :native annotations are to support cross-compiling, see README.Debian
 Build-Depends:
  debhelper (>= 9),
- debhelper-compat (= 12),
+ debhelper-compat (= 13),
  dpkg-dev (>= 1.17.14),
  python3:native,
- cargo:native (>= 0.40.0)      <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.51.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.52.1++)    <!pkg.rustc.dlstage0>,
- llvm-11-dev:native,
- llvm-11-tools:native,
+ cargo:native (>= 1.79.0+dfsg)      <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.79.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.80.1++)    <!pkg.rustc.dlstage0>,
+ llvm-17-dev:native,
+ llvm-17-tools:native,
  gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
  gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm11,
- cmake (>= 3.0) | cmake3,
+ libllvm17 (>= 1:17.0.0),
+ libclang-rt-17-dev:native,
+ libclang-rt-17-dev,
+ cmake (>= 3.0),
 # needed by some vendor crates
- pkg-config,
+ pkgconf:native,
+ pkgconf,
 # this is sometimes needed by rustc_llvm
  zlib1g-dev:native,
  zlib1g-dev,
 # used by rust-installer
  liblzma-dev:native,
+# used by cargo
+ bash-completion,
+ libcurl4-openssl-dev | libcurl4-gnutls-dev,
+ libssh2-1-dev,
+ libssl-dev,
+ libsqlite3-dev,
+ libgit2-dev (>= 1.7.2),
+ libgit2-dev (<< 1.8~~),
+ libhttp-parser-dev,
+ libonig-dev,
 # test dependencies:
  binutils (>= 2.26) <!nocheck> | binutils-2.26 <!nocheck>,
+# temporarily disabled cause of #1066794 / t64 transition
  git <!nocheck>,
  procps <!nocheck>,
 # below are optional tools even for 'make check'
@@ -38,11 +53,12 @@ Build-Depends:
  curl <pkg.rustc.dlstage0>,
  ca-certificates <pkg.rustc.dlstage0>,
 Build-Depends-Indep:
- wasi-libc (>= 0.0~git20201130.5879558~~) <!nowasm>,
- wasi-libc (<= 0.0~git20201130.5879558++) <!nowasm>,
- clang-11:native,
-Build-Conflicts: gdb-minimal <!nocheck>
-Standards-Version: 4.2.1
+ wasi-libc (>= 0.0~git20240411.9e8c542-3~~) <!nowasm>,
+ wasi-libc (<= 0.0~git20240411.9e8c542++) <!nowasm>,
+ clang-17:native,
+# see #1057780, gdb now Conflicts gdb-minimal
+#Build-Conflicts: gdb-minimal <!nocheck>
+Standards-Version: 4.7.0
 Homepage: http://www.rust-lang.org/
 Vcs-Git: https://salsa.debian.org/rust-team/rust.git
 Vcs-Browser: https://salsa.debian.org/rust-team/rust
@@ -51,12 +67,13 @@ Package: rustc
 Architecture: any
 Multi-Arch: allowed
 Pre-Depends: ${misc:Pre-Depends}
-Depends: ${shlibs:Depends}, ${misc:Depends}, libstd-rust-dev (= ${binary:Version}),
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libstd-rust-dev (= ${binary:Version}),
  gcc, libc-dev, binutils (>= 2.26)
-Recommends: cargo (>= 0.53.0~~), cargo (<< 0.54.0~~), rust-gdb | rust-lldb
-# lld is needed for wasm compilation
-# llvm is needed for llvm-dwp for split-debuginfo
-Suggests: rust-doc, rust-src, lld-11, llvm-11
+Recommends:
+ cargo (= ${binary:Version}),
+# llvm is needed for llvm-dwp for -C split-debuginfo=packed
+ rust-llvm,
 Replaces: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
 Breaks: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
 Description: Rust systems programming language
@@ -72,7 +89,7 @@ Description: Rust systems programming language
  generic programming and meta-programming, in both static and dynamic
  styles.
 
-Package: libstd-rust-1.52
+Package: libstd-rust-1.80
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -98,7 +115,8 @@ Package: libstd-rust-dev
 Section: libdevel
 Architecture: any
 Multi-Arch: same
-Depends: ${shlibs:Depends}, ${misc:Depends}, libstd-rust-1.52 (= ${binary:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libstd-rust-1.80 (= ${binary:Version}),
 Description: Rust standard libraries - development files
  Rust is a curly-brace, block-structured expression language.  It
  visually resembles the C language family, but differs significantly
@@ -149,9 +167,11 @@ Multi-Arch: foreign
 Depends: ${shlibs:Depends}, ${misc:Depends}
 # Embeds wasi-libc so doesn't need to depend on it
 # None of its licenses require source redistrib, so no need for Built-Using
-Recommends: lld-11
-Suggests: clang-11, nodejs (>= 12.16)
+Recommends:
+ lld-17, clang-17,
+Suggests:
 # nodejs contains wasi-node for running the program
+ nodejs (>= 12.16),
 Build-Profiles: <!nowasm>
 Description: Rust standard libraries - development files
  Rust is a curly-brace, block-structured expression language.  It
@@ -168,7 +188,7 @@ Description: Rust standard libraries - development files
  .
  This package contains the standard Rust libraries including development files,
  needed to cross-compile Rust programs to the wasm32-unknown-unknown and
- wasm32-wasi targets.
+ wasm32-wasip1/wasm32-wasip2 targets.
 
 Package: rust-gdb
 Architecture: all
@@ -194,7 +214,7 @@ Description: Rust debugger (gdb)
 Package: rust-lldb
 Architecture: all
 # When updating, also update rust-lldb.links
-Depends: lldb-11, ${misc:Depends}, python3-lldb-11
+Depends: lldb-17, ${misc:Depends}, python3-lldb-17
 Replaces: rustc (<< 1.1.0+dfsg1-1)
 Description: Rust debugger (lldb)
  Rust is a curly-brace, block-structured expression language.  It
@@ -212,6 +232,38 @@ Description: Rust debugger (lldb)
  This package contains pretty printers and a wrapper script for
  invoking lldb on rust binaries.
 
+Package: rust-llvm
+Architecture: all
+Breaks:
+ rustc (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
+Replaces:
+ rustc (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
+Depends:
+ ${misc:Depends},
+# lld and clang are needed for wasm compilation
+ lld-17, clang-17,
+# llvm is needed for llvm-dwp for split-debuginfo=packed
+ llvm-17
+Description: Rust LLVM integration
+ Rust is a curly-brace, block-structured expression language.  It
+ visually resembles the C language family, but differs significantly
+ in syntactic and semantic details.  Its design is oriented toward
+ concerns of "programming in the large", that is, of creating and
+ maintaining boundaries - both abstract and operational - that
+ preserve large-system integrity, availability and concurrency.
+ .
+ It supports a mixture of imperative procedural, concurrent actor,
+ object-oriented and pure functional styles.  Rust also supports
+ generic programming and meta-programming, in both static and dynamic
+ styles.
+ .
+ This package contains symlinks for integration with LLVM tools such as lld and
+ grcov.
+
 Package: rust-doc
 Section: doc
 Architecture: all
@@ -257,8 +309,9 @@ Description: Rust systems programming language - source code
 
 Package: rust-clippy
 Architecture: any
+Multi-Arch: allowed
 Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.48
+ libstd-rust-1.80 (= ${binary:Version})
 Recommends: cargo
 Description: Rust linter
  Rust is a curly-brace, block-structured expression language.  It
@@ -284,7 +337,9 @@ Description: Rust linter
 
 Package: rustfmt
 Architecture: any
+Multi-Arch: allowed
 Depends: ${misc:Depends}, ${shlibs:Depends},
+ libstd-rust-1.80 (= ${binary:Version}),
 Recommends: cargo
 Description: Rust formatting helper
  Rust is a curly-brace, block-structured expression language.  It
@@ -302,3 +357,81 @@ Description: Rust formatting helper
  This package contains 'rustfmt', a tool for formatting Rust code according to
  style guidelines, as well as 'cargo-fmt', a helper enabling running rustfmt
  directly with 'cargo fmt'.
+
+Package: rust-all
+Architecture: all
+Depends: ${misc:Depends}, ${shlibs:Depends},
+ rustc (>= ${binary:Version}),
+ rustfmt (>= ${binary:Version}),
+ rust-clippy (>= ${binary:Version}),
+ rust-gdb (>= ${binary:Version}) | rust-lldb (>= ${binary:Version}),
+ cargo,
+Recommends:
+ cargo (= ${binary:Version})
+Suggests:
+ rust-doc (>= ${binary:Version}),
+ rust-src (>= ${binary:Version}),
+ libstd-rust-dev-wasm32 (>= ${binary:Version}),
+ libstd-rust-dev-windows (>= ${binary:Version}),
+Description: Rust systems programming language - all developer tools
+ Rust is a curly-brace, block-structured expression language.  It
+ visually resembles the C language family, but differs significantly
+ in syntactic and semantic details.  Its design is oriented toward
+ concerns of "programming in the large", that is, of creating and
+ maintaining boundaries - both abstract and operational - that
+ preserve large-system integrity, availability and concurrency.
+ .
+ It supports a mixture of imperative procedural, concurrent actor,
+ object-oriented and pure functional styles.  Rust also supports
+ generic programming and meta-programming, in both static and dynamic
+ styles.
+ .
+ This package is an empty metapackage that depends on all developer tools
+ in the standard rustc distribution that have been packaged for Debian.
+
+# Cargo binaries
+Package: cargo
+Architecture: any
+Multi-Arch: allowed
+Depends: ${shlibs:Depends}, ${misc:Depends},
+         rustc (= ${binary:Version}),
+         binutils,
+         gcc | clang | c-compiler
+Suggests: cargo-doc, python3
+Description: Rust package manager
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+  * Introduces two metadata files with various bits of project information.
+  * Fetches and builds your project's dependencies.
+  * Invokes rustc or another build tool with the correct parameters to build
+    your project.
+  * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project's dependencies and compiles your
+ project.
+
+Package: cargo-doc
+Section: doc
+Architecture: all
+Build-Profiles: <!nodoc>
+Recommends: rust-doc
+Depends: ${misc:Depends}
+Description: Rust package manager, documentation
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+  * Introduces two metadata files with various bits of project information.
+  * Fetches and builds your project's dependencies.
+  * Invokes rustc or another build tool with the correct parameters to build
+    your project.
+  * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project's dependencies and compiles your
+ project.
+ .
+ This package contains the documentation.
+
+# TODO: add a cargo-src package