]> git.proxmox.com Git - llvm-toolchain.git/blobdiff - debian/patches/x86-fuzzer.patch
Merge tag 'debian/11.0.0-5' into proxmox/buster
[llvm-toolchain.git] / debian / patches / x86-fuzzer.patch
diff --git a/debian/patches/x86-fuzzer.patch b/debian/patches/x86-fuzzer.patch
new file mode 100644 (file)
index 0000000..1e1895e
--- /dev/null
@@ -0,0 +1,14 @@
+Description: fuzzer: EMULATION_ARGUMENT is also required when building on i386 for x86_64
+Author: Adrian Bunk <bunk@debian.org>
+
+--- llvm-toolchain-11-11.0.0.orig/compiler-rt/lib/fuzzer/CMakeLists.txt
++++ llvm-toolchain-11-11.0.0/compiler-rt/lib/fuzzer/CMakeLists.txt
+@@ -121,6 +121,8 @@ if(OS_NAME MATCHES "Linux|Fuchsia" AND
+   macro(partially_link_libcxx name dir arch)
+     if(${arch} MATCHES "i386")
+       set(EMULATION_ARGUMENT "-m" "elf_i386")
++    elseif(${arch} MATCHES "x86_64")
++      set(EMULATION_ARGUMENT "-m" "elf_x86_64")
+     else()
+       set(EMULATION_ARGUMENT "")
+     endif()