]> git.proxmox.com Git - ovs.git/blobdiff - debian/rules
Blacklist flacky test on all arch: 526: tcp vconn - refuse connection.
[ovs.git] / debian / rules
index 3020b0315e2e733540917e2820af9590d06be089..257cdecd1f6347ab09922e101abb261828c38ee7 100755 (executable)
@@ -42,7 +42,7 @@ endif
 # that one doesn't feel like deterministic.
 # 1021: ofproto-dpif - select group with weights FAILED (ofproto-dpif.at:535)
 # 1057: ofproto-dpif - controller action without megaflows FAILED (ofproto-dpif.at:1893)
-TEST_LIST = 1-19 21-531 533-1020 1022-1056 1058-
+TEST_LIST = 1-19 21-525 527-531 533-1020 1022-1056 1058-
 TEST_LIST_DPDK = $(TEST_LIST)
 
 # armhf:
@@ -53,7 +53,7 @@ TEST_LIST_DPDK = $(TEST_LIST)
 # 1021: ofproto-dpif - select group with weights        FAILED (ofproto-dpif.at:535)
 # 1057: ofproto-dpif - controller action without megaflows FAILED (ofproto-dpif.at:1893)
 ifneq (,$(filter armhf, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-23 28-531 533-917 919-1020 1022-1056 1058-
+TEST_LIST = 1-19 21-23 28-525 527-531 533-917 919-1020 1022-1056 1058-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif # armhf
 
@@ -71,7 +71,7 @@ endif # armhf
 #  1071: ofproto-dpif - controller action without megaflows
 #  1136: ofproto-dpif - sFlow packet sampling - LACP structures
 ifneq (,$(filter mipsel, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 22-531 533-916 920-926 928-1020 1022-1034 1036-1056 1058-1068 1070 1072-1101 1103-1135 1137-
+TEST_LIST = 1-19 22-525 527-531 533-916 920-926 928-1020 1022-1034 1036-1056 1058-1068 1070 1072-1101 1103-1135 1137-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif # mipsel
 
@@ -82,7 +82,7 @@ endif # mipsel
 #  1021: ofproto-dpif - select group with weights        FAILED (ofproto-dpif.at:535)
 #  1069: ofproto-dpif - controller action without megaflows
 ifneq (,$(filter mips64el, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 22-531 533-1020 1022-1032 1034-1056 1058-1068 1070 1072-1120 1122-
+TEST_LIST = 1-19 22-525 527-531 533-1020 1022-1032 1034-1056 1058-1068 1070 1072-1120 1122-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif # mips64el
 
@@ -90,7 +90,7 @@ endif # mips64el
 #  1021: ofproto-dpif - select group with weights        FAILED (ofproto-dpif.at:535)
 #  1123: ofproto-dpif - sFlow packet sampling - LACP structures FAILED (ofproto-dpif.at:6643)
 ifneq (,$(filter armel, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-531 533-1020 1022-1056 1058-1122 1124-
+TEST_LIST = 1-19 21-525 527-531 533-1020 1022-1056 1058-1122 1124-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #armel
 
@@ -99,7 +99,7 @@ endif #armel
 #  1021: ofproto-dpif - select group with weights        FAILED (ofproto-dpif.at:535)
 #  1057: ofproto-dpif - controller action without megaflows FAILED (ofproto-dpif.at:1893)
 ifneq (,$(filter arm64, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-158 160-531 533-1020 1022-1056 1058-
+TEST_LIST = 1-19 21-158 160-525 527-531 533-1020 1022-1056 1058-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #arm64
 
@@ -108,7 +108,7 @@ endif #arm64
 #  2728: ovn -- vlan traffic for external network with distributed router gateway port FAILED (ovn.at:8563)
 #  2737: ovn -- IPv6 periodic RA                         FAILED (ovn.at:9916)
 ifneq (,$(filter alpha, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-531 533-2723 2725-2727 2729-2736 2738-
+TEST_LIST = 1-19 21-525 527-531 533-2723 2725-2727 2729-2736 2738-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #alpha
 
@@ -132,7 +132,7 @@ endif #alpha
 #  1735: ovsdb-server combines updates on backlogged connections FAILED (ovsdb-server.at:1205)
 #  2193: RSTP - dummy interface FAILED (rstp.at:210)
 ifneq (,$(filter hppa, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-531 533-846 848-849 851-915 920-941 943-1020 1022-1056 1058-1101 1103-1104 1106-1122 1124-1180 1182-1208 1210-1734 1736-2192 2194-
+TEST_LIST = 1-19 21-525 527-531 533-846 848-849 851-915 920-941 943-1020 1022-1056 1058-1101 1103-1104 1106-1122 1124-1180 1182-1208 1210-1734 1736-2192 2194-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #hppa
 
@@ -149,7 +149,7 @@ endif #hppa
 #  2185: STP - flush the fdb and mdb when topology changed FAILED (stp.at:529)
 #  2249: auto-attach - packets                           FAILED (auto-attach.at:5)
 ifneq (,$(filter sparc64, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-25 27-465 467-531 533-899 901-917 919-941 943-997 999-1056 1058-2183 2186-2248 2250-
+TEST_LIST = 1-19 21-25 27-465 467-525 527-531 533-899 901-917 919-941 943-997 999-1056 1058-2183 2186-2248 2250-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #sparc64
 
@@ -158,7 +158,7 @@ endif #sparc64
 #  1021: ofproto-dpif - select group with weights        FAILED (ofproto-dpif.at:535)
 #  1057: ofproto-dpif - controller action without megaflows FAILED (ofproto-dpif.at:1893)
 ifneq (,$(filter ia64, $(DEB_HOST_ARCH)))
-TEST_LIST = 1-19 21-531 533-1020 1022-1056 1058-
+TEST_LIST = 1-19 21-525 527-531 533-1020 1022-1056 1058-
 TEST_LIST_DPDK = $(TEST_LIST)
 endif #ia64