]> git.proxmox.com Git - lxc.git/blobdiff - debian/rules
add a depend on lxcfs
[lxc.git] / debian / rules
index a18e75cac59652eee87c6370ce8b806ab11eb2a8..1515ccbe0cf7b7b0eeb6a19041a4c15f974b3879 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
+
 # output every command that modifies files on the build system.
 #DH_VERBOSE = 1
 
@@ -7,24 +7,14 @@
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
-# see FEATURE AREAS in dpkg-buildflags(1)
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
-# package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-
-
-# main packaging script based on dh7 syntax
 %:
-       dh $@  --with autoreconf,autotools-dev,systemd
+       dh $@  --with autoreconf,autotools-dev,quilt,systemd
 
 override_dh_auto_configure:
        dh_auto_configure -- \
        --with-distro=debian \
        --with-init-script=systemd \
+       --with-config-path=/etc/pve/lxc \
        --enable-apparmor       \
        --enable-doc    \
        --enable-api-docs \
@@ -34,14 +24,20 @@ override_dh_auto_configure:
        --enable-cgmanager \
        --disable-python \
        --disable-lua \
-       --disable-examples \
-       --enable-configpath-log 
+       --disable-examples
 
 override_dh_strip:
-       dh_strip --dbg-package=lxc-dbg
+       dh_strip --dbg-package=lxc-pve-dbg
 
 
 
 override_dh_install:
-       dh_apparmor -p lxc --profile-name=usr.bin.lxc-start
+       dh_apparmor -p lxc-pve --profile-name=usr.bin.lxc-start
+
+       # do not include dirs on /etc/pve
+#      rmdir $(CURDIR)/debian/tmp/etc/pve/lxc
+#      rmdir $(CURDIR)/debian/tmp/etc/pve
+
+#      rm $(CURDIR)/debian/tmp/var/lib/lxc/README
+
        dh_install --fail-missing