]> git.proxmox.com Git - pve-kernel.git/blobdiff - debian/rules
update ABI file for 5.18.0-1-pve
[pve-kernel.git] / debian / rules
index 6be3f18d964dee4b86a3d56c25de51568f5af0dd..365b4fa5ea1bb86397325399cf8ddcf1d44c821f 100755 (executable)
@@ -35,16 +35,20 @@ PVE_CONFIG_OPTS= \
 -m CONFIG_HFS_FS \
 -m CONFIG_HFSPLUS_FS \
 -e CIFS_SMB_DIRECT \
+-e CONFIG_SQUASHFS_DECOMP_MULTI_PERCPU \
 -e CONFIG_BRIDGE \
 -e CONFIG_BRIDGE_NETFILTER \
 -e CONFIG_BLK_DEV_SD \
 -e CONFIG_BLK_DEV_SR \
 -e CONFIG_BLK_DEV_DM \
--e CONFIG_BLK_DEV_NVME \
+-m CONFIG_BLK_DEV_NVME \
 -e CONFIG_NLS_ISO8859_1 \
 -d CONFIG_INPUT_EVBUG \
 -d CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND \
+-d CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL \
 -e CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE \
+-e CONFIG_SYSFB_SIMPLEFB \
+-e CONFIG_DRM_SIMPLEDRM \
 -d CONFIG_MODULE_SIG \
 -d CONFIG_MEMCG_DISABLED \
 -e CONFIG_MEMCG_SWAP_ENABLED \
@@ -75,6 +79,7 @@ PVE_CONFIG_OPTS= \
 -d CONFIG_UNWINDER_GUESS \
 -e CONFIG_UNWINDER_FRAME_POINTER \
 --set-str CONFIG_SYSTEM_TRUSTED_KEYS ""\
+--set-str CONFIG_SYSTEM_REVOCATION_KEYS ""\
 -d CONFIG_SECURITY_LOCKDOWN_LSM \
 -d CONFIG_SECURITY_LOCKDOWN_LSM_EARLY \
 --set-str CONFIG_LSM yama,integrity,apparmor \
@@ -137,7 +142,10 @@ binary: install
        # remove firmware
        rm -rf debian/${PVE_KERNEL_PKG}/lib/firmware
 
-       # debug package
+ifeq ($(filter pkg.pve-kernel.debug,$(DEB_BUILD_PROFILES)),)
+       echo "'pkg.pve-kernel.debug' build profile disabled, skipping -dbgsym creation"
+else
+       echo "'pkg.pve-kernel.debug' build profile enabled, creating -dbgsym contents"
        mkdir -p debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/lib/modules/${KVNAME}
        mkdir debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/boot
        install -m 644 ${KERNEL_SRC}/vmlinux debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/boot/vmlinux-${KVNAME}
@@ -145,6 +153,7 @@ binary: install
        rm -f debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/lib/modules/${KVNAME}/source
        rm -f debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/lib/modules/${KVNAME}/build
        rm -f debian/${PVE_DEBUG_KERNEL_PKG}/usr/lib/debug/lib/modules/${KVNAME}/modules.*
+endif
 
        # strip debug info
        find debian/${PVE_KERNEL_PKG}/lib/modules -name \*.ko -print | while read f ; do strip --strip-debug "$$f"; done
@@ -228,7 +237,6 @@ binary: install
 .usr_headers_install_mark: .config_mark
        rm -rf '${PKG_DIR}'
        mkdir -p  '${PKG_DIR}'
-       $(MAKE) -C ${KERNEL_SRC} headers_check ARCH=$(KERNEL_HEADER_ARCH)
        $(MAKE) -C ${KERNEL_SRC} headers_install ARCH=$(KERNEL_HEADER_ARCH) INSTALL_HDR_PATH='$(CURDIR)'/$(OUT_DIR)
        rm -rf $(OUT_DIR)/include/drm $(OUT_DIR)/include/scsi
        find $(OUT_DIR)/include \( -name .install -o -name ..install.cmd \) -execdir rm {} +