]> git.proxmox.com Git - pmg-api.git/blobdiff - debian/rules
add rule attributes and/invert (for each relevant type)
[pmg-api.git] / debian / rules
index 6834364d2aa0fb76a543c343cb9df07f1b69e713..3e1507951a5e51fab2d0938b5af5cf740189d618 100755 (executable)
@@ -3,11 +3,20 @@
 # output every command that modifies files on the build system.
 #DH_VERBOSE = 1
 
+include /usr/share/dpkg/pkg-info.mk
+
+export PACKAGE=pmg-api
+export PMGVERSION = $(DEB_VERSION_UPSTREAM_REVISION)
+export PMGRELEASE = $(shell echo $(DEB_VERSION_UPSTREAM) | cut -c 1-3)
+
+include debian/rules.env
+export REPOID=${REPOID_GENERATED}
+
 %:
        dh $@
 
 override_dh_installsystemd:
-       dh_installsystemd --no-start \
+       dh_installsystemd --no-start --no-stop-on-upgrade \
                pmg-hourly.service \
                pmg-daily.service \
                pmgspamreport.service \