]> git.proxmox.com Git - cargo.git/blobdiff - vendor/git2/Cargo.toml
New upstream version 0.66.0
[cargo.git] / vendor / git2 / Cargo.toml
index 8027c8506c904fe5eaae5637899c7875ece80550..bdd1db6c86e385de86a1bc9380e1b90cd91d4b33 100644 (file)
 [package]
 edition = "2018"
 name = "git2"
-version = "0.14.2"
-authors = ["Josh Triplett <josh@joshtriplett.org>", "Alex Crichton <alex@alexcrichton.com>"]
-description = "Bindings to libgit2 for interoperating with git repositories. This library is\nboth threadsafe and memory safe and allows both reading and writing git\nrepositories.\n"
+version = "0.15.0"
+authors = [
+    "Josh Triplett <josh@joshtriplett.org>",
+    "Alex Crichton <alex@alexcrichton.com>",
+]
+description = """
+Bindings to libgit2 for interoperating with git repositories. This library is
+both threadsafe and memory safe and allows both reading and writing git
+repositories.
+"""
 documentation = "https://docs.rs/git2"
 readme = "README.md"
 keywords = ["git"]
 categories = ["api-bindings"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-lang/git2-rs"
+
 [dependencies.bitflags]
 version = "1.1.0"
 
@@ -28,13 +36,14 @@ version = "1.1.0"
 version = "0.2"
 
 [dependencies.libgit2-sys]
-version = "0.13.2"
+version = "0.14.0"
 
 [dependencies.log]
 version = "0.4.8"
 
 [dependencies.url]
 version = "2.0"
+
 [dev-dependencies.paste]
 version = "1"
 
@@ -48,11 +57,20 @@ version = "3.1.0"
 version = "0.1.39"
 
 [features]
-default = ["ssh", "https", "ssh_key_from_memory"]
-https = ["libgit2-sys/https", "openssl-sys", "openssl-probe"]
+default = [
+    "ssh",
+    "https",
+    "ssh_key_from_memory",
+]
+https = [
+    "libgit2-sys/https",
+    "openssl-sys",
+    "openssl-probe",
+]
 ssh = ["libgit2-sys/ssh"]
 ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
 unstable = []
+
 [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
 version = "0.1"
 optional = true