]> git.proxmox.com Git - libgit2.git/blobdiff - debian/patches/fix-unit-tests.patch
Merge https://salsa.debian.org/debian/libgit2 into proxmox/bullseye
[libgit2.git] / debian / patches / fix-unit-tests.patch
diff --git a/debian/patches/fix-unit-tests.patch b/debian/patches/fix-unit-tests.patch
new file mode 100644 (file)
index 0000000..35f45fc
--- /dev/null
@@ -0,0 +1,135 @@
+From: =?utf-8?q?Timo_R=C3=B6hling?= <roehling@debian.org>
+Date: Sun, 28 Aug 2022 17:20:01 +0200
+Subject: Fix unit tests
+
+---
+ tests/libgit2/CMakeLists.txt      |  2 +-
+ tests/libgit2/network/url/parse.c | 67 ++++-----------------------------------
+ 2 files changed, 7 insertions(+), 62 deletions(-)
+
+diff --git a/tests/libgit2/CMakeLists.txt b/tests/libgit2/CMakeLists.txt
+index 213076f..9a56bd7 100644
+--- a/tests/libgit2/CMakeLists.txt
++++ b/tests/libgit2/CMakeLists.txt
+@@ -65,7 +65,7 @@ endif()
+ include(AddClarTest)
+ add_clar_test(libgit2_tests offline             -v -xonline)
+-add_clar_test(libgit2_tests invasive            -v -score::ftruncate -sfilter::stream::bigfile -sodb::largefiles -siterator::workdir::filesystem_gunk -srepo::init -srepo::init::at_filesystem_root)
++add_clar_test(libgit2_tests invasive            -v -sfilter::stream::bigfile -sodb::largefiles -siterator::workdir::filesystem_gunk -srepo::init -srepo::init::at_filesystem_root)
+ if(NOT DISABLE_ONLINE_TESTS)
+       add_clar_test(libgit2_tests online              -v -sonline -xonline::customcert)
+       add_clar_test(libgit2_tests online_customcert   -v -sonline::customcert)
+diff --git a/tests/libgit2/network/url/parse.c b/tests/libgit2/network/url/parse.c
+index 8149ba5..729302e 100644
+--- a/tests/libgit2/network/url/parse.c
++++ b/tests/libgit2/network/url/parse.c
+@@ -65,14 +65,7 @@ void test_network_url_parse__hostname_implied_root_custom_port(void)
+ void test_network_url_parse__hostname_implied_root_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://example.com:"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "example.com");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://example.com:"));
+ }
+ void test_network_url_parse__hostname_encoded_password(void)
+@@ -131,14 +124,7 @@ void test_network_url_parse__hostname_port(void)
+ void test_network_url_parse__hostname_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://example.com:/resource"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "example.com");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/resource");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://example.com:/resource"));
+ }
+ void test_network_url_parse__hostname_user_port(void)
+@@ -221,14 +207,7 @@ void test_network_url_parse__ipv4_implied_root_custom_port(void)
+ void test_network_url_parse__ipv4_implied_root_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://192.168.1.1:"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "192.168.1.1");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://192.168.1.1:"));
+ }
+ void test_network_url_parse__ipv4_encoded_password(void)
+@@ -285,14 +264,7 @@ void test_network_url_parse__ipv4_port(void)
+ void test_network_url_parse__ipv4_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://192.168.1.1:/resource"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "192.168.1.1");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/resource");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://192.168.1.1:/resource"));
+ }
+ void test_network_url_parse__ipv4_user_port(void)
+@@ -373,27 +345,7 @@ void test_network_url_parse__ipv6_implied_root_custom_port(void)
+ void test_network_url_parse__ipv6_implied_root_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "fe80::dcad:beff:fe00:0001");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
+-}
+-
+-void test_network_url_parse__ipv6_encoded_password(void)
+-{
+-      cl_git_pass(git_net_url_parse(&conndata,
+-              "https://user:pass%2fis%40bad@[fe80::dcad:beff:fe00:0001]:1234/"));
+-      cl_assert_equal_s(conndata.scheme, "https");
+-      cl_assert_equal_s(conndata.host, "fe80::dcad:beff:fe00:0001");
+-      cl_assert_equal_s(conndata.port, "1234");
+-      cl_assert_equal_s(conndata.path, "/");
+-      cl_assert_equal_s(conndata.username, "user");
+-      cl_assert_equal_s(conndata.password, "pass/is@bad");
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:"));
+ }
+ void test_network_url_parse__ipv6_user(void)
+@@ -437,14 +389,7 @@ void test_network_url_parse__ipv6_port(void)
+ void test_network_url_parse__ipv6_empty_port(void)
+ {
+-      cl_git_pass(git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:/resource"));
+-      cl_assert_equal_s(conndata.scheme, "http");
+-      cl_assert_equal_s(conndata.host, "fe80::dcad:beff:fe00:0001");
+-      cl_assert_equal_s(conndata.port, "80");
+-      cl_assert_equal_s(conndata.path, "/resource");
+-      cl_assert_equal_p(conndata.username, NULL);
+-      cl_assert_equal_p(conndata.password, NULL);
+-      cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
++      cl_git_fail_with(GIT_EINVALIDSPEC, git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:/resource"));
+ }
+ void test_network_url_parse__ipv6_user_port(void)