]> git.proxmox.com Git - lxc.git/blobdiff - debian/rules
buildsys: rules: use build architecture
[lxc.git] / debian / rules
index 3027c5c35b1b842eb56c3d3703b44bb7e2b3b474..3eb2d7d3e1a71183fff1499265da38243a43d572 100755 (executable)
@@ -3,12 +3,14 @@
 # output every command that modifies files on the build system.
 #DH_VERBOSE = 1
 
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
 %:
-       dh $@  --with autoreconf,autotools-dev,quilt,systemd
+       dh $@ --parallel --with autoreconf,autotools-dev,quilt,systemd
 
 override_dh_auto_configure:
        dh_auto_configure -- \
@@ -20,19 +22,23 @@ override_dh_auto_configure:
        --disable-rpath \
        --disable-selinux \
        --enable-bash \
-       --enable-cgmanager \
+       --disable-cgmanager \
        --disable-python \
        --disable-lua \
-       --disable-examples
+       --disable-examples \
+       --enable-seccomp
 
 override_dh_strip:
        dh_strip --dbg-package=lxc-pve-dbg
 
-
+override_dh_fixperms:
+       dh_fixperms -Xusr/lib/$(DEB_HOST_MULTIARCH)/lxc/lxc-user-nic
 
 override_dh_install:
+       rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
        dh_apparmor -p lxc-pve --profile-name=usr.bin.lxc-start
-
+       dh_apparmor -p lxc-pve --profile-name=lxc-containers
        dh_install --fail-missing
 
-
+override_dh_systemd_start:
+       dh_systemd_start --no-restart-on-upgrade