]> git.proxmox.com Git - perlmod.git/blame - perlmod/debian/changelog
bump perlmod & macro to 0.11.0-1 and 0.7.0-1
[perlmod.git] / perlmod / debian / changelog
CommitLineData
cd521468
WB
1rust-perlmod (0.11.0-1) stable; urgency=medium
2
3 * support visibility in `perl_fn!`
4
5 * bump macro to 0.7.0
6
7 -- Proxmox Support Team <support@proxmox.com> Tue, 25 Jan 2022 09:32:52 +0100
8
44c4c44b
WB
9rust-perlmod (0.10.1-1) stable; urgency=medium
10
11 * let ffi::RSPL_newXS_flags return the CV pointer
12
13 * let the perl_fn! macro also handle just types, not full functions with
14 bodies
15
16 * add Value::new_xsub as an taking a `perl_fn!(extern "C" fn(*mut CV))`
17
18 * use #[deny(unsafe_op_in_unsafe_fn)] and update code accordingly
19
20 -- Proxmox Support Team <support@proxmox.com> Fri, 17 Dec 2021 09:21:24 +0100
21
86f538fe
WB
22rust-perlmod (0.10.0-1) stable; urgency=medium
23
24 * bugfix: declare_magic now declares MAGIC as a static instead of a const,
25 since it needs its storage guarantees
26
27 * bugfix: instantiate_magic uses the provided magic value rather than
28 hardcoding literally 'MAGIC'
29
30 * MagicSpec has no value anymore, its with_value creates a new MagicValue
31
32 * MagicValue combines a MagicSpec with a value
33
34 * bump to rust edition 2021
35
36 * some documentation fixups
37
38 -- Proxmox Support Team <support@proxmox.com> Tue, 14 Dec 2021 13:41:25 +0100
39
b44db428
WB
40rust-perlmod (0.9.0-1) stable; urgency=medium
41
42 * build glue c code with opt_level 3 even in debug mode
43
44 * update perlmod-macro to 0.6
45
46 -- Proxmox Support Team <support@proxmox.com> Fri, 26 Nov 2021 14:02:33 +0100
47
78e2b8b2
WB
48rust-perlmod (0.8.2-1) stable; urgency=medium
49
50 * add enum in deserialization support
51
52 -- Proxmox Support Team <support@proxmox.com> Fri, 05 Nov 2021 10:14:50 +0100
53
fa8cf134
WB
54rust-perlmod (0.8.1-1) stable; urgency=medium
55
56 * Add Value::as_array
57
58 * Add Value::as_array_mut
59
60 * Add Value::as_hash
61
62 * Add Value::as_hash_mut
63
64 -- Proxmox Support Team <support@proxmox.com> Tue, 02 Nov 2021 14:32:02 +0100
65
5be6fc83
WB
66rust-perlmod (0.8.0-1) stable; urgency=medium
67
68 * add Value::new_hash for convenience
69
70 * impl AsRef<ScalarRef> for Value
71
72 * impl AsMut<ScalarRef> for Value
73
74 * add glue code for working with "magic"
75
76 * add helpers to add magic with less unsafe code and have drop handlers
77 called automatically
78
79 -- Proxmox Support Team <support@proxmox.com> Thu, 28 Oct 2021 09:18:51 +0200
80
35762913
WB
81rust-perlmod (0.7.2-1) stable; urgency=medium
82
83 * ffi: add RSPL_newXS_flags helper to allow making bootstrap functions
84
85 -- Proxmox Support Team <support@proxmox.com> Mon, 25 Oct 2021 10:05:09 +0200
86
ebe0ba64
WB
87rust-perlmod (0.7.1-1) stable; urgency=medium
88
89 * add Value::bless_box helper
90
91 * improve documentation
92
93 -- Proxmox Support Team <support@proxmox.com> Tue, 19 Oct 2021 10:31:07 +0200
94
81da219d
WB
95rust-perlmod (0.7.0-1) stable; urgency=medium
96
97 * properly prevent ScalarRef values from being created
98
99 -- Proxmox Support Team <support@proxmox.com> Thu, 14 Oct 2021 15:22:12 +0200
100
b8ef338c
WB
101rust-perlmod (0.6.0-1) stable; urgency=medium
102
103 * update to perlmod-macro 0.4.0
104
105 * impl Clone for Value, Scalar, Hash, Array
106
107 * add RawValue as a raw value *de*serialization helper
108
109 * perlmod::to_value now will NOT copy perl values anymore, instead, they
110 will be serialized as references now
111
112 * perlmod::from_value will now cause perl values to NOT be copied anymore
113 either, instead, they will be references
114
115 -- Proxmox Support Team <support@proxmox.com> Wed, 13 Oct 2021 11:30:30 +0200
116
c9d79aae
WB
117rust-perlmod (0.5.3-3) stable; urgency=medium
118
119 * improve deserialization of 'undef'
120
121 -- Proxmox Support Team <support@proxmox.com> Mon, 19 Jul 2021 10:32:31 +0200
122
ab3923dc
WB
123rust-perlmod (0.5.2-2) stable; urgency=medium
124
125 * bump perlmod-macro dependency
126
127 * mark strings with codepoints >=128 as utf8 when serializing to perl
128
129 -- Proxmox Support Team <support@proxmox.com> Fri, 02 Jul 2021 11:40:24 +0200
130
36bbf1d1
WB
131rust-perlmod (0.5.1-1) stable; urgency=medium
132
133 * fix newtype struct deserialization
134
135 -- Proxmox Support Team <support@proxmox.com> Wed, 23 Jun 2021 10:58:40 +0200
136
0daaa90c
WB
137rust-perlmod (0.5.0-1) stable; urgency=medium
138
139 * add support for deserializing PVLV magic (lvalues)
140
141 -- Proxmox Support Team <support@proxmox.com> Mon, 21 Jun 2021 12:38:48 +0200
142
ec6f42c3
WB
143rust-perlmod (0.4.3-1) stable; urgency=medium
144
145 * fix an issue with serializing empty arrays
146
147 -- Proxmox Support Team <support@proxmox.com> Tue, 09 Mar 2021 15:35:59 +0100
148
4aee0cb5
WB
149rust-perlmod (0.4.2-1) stable; urgency=medium
150
151 * allow scalars with magic in deserialization
152
153 * bump macro to 0.3.1
154
155 -- Proxmox Support Team <support@proxmox.com> Tue, 23 Feb 2021 14:25:34 +0100
156
a3361698
WB
157rust-perlmod (0.4.1-1) stable; urgency=medium
158
159 * fix a refcount issue with Hash::insert_by_value
160
161 -- Proxmox Support Team <support@proxmox.com> Tue, 16 Feb 2021 12:37:43 +0100
162
53ad5e5f
WB
163rust-perlmod (0.4.0-1) stable; urgency=medium
164
165 * depend on perlmod-macro 0.3.0
166
167 -- Proxmox Support Team <support@proxmox.com> Tue, 16 Feb 2021 10:44:08 +0100
168
fee0609d
WB
169rust-perlmod (0.3.0-1) stable; urgency=medium
170
171 * breaking change to destructor macro due to compiler restructions
172
173 -- Proxmox Support Team <support@proxmox.com> Mon, 15 Feb 2021 16:05:44 +0100
174
6dd6718b
WB
175rust-perlmod (0.2.3-1) stable; urgency=medium
176
177 * fix an issue with deserializing 'undef' values
178
179 * bump macro dependency
180
181 -- Proxmox Support Team <support@proxmox.com> Mon, 15 Feb 2021 14:55:45 +0100
182
fcd20b78
WB
183rust-perlmod (0.2.2-1) stable; urgency=medium
184
185 * `#[export]` fns now accept a `#[try_from_ref]` attribute on parameters
186
187 * improve documentation
188
189 -- Proxmox Support Team <support@proxmox.com> Wed, 09 Dec 2020 09:23:46 +0100
190
63af6eeb
WB
191rust-perlmod (0.2.1-1) stable; urgency=medium
192
193 * depend on perlmod-macro 0.2.1: non-debug builds don't include
194 `-L./target/debug` in their perl modules anymore
195
196 * support deserializing borrowed strings (mostly useful for exporter
197 function parameters)
198
199 -- Proxmox Support Team <support@proxmox.com> Fri, 27 Nov 2020 14:34:44 +0100
200
f4832286
WB
201rust-perlmod (0.2.0-1) stable; urgency=medium
202
203 * add convenience methods for raw pointer types
204
205 * support blessed values
206
207 * support deserializing by reference to allow `&[u8]` parameters
208 introduces: perlmod::from_ref_value(&Value)
209
210 * improve documentation and examples
211
212 * make `SvPVbyte` in `Value`s safe by checking whether they can be converted
213 first (otherwise it could potentially trigger a `longjmp`)
214
215 * add `destructor!` convenience macro
216
217 * `Serializer` and `Deserializer` & helper types are now private
218
219 -- Proxmox Support Team <support@proxmox.com> Thu, 26 Nov 2020 13:51:51 +0100
220
245289bd 221rust-perlmod (0.1.0-1) stable; urgency=medium
46d6d8fa
WB
222
223 * initial packaging
224
245289bd 225 -- Proxmox Support Team <support@proxmox.com> Fri, 20 Nov 2020 13:55:27 +0100