]> git.proxmox.com Git - proxmox.git/blame - proxmox-api-macro/debian/changelog
bump proxmox-api-macro to 1.0.8-1
[proxmox.git] / proxmox-api-macro / debian / changelog
CommitLineData
ca6ca904
WB
1rust-proxmox-api-macro (1.0.8-1) stable; urgency=medium
2
3 * update to proxmox-schema 3
4
5 * make #[serde(skip_serializing_if)] without #[serde(default)] an error
6
7 -- Proxmox Support Team <support@proxmox.com> Fri, 02 Feb 2024 13:44:40 +0100
8
1f377da0
WB
9rust-proxmox-api-macro (1.0.7-1) stable; urgency=medium
10
11 * make serde(skip_serializing_if) without serde(default) for non-Option
12 types an error
13
14 * split field and variant attribute parsing
15
16 -- Proxmox Support Team <support@proxmox.com> Wed, 06 Dec 2023 16:02:11 +0100
17
04e2d0e5
FG
18rust-proxmox-api-macro (1.0.6-1) stable; urgency=medium
19
20 * clippy fix: this (Default) `impl` can be derived
21
22 * update to syn 2, rework attribute parsing
23
24 -- Proxmox Support Team <support@proxmox.com> Mon, 02 Oct 2023 09:27:12 +0200
25
34a79cdd
WB
26rust-proxmox-api-macro (1.0.5-1) bookworm; urgency=medium
27
28 * support non-idents in serde rename attributes on enum variants
29
30 -- Proxmox Support Team <support@proxmox.com> Thu, 03 Aug 2023 08:23:42 +0200
31
7bc85c05
WB
32rust-proxmox-api-macro (1.0.4-1) stable; urgency=medium
33
34 * support #[default] attribute for types which derive Default
35
36 * documentation updates
37
38 -- Proxmox Support Team <support@proxmox.com> Mon, 12 Dec 2022 11:31:34 +0100
39
b49f3554
WB
40rust-proxmox-api-macro (1.0.3-1) stable; urgency=medium
41
42 * allow overriding fiel attributes when deriving an updater
43
44 -- Proxmox Support Team <support@proxmox.com> Thu, 19 May 2022 12:03:36 +0200
45
bcf6abaa
WB
46rust-proxmox-api-macro (1.0.2-1) stable; urgency=medium
47
48 * support streaming api handlers
49
50 -- Proxmox Support Team <support@proxmox.com> Tue, 12 Apr 2022 14:26:46 +0200
51
d1829219
WB
52rust-proxmox-api-macro (1.0.1-1) stable; urgency=medium
53
54 * stop adding automatically_derived to derived output to please new rustc
55
56 -- Proxmox Support Team <support@proxmox.com> Tue, 12 Oct 2021 14:49:35 +0200
57
41f3fdfe
WB
58rust-proxmox-api-macro (1.0.0-1) stable; urgency=medium
59
60 * schema was split out of proxmox into a new proxmox-schema crate
61
62 -- Proxmox Support Team <support@proxmox.com> Thu, 07 Oct 2021 14:28:14 +0200
63
cb96de1c
WB
64rust-proxmox-api-macro (0.5.1-1) stable; urgency=medium
65
66 * allow external `returns` specification on methods, refereincing a
67 `ReturnType`.
68
69 -- Proxmox Support Team <support@proxmox.com> Mon, 30 Aug 2021 10:44:21 +0200
70
0f2caafc
WB
71rust-proxmox-api-macro (0.5.0-1) stable; urgency=medium
72
73 * for non structs without Updater types and methods, `type: Foo` can now be
74 omitted for api types
75
76 * Adapt to the changes to Updatable in the proxmox crate
77
78 * Updaters have no try_build_from or update_from method anymore for now
79
80 * #[api] types automatically implement the new ApiType trait
81
82 -- Proxmox Support Team <support@proxmox.com> Tue, 24 Aug 2021 15:22:05 +0200
83
c75e7060
TL
84rust-proxmox-api-macro (0.4.0-1) stable; urgency=medium
85
86 * update proxmox to 0.12.0
87
88 -- Proxmox Support Team <support@proxmox.com> Tue, 20 Jul 2021 17:09:40 +0200
89
6729d411
WB
90rust-proxmox-api-macro (0.3.4-1) unstable; urgency=medium
91
92 * fix path in generated Updatable derive entry to not require explicit
93 imports of the trait
94
95 -- Proxmox Support Team <support@proxmox.com> Wed, 14 Apr 2021 11:59:04 +0200
96
1f6a2a66
WB
97rust-proxmox-api-macro (0.3.3-1) unstable; urgency=medium
98
99 * updater: take serde renames into account
100
101 -- Proxmox Support Team <support@proxmox.com> Wed, 24 Feb 2021 09:36:24 +0100
102
4e375ba9
WB
103rust-proxmox-api-macro (0.3.2-1) unstable; urgency=medium
104
105 * added Updater derive macros
106
107 -- Proxmox Support Team <support@proxmox.com> Wed, 10 Feb 2021 10:09:13 +0100
108
586d9494
FG
109rust-proxmox-api-macro (0.3.1-1) unstable; urgency=medium
110
111 * adapt to ParameterSchema move from router:: to schema::
112
113 -- Proxmox Support Team <support@proxmox.com> Thu, 14 Jan 2021 15:38:42 +0100
114
04417d1d 115rust-proxmox-api-macro (0.3.0-1) unstable; urgency=medium
bc0355e5
WB
116
117 * removed `pub const API_RETURN_SCHEMA_*` generation
118 This could already be accessed via the public `API_METHOD_FOO.returns`.
119
120 * Note that a previous `schema: API_RETURN_SCHEMA_FOO` must now dereference
121 the schema via: `schema: *API_METHOD_FOO.returns.schema`.
122
123 -- Proxmox Support Team <support@proxmox.com> Fri, 11 Dec 2020 14:56:02 +0100
124
8cc4c167
WB
125rust-proxmox-api-macro (0.2.4-1) unstable; urgency=medium
126
127 * support raw parameter name identifiers (eg. `r#type`)
128
129 * correctly produce errors when using a `description` with external
130 schema/type references, as those descriptions will never be used. This
131 distinguishes between explicitly set descriptions and doc comments. The
132 latter is still allowed since forbidding those doesn't make any sense as
133 they're part of the crate documentation.
134
135 * Change a lot of errors to not be "fatal", so they still generate code, to
136 avoid getting additional errors about the method & variable names not
137 existing. This should generally improve error output a lot for the cases
138 where this can actually be done.
139
140 -- Proxmox Support Team <support@proxmox.com> Wed, 09 Dec 2020 10:40:30 +0100
141
0c816fe3
TL
142rust-proxmox-api-macro (0.2.3-1) unstable; urgency=medium
143
144 * api macro: reuse generated default const for "unwrap_or" instead of adding
145 a closure which returned the default value inline. This allows one to
146 define optional params with a default as non-option type in a API handler
147 signature without getting a warning that the const generated for that
148 default is now unused.
149
150 -- Proxmox Support Team <support@proxmox.com> Sat, 31 Oct 2020 08:38:18 +0100
151
2702a2a7
DM
152rust-proxmox-api-macro (0.2.2-1) unstable; urgency=medium
153
154 * api-macro: replace ident hashmap with simple find
155
156 -- Proxmox Support Team <support@proxmox.com> Sat, 19 Sep 2020 06:29:31 +0200
157
2fb7f4a3
DM
158rust-proxmox-api-macro (0.2.1-1) unstable; urgency=medium
159
160 * api-macro: relax Fieldname rules
161
162 * api-macro: fix broken binary ident search
163
164 -- Proxmox Support Team <support@proxmox.com> Thu, 17 Sep 2020 08:25:55 +0200
165
2904b622
WB
166rust-proxmox-api-macro (0.2.0-1) proxmox-rust; urgency=medium
167
168 * All api-macro generated schema declarations are now values instead of
169 references, usage of them always adds the '&' instead of "sometimes", for
170 consistency. This allows referencing generated schemas (eg.
171 API_RETURN_SCHEMA_FOO) via the `schema:` key inside objects.
172
173 -- Proxmox Support Team <support@proxmox.com> Fri, 10 Jul 2020 10:50:38 +0200
174
fa25b17c
WB
175rust-proxmox-api-macro (0.1.9-1) proxmox-rust; urgency=medium
176
177 * remove some unnecessary parentheses to silence warnings in newer rustc
178
179 -- Proxmox Support Team <support@proxmox.com> Mon, 18 May 2020 09:16:00 +0200
180
c329cedb
WB
181rust-proxmox-api-macro (0.1.8-1) proxmox-rust; urgency=medium
182
183 * add descriptions to enum variants
184
185 -- Proxmox Support Team <support@proxmox.com> Wed, 29 Apr 2020 10:45:50 +0200
186
95403224
WB
187rust-proxmox-api-macro (0.1.7-1) proxmox-rust; urgency=medium
188
189 * replace failure with anyhow crate
190
191 * fix error message suggestiong 'permissions' instead of 'permission'
192
193 -- Proxmox Support Team <support@proxmox.com> Fri, 17 Apr 2020 18:36:03 +0200
194
b07d5925
DM
195rust-proxmox-api-macro (0.1.6-1) proxmox-rust; urgency=medium
196
197 * support reload_timezone option for methods
198
199 * support 'access' specification for methods
200
201 * error on unexpected keys
202
203 * cleanups, more tests
204
205 -- Proxmox Support Team <support@proxmox.com> Thu, 16 Apr 2020 08:29:31 +0200
206
2065bcb1
WB
207rust-proxmox-api-macro (0.1.5-1) proxmox-rust; urgency=medium
208
209 * include default min/max for integer types
210
211 -- Proxmox Support Team <support@proxmox.com> Thu, 19 Mar 2020 09:55:25 +0100
212
d7be7df8
WB
213rust-proxmox-api-macro (0.1.4-1) proxmox-rust; urgency=medium
214
215 * make parameter and return schema of api methods public
216
217 -- Proxmox Support Team <support@proxmox.com> Thu, 27 Feb 2020 13:09:40 +0100
218
db741bfb
WB
219rust-proxmox-api-macro (0.1.3-1) proxmox-rust; urgency=medium
220
221 * expose parameter and return schema of api methods as
222 - API_RETURN_SCHEMA_<method-name>
223 - API_PARAMETER_SCHEMA_<method-name>
224
225 -- Proxmox Support Team <support@proxmox.com> Thu, 30 Jan 2020 12:32:37 +0100
226
a5373a96
WB
227rust-proxmox-api-macro (0.1.2-1) proxmox-rust; urgency=medium
228
229 * fix a case were object properties weren't sorted
230
231 -- Proxmox Support Team <support@proxmox.com> Thu, 23 Jan 2020 13:16:30 +0100
232
a94de245
FG
233rust-proxmox-api-macro (0.1.1-1) proxmox-rust; urgency=medium
234
235 * switch packaging to debcargo with local crate support
236
237 -- Proxmox Support Team <support@proxmox.com> Mon, 13 Jan 2020 10:41:01 +0100
238
66d9d43c
WB
239rust-proxmox-api-macro (0.1.1) proxmox-rust; urgency=medium
240
241 * cover all the basic struct support in the #[api] macro
242
243 * support #[serde(rename_all)] on enums and structs
244
245 -- Proxmox Support Team <support@proxmox.com> Wed, 08 Jan 2020 11:03:31 +0100
246
8840877c
FG
247rust-proxmox-api-macro (0.1.0) proxmox-rust; urgency=medium
248
249 * Initial packaging.
250
251 -- Proxmox Support Team <support@proxmox.com> Tue, 17 Dec 2019 14:47:44 +0100