]> git.proxmox.com Git - pve-cluster.git/blobdiff - debian/rules
buildsys: replace autotools with plain makefiles
[pve-cluster.git] / debian / rules
index ed17ae445312fb70ef127621254286fe2b498799..7a9be9e3eed00b8cded8dde4865b2af7bef2bd6c 100755 (executable)
@@ -5,25 +5,12 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@ --with=systemd --with=autoreconf
+       dh $@ --with=systemd
 
 override_dh_strip:
-       dh_strip --dbg-package=pve-cluster-dbg
+       dh_strip --dbgsym-migration='pve-cluster-dbg (<< 5.0-16)'
 
 override_dh_systemd_start:
        dh_systemd_start --restart-after-upgrade
 
-override_dh_auto_install:
-
-       make -j1 install DESTDIR=../debian/pve-cluster
-
-override_dh_install:
-
-       dh_install
-
-       # we do not install this, because we don't want to break
-       # existing tools which parse syslog entries
-       #install -m 0644 -D debian/pve-rsyslog.conf debian/pve-cluster/etc/rsyslog.d/pve-rsyslog.conf
-       install -m 0644 -D debian/sysctl.conf debian/pve-cluster/etc/sysctl.d/pve.conf
-
 override_dh_installinit: