]> git.proxmox.com Git - pve-firewall.git/blobdiff - debian/rules
whitespace fixup
[pve-firewall.git] / debian / rules
index b760bee7f4c367c013d228df52f8332ae6744cf2..13b11d78e5e56634c41726a73b96c611a2f00e80 100755 (executable)
@@ -1,13 +1,17 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 %:
-       dh $@ 
+       dh $@ --with systemd
+
+override_dh_systemd_enable:
+       dh_systemd_enable --name pvefw-logger pve-fwlogger.service
+       dh_systemd_enable --name pve-firewall pve-firewall.service
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade pvefw-logger.service
+       # pve-firewall start/try-reload-restart manually in postinst
+
+override_dh_installinit: