]> git.proxmox.com Git - pve-kernel.git/blobdiff - debian/rules
d/rules: perf: build without libtraceevent
[pve-kernel.git] / debian / rules
index dac31d4e3749014d5e27d8104c7da4f3b75a636c..8a88a7d44a648e393ae93c0d4a65ce8b0310c46f 100755 (executable)
@@ -196,11 +196,11 @@ endif
        touch $@
 
 .tools_compile_mark: .compile_mark
-       $(MAKE) -C $(KERNEL_SRC)/tools/perf prefix=/usr HAVE_NO_LIBBFD=1 HAVE_CPLUS_DEMANGLE_SUPPORT=1 NO_LIBPYTHON=1 NO_LIBPERL=1 NO_LIBCRYPTO=1 PYTHON=python3
+       $(MAKE) -C $(KERNEL_SRC)/tools/perf prefix=/usr NO_LIBTRACEEVENT=1 HAVE_NO_LIBBFD=1 HAVE_CPLUS_DEMANGLE_SUPPORT=1 NO_LIBPYTHON=1 NO_LIBPERL=1 NO_LIBCRYPTO=1 PYTHON=python3
        echo "checking GPL-2 only perf binary for library linkage with incompatible licenses.."
        ! ldd $(KERNEL_SRC)/tools/perf/perf | grep -q -E '\blibbfd'
        ! ldd $(KERNEL_SRC)/tools/perf/perf | grep -q -E '\blibcrypto'
-       $(MAKE) -C $(KERNEL_SRC)/tools/perf man
+       $(MAKE) -C $(KERNEL_SRC)/tools/perf NO_LIBTRACEEVENT=1 man
        touch $@
 
 .tools_install_mark: .tools_compile_mark