]> git.proxmox.com Git - pve-lxc-syscalld.git/blobdiff - debian/rules
buildsys: cleanup, derive upload dist, drop debcargo usage
[pve-lxc-syscalld.git] / debian / rules
index 9f608f50aa30dca2cb7e448ea6e0f188879ef903..d1215aa21d2bd76fe4b3d927dbb32abe1da8f76f 100755 (executable)
@@ -21,6 +21,8 @@ export DEB_CARGO_PACKAGE=pve-lxc-syscalld
        dh $@
 
 override_dh_auto_configure:
+       @perl -ne 'if (/^version\s*=\s*"(\d+(?:\.\d+)+)"/) { my $$v_cargo = $$1; my $$v_deb = "$(DEB_VERSION_UPSTREAM)"; \
+           die "ERROR: d/changelog <-> Cargo.toml version mismatch: $$v_cargo != $$v_deb\n" if $$v_cargo ne $$v_deb; exit(0); }' Cargo.toml
        $(CARGO) prepare-debian $(CURDIR)/debian/cargo_registry --link-from-system
        dh_auto_configure