]> git.proxmox.com Git - ceph.git/blobdiff - ceph/ceph.spec
update sources to v12.1.2
[ceph.git] / ceph / ceph.spec
index 08882641e68c67f8df4b6f19c70815f7bf1cb0be..993c00cd8430c2cb6dd4494dba95175befcd647c 100644 (file)
@@ -22,7 +22,6 @@
 %bcond_without ceph_test_package
 %endif
 %bcond_with make_check
-%bcond_with xio
 %ifarch s390 s390x
 %bcond_with tcmalloc
 %else
@@ -62,7 +61,7 @@
 # main package definition
 #################################################################################
 Name:          ceph
-Version:       12.1.1
+Version:       12.1.2
 Release:       0%{?dist}
 %if 0%{?fedora} || 0%{?rhel}
 Epoch:         2
@@ -77,7 +76,7 @@ License:      LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and BSD-3-Clause and
 Group:         System/Filesystems
 %endif
 URL:           http://ceph.com/
-Source0:       http://ceph.com/download/ceph-12.1.1.tar.bz2
+Source0:       http://ceph.com/download/ceph-12.1.2.tar.bz2
 %if 0%{?suse_version}
 %if 0%{?is_opensuse}
 ExclusiveArch:  x86_64 aarch64 ppc64 ppc64le
@@ -102,6 +101,18 @@ BuildRequires:     checkpolicy
 BuildRequires: selinux-policy-devel
 BuildRequires: /usr/share/selinux/devel/policyhelp
 %endif
+%if 0%{with make_check}
+%if 0%{?fedora} || 0%{?rhel}
+BuildRequires: python-cherrypy
+BuildRequires: python-werkzeug
+%endif
+%if 0%{?suse_version}
+BuildRequires: python-CherryPy
+BuildRequires: python-Werkzeug
+%endif
+BuildRequires: python-pecan
+BuildRequires: socat
+%endif
 BuildRequires: bc
 BuildRequires: gperf
 BuildRequires:  cmake
@@ -127,11 +138,8 @@ BuildRequires:     pkgconfig
 BuildRequires: python
 BuildRequires: python-devel
 BuildRequires: python-nose
-BuildRequires: python-pecan
 BuildRequires: python-requests
 BuildRequires: python-virtualenv
-BuildRequires: python-werkzeug
-BuildRequires: socat
 BuildRequires: snappy-devel
 BuildRequires: udev
 BuildRequires: util-linux
@@ -159,7 +167,6 @@ BuildRequires:      keyutils-devel
 BuildRequires:  libopenssl-devel
 BuildRequires:  lsb-release
 BuildRequires:  openldap2-devel
-BuildRequires: python-CherryPy
 BuildRequires: python-Cython
 BuildRequires: python-PrettyTable
 BuildRequires: python-Sphinx
@@ -176,7 +183,6 @@ BuildRequires:  openldap-devel
 BuildRequires:  openssl-devel
 BuildRequires:  redhat-lsb-core
 BuildRequires: Cython
-BuildRequires: python-cherrypy
 BuildRequires: python-prettytable
 BuildRequires: python-sphinx
 %endif
@@ -211,10 +217,6 @@ BuildRequires:     expat-devel
 %if 0%{?fedora} || 0%{?rhel}
 BuildRequires:  redhat-rpm-config
 %endif
-# Accelio IB/RDMA
-%if 0%{with xio}
-BuildRequires:  libxio-devel
-%endif
 
 %description
 Ceph is a massively scalable, open-source, distributed storage system that runs
@@ -251,9 +253,6 @@ Requires:      which
 %if 0%{?suse_version}
 Recommends:    ntp-daemon
 %endif
-%if 0%{with xio}
-Requires:      libxio
-%endif
 %description base
 Base is the package that includes all the files shared amongst ceph servers
 
@@ -280,9 +279,6 @@ Requires:   python-requests
 %if 0%{?suse_version}
 Requires(pre): pwdutils
 %endif
-%if 0%{with xio}
-Requires:       libxio
-%endif
 %description -n ceph-common
 Common utilities to mount and interact with a ceph storage cluster.
 Comprised of files that are common to Ceph clients and servers.
@@ -682,6 +678,7 @@ Group:              System/Benchmark
 Requires:      ceph-common
 Requires:      xmlstarlet
 Requires:      jq
+Requires:      socat
 %description -n ceph-test
 This package contains Ceph benchmarks and test tools.
 %endif
@@ -775,7 +772,7 @@ python-rbd, python-rgw or python-cephfs instead.
 # common
 #################################################################################
 %prep
-%autosetup -p1 -n ceph-12.1.1
+%autosetup -p1 -n ceph-12.1.2
 
 %build
 %if 0%{with cephfs_java}
@@ -817,6 +814,7 @@ cmake .. \
     -DCMAKE_INSTALL_SYSCONFDIR=%{_sysconfdir} \
     -DCMAKE_INSTALL_MANDIR=%{_mandir} \
     -DCMAKE_INSTALL_DOCDIR=%{_docdir}/ceph \
+    -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
     -DWITH_EMBEDDED=OFF \
     -DWITH_MANPAGE=ON \
     -DWITH_PYTHON3=ON \
@@ -824,9 +822,6 @@ cmake .. \
 %if 0%{?rhel} && ! 0%{?centos}
     -DWITH_SUBMAN=ON \
 %endif
-%if 0%{with xio}
-    -DWITH_XIO=ON \
-%endif
 %if 0%{without ceph_test_package}
     -DWITH_TESTS=OFF \
 %endif
@@ -838,10 +833,10 @@ cmake .. \
 %endif
 %if %{with lttng}
     -DWITH_LTTNG=ON \
-    -DWTIH_BABELTRACE=ON \
+    -DWITH_BABELTRACE=ON \
 %else
     -DWITH_LTTNG=OFF \
-    -DWTIH_BABELTRACE=OFF \
+    -DWITH_BABELTRACE=OFF \
 %endif
     $CEPH_EXTRA_CMAKE_ARGS \
 %if 0%{with ocf}