]> git.proxmox.com Git - pve-qemu.git/blobdiff - debian/patches/pve/0034-PVE-Migrate-dirty-bitmap-state-via-savevm.patch
update submodule and patches to QEMU 8.2.2
[pve-qemu.git] / debian / patches / pve / 0034-PVE-Migrate-dirty-bitmap-state-via-savevm.patch
index 1015db38575b6359f49e5e396b9f246437e7331f..f61465b98e544ecd619c9652ebc0c5a9b1dfcfe1 100644 (file)
@@ -26,10 +26,10 @@ Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
  create mode 100644 migration/pbs-state.c
 
 diff --git a/include/migration/misc.h b/include/migration/misc.h
-index 7dcc0b5c2c..4c940b2475 100644
+index 1bc8902e6d..43eb0e46d6 100644
 --- a/include/migration/misc.h
 +++ b/include/migration/misc.h
-@@ -77,4 +77,7 @@ bool migration_in_bg_snapshot(void);
+@@ -80,4 +80,7 @@ bool migration_in_bg_snapshot(void);
  /* migration/block-dirty-bitmap.c */
  void dirty_bitmap_mig_init(void);
  
@@ -38,7 +38,7 @@ index 7dcc0b5c2c..4c940b2475 100644
 +
  #endif
 diff --git a/migration/meson.build b/migration/meson.build
-index 07f6057acc..343994d891 100644
+index 8f9d122187..2b9d2cc881 100644
 --- a/migration/meson.build
 +++ b/migration/meson.build
 @@ -7,7 +7,9 @@ migration_files = files(
@@ -52,10 +52,10 @@ index 07f6057acc..343994d891 100644
  system_ss.add(files(
    'block-dirty-bitmap.c',
 diff --git a/migration/migration.c b/migration/migration.c
-index 7a4c8beb5d..0a955a2a18 100644
+index 982ab85f04..b84924442d 100644
 --- a/migration/migration.c
 +++ b/migration/migration.c
-@@ -162,6 +162,7 @@ void migration_object_init(void)
+@@ -202,6 +202,7 @@ void migration_object_init(void)
      blk_mig_init();
      ram_mig_init();
      dirty_bitmap_mig_init();
@@ -174,10 +174,10 @@ index 0000000000..887e998b9e
 +                         NULL);
 +}
 diff --git a/pve-backup.c b/pve-backup.c
-index ae3d137e12..e6b17b797e 100644
+index 903afcd7e9..777db7938e 100644
 --- a/pve-backup.c
 +++ b/pve-backup.c
-@@ -1082,6 +1082,7 @@ ProxmoxSupportStatus *qmp_query_proxmox_support(Error **errp)
+@@ -1096,6 +1096,7 @@ ProxmoxSupportStatus *qmp_query_proxmox_support(Error **errp)
      ret->pbs_library_version = g_strdup(proxmox_backup_qemu_version());
      ret->pbs_dirty_bitmap = true;
      ret->pbs_dirty_bitmap_savevm = true;
@@ -186,10 +186,10 @@ index ae3d137e12..e6b17b797e 100644
      ret->pbs_masterkey = true;
      ret->backup_max_workers = true;
 diff --git a/qapi/block-core.json b/qapi/block-core.json
-index d67a6d448a..09de550c95 100644
+index a4050268ca..7b977459fa 100644
 --- a/qapi/block-core.json
 +++ b/qapi/block-core.json
-@@ -991,6 +991,11 @@
+@@ -993,6 +993,11 @@
  # @pbs-dirty-bitmap-savevm: True if 'dirty-bitmaps' migration capability can
  #                           safely be set for savevm-async.
  #
@@ -201,7 +201,7 @@ index d67a6d448a..09de550c95 100644
  # @pbs-masterkey: True if the QMP backup call supports the 'master_keyfile'
  #                 parameter.
  #
-@@ -1001,6 +1006,7 @@
+@@ -1003,6 +1008,7 @@
    'data': { 'pbs-dirty-bitmap': 'bool',
              'query-bitmap-info': 'bool',
              'pbs-dirty-bitmap-savevm': 'bool',