]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
dh systemd: use newer --no-start flag and autogen postinst
[lxcfs.git] / debian / rules
index 9b6dc587f595721109e466545334805acf051599..1b0c270da394b39179757e4b94fc226c1415f77f 100755 (executable)
@@ -4,20 +4,22 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autoreconf,quilt
+       dh $@
 
-override_dh_install:
-       find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
-       sed -i "/dependency_libs/ s/'.*'/''/" \
-           "$(CURDIR)/debian/lxcfs/usr/lib/x86_64-linux-gnu/lxcfs/liblxcfs.la"
+override_dh_auto_clean:
+       rm -fr build
 
 override_dh_auto_configure:
-       dh_auto_configure -- --with-init-script=systemd \
-               FUSE_CFLAGS="$(shell pkg-config --cflags fuse)" \
-               FUSE_LIBS="$(shell pkg-config --libs fuse)"
+       mkdir -p build
+       cd build && meson .. --prefix=/usr \
+               -Dinit-script=systemd \
+               -Dfuse-version=2
 
 override_dh_auto_install:
        dh_auto_install --destdir=debian/lxcfs
 
 override_dh_installsystemd:
-       dh_installsystemd -p lxcfs --no-stop-on-upgrade lxcfs.service
+       install -dm755 $(CURDIR)/debian/lxcfs/lib
+       mv $(CURDIR)/debian/lxcfs/usr/lib/systemd \
+          $(CURDIR)/debian/lxcfs/lib/systemd
+       dh_installsystemd -p lxcfs --no-start --no-stop-on-upgrade lxcfs.service