]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
bump version to 5.0.3-pve2
[lxcfs.git] / debian / rules
index 3c866a63c2a5f54496c8d85036eeb06b7597e93e..1b0c270da394b39179757e4b94fc226c1415f77f 100755 (executable)
@@ -4,16 +4,22 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+       dh $@
 
-override_dh_install:
-       find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
+override_dh_auto_clean:
+       rm -fr build
+
+override_dh_auto_configure:
+       mkdir -p build
+       cd build && meson .. --prefix=/usr \
+               -Dinit-script=systemd \
+               -Dfuse-version=2
 
 override_dh_auto_install:
        dh_auto_install --destdir=debian/lxcfs
 
-override_dh_installinit:
-       dh_installsystemd -p lxcfs --no-restart-on-upgrade
-
-override_dh_systemd_start:
-       dh_systemd_start -p lxcfs --no-restart-on-upgrade lxcfs.service
+override_dh_installsystemd:
+       install -dm755 $(CURDIR)/debian/lxcfs/lib
+       mv $(CURDIR)/debian/lxcfs/usr/lib/systemd \
+          $(CURDIR)/debian/lxcfs/lib/systemd
+       dh_installsystemd -p lxcfs --no-start --no-stop-on-upgrade lxcfs.service