]> git.proxmox.com Git - novnc-pve.git/blobdiff - debian/rules
ship minimal packages.json
[novnc-pve.git] / debian / rules
index 915f1dc51005edeeebaca7fef9462da070a1bfef..3599277996ff83f42708c49c0cbe29c786f4c28d 100755 (executable)
@@ -1,16 +1,21 @@
 #!/usr/bin/make -f
 
+include /usr/share/dpkg/pkg-info.mk
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 export DEB_BUILD_HARDENING=1
 
-clean:
-       make -C utils clean
-       dh clean
+%:
+       dh ${@} --with quilt
 
-build:
-       make -C utils rebind.so
+override_dh_auto_build:
+       compile-modules convert -f bundle app/ui.js > app.js
+       dh_auto_build
 
-%:
-       dh ${@}
+override_dh_install:
+       cp vnc.html index.html.tpl
+       sed -i -re "s/\.(css|js)/\.\1?ver=${DEB_VERSION_UPSTREAM_REVISION}/g" index.html.tpl
+       echo "{ \"version\": \"${DEB_VERSION_UPSTREAM_REVISION}\" }" >package.json
+       dh_install