]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
bump version to 2.0.2-pve1
[lxcfs.git] / debian / rules
index 60d76bab17fe48aadbafbb9956afbab1165af17d..584392c67d90baeaa199036840173b05cdbb921a 100755 (executable)
@@ -4,4 +4,21 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd
+       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+
+override_dh_strip:
+       dh_strip --dbg-package=lxcfs-dbg
+
+# Don't install PAM module for now, we don't need it.
+override_dh_install:
+       rm $(CURDIR)/debian/lxcfs/lib/*/security/pam_cgfs.so
+       find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/lxcfs
+
+override_dh_installinit:
+       dh_installinit -p lxcfs --no-restart-on-upgrade
+
+override_dh_systemd_start:
+       dh_systemd_start -p lxcfs --no-restart-on-upgrade lxcfs.service