]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
d/patches: refresh error out on missing lxcfs-mount patch
[lxcfs.git] / debian / rules
index 775ebf20875356ba043a00166d9e8161604b43d8..8ca3dc000eeae55f8d64ff0ed912741a8f282ad0 100755 (executable)
@@ -4,4 +4,22 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+       dh $@ --with quilt
+
+override_dh_auto_clean:
+       rm -fr build
+
+override_dh_auto_configure:
+       mkdir -p build
+       cd build && meson .. --prefix=/usr \
+               -Dinit-script=systemd \
+               -Dfuse-version=2
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/lxcfs
+
+override_dh_installsystemd:
+       install -dm755 $(CURDIR)/debian/lxcfs/lib
+       mv $(CURDIR)/debian/lxcfs/usr/lib/systemd \
+          $(CURDIR)/debian/lxcfs/lib/systemd
+       dh_installsystemd -p lxcfs --no-stop-on-upgrade lxcfs.service