]> git.proxmox.com Git - vzctl.git/blobdiff - debian/rules
enable debian hardening-wrapper
[vzctl.git] / debian / rules
index f988e255adf4c49fea2eeaba7931ffbba1ee3137..8f94737919ec23f5b018639337f0fa55fa7da1d1 100644 (file)
@@ -3,6 +3,8 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DEB_BUILD_HARDENING=1
+
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -27,10 +29,13 @@ config.status:  configure
        dh_testdir
        sed -i "s/'$(VZCTL_VERSION)'/'$(VZCTL_DEBVERSION)'/g" configure
        ./configure \
+           --without-ploop \
            --host=$(DEB_HOST_GNU_TYPE) \
            --build=$(DEB_BUILD_GNU_TYPE) \
            --prefix=/usr               \
            --sysconfdir=/etc           \
+           --libdir=/usr/lib           \
+           --libexecdir=/usr/lib       \
            --localstatedir=/var        \
            --enable-bashcomp           \
            --enable-logrotate          \
@@ -92,6 +97,12 @@ install: build
        rm -rf $(CURDIR)/debian/vzctl/etc/vz/conf
        # we create the symlink to /etc/pve/openvz inside the preinst script
 
+       # install perl vznetaddbr version
+       install -m 755 $(CURDIR)/debian/vznetaddbr $(CURDIR)/debian/vzctl/usr/sbin/vznetaddbr
+
+       # install proxmox bridge cleanup script
+       install -m 755 $(CURDIR)/debian/proxmox.umount $(CURDIR)/debian/vzctl/usr/lib/vzctl/scripts/proxmox.umount
+
 
 
 # Build architecture-independent files here.