]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
d/rules: remove depreacated autotools_dev from dh
[lxcfs.git] / debian / rules
index 775ebf20875356ba043a00166d9e8161604b43d8..98d08c0c82dc62e86287cdc73beb986df2b53f03 100755 (executable)
@@ -4,4 +4,21 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+       dh $@  --with autoreconf,systemd,quilt
+
+override_dh_install:
+       find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
+       sed -i "/dependency_libs/ s/'.*'/''/" \
+           "$(CURDIR)/debian/lxcfs/usr/lib/x86_64-linux-gnu/lxcfs/liblxcfs.la"
+
+override_dh_auto_configure:
+       dh_auto_configure -- --with-init-script=systemd
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/lxcfs
+
+override_dh_installinit:
+       dh_installsystemd -p lxcfs --no-restart-on-upgrade
+
+override_dh_systemd_start:
+       dh_systemd_start -p lxcfs --no-restart-on-upgrade lxcfs.service