]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
build fix: override fuse library
[lxcfs.git] / debian / rules
index 6d2b7376d37d10aa5408c203cf55a9891cd887c0..9b6dc587f595721109e466545334805acf051599 100755 (executable)
@@ -4,19 +4,20 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+       dh $@  --with autoreconf,quilt
 
 override_dh_install:
        find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
+       sed -i "/dependency_libs/ s/'.*'/''/" \
+           "$(CURDIR)/debian/lxcfs/usr/lib/x86_64-linux-gnu/lxcfs/liblxcfs.la"
 
 override_dh_auto_configure:
-       dh_auto_configure -- --with-init-script=systemd
+       dh_auto_configure -- --with-init-script=systemd \
+               FUSE_CFLAGS="$(shell pkg-config --cflags fuse)" \
+               FUSE_LIBS="$(shell pkg-config --libs fuse)"
 
 override_dh_auto_install:
        dh_auto_install --destdir=debian/lxcfs
 
-override_dh_installinit:
-       dh_installsystemd -p lxcfs --no-restart-on-upgrade
-
-override_dh_systemd_start:
-       dh_systemd_start -p lxcfs --no-restart-on-upgrade lxcfs.service
+override_dh_installsystemd:
+       dh_installsystemd -p lxcfs --no-stop-on-upgrade lxcfs.service