]> git.proxmox.com Git - pve-qemu.git/blobdiff - debian/rules
import QEMU 5.0.0-rc2 and rebase patches
[pve-qemu.git] / debian / rules
index 4f6987e60fd49d3f4efc3a9024fd357c1838ad4e..c73d6a18a363a27d53a09c05b9ab6ab56556bdb2 100755 (executable)
@@ -21,6 +21,8 @@ ARCH ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
 PACKAGE=pve-qemu-kvm
 destdir := $(CURDIR)/debian/$(PACKAGE)
 
+flagfile := $(destdir)/usr/share/kvm/recognized-CPUID-flags-x86_64
+
 CFLAGS = -Wall
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -113,12 +115,10 @@ install: build
        rm -rf $(destdir)/usr/share/kvm/openbios-*
        # remove ppc files
        rm $(destdir)/usr/share/kvm/*.dtb
-       rm $(destdir)/usr/share/kvm/ppc_rom.bin
        rm $(destdir)/usr/share/kvm/s390-ccw.img
        rm $(destdir)/usr/share/kvm/s390-netboot.img
        rm $(destdir)/usr/share/kvm/qemu_vga.ndrv
        rm $(destdir)/usr/share/kvm/slof.bin
-       rm $(destdir)/usr/share/kvm/spapr-rtas.bin
        rm $(destdir)/usr/share/kvm/u-boot.e500
        # remove Aplha files
        rm $(destdir)/usr/share/kvm/palcode-clipper
@@ -128,6 +128,9 @@ install: build
        rm -Rf $(destdir)/usr/include
        rm -Rf $(destdir)/usr/lib*
 
+       # CPU flags are static for QEMU version, allows avoiding more costly checks
+       $(destdir)/usr/bin/qemu-system-x86_64 -cpu help | ./debian/parse-cpu-flags.pl > $(flagfile)
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -159,7 +162,9 @@ binary-arch: build install
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
-       dh_shlibdeps
+       # Debian >= Buster has libglusterfs0 and lots of libgfFOO, upstream has the libs in glusterfs-common
+       # pass -x to dpkg-shlibdeps and specify dependencies in d/control instead
+       dh_shlibdeps -- -xlibglusterfs0 -xlibgfxdr0 -xlibgfrpc0 -xlibgfdb0 -xlibgfchangelog0 -xlibgfapi0
        dh_gencontrol
        dh_md5sums
        dh_builddeb