]> git.proxmox.com Git - arch-pacman.git/blobdiff - debian/rules
d/rules: update to meson buildsystem switch in 6.0
[arch-pacman.git] / debian / rules
index bd9d857f3f96751856c071896ca8ac9001459da3..43bac11ce0b7c78dfb44adaa783b4fbd199478ac 100755 (executable)
@@ -8,15 +8,10 @@ DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/default.mk
 
 %:
-       dh $@ --with quilt
+       dh $@ --buildsystem=meson
 
 override_dh_auto_configure:
-       ./autogen.sh
-       dh_auto_configure -- \
-       --disable-static \
-       --disable-doc \
-       --with-pkg-ext=.tar.xz \
-       --with-scriptlet=/bin/bash
-
-override_dh_auto_install:
-       $(MAKE) install DESTDIR=$$(pwd)/debian/arch-pacman
+       dh_auto_configure  -- \
+         -Ddoc=disabled \
+         -Dpkg-ext=.tar.xz \
+         -Dscriptlet-shell=/bin/bash