]> git.proxmox.com Git - cargo.git/blob - vendor/syn/debian/patches/relax-deps.patch
New upstream version 0.66.0
[cargo.git] / vendor / syn / debian / patches / relax-deps.patch
1 Index: syn/Cargo.toml
2 ===================================================================
3 --- syn.orig/Cargo.toml
4 +++ syn/Cargo.toml
5 @@ -108,9 +108,6 @@ version = "1.0"
6 version = "0.11"
7 features = ["blocking"]
8
9 -[dev-dependencies.syn-test-suite]
10 -version = "0"
11 -
12 [dev-dependencies.tar]
13 version = "0.4.16"
14
15 @@ -139,6 +136,6 @@ proc-macro = [
16 "proc-macro2/proc-macro",
17 "quote/proc-macro",
18 ]
19 -test = ["syn-test-suite/all-features"]
20 +#test = ["syn-test-suite/all-features"]
21 visit = []
22 visit-mut = []
23 Index: syn/tests/repo/mod.rs
24 ===================================================================
25 --- syn.orig/tests/repo/mod.rs
26 +++ syn/tests/repo/mod.rs
27 @@ -188,7 +188,7 @@ fn download_and_unpack() -> Result<()> {
28 "https://github.com/rust-lang/rust/archive/{}.tar.gz",
29 REVISION
30 );
31 - let response = reqwest::blocking::get(url)?.error_for_status()?;
32 + let response = reqwest::get(url)?.error_for_status()?;
33 let progress = Progress::new(response);
34 let decoder = GzDecoder::new(progress);
35 let mut archive = Archive::new(decoder);