]> git.proxmox.com Git - ceph.git/blame - ceph/src/boost/tools/build/src/engine/debian/rules
import new upstream nautilus stable release 14.2.8
[ceph.git] / ceph / src / boost / tools / build / src / engine / debian / rules
CommitLineData
7c673cae
FG
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4# GNU copyright 2001 by Yann Dirson.
5
6# This is the debian/rules file for packages jam and ftjam
7# It should be usable with both packages without any change
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
92f5a8d4 12# This is the debhelper compatibility version to use.
7c673cae
FG
13export DH_COMPAT=3
14
15topdir=$(shell pwd)
16
17jam=bjam
18binname=bjam
19
20build: build-stamp
21build-stamp: debian/jam.1
22 dh_testdir
23
24 ./build.sh
25
26 touch build-stamp
27
28%.1: %.man.sgml
29 /usr/bin/docbook-to-man $< > $@
30
31clean:
32 dh_testdir
33 dh_testroot
34 rm -f build-stamp
35 rm -rf bin.*
36 rm -f jam0 debian/jam.1
37 dh_clean
38
39install: build
40 dh_testdir
41 dh_testroot
42 dh_clean -k
43 dh_installdirs
44
45 install -d ${topdir}/debian/${jam}/usr/bin
46 install -m755 bin.linuxx86/bjam ${topdir}/debian/${jam}/usr/bin/
47 install -d ${topdir}/debian/${jam}/usr/share/man/man1/
48 install -m644 debian/jam.1 ${topdir}/debian/${jam}/usr/share/man/man1/${binname}.1
49
50
51# Build architecture-independent files here.
52binary-indep: build install
53# We have nothing to do by default.
54
55# Build architecture-dependent files here.
56binary-arch: build install
57 dh_testdir
58 dh_testroot
59 dh_installdocs README RELNOTES Jambase *.html
60# dh_installemacsen
61# dh_undocumented
62 dh_installchangelogs
63 dh_strip
64 dh_compress
65 dh_fixperms
66 dh_installdeb
67 dh_shlibdeps
68 dh_gencontrol
69 dh_md5sums
70 dh_builddeb
71
72binary: binary-indep binary-arch
73.PHONY: build clean binary-indep binary-arch binary install configure